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Notice

The information contained in this document is subject to change without 
notice.

This document contains proprietary information that is protected by 
copyright. All rights are reserved. No part of this document may be 
photocopied, reproduced, or translated to another language without 
prior written consent of Agilent Technologies.

CAUTION The Agilent Versatest Series Test System Software 
loaded on the test system and provided on a CD-ROM is 
supported for use only as documented in the system 
manuals and training classes. Use of the system 
software and files not documented in the manuals or 
training is not supported and may cause damage to the 
system and is not covered by warranty.

Trademark Acknowledgements:

Adobe Acrobat® and Adobe Reader® are registered trademarks of Adobe 
Systems Incorporated

Windows XP® and Windows NT® are registered trademarks of Microsoft 
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Safety Considerations
Introductions
The following general safety precautions must be observed during all 
phases of operation, service, and repair of the system. Failure to comply 
with these precautions or with specific warnings elsewhere in this man-
ual violates safety standards of design, manufacture, and intended use 
of the system. Agilent Technologies assumes no liability for customer’s 
failure to comply with these requirements.

Ground the System
To minimize shock hazard, the system must be connected to an electri-
cal ground. The power terminal and the power cable must meet Inter-
national Electotechnical Commission (IEC) safety standards.

Keep Away From Live Circuits
Operation personnel must not open doors or remove covers. Replace-
ment of field replaceable units (FRU) and internal adjustments must be 
made by qualified maintenance personnel. Do not replace any FRUs, ca-
bles, or other components with power applied to the system. Under cer-
tain conditions dangerous voltages can exist even with power removed. 
To avoid injuries, always disconnect power and discharge circuits before 
touching them.

Do Not Service or Adjust Alone
Do not attempt internal service or adjustments unless another person 
(capable of rendering first aid and resuscitation) is present.

Do Not Substitute Parts or Modify System Instru-
ments
Because of the danger of introducing additional hazards, do not install 
substitute parts or perform unauthorized modifications to the system.

Do Not Defeat Interlocks
Defeating interlocks can cause hazardous conditions when servicing the 
system.
ies IDE User’s Guide 3
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Safety Symbols
The general definitions for safety symbols used on equipment or in man-
uals are listed below.

✸
Instruction manual symbol. The system is marked with this symbol 
when it is necessary for the user to refer to the instruction manual in 
order to protect against damage to the system.

✺
Indicates hazardous voltages.

✧
Indicates earth ground.

Warning THE WARNING SIGN DENOTES A HAZARD TO 
PERSONNEL. IT CALLS ATTENTION TO A PROCE-
DURE, PRACTICE, CONDITION OR THE LIKE, 
WHICH, IF NOT CORRECTLY PERFORMED OR 
ADHERED TO, COULD RESULT IN INJURY OR 
DEATH TO PERSONNEL

CAUTION The caution sign denotes a hazard to equipment. It calls 
attention to a procedure, practice, condition or the like, 
which, if not correctly performed or adhered to, could re-
sult in damage or destruction of part or all of the system.

NOTE The note sign denotes important information. It calls at-
tention to a procedure, practice, condition or the like, 
which is essential to highlight.
Versatest Series IDE User’s Guide
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Chapter 1  Introduction

Welcome
Welcome

Welcome to the Versatest Series Integrated Development Environment 
User’s Guide. Integrated Development Environment (IDE) refers to a 
unified collection of software development and debug tools that operate 
together. This manual contains information required by Agilent 
Versatest test system programmers to use the IDE tools to develop 
debug test programs.

NOTE The IDE tools support versions of V4K software ≥ B.02.04. The version 
of software a system is running can be displayed from the VK Test 
main window by selecting Help > About VK Test Station.

Manual Contents

The following information is contained in this manual:

• Chapter 1, “Introduction,” provides in the remainder of this chapter 
the following information:

• How to use this manual on page 25.

• What this manual assumes on page 25.

• Chapter 2, “Integrated Development Environment,” describes the 
IDE, its tools, and capabilities.

• Chapter 3, “Pin Tool,” provides information about its interface, 
capabilities, and a “Getting Started” that describes how to display 
the Pin Tool document window, configure tester resources on its 
General tab, assign pins to tester resources on its Pin Mapping tab, 
and define pin groups on its Pin Groups tab.

• Chapter 4, “C Program Debugger,” provides information about its 
interface, capabilities, and a “Getting Started” that describes how 
to perform several tasks using the tool such as setting break points 
and stepping through a test program.

• Chapter 5, “Pattern Tool,” describes its interface, capabilities, and 
a “Getting Started” that describes how to retrieve pattern 
information and view and debug failures.

• Chapter 6, “Waveform Tool,” provides information about its 
interface, and a “Getting Started” that describes how to setup, 
capture, and display waveforms for analysis.

• Chapter 7, “Timing Tool,” provides an overview of the tool, 
description of its interface, capabilities, and a “Getting Started” 
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How to Use This Manual
that describes how to load and display the timing data in the 
Timing Tool graphical and tabular views. It also describes how to 
run the Timing Tool in offline mode.

• Chapter 8, “Bitmap Tool,” provides an overview of the tool, a 
description of its interface, a “Getting Started” that describes how 
to create and load DUT definition files, and load and view bitmap 
files. It also has a section that provides detailed information about 
how to create DUT definition files.

NOTE The actual colors displayed in this manual can be viewed from its 
Acrobat Reader PDF file on the Versatest Series Online Manuals CD-
ROM. If you are viewing the PDF file, you can use Acrobat Reader’s 
View > Zoom In and View > Zoom Out menu bar commands to 
adjust the display magnification to help you see graphics such as 
waveforms.

How to Use This Manual

The best place to start is chapter 2, “Integrated Development 
Environment.” Chapter 2 will familiarize you with the IDE, its tools, 
and capabilities. A complete description of each tool can be found in 
their respective chapters in this manual.

Assumptions

This manual assumes the following:

• That you have a basic understanding of computer operation and the 
Windows XP Professional interface. If you are new to Windows XP, 
it is recommended that you see the  > Help and Support 
> Help and Support Center window.

• That you are familiar with C language programming and 
programming of Versatest Series test systems. If you need to learn 
more about the test systems, there are manuals and classes 
available to learn about how to program and maintain the systems. 
All of the manuals and programming training can be found on the 
Versatest Series Manuals CD-ROM. The latest version of the 
Manuals CD is shipped with each system.

• That you have a working knowledge of IC or wafer testing.
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Assumptions
Use of System Software

CAUTION The Agilent Versatest Series Test System Software loaded on the test 
system and provided on a CD-ROM is supported for use only as 
documented in the system manuals and training classes. Use of the 
system software and files not documented in the manuals or training is 
not supported and may cause damage to the system and is not covered 
by warranty.
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Chapter 2  Integrated Development Environment

Introduction
Introduction

Integrated Development Environment (IDE) refers to a unified 
collection of software development and debug tools that operate 
together. For the Versatest Series software, the IDE is a central 
application which manages all test program components. It provides a 
central application with a common graphical user interface (GUI) that 
manages the Pin Tool, C Program Debugger, Pattern Tool, Waveform 
Tool, Timing Tool, and Bitmap Tool (Figure 2-1). Each tool is a plug-in 
to the IDE. And any tool can be more aware of the test program and 
other tools. The tools' operations can then be synchronized if needed.

Figure 2-1. IDE Tools  

The IDE consists of the following tools:

• Pin Tool: Provides the capability to map tester resources to DUT 
pins for both test program .c and pattern .apg files. It also allows 
the user to add, delete, or modify pin definitions through its 
interface.

IDE

Pin Tool
C

Debugger

Timing
Tool

Bitmap
Tool

Waveform
Tool

Pattern
Tool
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Online and Offline Modes
• C Program Debugger: Provides the capability to debug test 
program C code using the IDE GUI with standard windows 
conventions.

• Pattern Tool: Provides the capability within the IDE to debug 
patterns that have been loaded into hardware.

• Waveform Tool: Displays within the IDE GUI the actual and 
expected waveforms that are output to the DUT. This tool acts as 
an oscilloscope and logic analyzer that is automatically configured 
for the test system.

• Timing Tool: Displays within the IDE GUI global time set (GTS), 
local time set (LTS), and timing edge information in a graphical 
and tabular format, and checks for APG rules violations.

• Bitmap Tool: Allows you to view and compare multiple failed 
bitmap files within the IDE GUI. Using the Bitmap Tool, you can 
pinpoint specific locations where memory bits pass and fail tests, 
create overlays of bitmaps, and create bitmap logical operations.

NOTE The actual colors displayed in this manual can be viewed from its 
Acrobat Reader PDF file on the Versatest Series Online Manuals CD-
ROM. If you are viewing the PDF file, you can use Acrobat Reader’s 
View > Zoom In and View > Zoom Out menu bar commands to 
adjust the display magnification to help you see graphics such as 
waveforms.

Online and Offline Modes

The following tools currently support online mode:

• C Program Debugger (currently has no offline capability)

• Pattern Tool (currently has no offline capability)

• Waveform Tool

• Timing Tool

The following tools currently support offline mode:

• Pin Tool (currently has no online capability other than to customize 
pin sets from the Waveformsetup Tool and Pattern Tool)

• Waveform Tool (viewing saved files only)

• Timing Tool (viewing saved files only)

• Bitmap Tool (currently has no online capability)
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IDE Benefits
IDE Benefits

The IDE provides multiple benefits with a more cohesive development 
and debug environment. These benefits include the following:

• Unified management of windows: Tools are no longer just a 
collection of independent windows.

• Reduce visual clutter: Tools and objects can now be grouped or 
categorized appropriately.

• Faster learning curve can now be achieved because the single IDE 
GUI environment now has a common look and feel with similar 
windows, menus, and toolbars.

All of these IDE benefits result in faster test program development and 
debug using the tools.

IDE Overview

The IDE consists of the following seven functional areas (Figure 2-2):

• Menu bar

• Toolbar

• Navigator pane

• Tool Document window

• Document Tabs (one for each corresponding Tool Document 
window)

• Output pane

• Status bar
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IDE Overview
Figure 2-2. IDE Main Window  

Each of these components (except the Menu bar) can be displayed or 
hidden by going to the View menu (Figure 2-3), and checking or 
unchecking the component you wish to change.

Figure 2-3. View Menu  

Menu Bar Toolbar

Tool Document Window

Document Tab

Output Pane

Navigator Pane

Status Bar
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IDE Overview
The Menu bar and Toolbar are context-sensitive and change as the 
active document changes. The Menu bar and Toolbar only display or 
enable menus and toolbar buttons that are relevant to the tool or 
document you have selected.

The Navigator pane presents the test program components in logical, 
hierarchical groupings. It allows any test program component to be 
edited and provides visual feedback as to which test program elements 
are currently active. Tools can also add special navigation panes for 
their needs.

The IDE is designed on a docking window paradigm. It has the ability 
for you to move and resize windows or toolbars.

After configuring the position and look of the IDE, you can easily save 
that configuration for future retrieval. This capability is called saving 
your Workspace. The Workspace consists of the tools, layout, and open 
documents. Selecting the File > Save Workspace command 
displays a Save Workspace dialog box from which you can save the 
workspace with a workspace .wsp extension. The previously saved 
workspace can be displayed by selecting the File > Open 
Workspace command to display an Open Workspace dialog box from 
which you can select and open the workspace.
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Chapter 3  Pin Tool

Introduction
Introduction

This chapter provides information about the Versatest Series Pin Tool. 
The Pin Tool’s graphical interface provides the capability to map tester 
resources to DUT pins for both test program .c and pattern .apg files. It 
also allows the user to add, delete, or modify pin definitions through its 
interface.

Without the Pin Tool, the user’s only option is to manually map tester 
resources to DUT pins for both test program .c and pattern .apg files. 
This is done by creating a pin list that is a data structure consisting of 
a one-dimensional four-integer array for each DUT pin in a project .c 
file. Data structures called pin and pin groups also have to be created 
for use in pattern files. The Pin Tool provides an alternative to the 
arduous and overlapping task of manually mapping tester resources to 
DUT pins for test program and pattern files with error checking 
capability.

Chapter Contents

This chapter contains the following information about the Timing Tool:

• “Pin Tool Main Window” on page 35: Provides descriptions of the 
application interface functional areas, menus, menu commands, 
and dialog boxes.

• “Pin Tool Getting Started” on page 55: Describes how to display the 
Pin Tool document window, configure tester resources on the 
General tab, assign pins to tester resources on the Pin Mapping 
tab, and define pin groups on the Pin Groups tab.

NOTE The actual colors displayed in this manual can be viewed from its 
Acrobat Reader PDF file on the Versatest Series Manuals CD-ROM. If 
you are viewing the PDF file, you can use Acrobat Reader’s View > 
Zoom In and View > Zoom Out menu bar commands to adjust the 
display magnification to help you see graphics such as waveforms.
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Pin Tool Main Window
Pin Tool Main Window

The Pin Tool main window shown in Figure 3-1 is the tool’s interface. 
The interface is composed of the following functional areas:

• Navigator Pane: See the View > Navigator Pane command on 
page 47

• Menu bar on page 36

• File menu on page 37

• Edit menu on page 43

• View menu on page 45

• Tools menu on page 48

• Tester menu on page 49

• Pin Tool menu on page 51

• Window menu on page 52

• Help menu on page 53

• Toolbar: See the View > Toolbar command on page 46

• Tool Document Window: Consists of the following Pin Tool 
document window tabs:

• General tab: See “Configuring Tester Resources on the General 
Tab” on page 58.

• Pin Mapping tab: See “Assigning Pins to Tester Resources on 
the Pin Mapping Tab” on page 61.

• Pin Groups tab: See “Defining Pin Groups Using the Pin Groups 
Tab” on page 68.

• Display List tab: Used to customize pin sets from the 
Waveformsetup Tool > Custom > Display List tab and the 
Pattern Tool’s > Edit Vector Pane > Format tab > Custom > 
Display List tab.

• Output Pane: See the View > Output Pane command on 
page 48

• Status Bar: See the View > Status Bar command on page 47
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Pin Tool Main Window
Figure 3-1. Pin Tool Main Window General Tab  

Menu Bar

The menu bar at the top of the Timing Tool main window (Figure 3-1 
on page 36) contains the following eight pull-down menus from which 
you can select commands:

• File menu on page 37

• Edit menu on page 43

• View menu on page 45

• Tools menu on page 48

• Tester menu on page 49

• Pin Tool menu on page 51

• Window menu on page 52
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Pin Tool Main Window
• Help menu on page 53

File Menu

Selecting File in the menu bar opens the menu in Figure 3-2.

Figure 3-2. File Menu  

The File menu contains the following commands:

•  New command on page 38

•  Open command on page 39

• Close command on page 41

• Close All command on page 41

•  Save command on page 41

• Save As command on page 42

• Open Workspace command on page 42

• Save Workspace command on page 42

• Close Workspace Command on page 42

•  Print command on page 42

• Print Preview command on page 42

• Print Setup command on page 43

• Recent Workspaces on page 43
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Pin Tool Main Window
• Exit command on page 43

New Command (File Menu)

 Displays the New command submenu (Figure 3-3) that allows you 
to display a new Workspace or create new IDE documents. The New  
toolbar button displays a New dialog box that lists the same items to 
select as the submenu.

Figure 3-3. File > New Command Submenu  

The New command submenu contains the following commands:

• Workspace command on page 38

• PinTool Document command on page 38

• Waveform Document command on page 38

• Waveform Setup Document command on page 39

• Timing Tool Document command on page 39

Workspace Command (New Command Submenu)

Displays as the active Workspace its default with its corresponding 
Menu bar, Toolbar, Navigator pane, Output pane, and Status bar.

PinTool Document Command (New Command Submenu)

Displays as the active document a blank PinTool document with its 
corresponding Menu bar, Toolbar, Navigator pane, Document tab (and 
window), Output pane, and Status bar.

Waveform Document Command (New Command Submenu)

Displays as the active document a blank Waveform Tool document 
with its corresponding Menu bar, Toolbar, Navigator pane, Document 
tab (and window), Output pane, and Status bar.
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Pin Tool Main Window
Waveform Setup Document Command (New Command Submenu)

Displays as the active document the default Waveform Setup Tool 
document with its corresponding Menu bar, Toolbar, Navigator pane, 
Document tab (and window), Output pane, and Status bar.

Timing Tool Document Command (New Command Submenu)

Displays as the active document a blank Timing Tool document with 
its corresponding Menu bar, Toolbar, Navigator pane, Document tab 
(and graphical display window), Output pane, and Status bar.

Open Command (File Menu)

 Displays the Open command submenu (Figure 3-4) that allows you 
to open a Workspace or IDE documents from the submenu list. The 
Open  toolbar button displays a generic Open dialog box from which 
you can open a selection listed in the submenu.

Figure 3-4. Open Command Submenu  

The Open command submenu contains the following commands that 
display an Open dialog box similar to Figure 3-5:

• C Debugger Document command on page 40

• PinTool Document command on page 40

• Waveform Document command on page 40

• Waveform Setup Document command on page 41

• Timing Tool Document command on page 41

• Pattern Tool Document command on page 41

• Bitmap Tool DUT Document command on page 41
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Pin Tool Main Window
Figure 3-5. File > Open Dialog Box  

C Debugger Document Command (Open Command Submenu)

Displays an Open dialog box (similar to Figure 3-5) to select a 
previously saved C Debugger Tool document file with a *.cof extension.

PinTool Document Command (Open Command Submenu)

Displays an Open dialog box (similar to Figure 3-5) to select a 
previously saved PinTool document file with a *.pin file extension. 
After selecting a .pin file the dialog box shown in Figure 3-6 displays. 
This dialog box is for when the IDE is set online and you have a test 
program loaded and want to ensure that the Pin Tool .pin file you are 
loading is compatible with the test program for debugging purposes.

Figure 3-6. Versatest IDE Dialog Box  

Waveform Document Command (Open Command Submenu)

Displays an Open dialog box (similar to Figure 3-5) to select a 
previously saved Waveform document file with a *.dnc file extension.
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Pin Tool Main Window
Waveform Setup Document Command (Open Command Submenu)

Displays an Open dialog box (similar to Figure 3-5) to select a 
previously saved Waveform Setup document file with a *.stp file 
extension.

Timing Tool Document Command (Open Command Submenu)

Displays an Open dialog box (similar to Figure 3-5) to select a 
previously saved Timing Tool document file with a *.vtt file extension.

Pattern Tool Document Command (Open Command Submenu)

Displays an Open dialog box (Figure 3-5) to select a previously saved 
Pattern Tool document file with an *.apg2 file extension.

Bitmap Tool DUT Document Command (Open Command Submenu)

Displays an Open dialog box (similar to Figure 3-5) to select a 
previously saved Bitmap Tool DUT definition document file with a 
*.dut file extension.

Close Command (File Menu)

Closes the active tool document.

Close All Command (File Menu)

Closes all tool documents and displays the default IDE main window.

Save Command (File Menu)

 Saves the active document file. Saving a Pin Tool document file 
saves the Pin Tool .pin file and also generates *.c and *.h files. You 
should not edit the generated .c and .h files. The .pin file is only for use 
with the IDE Pin Tool. Include the generated *.c and *.h files as follows 
before compiling using the “make” command:

• Include the generated .h file in your test program .c file.

• Include the generated .h file in your .apg file.

• Include the generated .c file in your makefile.

When saving a Pin Tool file, the system first validates all the pin/cam 
settings. If there are any errors, it will print the error message to the 
Error Log tab on the Output Window. Once the setting passes the 
validation, it then saves the three files: *.pin, *.c, and *.h.
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Pin Tool Main Window
Save As Command (File Menu)

Displays the Save As dialog box to save the active tool document file. 
When saving a Pin Tool document file, typing a filename with a *.pin 
extension in the dialog box and then selecting the  button saves 
the Pin Tool .pin file and also generates *.c and *.h files. You should 
not edit the generated .c and .h files. The .pin file is only for use with 
the IDE Pin Tool. Include the generated *.c and *.h files as follows 
before compiling using the “make” command:

• Include the generated .h file in your test program .c file.

• Include the generated .h file in your .apg file.

• Include the generated .c file in your makefile.

When saving a Pin Tool file, the system first validates all the pin/cam 
settings. If there are any errors, it will print the error message to the 
Error Log tab on the Output Window. Once the setting passes the 
validation, it then saves the three files: *.pin, *.c, and *.h.

Open Workspace Command (File Menu)

Displays an Open Workspace dialog box with a *.wsp extension. If 
changes have been made to the current workspace, you will be asked if 
you would like to save the changes before closing the current 
workspace and opening another. The Workspace consists of the tools, 
layout, and open documents.

Save Workspace Command (File Menu)

Saves the current workspace with a *.wsp extension. The Workspace 
consists of the tools, layout, and open documents.

Close Workspace Command (File Menu)

Closes the current workspace. If changes have been made to the 
current workspace, you will be asked if you would like to save the 
changes before closing the current workspace.

Print Command (File Menu)

 Prints the contents of the Pin Mapping tab in the active Pin Tool 
document window.

Print Preview Command (File Menu)

Displays a print preview window of the Pin Mapping tab in the active 
Pin Tool document window.

Save
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Pin Tool Main Window
Print Setup Command (File Menu)

Displays a printer setup dialog box that allows you to select and 
configure a printer.

Recent Workspaces Command (File Menu)

Displays a Recent Workspaces submenu from which you can select a 
workspace.

Exit Command (File Menu)

Closes the IDE. If the workspace or any other tool document files have 
changed, you will be asked if you would like to save them.

Edit Menu

Selecting Edit in the menu bar opens the menu in Figure 3-2.

Figure 3-7. Edit Menu  

The Edit menu contains the following commands:

• Undo command below on page 44

• Redo command on page 44

•  Cut command on page 44

•  Copy command below on page 44

•  Paste command on page 44

• Find command on page 44

• Replace command on page 45

• Find in Workspace on page 45
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Pin Tool Main Window
Undo Command (Edit Menu)

Not supported by the Pin Tool.

Redo Command (Edit Menu)

Not supported by the Pin Tool.

Cut Command (Edit Menu)

 Cuts the currently selected contents on the Pin Tool’s Pin Mapping 
tab for insertion elsewhere on the tab. Rows are selected by placing the 
mouse cursor over a numbered column on the left side of the tab at the 
beginning of a row until a black right arrow appears and selecting the 
left mouse button. Multiple selections are made using the black arrow 
in combination with the  key for range selections or with the  to 
select rows individually. Column selections are made by clicking and 
dragging the mouse over the desired area in the column.

Copy Command (Edit Menu)

 Copies the currently selected contents on the Pin Tool’s Pin 
Mapping tab for insertion elsewhere on the tab. Rows are selected by 
placing the mouse cursor over a numbered column on the left side of 
the tab at the beginning of a row until a black right arrow appears and 
selecting the left mouse button. Multiple selections are made using the 
black arrow in combination with the  key for range selections or 
with the  to select rows individually. Column selections are made by 
clicking and dragging the mouse over the desired area in the column.

Paste Command (Edit Menu)

 Inserts the last copied/cut contents on the Pin Tool’s Pin Mapping 
tab to the cursor location on the tab.

Find Command (Edit Menu)

On the Pin Tool’s Pin Mapping tab, finds the specified device pin name 
in the Device Pin Name column (Figure 3-8).

Shift Ctrl

Shift

Ctrl
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Pin Tool Main Window
Figure 3-8. Find Command Dialog Box  

Replace Command (Edit Menu)

On the Pin Tool’s Pin Mapping tab does a find and replace on the 
selected column (Figure 3-9).

Figure 3-9. Replace Dialog Box  

Find in Workspace Command (Edit Menu)

Not currently supported by the IDE.

View Menu

Selecting View in the menu bar opens the menu in Figure 3-10.
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Pin Tool Main Window
Figure 3-10. View Menu  

The View menu contains the following commands:

• Toolbar command on page 46

• Status Bar command on page 47

• Navigator Pane command on page 47

• Output Pane command on page 48

• Document Tabs command on page 48

Toolbar Command (View Menu)

Displays or hides the toolbar shown in Figure 3-11. The toolbar 
displays at the top of the Timing Tool main window when a ✓  displays 
in front of its command in the View menu. Clicking on the buttons in 
the toolbar give you quick access to many of the menu bar commands. 
Positioning the mouse cursor over a toolbar button displays tooltip text 
with the corresponding command description.

Figure 3-11. Pin Tool Toolbar  
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Status Bar Command (View Menu)

Displays or hides the Status Bar (Figure 3-1 on page 36). The Status 
Bar displays at the bottom of the Pin Tool main window when a ✓  
displays in front of its command in the View menu. The Status Bar 
provides information about the current state of what you are viewing 
in the window and any other status-oriented information.

Navigator Pane Command (View Menu)

Displays the Navigator Pane (similar to Figure 3-1 on page 36) when a 
✓  displays in front of its command in the View menu.

The Pin Tool is associated with the Pin Tool icon on the Tools Tab 
 in the Navigator Pane.

 File > New on page 38  Tester > Disconnect from VersaStation on 
page 50

 File > Open on page 39  Tester > Power On on page 51

 File > Save on page 41  Tester > Power Off on page 51

 Edit > Cut on page 44  Tester > Set Online on page 50

 Edit > Copy on page 44  Tester > Set Offline on page 50

 Edit > Paste on page 44  IDE Site Connect Status

 File > Print on page 42  Tester > Acquire Data on page 51 (not 
supported by Pin Tool)

 Help > About on page 53  Tester > Apply Changes on page 51 (not 
supported by Pin Tool)

 Help > Help on page 53  Tester > Abort Acquire on page 51 (not 
supported by Pin Tool)

 Tester > Connect to VersaStation on page 50
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Output Pane Command (View Menu)

Displays the Output Pane (similar to Figure 3-1 on page 36) when a ✓  
displays in front of its command in the View menu.

The Pin Tool is associated with the VOS Command tab in the Output 
Pane. The VOS Command tab is enabled when the IDE is set online by 
the selecting the yellow Set Online  toolbar button or the 
corresponding Tester > Set Online command. The VOS 
Command tab allows you to enter VOS terminal commands and 
display the results on the tab and in the corresponding test site 
window in the VK Test Station main window. See the “VOS Terminal 
Commands” chapter in the Command Reference Volume 2 for the 
available commands.  

Document Tabs Command (View Menu)

Displays the Document Tabs at the bottom of the Tool Document 
Window (similar to Figure 3-1 on page 36) when a ✓  displays in front of 
its command in the View menu.

Tools Menu

Selecting Tools in the menu bar opens the menu in Figure 3-12.

Figure 3-12. Tools Menu  

The Tools menu contains the following commands:

• Options command on page 48

• Properties command on page 49

Options Command (Tools Menu)

Displays the Options submenu shown in Figure 3-13.

Figure 3-13. Options Submenu  
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The Options command submenu contains the following command:

• PinTool Options command on page 49

PinTool Options Command (Options Command Submenu)

Not currently supported by the IDE.

Properties Command (Tools Menu)

Displays the Properties submenu shown in Figure 3-14.

Figure 3-14. Properties Submenu  

The Properties command submenu contains the following command:

• PinTool Properties command on page 49

PinTool Properties Command (Properties Command Submenu)

Not currently supported by the IDE.

Tester Menu

Selecting Tester in the menu bar opens the menu in Figure 3-15.

Figure 3-15. Tester Menu  

The Tester menu contains the following commands:
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•  Connect to VersaStation on page 50

•  Disconnect from VersaStation on page 50

•  Set Online command on page 50

•  Set Offline command on page 50

•  Acquire Data command on page 51

•  Apply Changes command on page 51

•  Abort Acquire command on page 51

•  Tester Power On command on page 51

•  Tester Power Off command on page 51

Connect to VersaStation Command (Tester Menu)

 Connects the IDE to VersaStation (formerly called PCM). The IDE 
must be connected to VersaStation (PCM) before it can be connected to 
a specific tester test site.

Disconnect from VersaStation Command (Tester Menu)

 Disconnects the IDE from VersaStation (formerly called PCM).

Set Online Command (Tester Menu)

 Connects the IDE to the tester for the following tools that support 
online mode. The IDE must be connected to VersaStation (formerly 
PCM) before it can be connected to a specific test site.

• C Program Debugger (currently has no offline capability)

• Pattern Tool (currently has no offline capability)

• Waveform Tool

• Timing Tool

Set Offline Command (Tester Menu)

 Disconnects the IDE from the tester. The following tools support 
offline mode:

• Pin Tool (currently has no online capability)

• Waveform Tool (viewing saved files only)

• Timing Tool (viewing saved files only)

• Bitmap Tool (currently has no online capability)
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Select the Open  toolbar button or the File > Open PinTool 
Document command to display an open dialog box from which a Pin 
Tool file with a .pin extension is opened. The .pin file is created by 
selecting File > Save after configuring a Pin Tool document.

Acquire Data Command (Tester Menu)

 Not currently supported by the Pin Tool. The Timing Tool supports 
this command.

Apply Changes Command (Tester Menu)

 Not currently supported by the Pin Tool. The Timing Tool supports 
this command.

Abort Acquire Command (Tester Menu)

 Not currently supported by the Pin Tool. The Timing Tool supports 
this command.

Tester Power On Command (Tester Menu)

 Same as the VK Test Station main window Utilities > Power 
On command and its corresponding  toolbar button. Resets and 
powers up the test sites (Test Head).

Tester Power Off Command (Tester Menu)

 Same as the VK Test Station main window Utilities > Power 
Off command and its corresponding  toolbar button. Turns off 
power to the test sites (Test Head).

Pin Tool Menu

Selecting Pin Tool in the menu bar opens the menu in Figure 3-17.

Figure 3-16. Pin Tool Menu  

The Pin Tool menu contains the following commands:

• Increasing pin numbering on page 52

• Decreasing pin numbering on page 52
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Increasing pin numbering Command (Window Menu)

In the Pin Tool’s Pin Mapping tab, causes entry values to increase in 
numbering as you click and drag to add to the initial entry in the 
columns on the tab:

• Device Pin Name

• Socket Pin Out

• DUT Tester Channel

Decreasing pin numbering Command (Window Menu)

In the Pin Tool’s Pin Mapping tab, causes entry values to decrease in 
numbering as you click and drag to add to the initial entry in the 
columns on the tab:

• Device Pin Name

• Socket Pin Out

• DUT Tester Channel

Window Menu

Selecting Window in the menu bar opens the menu in Figure 3-17.

Figure 3-17. Window Menu  

The Window menu contains the following commands:

• New Window command on page 53

• Close command on page 53

• Close All command on page 53

• Cascade command on page 53

• Tile command on page 53

• Minimize All command on page 53
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New Window Command (Window Menu)

Displays a duplicate of the active Pin Tool document window.

Close Command (Window Menu)

Closes the active tool document window.

Close All Command (Window Menu)

Closes all tool document windows with their corresponding tabs.

Cascade Command (Window Menu)

Cascades all open tool document windows in an overlapping fashion 
one on top of another with the title bar of each visible.

Tile Command (Window Menu)

Tiles all open tool document windows in a non-overlapping fashion.

Minimize All Command (Window Menu)

Not currently supported.

Help Menu

Selecting Help in the menu bar opens the menu in Figure 3-18.

Figure 3-18. Help Menu  

The Help menu contains the following two commands:

Help Topics Command (Help Menu)

 Not currently supported.

About Versatest Integrated Development Environment Command 
(Help Menu)

 Displays the About Versatest Integrated Development 
Environment dialog box that contains software component version and 
copyright information (similar to Figure 3-19).
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Pin Tool Main Window
Figure 3-19. About Versatest Integrated Development Environment  
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Pin Tool Getting Started
Pin Tool Getting Started

This Getting Started demonstrates how use the Pin Tool to create pin 
lists and groups from scratch before you develop your test program.

The Pin Tool’s graphical interface provides the capability to map tester 
resources to DUT pins for both test program .c and pattern .apg files. It 
also allows the user to add, delete, or modify pin definitions through its 
interface. Without the Pin Tool, the user’s only option is to manually 
map tester resources to DUT pins for both test program .c and pattern 
.apg files. This is done by creating a pin list that is a data structure 
consisting of a one-dimensional four-integer array for each DUT pin in 
a project .c file. Data structures called pin and pin groups also have to 
be created for use in pattern files. The Pin Tool provides an alternative 
to the arduous and overlapping task of manually mapping tester 
resources to DUT pins for test program and pattern files.

For additional information about the Timing Too, see the “Pin Tool 
Main Window” section on page 35 that provides descriptions of all the 
menus, menu commands, and dialog boxes that make up the tool’s 
interface.

Getting Started Contents

This Getting Started contains the following examples:

• “Launching the IDE and Displaying the Pin Tool Document 
Window” on page 56

• “Configuring Tester Resources on the General Tab” on page 58

• “Assigning Pins to Tester Resources on the Pin Mapping Tab” on 
page 61

• “Defining Pin Groups Using the Pin Groups Tab” on page 68

NOTE The actual colors displayed in this manual can be viewed from its 
Acrobat Reader PDF file on the Versatest Series Manuals CD-ROM. If 
you are viewing the PDF file, you can use Acrobat Reader’s View > 
Zoom In and View > Zoom Out menu bar commands to adjust the 
display magnification to help you see graphics such as waveforms.
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Launching the IDE and Displaying the Pin Tool 
Document Window

This section demonstrates how to launch IDE and display the Pin Tool 
Document Window in preparation to create a Pin Tool document.

1 Selecting  > Programs > Versatest Test System 
Software > Integrated Development Environment displays its 
default main window (Figure 3-20).

Figure 3-20. Versatest Integrated Development Environment Main Window  

2 Double-clicking the Pin Tool icon on the Tools Tab in the Navigator 
Pane(Figure 3-20) displays the Pin Tool as the active tool in the Tool 
Document window (Figure 3-21). This also adds the Pin Tool Document 

 tab at the bottom of the Pin Tool Document window, and its 
menu bar and toolbar.

Navigator Pane Menu Bar Toolbar

Tool Document Window

Output Pane

Tools Tab

Status Bar

Workspace
Tab

Pin Tool Icon
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Figure 3-21. Pin Tool Default Main Window  

Tool Document Window

Navigator Pane

Pin Tool Document Tab

Output Pane

Workspace
Tools Tab

Tab

Tester Configuration

Number of DUT per site

Combined Resource
Mode
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Configuring Tester Resources on the General Tab

This section demonstrates how to select the test system you want to 
create the pin lists for and configure its resources on the General 

 tab. This includes selecting the tester configuration, number 
of DUTs per site, and the combined-resource mode (CRM).

1 Selecting the down-arrow  button on the right side of the Tester 
Configuration field displays a drop-down list box of the available 
test system configurations.

Figure 3-22. Tester Configuration Drop-Down List Box  

2 For this example, we will select the V5400.cfg configuration 
(Figure 3-23) that has the following configuration resources:

• Four test sites per site module.

• Thirty-two PE channels per test site (128 per site module).

Tool Document Window

Navigator Pane

Pin Tool Document Tab

Output Pane

Workspace
Tools Tab

Tab

Tester Configuration
Drop-Down List Box

General Tab
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• Supports single-site mode (CRM-1 with 32 PE channels), CRM-2 
(with 64 PE channels), or CRM-4 (with 128 PE channels) on each 
test site module.

Figure 3-23. Tester Configuration Set to V5400.cfg  

3 Selecting the down-arrow  button on the right side of the Number 
of DUT per site field displays a drop-down list box that allows you 
to select the number of DUTs per site (Figure 3-24).

Figure 3-24. Number of DUT Per Site Drop-Down List Box  

V5400.cfg Tester Configuration

Number of DUT per site

Combined Resource Mode (CRM)
Versatest Series IDE User’s Guide 59

Revision D, May 2005



Chapter 3  Pin Tool

Pin Tool Getting Started
4 Selecting 2 closes the list box, and then selecting the Combined 
Resource Mode drop-down  button displays the V5400.cfg 
supported CRM modes (Figure 3-25).

Figure 3-25. Combined Resource Mode Drop-Down List Box  

5 Selecting 2 specifies CRM-2 and displays the configured General 
 tab (Figure 3-26).

Figure 3-26. Configured General Tab  
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Assigning Pins to Tester Resources on the Pin 
Mapping Tab

This section demonstrates how to use the Pin Mapping  tab to 
assign pins to tester resources. This includes defining pin names, and 
mapping DUT pins and PE or PPS resources to those names.

1 Selecting the Pin Mapping  tab (Figure 3-27) displays how it 
was configured on the General  tab. For example, it was 
previously configured with two DUTs.

Figure 3-27. Pin Tool’s Pin Mapping Tab  

2 Selecting the cell in row 1 under the Device Pin Name column and 
typing addr0 defines the first pin name (Figure 3-28).
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Figure 3-28. Pin Mapping’s Tab Defined Pin Name  

3  + left-clicking the mouse cursor on the addr0 cell and dragging 
the cursor down to row 8 highlights the cells and assigns pin names 
addr1 through addr7 to the selected cells (Figure 3-29). Note that 
whether a selection increases or decreases its numbering is determined 
by selecting either the Pin Tool > ✓ Increasing pin number 
command or Pin Tool > ✓ Decrease pin numbering command in 
the menu bar.

Figure 3-29. Clicking and Dragging to Assign Additional Pin Names  

4 Selecting the cell in row 9 and typing data0 defines that row’s pin 
name, and the repeating the process of clicking and dragging down to 
row 16 assigns data1 through data7 to the corresponding cells 
(Figure 3-30). An additional pin name is assigned by typing VCC in row 
17.

Shift
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Figure 3-30. Assigning Additional Pin Names  

5 Selecting the cell in row 1 under the Socket Pin Out column and 
typing A0 maps it to the Addr0 Device Pin Name, and then  + 
clicking and dragging down to row 17 in the column assigns A1 
through A16 (Figure 3-31). Again, note that whether a selection 
increases or decreases its numbering is determined by selecting either 
the Pin Tool > ✓ Increasing pin number command or Pin 
Tool > ✓ Decrease pin numbering command in the menu bar.

Shift
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Figure 3-31. Mapping Pins to Pin Names  

6 Selecting the cell in row 1 in the DUT 1 Tester Channel column 
enables a drop-down list box that displays the available channels when 
you select the drop-down  button (Figure 3-32)
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Figure 3-32. Displaying Tester PE Channels  

7 Selecting PE2 and then  + clicking and dragging down to row 8 
(A7) maps PE2 to A0 through PE9 to A7 (similar to Figure 3-33). 
The mapping of PE11 through PE18 is done similarly.

Shift
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Figure 3-33. Mapping DUT 1 PE Channels  

8 Mapping PE channels for the DUT 2 Tester Channel column is 
done the same way as for DUT 1 (Figure 3-34).
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Figure 3-34. Mapping DUT 2 PE Channels  

9 Mapping of PPS resources for the VCC pin name for DUT 1 and DUT 
2 in row 17 is done using the same process (Figure 3-35).
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Figure 3-35. Mapping VCC PPS Resources  

Defining Pin Groups Using the Pin Groups Tab

This section demonstrates how to define pin groups on the Pin Groups 
 tab using the pins that were mapped in the previous section 

using the Pin Mapping  tab, clone and edit pin those pin 
groups, and save the .pin Pin Tool file. Information is also included 
about the .c and .h files that are generated by the Pin Tool and where 
these files should be included before compiling.
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1 Selecting the Pin Group  tab displays its tab (similar to 
Figure 3-36) configured using the mapping that was done on the Pin 
Mapping  tab.

Figure 3-36. Pin Groups Tab  

2 Right-clicking the PINGROUP icon in the Define Pin Groups panel 
on the left displays a pop-up menu, and selecting the Create A Pin 
Group command displays a NewPinGrp icon (Figure 3-37).

Figure 3-37. NewPinGrp Icon  

3 Selecting the NewPinGrp icon and typing addr changes its group 
name (Figure 3-38).
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Figure 3-38. Changing NewPinGrp Icon to Addr Group Name  

4 Selecting addr0 through addr7 on the right side in the Pins/Pins 
Group panel and right clicking displays a pop-up menu that contains a 
Add Pins/Sub Pins To Pin Group command (Figure 3-39) that 
adds them to the addr group on the left side in the Define Pin 
Groups panel.

Figure 3-39. Adding Pins to the addr Group Name  

5 Selecting the PINGROUP icon again on the right in the Define Pin 
Groups pane, right-clicking to display the pop menu (Figure 3-26 on 
page 60), selecting the Create A Pin Group command, and 
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changing the NewPinGrp1 name to data creates a second pin group 
name (Figure 3-40).

Figure 3-40. Second Pin Group Named data  

6 Selecting data0 through data7 on the right side in the Pins/Pins 
Group panel and right clicking to display the pop-up menu with the 
Add Pins/Sub Pins To Pin Group command (Figure 3-41) adds 
those pins to the data group on the left side in the Define Pin 
Groups panel.

Figure 3-41. Adding Pins to the data Group Name  
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7 Selecting the addr pin group to highlight it in the Define Pin 
Groups panel on the left displays a pop-up menu that contains the 
Clone command (Figure 3-42).

Figure 3-42. Define Pin Groups addr Pop-Up Menu  

8 Selecting the Clone command in the pop-up menu creates and 
displays an addr_0 pin group (Figure 3-43).

Figure 3-43. Cloning a Pin Group  

9 Selecting the addr_0 pin group and typing addr_even changes the 
cloned pin group name (Figure 3-44).

Figure 3-44. Changing Cloned Pin Group Name  

10 Selecting the addr_even pin group expand  button opens the tree 
to display the component pins. Selecting the odd numbered channels 
and right-clicking displays a pop-up menu that contains a Delete 
command (Figure 3-45).

+
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Figure 3-45. Deleting Pins from a Pin Group  

11 Selecting the Delete command in the pop-up menu deletes the 
selected pins (Figure 3-46).

Figure 3-46. Modified addr_even Pin Group  

12 This completes the definition of the pin groups that can be used in your 
test program .C and .APG files to compile. Selecting the File > Save 
As command displays the Save As dialog box (similar to Figure 3-47).
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Figure 3-47. Pin Tool Save As Dialog Box  

13 Typing the file name demo.pin in the dialog box and then selecting 
the  button saves the Pin Tool .pin file and also generates demo.c 
and demo.h files. You should not edit the generated .c and .h files. The 
.pin file is only for use with the IDE Pin Tool. Include the generated 
demo.c and demo.h files as follows before compiling using the “make” 
command:

• Include the generated .h file in your test program .c file.

• Include the generated .h file in your .apg file.

• Include the generated .c file in your makefile.

When saving a Pin Tool file, the system first validates all the pin/cam 
settings. If there are any errors, it will print the error message to the 
Error Log tab on the Output Window. Once the setting passes the 
validation, it then saves the three files: *.pin, *.c, and *.h.

Save
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Introduction
Introduction

This chapter provides information for the Versatest Series C Program 
Debugger. The debugger presents you the high-level language source 
code that is executed directly by the CPU on the Test Site Controller. 
You are able to control the execution and inspect the status of the 
debugger at the source code C language level.

The Agilent Versatest Series test systems use VxWorks as the 
operating system to run VOS (Versatest Operating System) and the 
device test program. The C Debugger supports only test programs 
compiled with the GCC (GNU C Compiler) compiler provided with the 
system software.

Chapter Contents

This chapter contains the following information about the C Program 
Debugger:

• “C Program Debugger Overview” on page 77: Provides a description 
of what a debugging tool does and its purpose, how this debugger 
interacts with the system, the software and compiler that support 
the debugger, and a list of the tasks that this debugger supports.

• “C Program Debugger Main Window” on page 78: Provides 
descriptions of the main window’s functional areas, menus, menu 
commands, and dialog boxes.

• “C Program Debugger Getting Started” on page 114: Demonstrates 
how to load and run a test program on the system and the C 
Program Debugger and use many of the debugger’s features.

NOTE The actual colors displayed in this manual can be viewed from its 
Acrobat Reader PDF file on the Versatest Series Online Manuals CD-
ROM. If you are viewing the PDF file, you can use Acrobat Reader’s 
View > Zoom In and View > Zoom Out menu bar commands to 
adjust the display magnification to help you see graphics such as 
waveforms.
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C Program Debugger Overview

A debugger is a tool used to help track down, isolate, and remove bugs 
from software programs. Also, debuggers are tools to illuminate the 
dynamic nature of a program. It aids a programmer in understanding a 
program and then finding the cause of any discrepancy. A typical 
debugger is able to control the application being debugged so that it 
allows the programmer to follow the flow of program execution, and at 
any desired point, stop the program, and inspect the state of the 
program to verify its correctness.

Debugging is the process of correcting or modifying the code in your 
project so that you can “make” and run your project smoothly, it will 
act as you expect, and be easy to maintain later. The device test 
program debugger is a tool that provides the test program developer 
the capability to interactively develop a test program.

The C Program Debugger can load a test program from the disk and 
download it to the target CPU on the Test Site Controller. The C 
Debugger also allows the you to control the execution of the program, 
that is, launching the program, suspending the program at a desired 
place, or stepping through the program. The debugger also provides 
the capability to watch and set the values of variables.

The Agilent Versatest Series test systems use VxWorks as the 
operating system to run VOS (Versatest Operating System) and the 
device test program. The C Debugger supports only test programs 
compiled with the GCC (GNU C Compiler) compiler provided with the 
system software.

The device test program debugger is able to debug C programs but not 
APG vectors.

You can use the debugger to do the following:

• Download a device test program 

• Browse through the source code

• Set break points

• Run/terminate a device test program

• Single step

• Monitor/modify variable values

• Monitor/modify certain memory area

• Monitor calling stacks
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C Program Debugger Main Window

The C Program Debugger main window shown in Figure 4-1 is the 
debugger interface. The interface is composed of the following 
functional areas:

• Navigator Pane: See the View > Navigator Pane command on 
page 94.

• Menu Bar on page 79.

• Tool Document Window: Consists of the following C Debugger 
components:

• Source Code Browser Pane: Displays the source code for the 
selected file or function in the C Debugger Tab  (Cdeb) in 
the Navigator Pane.

• Stack Pane: See the View > Stack command on page 98.

• Memory Pane: See the View > Memory command on page 97.

• General Variables Watcher Pane: See the View > Watch 
command on page 97.

• Local Variables Pane: See the View > Variable command on 
page 96.

• Document Tabs: See the View > Document Tabs command 
on page 96.

• Toolbar: See the View > Toolbar command on page 92.

• Output Pane: See the View > Output Pane command on 
page 95.

• Status Bar: See the View > Status Bar command page 93.
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Figure 4-1. C Program Debugger Main Window  

Menu Bar

The menu bar at the top of the C Program Debugger main window 
(Figure 4-1) contains the following 10 pull-down menus from which you 
can select commands. The C Debugger menu bar and toolbar buttons 
are enabled when a C Debugger Tool Document Window is the active 
document and a test program .COF file is finished loading.

• File menu on page 80

• Edit menu on page 88

• View menu on page 91

• Tools menu on page 99

Navigator Pane Menu Bar ToolbarTool Document Window

Stack Pane

Memory Pane

General Variables Watcher Pane

Local Variables Pane

Output Pane

Status Bar

Source Code Browser Pane

Green Test Flow Arrow

 C Debugger Document Tab

Cdeb Tab

Workspace Tab

Tools Tab
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• Tester menu on page 102

• Program menu on page 104

• Build menu on page 104

• Debug menu on page 105

• Window menu on page 110

• Help menu on page 112

File Menu

Selecting File in the menu bar opens the menu in Figure 4-2.

Figure 4-2. File Menu  

The File menu contains the following commands:

•  New command on page 81

•  Open command on page 83

• Close command on page 85

• Close All command on page 85

•  Save command on page 85
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• Save As command on page 86

• Open Workspace command on page 86

• Save Workspace command on page 86

• Close Workspace Command on page 86

•  Print command on page 87

• Print Preview command on page 87

• Print Setup command on page 87

• Recent Workspaces command on page 87

• Exit command on page 87

•  Attach to Test Program on page 87

• Unload Test Program on page 87

• Data Log command on page 87

• Test Communication command on page 87

New Command (File Menu)

 Displays the New command submenu (Figure 4-3) that allows you 
to display a new Workspace or create new IDE documents. The New  
toolbar button displays a New dialog box that lists the same items to 
select as the submenu.

Figure 4-3. File > New Command Submenu  

The New command submenu contains the following commands:

• Workspace command on page 82

• C Debugger Document command on page 82

• PinTool Document command on page 82
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• Waveform Document command on page 82

• Waveform Setup Document command on page 82

• Test Program Document command on page 82

• Timing Tool Document command on page 82

• Pattern Tool Document command on page 83

• Bitmap Tool DUT Document command on page 83

• File command on page 83

Workspace Command (New Command Submenu)

Displays as the active Workspace its default with its corresponding 
Menu bar, Toolbar, Navigator pane, Output pane, and Status bar.

C Debugger Document Command (New Command Submenu)

Displays as the active document a blank C Debugger document with its 
corresponding Menu bar, Toolbar, Navigator pane, Document tab (and 
window), Output pane, and Status bar.

PinTool Document Command (New Command Submenu)

Displays as the active document a blank PinTool document with its 
corresponding Menu bar, Toolbar, Navigator pane, Document tab (and 
window), Output pane, and Status bar.

Waveform Document Command (New Command Submenu)

Displays as the active document a blank Waveform Tool document 
with its corresponding Menu bar, Toolbar, Navigator pane, Document 
tab (and window), Output pane, and Status bar.

Waveform Setup Document Command (New Command Submenu)

Displays as the active document a blank Waveform Setup Tool 
document with its corresponding Menu bar, Toolbar, Navigator pane, 
Document tab (and window), Output pane, and Status bar.

Test Program Document Command (New Command Submenu)

Note currently supported by the IDE.

Timing Tool Document Command (New Command Submenu)

Displays as the active document a blank Timing Tool document with 
its corresponding Menu bar, Toolbar, Navigator pane, Document tab 
(and graphical display window), Output pane, and Status bar.
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Pattern Tool Document Command (New Command Submenu)

Displays as the active document a blank Pattern Tool document with 
its corresponding Menu bar, Toolbar, Navigator pane, Document tab 
(and window), Output pane, and Status bar.

Bitmap Tool DUT Document Command (New Command Submenu)

Displays an Open dialog box from which you open a DUT Description 
file (.dut) to display a blank Bitmap Tool document with the loaded 
DUT file and corresponding Menu bar, Toolbar, Navigator pane, 
Document tab (and window), Output pane, and Status bar.

File Command (New Command Submenu)

Not currently supported by the IDE.

Open Command (File Menu)

 Displays the Open command submenu (Figure 4-4) that allows you 
to open a Workspace or IDE documents from the submenu list. The 
Open  toolbar button displays a generic Open dialog box from which 
you can open a selection listed in the submenu.

Figure 4-4. Open Command Submenu  

The Open command submenu contains the following commands that 
display an Open dialog box similar to Figure 4-5:

• C Debugger Document command on page 84

• PinTool Document command on page 84

• Waveform Document command on page 85

• Waveform Setup Document command on page 85
Versatest Series IDE User’s Guide 83

Revision D, May 2005



Chapter 4  C Program Debugger

C Program Debugger Main Window
• Test Program Document command on page 85

• Timing Tool Document command on page 85

• Pattern Tool Document command on page 85

• Bitmap Tool DUT Document command on page 85

• File command on page 85

Figure 4-5. File > Open Dialog Box  

C Debugger Document Command (Open Command Submenu)

Displays an Open dialog box (Figure 4-5) to select a previously saved C 
Debugger Tool document file with a *.COF extension. Typically the 
.COF for the test program is located in the P:\SRC folder.

The C Program Debugger loads a test program via loading the .COF 
file format compiled by the GCC (GNU C Compiler). The .COF file is 
the C language test program object code file that is created by the GNU 
compiler when you “make” your test program. It is the object code file 
that is downloaded to the test sites. During the loading of the test 
program, the debugger extracts debug information that is put into the 
.COF file by the compiler. Thus the debugger knows the source code 
files for the loaded test program.

PinTool Document Command (Open Command Submenu)

Displays an Open dialog box (similar to Figure 4-5) to select a 
previously saved PinTool document file with a *.pin file extension.
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Waveform Document Command (Open Command Submenu)

Displays an Open dialog box (similar to Figure 4-5) to select a 
previously saved Waveform document file with a *.dnc file extension.

Waveform Setup Document Command (Open Command Submenu)

Displays an Open dialog box (similar to Figure 4-5) to select a 
previously saved Waveform Setup document file with a *.stp file 
extension.

Test Program Document Command (Open Command Submenu)

Displays an Open dialog box (similar to Figure 4-5) to select a 
previously saved Test Program Tool document file with a *.tpg file 
extension.

Timing Tool Document Command (Open Command Submenu)

Displays an Open dialog box (similar to Figure 4-5) to select a 
previously saved Timing Tool document file with a *.vtt file extension.

Pattern Tool Document Command (Open Command Submenu)

Displays an Open dialog box (similar to Figure 4-5) to select a 
previously saved Pattern Tool document file with an *.apg2 file 
extension.

Bitmap Tool DUT Document Command (Open Command Submenu)

Displays an Open dialog box (similar to Figure 4-5) to select a 
previously saved Bitmap Tool DUT definition document file with a 
*.dut file extension.

File Command (Open Command Submenu)

Displays an Open dialog box (similar to Figure 4-5) to select a file for 
display.

Close Command (File Menu)

Closes the active tool document.

Close All Command (File Menu)

Closes all tool documents.

Save Command (File Menu)

 Saves the active document file.
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Save As Command (File Menu)

Displays the Save As dialog box to save the active tool document file 
(similar to Figure 4-6).

Figure 4-6. Save As Dialog Box   

Open Workspace Command (File Menu)

Displays an Open Workspace dialog box with a *.wsp extension. If 
changes have been made to the current workspace, you will be asked if 
you would like to save the changes before closing the current 
workspace and opening another. The Workspace consists of the tools, 
layout, and open documents.

Save Workspace Command (File Menu)

Saves the current workspace with a *.wsp extension. The Workspace 
consists of the tools, layout, and open documents. This command 
enables you to save the tools, layout, and open documents’ current 
state, and later resume with the same Workspace by using the File > 
Open Workspace command.

Close Workspace Command (File Menu)

Closes the current workspace. If changes have been made to the 
current workspace, you will be asked if you would like to save the 
changes before closing the current workspace.
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Print Command (File Menu)

 Prints the source code of the function currently displaying in the 
Source Code Browser Pane.

Print Preview Command (File Menu)

Displays a Print Preview window that allows you to view the source 
code in Source Code Browser window before printing. Pressing the  
key returns to the C Program Debugger main window.

Print Setup Command (File Menu)

Displays a printer setup dialog box that allows you to select and 
configure a printer.

Recent Workspaces Command (File Menu)

Displays a Recent Workspaces submenu from which you can select a 
workspace.

Exit Command (File Menu)

Closes the IDE. If the workspace or any other tool document files have 
changed, you will be asked if you would like to save them.

Attach to Test Program Command (File Menu)

 If the IDE is already set online (connected to the tester), this 
command attaches the C Debugger to the site’s .COF file specified in 
the toolbar’s  Site Connect Status field.

Unload Test Program Command (File Menu)

Unloads the .COF file test program information from the C Program 
Debugger and displays its default main window.

Data Log Command (File Menu)

Supported for Agilent internal use only.

Test Communication Command (File Menu)

Supported for Agilent internal use only.

Esc
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Edit Menu

Selecting Edit in the menu bar opens the menu in Figure 4-7. Most of 
the commands in this menu are not currently supported by the C 
Debugger because after the compiled test program .COF file is loaded 
the source code files are not currently editable from this tool.  

Figure 4-7. Edit Menu  

The Edit menu contains the following commands:

• Undo command on page 88

• Redo command on page 88

•  Cut command on page 88

•  Copy command on page 89

•  Paste command on page 89

• Find command on page 89

• Replace command on page 89

• Find in Files command on page 89

Undo Command (Edit Menu)

Not currently supported by the C Debugger.  

Redo Command (Edit Menu)

Not currently supported by the C Debugger.  

Cut Command (Edit Menu)

 Not currently supported by the C Debugger.  
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Copy Command (Edit Menu)

 Not currently supported by the C Debugger.  

Paste Command (Edit Menu)

 Not currently supported by the C Debugger.  

Find Command (Edit Menu)

Displays the Find dialog box (Figure 4-8) used for text searching.

Figure 4-8. Find Dialog Box  

Replace Command (Edit Menu)

Displays the Replace dialog box (Figure 4-9) that provides text 
replacement capability based on the criteria you specify.

Figure 4-9. Replace Dialog Box  

Find in Files Command (Edit Menu)

Displays the Find in Files dialog box (Figure 4-10) that provides search 
capability based on the criteria you specify.
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The dialog box contains the following fields:

• Find What – Enter the name of symbol or text you would like to 
find.

• In files/file types – The type of files to look in (referenced by 
extension), or specific files that you would like to search (for 
example, "*.c" or ".apg", or "p:\src\myprogram\file1"). If you would 
like to specify multiple types of files, separate each term by a space, 
for example, "*.c *.apg p:\src\myprogram\file1".

• In folder – Enter the name of the directories you would like to 
search in. If you click on the button next to this field (labeled "…"), 
you can select a folder through a GUI file dialog interface.

• Match whole word only – If you check this box, only the lines 
containing the target as a whole (and not as part of another word) 
will be displayed.

• Match case  – If you check this box, the lines containing the target 
will be displayed only if the cases match.

• Regular Expressions – If you check this box, the text in the 
Find What field will be interpreted as a regular expression,

• Look in subfolders  – If you check this box, in addition to 
searching the folders specified in the In Folder field, the 
subdirectories of the folders specified in the In Folder field will 
be searched.

• Find in Workspace – If you check this box, only the files 
contained in the workspace will be searched. The "In Folder" field 
will be ignored.

After clicking on the  button, the Find in Files output tab will be 
brought to the front in the Output Pane, the results from the search 
process will be displayed as they are generated. If you double-click on 
any of the lines, the file specified on that line will be opened, and the 
file window will be scrolled to the location specified by the line you 
double-clicked.

Find
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Figure 4-10. Find in Files Dialog Box  

View Menu

Selecting View in the menu bar opens the menu in Figure 4-11.

Figure 4-11. View Menu  

The View menu contains the following commands:

• Toolbar command on page 92

• Status Bar command on page 93

• Navigator Pane command on page 94

• Output Pane command on page 95

• Document Tabs command on page 96

• Variable command on page 96

• Watch command on page 97
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• Memory command on page 97

• Stack command on page 98

• Break Point command on page 98

Toolbar Command (View Menu)

Displays or hides the toolbar shown in Figure 4-12. The toolbar 
displays at the top of the C Program Debugger main window when a ✓  
is displayed in front of the Toolbar command. Clicking on the buttons 
in the toolbar give you quick access to many of the menu bar 
commands. The C Debugger menu bar and toolbar buttons are enabled 
after a test program .COF file is finished loading and it is selected as 
the active document window.

Figure 4-12. C Program Debugger Toolbar  
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The toolbar contains the following command buttons:

Status Bar Command (View Menu)

Displays or hides the Status Bar. The Status Bar displays at the 
bottom of the C Program Debugger main window when a ✓  is displayed 
in front of the Status Bar command.

 File > New on page 81  Tester > Set Online on page 103

 File > Open on page 83  Tester > Set Offline on page 103

 File > Save on page 85  Tester > Acquire Data on page 103 (not 
supported by C Debugger)

 Edit > Cut on page 88  Tester > Apply Changes on page 103 (not 
supported by C Debugger)

 Edit > Copy on page 89  Tester > Abort Acquire on page 103 (not 
supported by C Debugger)

 Edit > Paste on page 89  IDE Site Connect Status

 File > Print on page 87  Tester > Power On on page 103

 Help > About V4400 Software on 
page 112

 Tester > Power Off on page 103

 Help > Help Topics on page 112

 File > Attach page 87  Debug > Step Over on page 106

 Debug > Run on page 106  Debug > Step Out on page 108

 Debug > Stop on page 109  View > Local Variables on page 96

 Debug > Continue on page 109  View > Watcher on page 97

 Debug > Insert/Remove Breakpoint on 
page 108

 View > Memory on page 97

 Debug > Step In on page 106  View > Calling Stack on page 98
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The Status Bar displays which line (Ln) and column (Col) the cursor is 
active in the Source Code Browser Pane. It also displays the last 
command executed by the C Debugger such as Run program, Step 
in, Step Over, and so forth.

Navigator Pane Command (View Menu)

Displays or hides the Navigator Pane (similar to Figure 4-13 or Figure 
4-1 on page 79). The Navigator Pane displays on the left side of the C 
Debugger main window when a ✓  displays in front of its command in 
the View menu.

The C Debugger is associated with the following two tabs on the 
Navigator Pane:

• Tools Tab : Within the Tools Tab is a CDebugger icon that can 
be used to launch the tool. Double-clicking the icon displays the 
default C Debugger Document Window.

• C Debugger Tab  (Cdeb): The C Debugger Tab lists all the 
source code file names and function names for the loaded test 
program. Navigating to and selecting a source code file name or 
function displays its source code in the Source Code Browser 
window (similar to Figure 4-1 on page 79).
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Figure 4-13. Navigator Pane C Debugger (Cdeb) Tab   

Output Pane Command (View Menu)

Displays the Output Pane (similar to Figure 4-1 on page 79) when a ✓  
displays in front of its command in the View menu.

The C Debugger is associated with the following tabs in the Output 
Pane:

• VOS Command tab: The VOS Command tab is enabled when the 
IDE is set online by the selecting the yellow Set Online  toolbar 
button or the corresponding Tester > Set Online command. 
The VOS Command tab allows you to enter VOS terminal 
commands and display the results on the tab and in the 
corresponding test site window in the VK Test Station main 

Tools Tab Cdeb Tab

Navigator Pane
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window. See the “VOS Terminal Commands” chapter in the 
Command Reference Volume 2 for the available commands.

• Find in Files tab: This tab displays output from a Find In Files 
process as it is generated from the results of the Edit > Find In 
Files command dialog box (Figure 4-10 on page 91).

Document Tabs Command (View Menu)

Displays the Document Tabs at the bottom of the Tool Document 
Window (similar to Figure 4-1 on page 79) when a ✓  displays in front of 
its command in the View menu.

Variable Command (View Menu)

 Displays or hides the Local Variables Pane in the C Debugger 
main window (similar to Figure 4-14 or Figure 4-1 on page 79). The 
Local Variables Pane displays when a ✓  is displayed in front of the its 
command in the View menu.

Figure 4-14. Local Variables Pane  

An important feature the debugger provides is the capability to 
monitor the values of local variables. The C Program Debugger has 
various features that provide this capability.

When you step into a function, the values of local variables need to be 
checked frequently. The debugger provides a Local Variables Pane that 
lists all the local variables. It automatically queries for the values of 
those variables and then displays them every time you single step or 
hit a breakpoint.

If the variable is an array, structure, or other type of variable that 
contains sub-items, you can click the expand  button on the left side 
of the variable's name to expand the variable.

+
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Watch Command (View Menu)

 Displays or hides the General Variables Watcher Pane in the C 
Debugger main window (similar to Figure 4-15 or Figure 4-1 on page 
79). The General Variables Watcher Pane displays when a ✓  is 
displayed in front of its command in the View menu.

Figure 4-15. General Variables Watcher Pane  

Besides viewing local variables, you also need to monitor the values of 
global variables and modify the values of local and global variables. For 
this the debugger provides a general variables watcher. You can type 
in the name of a variable in the Variable name pane or highlight 
the variable in the browser window using the mouse and drag it to the 
pane, and the value of that variable displays on the right side of the 
pane. The debugger automatically queries the target for the values of 
those variables and then displays them every time you single step or 
hit a breakpoint. You can modify the values of the variables by clicking 
a variable value and typing in a new value.

Memory Command (View Menu)

 Displays or hides the Memory Pane in the C Debugger main 
window (similar to Figure 4-16 or Figure 4-1 on page 79). The Memory 
Pane displays when a ✓  is displayed in front of its command in the 
View menu.

The Memory Pane allows you to browse through the target memory 
controlled by the CPU on the Test Site Controller. You can enter a 
specific Address to browse and then the debugger queries the target 
to display its contents.

You can press the /  keys, the /  arrow keys, the 
scroll bar, or enter a new memory address to see the contents of a 
different memory area.

Page Up Page Down
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Figure 4-16. Memory Pane  

Stack Command (View Menu)

 Displays or hides the Stack Pane in the C Debugger main window 
(similar to Figure 4-17 or Figure 4-1 on page 79). The Stack Pane 
displays when a ✓  is displayed in front of its command in the View. It 
displays the current calling stack with the current function, the parent 
function, and the passed parameters.

When you step into a function, it is useful to know the parent function 
and the parameters passed into the function. The Stack Watcher pane 
provides the capability for you to watch the parent functions of the 
current function and the parameters passed to it.

Figure 4-17. Stack Pane  

Break Point Command (View Menu)

Displays the BreakPoint dialog box (similar to Figure 4-18). It displays 
the memory address location of each break point, the source code path 
and file name, and the source code line number of the break point. You 
can use this dialog box to remove break points. See the Debug > 
Insert/Remove Breakpoint command on page 108 for information 
about setting break points.
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Figure 4-18. BreakPoint Dialog Box  

Tools Menu

Selecting Tools in the menu bar opens the menu in Figure 4-19. The 
commands in the Tools menu are only for Agilent-internal use for the 
Waveform Tool.

Figure 4-19. Tools Menu  

The Tools menu contains the following commands:

• Options command on page 99

• Properties command on page 101

Options Command (Tools Menu)

Displays the Options submenu shown in Figure 4-20.
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Figure 4-20. Options Submenu  

The Options command submenu contains the following commands that 
are not currently supported by the IDE:

• Ide Options command on page 100

• TPIParser Options command on page 100

• TesterTool Options command on page 100

• StaticScopeTool Options command on page 100

• StaticPinTool Options command on page 100

• StaticTPT Options command on page 101

• CDebugTool Options command on page 101

Ide Options Command (Options Command Submenu)

Not currently supported by the IDE.

TPIParser Options Command (Options Command Submenu)

Not currently supported by the IDE.

TesterTool Options Command (Options Command Submenu)

Not currently supported by the IDE.

StaticScopeTool Options Command (Options Command Submenu)

Not currently supported by the IDE.

StaticPinTool Options Command (Options Command Submenu)

Not currently supported by the IDE.
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StaticTPT Options Command (Options Command Submenu)

Not currently supported by the IDE.

CDebugTool Options Command (Options Command Submenu)

Not currently supported by the IDE.

Properties Command (Tools Menu)

Displays the Properties submenu shown in Figure 4-21.

Figure 4-21. Properties Submenu  

The Properties command submenu contains the following commands 
that are not currently supported by the IDE:

• Ide Properties command on page 101

• TPIParser Properties command on page 101

• TesterTool Properties command on page 102

• StaticScopeTool Properties command on page 102

• StaticPinTool Properties command on page 102

• StaticTPT Properties command on page 102

• CDebugTool Properties command on page 102

Ide Properties Command (Properties Command Submenu)

Not currently supported by the IDE.

TPIParser Properties Command (Properties Command Submenu)

Not currently supported by the IDE.
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TesterTool Properties Command (Properties Command Submenu)

Not currently supported by the IDE.

StaticScopeTool Properties Command (Properties Command 
Submenu)

Not currently supported by the IDE.

StaticPinTool Properties Command (Properties Command Submenu)

Not currently supported by the IDE.

StaticTPT Properties Command (Properties Command Submenu)

Not currently supported by the IDE.

CDebugTool Properties Command (Properties Command Submenu)

Not currently supported by the IDE.

Tester Menu

Selecting Tester in the menu bar opens the menu in Figure 4-22.

Figure 4-22. Tester Menu  

The Tester menu contains the following commands:

•  Set Online command on page 103

•  Set Offline command on page 103

•  Acquire Data command on page 103

•  Apply Changes command on page 103

•  Abort Acquire command on page 103

•  Tester Power On command on page 103

•  Tester Power Off command on page 103
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Set Online Command (Tester Menu)

 Connects the IDE to the tester for the following tools that support 
online mode:

• C Program Debugger (currently has no offline capability)

• Pattern Tool (currently has no offline capability)

• Waveform Tool

• Timing Tool

Set Offline Command (Tester Menu)

 Disconnects the IDE from the tester. The following tools support 
offline mode:

• Pin Tool (currently has no online capability)

• Waveform Tool (viewing saved files only)

• Timing Tool (viewing saved files only)

• Bitmap Tool (currently has no online capability)

Acquire Data Command (Tester Menu)

 Not currently supported by the C Debugger. The Timing Tool 
supports this command.

Apply Changes Command (Tester Menu)

 Not currently supported by the C Debugger. The Timing Tool 
supports this command.

Abort Acquire Command (Tester Menu)

 Not currently supported by the C Debugger. The Timing Tool 
supports this command.

Tester Power On Command (Tester Menu)

 Same as the VK Test Station main window Utilities > Power 
On command and its corresponding  toolbar button. Resets and 
powers up the test sites (Test Head).

Tester Power Off Command (Tester Menu)

 Same as the VK Test Station main window Utilities > Power 
Off command and its corresponding  toolbar button. Turns off 
power to the test sites (Test Head).
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Program Menu

Selecting Program in the menu bar opens the menu in Figure 4-23. The 
Program menu is not currently supported by the IDE.

Figure 4-23. Program Menu  

The Program menu contains the following commands that are 
supported by the Test Program Tool:

• Set Active Test Program command on page 104

• Add Files to Test Program command on page 104

• Remove from Test Program command on page 104

Set Active Test Program Command (Program Menu)

Not currently supported by the IDE.

Add Files to Test Program Command (Program Menu)

Not currently supported by the IDE.

Remove from Test Program Command (Program Menu)

Not currently supported by the IDE.

Build Menu

Selecting Build in the menu bar opens the menu in Figure 4-24. The 
Build menu is not currently supported by the IDE.

Figure 4-24. Build Menu  
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The Build menu contains the following commands:

• Build command on page 105

• Compile command on page 105

• Compile Patterns command on page 105

• Compile C Sources command on page 105

• Rebuild All command on page 105

• Stop Build command on page 105

• Clean Build command on page 105

Build Command (Build Menu)

Not currently supported by the IDE.

Compile Command (Build Menu)

Not currently supported by the IDE.

Compile Patterns Command (Build Menu)

Not currently supported by the IDE.

Compile C Sources Command (Build Menu)

Not currently supported by the IDE.

Rebuild All Command (Build Menu)

Not currently supported by the IDE.

Stop Build Command (Build Menu)

Not currently supported by the IDE.

Clean Build Command (Build Menu)

Not currently supported by the IDE.

Debug Menu

Selecting Debug in the menu bar opens the menu in Figure 4-25.
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Figure 4-25. Debug Menu  

The Debug menu contains the following commands:

•  Run command on page 106

•  Step Into command on page 106

•  Step Over command on page 106

•  Step Out command on page 108

•  Insert/Remove Breakpoint command on page 108

•  Continue command on page 109

•  Stop command on page 109

• Argument command on page 110

Run Command (Debug Menu)

 Runs the test program to completion or to the first break point. See 
the Debug > Insert/Remove Breakpoint command on page 108 
for information about setting break points. This command is also 
executed by selecting the  key.

Step Into Command (Debug Menu)

 Steps into a subroutine. This command is also executed by 
selecting the  key.

Step Over Command (Debug Menu)

 Steps to the next C level instruction in the same routine. This 
command is also executed by selecting the  key.When you single 
step to a break point, the program stops with the green test flow arrow 
pointing in that line (similar to Figure 4-26).

F3

F11

F10
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Figure 4-26. Test Flow Stopped at Function with Break Point  

Single stepping into a function causes the debugger to jump to and 
display the source code of the function in the Source Code Browser 
Pane, and the green test flow arrow stops at the next C level 
instruction.

Single stepping is not allowed to Versatest Series C language 
commands. The C Debugger steps over all Versatest Series C language 
commands. See the “General Command Set” table in chapter 1 of the 
Versatest Series Command Reference Volume 1 for a listing of the C 
language commands with brief descriptions or chapter 2, “C Language 
Commands,” for detailed descriptions.
Versatest Series IDE User’s Guide 107

Revision D, May 2005



Chapter 4  C Program Debugger

C Program Debugger Main Window
Step Out Command (Debug Menu)

 Goes back to the parent routine that called the current routine. 
This command is also executed by selecting the  +  keys.

Insert/Remove Breakpoint Command (Debug Menu)

 Inserts a break point in the Source Code Browser Pane in the line 
of code where the mouse pointer cursor is placed (similar to 
Figure 4-27). When you set a break point, a red diamond tag displays 
in the gray boarder area on the left side of the Browser window. 
Repeating the process in other lines of code sets additional break 
points. This command is also executed by selecting the  key. 
Reselecting the command in a line of code with a break point, removes 
it. See the View > BreakPoint command on page 98 that lists all of 
the break points with memory address locations, source code file names 
and line numbers, and how to remove individual or multiple break 
points.

Setting break points is a common technique used to debug programs. 
Setting a break point at a certain location in the program forces the 
program to be suspended exactly at that location.

The break point can only be set on a source line. Therefore, for the 
following segment of source code, you would be able to set a break point 
on line 5 but not line 3.

Line1: int test(void)
Line2: {
Line3: int I;
Line4:
Line5: I=5
Line6:}

Shift F11

F9
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Figure 4-27. Browser Pane Displaying Break Points  

Continue Command (Debug Menu)

 Continues test program execution after it has been halted at a 
break point. This command is also executed by selecting the  key.

Stop Command (Debug Menu)

 Stops test program execution. You must select the  Debug > 
Run command to restart program execution from the beginning. This 
command is also executed by selecting the  key.

Break
Points

Green
Test
Flow
Arrow

F5

F12
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Argument Command (Debug Menu)

Displays the Argument dialog box (Figure 4-28). This dialog box 
specifies the argument that VOS passes to SHELL2A.C (V4400) or 
SHELL2B.C’s (V5400) main function that calls different functions in 
your DEVICE.C program based on those arguments. The default and 
most commonly used argument is test. It causes 
SHELL2A.C/SHELL2B.C to call the DoTestProgram function when 
you run your test program.

Another commonly used argument that can be entered in the dialog 
box is init. The init argument re-initializes the system and places 
it in a known state.

Other arguments that can be used can be found in the 
shell2a.c/shell2b.c file.

Figure 4-28. Argument Dialog Box  

Window Menu

Selecting Window in the menu bar opens the menu in Figure 4-29.

Figure 4-29. Window Menu  

The Window menu contains the following commands:

• New Window command on page 111
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• Close command on page 112

• Close All command on page 112

• Cascade command on page 112

• Tile command on page 112

• Minimize All command on page 112

New Window Command (Window Menu)

Displays a duplicate Source Code Browser Pane in the C Debugger 
main window (similar to Figure 4-30 or Figure 4-1 on page 79). The 
Source Code Browser window displays the source code for the file 
selected in the Project window.

Figure 4-30. Source Code Browser Pane  
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Close Command (Window Menu)

Closes the active tool document window.

Close All Command (Window Menu)

Closes all tool document windows with their corresponding tabs.

Cascade Command (Window Menu)

Arranges all open tool document windows in an overlapping fashion 
one on top of another with the title bar of each visible.

Tile Command (Window Menu)

Tiles all open tool document windows in a non-overlapping fashion.

Minimize All Command (Window Menu)

Not currently supported by the IDE.

Help Menu

Selecting Help in the menu bar opens the menu in Figure 4-31.

Figure 4-31. Help Menu  

The Help menu contains the following command:

Help Topics Command (Help Menu)

 Not currently supported.

About V4400 Software Command (Help Menu)

 Displays the About V4400 Series Tester Software dialog box that 
contains software component version and copyright information 
(similar to Figure 4-32).
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Figure 4-32. About V4400 Software Dialog Box   
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C Program Debugger Getting Started

This section demonstrates how to load and run a test program on the 
system and the C Program Debugger and use many of the debugger’s 
features. For additional information about the C Debugger, see the “C 
Program Debugger Main Window” section on page 78 that provides 
descriptions of all the menus, menu commands, and dialog boxes that 
make up the tool’s interface.

Getting Started Contents

This Getting Started describes how to perform the following tasks:

• “Loading the Test Program on the System” on page 114 
demonstrates how to load a plan file and power on the system from 
the VK Test Station main window.

• “Displaying the C Program Debugger Main Window” on page 118 
launches the IDE, connects the IDE to the tester, launches the C 
Program Debugger application, loads the test program, and 
navigates to browse source code.

• “Setting Break Points” on page 124 explains where break points 
can be set, and demonstrates how to set and remove break points.

• “Launching the Program” on page 126 sets an argument and runs 
the test program to a break point.

• “Single Stepping” on page 127 describes the three types of single 
steps, steps through the program, displays the output results in the 
VK Test Station main window, steps into and out of a function and 
displays its source code, and how to remove all or selected break 
points in a program.

Loading the Test Program on the System

This section describes how to load a plan file and power on the system 
from the VK Test Station main window.

1 Selecting  > All Programs > Versatest Test System 
Software > VK Test Station displays the VK Test Station main 
window (similar to Figure 4-33).
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Figure 4-33. VK Test Station Main Window  

2 In the menu bar, selecting Init Lot > Enter Lot Information 
command displays the Initialize Test Station Setup dialog box (similar 
to Figure 4-34) that is used to set up each lot for testing.

Menu Bar Toolbar Testing Status Window

Datalog Window

Status Bar
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Figure 4-34. Initialize Test Station Setup Dialog Box  

3 Selecting the  button displays an Open dialog box that lists the 
available plan files. The Test plan files define the tester setup that is 
used. The demo.pln plan file will be used for this example.

4 In the Open dialog box, the P:\PLN\demo.pln plan file is selected for 
this example, and then the  button is selected to display the 
Initialize Test Station Setup dialog box with the selected plan file 
displaying in the Test Plan field (Figure 4-34).

5 Selecting the  button in the dialog box (Figure 4-34) by default 
displays consecutively two Red Hand Alert dialog boxes warning about 
the loss of summary data, and to Z down the wafer and disconnect all 
DUTs prior to initialization of the test sites. The 
TEST_PLAN_WARNING configuration plan file switch controls 
whether the Alert dialog boxes display.

Test Plan

Save

Save
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6 Selecting  in the two Red Hand Alert dialog boxes displays the Test 
Plan Validation dialog box (Figure 4-35). The VALIDATE 0x10 plan 
file test switch controls whether this dialog box displays. It displays 
the corresponding checksums and adds them to the summary file.

Figure 4-35. Test Plan Validation Dialog Box  

7 Selecting  begins the test head power on and downloads the 
Versatest Operating System (VOS) and the test program files specified 
in the plan file. The power on is complete when the terminal prompt 
A1> displays in the Datalog window (Figure 4-36).

OK

OK
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Figure 4-36. VK Test Station Main Window After Power On  

Displaying the C Program Debugger Main Window

This section launches the IDE, connects the IDE to the tester, launches 
the C Program Debugger application, loads the test program, and 
navigates to browse source code. Prior to launching the IDE and the C 
Debugger application, the system must be powered on as described in 
the previous “Loading the Test Program on the System” procedure that 
starts on page 114. 

Datalog Window

Terminal Prompt

Site Status Window
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1 Selecting  > All Programs > Versatest Test System 
Software > Integrated Development Environment displays 
the default V4400 Series Tester Software main window that contains 
the Integrated Development Environment or IDE (similar to 
Figure 4-37). The Menu bar and Toolbar are context sensitive and 
change for the selected active tool or document. The menus and 
Toolbar show and enable only the commands and buttons that are 
relevant to the tool or document you select.

Figure 4-37. V4400 Series Tester Software IDE Main Window  

2 Selecting the yellow light bulb Set Online  toolbar button or 
corresponding Tester > Set Online command enables the IDE to 
connect to the tester when the Site Connect Status drop-down list box 
Site: A1  is enabled as shown in the toolbar in Figure 4-38.

Navigator Pane Menu Bar Toolbar

Tool Document Window

Output Pane

Workspace Tab

Tools Tab

Status Bar
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Figure 4-38. IDE Main Window Set Online  

3 Choosing the site that the IDE connects to is done by selecting the 
down-arrow  on the right side of the Site Connect Status drop-down 
list box to display the available sites and selecting from the list (similar 
to Figure 4-39). Selecting a tool makes the connection to that site and 
disables the Site Connect Status drop-down list box.

Figure 4-39. Site Connect Status Drop-Down List Box  

4 Selecting the Tools Tab  icon in the Navigator Pane displays its tab 
(Figure 4-40).

Output Pane

Site Connect Status drop-down list box
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Figure 4-40. Navigator Pane Tools Tab  

5 Double-clicking CDebugger under Debug Tools (Figure 4-40) 
displays the C Debugger as the active tool in the Tool Document pane, 
and connects the IDE to the previously selected test site and disables 
the Site Connect Status drop-down list box (Figure 4-41). This also 
adds the C Debugger  (Cdeb) tab to the Navigation pane, its menu 
bar and toolbar, and redisplays the Workspace tab  in the Navigator 
pane.

The C Program Debugger loads a test program via loading the .COF 
file format compiled by the GCC (GNU C Compiler). The .COF file is 
the C language test program object code file that is created by the GNU 
compiler when you “make” your test program. It is the object code file 
that is downloaded to the test sites. During the loading of the test 
program, the debugger extracts debug information that is put into the 
.COF file by the compiler. Thus the debugger knows the source code 
files for the loaded test program.

Navigator Pane

Workspace Tab
Tools Tab
Versatest Series IDE User’s Guide 121

Revision D, May 2005



Chapter 4  C Program Debugger

C Program Debugger Getting Started
Figure 4-41. IDE Displaying C Debugger  

6 Selecting the Cdeb  tab in the Navigation Pane displays its tab 
that lists all the source code file names and function names for the 
loaded test program (similar to Figure 4-42).

Output Pane

Cdeb Tab

C Debugger Document Tab

Workspace Tab
Tools Tab

Navigator Pane Menu Bar Toolbar

Tool Document Window

Status Bar
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Figure 4-42. C Debugger Cdeb Tab  

7 In the C Debugger  tab, navigating to and double-clicking the 
dtest.c > dtestmain function displays it in the Source Code 
Browser Pane. Selecting the Tool Document Window’s maximize  
button displays it full-screen (similar to Figure 4-43).

Workspace Tab

Tools Tab
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Figure 4-43. C Debugger Displaying dtest.c Document Window  

Setting Break Points

Setting break points is a common technique used to debug programs. 
Setting a break point at a certain location in the program forces the 
program to be suspended exactly at that location.

To set or remove a break point, place the cursor in the line of code in 
the Source Code Browser Pane and select Debug > Insert/Remove 
Breakpoint command or press the  key. The break point can only 
be set on a source line. Therefore, for the following segment of source 
code, you would be able to set a break point on line 5 but not line 3. If 
you attempt to set a break point in a line of code other than a source 
line, nothing will happen.

Line1: int test(void)
Line2: {
Line3: int I;
Line4:
Line5: I=5
Line6:}

Navigator Pane Tool Document Window

dtestmain

Cdeb Tab

Source Code Browser Pane

dtest.c Document Tab

F9

Workspace Tab

Tools Tab
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1 In the C Debugger  tab, navigating to and double-clicking the 
main.c > main function displays it in the Source Code Browser Pane 
(similar to Figure 4-44).

Figure 4-44. Source Code Browser Pane Displaying a Break Point  

2 In the Source Code Browser Pane, placing the cursor in the source line 
shown in Figure 4-44 and selecting the Debug > Insert/Remove 
Breakpoint command, its  toolbar button, or pressing the  key 
inserts a break point.

Navigator Pane

Break Point

Cdeb Tab

C Debugger main.c Document Tab

main Function

Status Bar (Ln 32, Col 5 Set Breakpoint)

F9
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When you set a break point, a red diamond tag displays in the gray 
boarder area on the left side of the Browser window (Figure 4-44). A 
break point is set at the target. If you press  on the same line, the 
red diamond disappears and the break point is removed from the 
corresponding target. Note that the Status bar at the bottom of the 
window displays which line (Ln) and column (Col) the cursor is active.

Launching the Program

This section runs the test program to the break point.

1 Selecting the Debug > Argument command displays the Argument 
dialog box (similar to Figure 4-45). The default argument is test. 
This dialog box specifies the argument that VOS passes to SHELL2A.C 
(V4400) or SHELL2B.C’s (V5400) main function that calls different 
functions in your DEVICE.C program based on those arguments. The 
default and most commonly used argument is test. It causes 
SHELL2A.C/SHELL2B.C to call the DoTestProgram function when 
you run your test program.

Another commonly used argument that can be entered in the dialog 
box is init. The init argument re-initializes the system and places 
it in a known state.

Figure 4-45. Argument Dialog Box  

2 Typing init in the text box to replace the default test argument 
(Figure 4-45) and selecting  closes the dialog box.

3 Selecting the Run  toolbar button or the Debug > Run command 
runs the test program to the break point (Figure 4-46). A green test 
flow arrow displays over the break point where the C Debugger has 
paused program execution.

F9

OK
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Figure 4-46. Program Runs to Break Point  

Single Stepping

Single stepping is another common technique used in debugging 
programs. There are three types of single steps and the C Program 
Debugger supports all three as follows:

• Step in (Debug > Step Into or  toolbar button): Steps into a 
subroutine.

• Step through (Debug > Step Over or  toolbar button): Steps 
to the next C level instruction in the same routine.

• Step out (Debug > Step Out or  toolbar button): Goes back to 
the parent routine that called the current routine.

Single stepping is not allowed to the C language commands. The C 
Debugger steps over all C language commands. See the “General 
Command Set” table in chapter 1 of the Versatest Series Command 
Reference Volume 1 for a listing of the C language commands with brief 
descriptions or chapter 2, “C Language Commands,” for detailed 
descriptions.

1 Selecting the Debug > Step Over command or Step Over  
toolbar button steps to the next C level instruction (Figure 4-47). The 
green test flow arrow indicates where the program is currently 
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suspended. Note that since init was passed as the argument, the 
program is following the “init” branch.

Figure 4-47. Program Single Stepping  

2 Selecting the Debug > Step Over command or Step Over  
toolbar button again steps to the next line in the program 
(Figure 4-48).

Figure 4-48. Single Stepping to the Next Line  

3 The VK Test Station Main Window displays Initialization in the 
Datalog Window (Figure 4-49) after execution of the
printf (“Initialization\n”); output function.
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Figure 4-49. VK Test Station Main Window Displaying “init” Branch Print Output  

4 Scrolling to line 60 a second break point is set and the Continue  
toolbar button or Debug > Continue command is selected to execute 
the program up to the second break point (Figure 4-50). This line is a 
function call to dtestmain.

Site A1 Datalog Window

Initialization Displaying at Terminal Prompt
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Figure 4-50. Setting and Continuing to a Second Break Point  

5 Selecting the Debug > Step In command or Step In  toolbar 
button steps into the dtestmain function and displays its source code 
in the Source Code Browser Pane and its dtest.c Document Tab 
(Figure 4-51).

Navigator Pane

dtestmain Function

Green Test Flow Arrow Displays over Red Break Point

C Debugger main.c Document Tab

Source Code Browser Pane

Status Bar (Ln 60, Col 5 Program is Suspended)
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Figure 4-51. Stepping Into and Displaying dtestmain Function  

6 Selecting the Debug > Step Out command or Step Out  toolbar 
button returns to the calling main function (Figure 4-52).

Navigator Pane

dtestmain Function

Green Test Flow Arrow Points
to Where Program is Suspended

Cdeb Tab
Source Code Browser Pane

dtest.c Document Tab

Status Bar (Ln 60, Col 2
Step Into, Program is Suspended)
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Figure 4-52. Step Out to Calling main Function  

7 Selecting the View > Break Point command displays the 
Breakpoint dialog box that displays the memory address location of 
each break point, the source code path and file name, and the source 
code line number (Figure 4-53). This dialog box allows you to view all 
break points and delete any undesired ones.

dtestmain Function

Green Test Flow Arrow Points
to Where Program is Suspended

main.c Document Tab

Source Code Browser Pane

Cdeb Tab

Navigator Pane

Status Bar (Ln 60, Col 5,
Step Out, Program is Suspended)
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Figure 4-53. BreakPoint Dialog Box Listing Break Points  

8 Selecting the  button removes all the break points 
(Figure 4-54) and then the  button closes the dialog box.

Figure 4-54. BreakPoint Dialog Box with Break Points Removed  

9 Since there are no more break points, selecting the Continue  
toolbar button or Debug > Continue command finishes the 
execution of the test program.

Remove All

Close
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Introduction
Introduction

This chapter provides information for the Versatest Series Pattern 
Tool. The Pattern Tool provides a means for easily managing APG 
patterns using an intuitive graphical user interface (GUI). The Pattern 
Tool currently provides a debugging environment and will provide a 
development environment in a future software release.

Chapter Contents

This chapter contains the following information about the Pattern 
Tool:

• “Pattern Tool Overview” on page 137: Provides a description of the 
tool, its purpose and the debugging capabilities

• “Pattern Tool Main Window” on page 138: Provides descriptions of 
the main window’s functional areas, menus, menu commands, and 
dialog boxes.

• “Pattern Tool Getting Started” on page 180: Demonstrates how to 
use the Pattern Tool to retrieve pattern information and view and 
debug failures.

NOTE The actual colors displayed in this manual can be viewed from its 
Acrobat Reader PDF file on the Versatest Series Online Manuals CD-
ROM. If you are viewing the PDF file, you can use Acrobat Reader’s 
View > Zoom In and View > Zoom Out menu bar commands to 
adjust the display magnification.
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Pattern Tool Overview

The Pattern Tool provides a means for easily managing APG patterns 
using an intuitive graphical user interface (GUI). The Pattern Tool 
offers both a debugging environment and development environment.

NOTE In the current version of the Pattern Tool, only debug mode features on 
the hardware are available. The development environment is not 
currently supported.

The debugging environment gives you the ability to analyze run-time 
characteristics of any pattern in their workspace, or loaded into the 
system hardware prior to debug. With the pattern loaded into the 
system, you can view and modify various hardware states (registers, 
memory content, and so forth) in the system on-the-fly. The purpose of 
debug mode is to provide a more efficient way of testing and analyzing 
the code that is developed in order to make improvements and 
corrections.

The development environment essentially manages all things related 
to APG patterns, such as the following:

• Micro-instructions (memory and logic instructions)
• Resources (macros, time sets, cams, and pin groups)
• Files related to both the instructions and resources.
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The Pattern Tool main window shown in Figure 5-1 is the application 
interface within the IDE.

Figure 5-1. Pattern Tool Main Window  

Navigator Pane

Menu Bar Toolbar
Entry Labels Vector Offset

Green Arrow Navigates

Address Sequencer (spga Command) 
Yellow Arrow Sets Pattern Generator 

(Uploaded Pattern
Information)

Patterns Tab

Vector Editor
HW Contents
Current Vectorto Vector Address 

Subroutine Patterns in @subroutine Blocks
Logic Patterns in @logic Blocks

Memory Patterns in @pattern Blocks

Displaying Data in Edit Vector Pane
Green Arrow Points to Vector

Pattern Source Code Pane
Double-Click Pattern to Display Source Code

DEEP_COUNT Entry Point
Yellow Arrow Where Hardware Stopped

Document Tabs

Output Pane

Edit Vector
Pane

Pattern Tool Tabs

Status Bar Registers Pane
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The interface is composed of the following functional areas:

• Navigator Pane: See View > Navigator Pane on page 153

• Menu bar on page 139.

• Toolbar: See the View > Toolbar command on page 151.

• Pattern Source Code Pane: See “Pattern Source Code Pane” on page 
177.

• Edit Vector Pane: See the View > EditVector command on 
page 157.

• Document Tabs: See the View > Document Tabs command on 
page 157

• Output Pane: See the View > Output Pane command on 
page 155.

• Status Bar: See the View > Status Bar command on page 153.

• Registers Pane: See the View > Registers command on 
page 160.

Menu Bar

The menu bar at the top of the Pattern Tool main window (Figure 5-1) 
contains the following eight pull-down menus from which you can 
select commands.

• File menu on page 139

• Edit menu on page 146

• View menu on page 150

• Tools menu on page 161

• Tester menu on page 168

• Program menu on page 170

• Build menu on page 171

• Debug menu on page 172

• Window menu on page 174

• Help menu on page 176

File Menu

Selecting File in the menu bar opens the menu in Figure 5-2.
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Figure 5-2. File Menu  

The File menu contains the following commands:

•  New command on page 141

•  Open command on page 143

• Close command on page 145

• Close All command on page 145

•  Save command on page 145

• Save As command on page 145

• Open Workspace command on page 145

• Save Workspace command on page 145

• Close Workspace Command on page 146

•  Print command on page 146

• Print Preview command on page 146

• Print Setup command on page 146

• Recent Workspaces command on page 146

• Exit command on page 146
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New Command (File Menu)

 Displays the New command submenu (Figure 5-3) that allows you 
to display a new Workspace or create new IDE documents. The New  
toolbar button displays a New dialog box that lists the same items to 
select as the submenu.

Figure 5-3. File > New Command Submenu  

The New command submenu contains the following commands:

• Workspace command on page 141

• C Debugger Document command on page 142

• PinTool Document command on page 142

• Waveform Document command on page 142

• Waveform Setup Document command on page 142

• Test Program Document command on page 142

• Timing Tool Document command on page 142

• Pattern Tool Document command (Pattern Tool) on page 142

• Bitmap Tool DUT Document command on page 142

• File command on page 142

Workspace Command (New Command Submenu)

Displays as the active Workspace its default with its corresponding 
Menu bar, Toolbar, Navigator pane, Output pane, and Status bar.
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C Debugger Document Command (New Command Submenu)

Displays as the active document a blank C Debugger document with its 
corresponding Menu bar, Toolbar, Navigator pane, Document tab (and 
window), Output pane, and Status bar.

PinTool Document Command (New Command Submenu)

Displays as the active document a blank PinTool document with its 
corresponding Menu bar, Toolbar, Navigator pane, Document tab (and 
window), Output pane, and Status bar.

Waveform Document Command (New Command Submenu)

Displays as the active document a blank Waveform Tool document 
with its corresponding Menu bar, Toolbar, Navigator pane, Document 
tab (and window), Output pane, and Status bar.

Waveform Setup Document Command (New Command Submenu)

Displays as the active document a blank Waveform Setup Tool 
document with its corresponding Menu bar, Toolbar, Navigator pane, 
Document tab (and window), Output pane, and Status bar.

Test Program Document Command (New Command Submenu)

Note currently supported by the IDE.

Timing Tool Document Command (New Command Submenu)

Displays as the active document a blank Timing Tool document with 
its corresponding Menu bar, Toolbar, Navigator pane, Document tab 
(and graphical display window), Output pane, and Status bar.

Pattern Tool Document Command (New Command Submenu)

Displays as the active document a blank Pattern Tool document with 
its corresponding Menu bar, Toolbar, Navigator pane, Document tab 
(and window), Output pane, and Status bar.

Bitmap Tool DUT Document Command (New Command Submenu)

Displays an Open dialog box from which you open a DUT Description 
file (.dut) to display a blank Bitmap Tool document with the loaded 
DUT file and corresponding Menu bar, Toolbar, Navigator pane, 
Document tab (and window), Output pane, and Status bar.

File Command (New Command Submenu)

Not currently supported by the IDE.
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Open Command (File Menu)

 Displays the Open command submenu (Figure 5-4) that allows you 
to open a Workspace or IDE documents from the submenu list. The 
Open  toolbar button displays a generic Open dialog box from which 
you can open a selection listed in the submenu.

Figure 5-4. Open Command Submenu  

The Open command submenu contains the following commands that 
display an Open dialog box similar to Figure 5-5:

• C Debugger Document command on page 144

• PinTool Document command on page 144

• Waveform Document command on page 144

• Waveform Setup Document command on page 144

• Test Program Document command on page 144

• Timing Tool Document command on page 144

• Pattern Tool Document command on page 145

• Bitmap Tool DUT Document command on page 145

• File command on page 145
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Figure 5-5. File > Open Dialog Box  

C Debugger Document Command (Open Command Submenu)

Displays an Open dialog box (Figure 5-5) to select a previously saved C 
Debugger Tool document file with a *.cof extension.

PinTool Document Command (Open Command Submenu)

Displays an Open dialog box (similar to Figure 5-5) to select a 
previously saved PinTool document file with a *.pin file extension.

Waveform Document Command (Open Command Submenu)

Displays an Open dialog box (similar to Figure 5-5) to select a 
previously saved Waveform document file with a *.dnc file extension.

Waveform Setup Document Command (Open Command Submenu)

Displays an Open dialog box (similar to Figure 5-5) to select a 
previously saved Waveform Setup document file with a *.stp file 
extension.

Test Program Document Command (Open Command Submenu)

Note currently supported by the IDE.

Timing Tool Document Command (Open Command Submenu)

Displays an Open dialog box (similar to Figure 5-5) to select a 
previously saved Timing Tool document file with a *.vtt file extension.
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Pattern Tool Document Command (Open Command Submenu)

Displays an Open dialog box (similar to Figure 5-5) to select a 
previously saved Pattern Tool document file with an *.apg2 file 
extension.

Bitmap Tool DUT Document Command (Open Command Submenu)

Displays an Open dialog box (similar to Figure 5-5) to select a 
previously saved Bitmap Tool DUT definition document file with a 
*.dut file extension.

File Command (Open Command Submenu)

Note currently supported by the IDE.

Close Command (File Menu)

Closes the active tool document.

Close All Command (File Menu)

Closes all tool documents and displays the default IDE main window.

Save Command (File Menu)

 Saves the active document file.

Save As Command (File Menu)

Displays the Save As dialog box to save the active tool document file.

Open Workspace Command (File Menu)

Displays an Open Workspace dialog box with a *.wsp extension. If 
changes have been made to the current workspace, you will be asked if 
you would like to save the changes before closing the current 
workspace and opening another. The Workspace consists of the tools, 
layout, and open documents.

Save Workspace Command (File Menu)

Saves the current workspace with a *.wsp extension. The Workspace 
consists of the tools, layout, and open documents. This command 
enables you to save the tools, layout, and open documents’ current 
state, and later resume with the same Workspace by using the File > 
Open Workspace command.
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Close Workspace Command (File Menu)

Closes the current workspace. If changes have been made to the 
current workspace, you will be asked if you would like to save the 
changes before closing the current workspace.

Print Command (File Menu)

 Prints the source code displaying in the active Pattern Source Code 
pane.

Print Preview Command (File Menu)

Displays the Pattern Tool print preview window showing the source 
code that will be printed. Pressing the  key returns to the Pattern 
Tool main window.

Print Setup Command (File Menu)

Displays a printer setup dialog box that allows you to select and 
configure a printer.

Recent Workspaces Command (File Menu)

Displays a Recent Workspaces submenu from which you can select a 
workspace.

Exit Command (File Menu)

Closes the IDE. If the workspace or any other tool document files have 
changed, you will be asked if you would like to save them.

Edit Menu

Selecting Edit in the menu bar opens the menu in Figure 5-6. Editing 
done on the Format  tab and Vector  tab in the Edit Vector 
pane is applied immediately to the hardware but can be undone/redone 
through the Edit menu.

Esc
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Figure 5-6. Edit Menu  

The Edit menu contains the following commands:

• Undo command on page 147

• Redo command on page 147

•  Cut command on page 148

•  Copy command on page 148

•  Paste command on page 148

• Find command on page 148

• Replace command on page 148

• Find in Files command on page 149

•  Undo Vector Edit command on page 150

•  Redo Vector Edit command on page 150

Undo Command (Edit Menu)

Allows you to undo changes. Undoes any edit of instruction words as 
well as format data for one or more vectors. The editing of multiple 
vectors ("block-editing") is only available for logic patterns displayed in 
the Logic Grid Display (Figure 5-35 on page 179).

Redo Command (Edit Menu)

Allows you to redo changes. Redoing changes is available up to the 
latest point of edit. For example, consider the following edit history: A-
B-C-D-E-F-G. If you undo back to step B and then introduce a new step 
H, the edit steps C-G will not be available anymore.
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Cut Command (Edit Menu)

 Cuts the selected text and copies it to the Clipboard.

Copy Command (Edit Menu)

 Copies the selected text and copies it to the Clipboard.

Paste Command (Edit Menu)

 Pastes the contents of the Clipboard to the cursor’s position.

Find Command (Edit Menu)

Displays the Find dialog box (Figure 5-7) used for text searching.

Figure 5-7. Find Dialog Box  

Replace Command (Edit Menu)

Displays the Replace dialog box (Figure 5-8) that provides text 
replacement capability based on the criteria you specify.

Figure 5-8. Replace Dialog Box  
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Find in Files Command (Edit Menu)

Displays the Find in Files dialog box (Figure 5-9) that provides search 
capability based on the criteria you specify.

The dialog box contains the following fields:

• Find What – Enter the name of symbol or text you would like to 
find.

• In files/file types – The type of files to look in (referenced by 
extension), or specific files that you would like to search (for 
example, "*.c" or ".apg", or "p:\src\myprogram\file1"). If you would 
like to specify multiple types of files, separate each term by a space, 
for example, "*.c *.apg p:\src\myprogram\file1".

• In folder – Enter the name of the directories you would like to 
search in. If you click on the button next to this field (labeled "…"), 
you can select a folder through a GUI file dialog interface.

• Match whole word only – If you check this box, only the lines 
containing the target as a whole (and not as part of another word) 
will be displayed.

• Match case  – If you check this box, the lines containing the target 
will be displayed only if the cases match.

• Regular Expressions – If you check this box, the text in the 
Find What field will be interpreted as a regular expression,

• Look in subfolders  – If you check this box, in addition to 
searching the folders specified in the In Folder field, the 
subdirectories of the folders specified in the In Folder field will 
be searched.

• Find in Workspace – If you check this box, only the files 
contained in the workspace will be searched. The "In Folder" field 
will be ignored.

After clicking on the  button, the Find in Files output tab will be 
brought to the front in the Output Pane, the results from the search 
process will be displayed as they are generated. If you double-click on 
any of the lines, the file specified on that line will be opened, and the 
file window will be scrolled to the location specified by the line you 
double-clicked.

Find
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Figure 5-9. Find in Files Dialog Box  

Undo Vector Edit Command (Edit Menu)

 Allows you to undo vector editing that has been entered in the Edit 
Vector pane.

Redo Vector Edit Command (Edit Menu)

 Allows you to redo vector editing that has been entered in the Edit 
Vector pane.

View Menu

Selecting View in the menu bar opens the menu in Figure 5-10.

Figure 5-10. View Menu  

The View menu contains the following commands:

• Toolbar command on page 151

• Status Bar command on page 153

• Navigator Pane command on page 153
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• Output Pane command on page 155

• Document Tabs command on page 157

• EditVector command on page 157

• Registers command on page 160

Toolbar Command (View Menu)

Displays or hides the optional toolbar shown in Figure 5-11. The 
toolbar displays at the top of the Pattern Tool main window when a ✓  
displays in front of its command in the View menu. Clicking on the 
buttons in the toolbars give you quick access to many of the menu bar 
commands. Clicking in the Pattern Tool main window activates the 
associated toolbar buttons.

Figure 5-11. Pattern Tool Toolbar  
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The two toolbars contain the following command buttons:

 File > New on page 141  Tester > Set Online on page 169

 File > Open on page 143  Tester > Set Offline on page 169

 File > Save on page 145  Tester > Acquire Data on page 170 (not supported 
by Pattern Tool)

 Edit > Cut on page 148  Tester > Apply Changes on page 170 (not 
supported by Pattern Tool)

 Edit > Copy on page 148  Tester > Abort Acquire on page 170 (not supported 
by C Debugger)

 Edit > Paste on page 148  IDE Site Connect Status

 File > Print on page 146  Tester > Power On on page 170

 Help > About on page 176  Tester > Power Off on page 170

 Help > Help on page 176

 Debug > Run on page 173  Debug > Step to Next Error on page 174

 Debug > Continue on page 173  Debug > Step to Previous Error on page 174

 Debug > Continue ‘n’ on page 173  Edit > Undo Vector Edit on page 150

 Debug > Step Into on page 173  Edit > Redo Vector Edit on page 150

 Debug > Step Over on page 174 Entry Labels in Current Pattern drop-down list box

 Debug > Step ‘n’ on page 173 Vector Offset drop-down list box

 Debug > Insert/Remove Breakpoint on 
page 174

 Navigate to specific vector in Vector Offset field

 Debug > Enable/disable break points on 
page 174

 Step APG to given vector in Vector Offset field
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Status Bar Command (View Menu)

Displays or hides the Status Bar (Figure 5-1 on page 138). The Status 
Bar displays at the bottom of the Pattern Tool main window when a ✓  
displays in front of its command in the View menu. The Status Bar 
provides information about the current state of what you are viewing 
in the window and any other status-oriented information.

Navigator Pane Command (View Menu)

Displays or hides the Navigator pane (similar to Figure 5-12 or Figure 
5-1 on page 138). The Navigator Pane displays on the left side of the 
Pattern Tool main window when a ✓  displays in front of its command 
in the View menu.

The Pattern Tool is associated with the following two tabs on the 
Navigator Pane:

• Workspace Tab : Within the Workspace tab tree is a Pattern 
icon that is used to launch the tool. Double-clicking the icon 
displays the default Pattern Tool Document Window.

• Patterns Tab : Displays the uploaded pattern information 
(similar to Figure 5-12 or Figure 5-1 on page 138).
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Figure 5-12. Navigator Pane  

The Patterns tab in the Navigator pane allows you to navigate to 
various Memory Patterns (in @pattern blocks), Subroutine 
Patterns (in @subroutine blocks), and Logic Patterns (in 
@logic blocks) loaded into the system hardware (debug mode) or 
within your workspace (that will be available in a future software 
release). Clicking on an expand plus  button opens that hierarchical 
branch in a tree, and clicking the collapse minus  button collapses 
that branch. You can navigate down to a pattern entry point label, and 
double-click on it to display the pattern source code in the Pattern 
Source Code pane.

Memory Patterns in @pattern Blocks

Subroutine Patterns in @subroutine Blocks
Logic Patterns in @logic Blocks

Navigator Pane

(Uploaded Pattern
Information)

Workspace
Tab

Patterns
Tab

+

–
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When in debug mode, the Pattern Tool contacts the hardware and 
retrieves information on the memory patterns, logic patterns, and 
subroutines that are currently loaded into the system. Again, double-
clicking on an entry point name or label causes that portion of the 
pattern, starting at the entry point name or label selected, to be 
displayed in the Pattern Source Code pane (similar to Figure 5-1 on 
page 138).

When in development mode (that will be available in a future software 
release), the Pattern Tool area shows the memory patterns, logic 
patterns, and subroutines that have been created in the given 
workspace. Through this view, you can navigate to any vector in your 
program.

Output Pane Command (View Menu)

Displays or hides the Output Pane (similar to Figure 5-13 below or 
Figure 5-1 on page 138). The Output Pane displays on the bottom left 
corner of the Pattern Tool main window when a ✓  displays in front of 
its command in the View menu. 

The Pattern Tool is associated with the following four tabs on the 
Output Pane:

• VOS Command tab on page 156

• Vector Unroll tab on page 156

• Failures tab on page 156

• Edit History tab on page 156

Figure 5-13. Pattern Tool Output Pane  

Edit History tab
Failures tab

Vector Unroll tab
VOS Command tab
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VOS Command Tab

The VOS Command tab is enabled when the IDE is set online by the 
selecting the yellow Set Online  toolbar button or the corresponding 
Tester > Set Online command. The VOS Command tab allows you 
to enter VOS terminal commands and display the results on the tab 
and in the corresponding test site window in the VK Test Station main 
window. See the “VOS Terminal Commands” chapter in the Command 
Reference Volume 2 for the available commands.

Vector Unroll Tab

Displays previous vector unrolling (like the dvec VOS terminal 
command), and displays previous vector register contents. It can be 
configured in the Tools > Properties > PatternTool 
Properties > Pattern Tool Properties dialog box Vector Unrolling 
tab on page 167.

Failures Tab

Provides a summary of pattern failures (similar to Figure 5-14).

Figure 5-14. Output Pane Failures Tab  

Edit History Tab

The Edit History Tab (similar to Figure 5-15) displays the editing 
history made in the View > EditVector > Edit Vector pane on 
page 157.

Clicking Failure # button displays corresponding vector
data in Pattern Source Code pane and Edit Vector pane

Failed Vectors and Offset Failures tab

Failed Pins
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Figure 5-15. Output Pane Edit History Tab  

Document Tabs Command (View Menu)

Displays the Document tabs at the bottom of the Tool Document 
Window (similar to Figure 5-1 on page 138) when a ✓  displays in front 
of its command in the View menu.

Edit Vector Command (View Menu)

Displays or hides the Edit Vector pane that consists of a Vector  
tab (similar to Figure 5-16 or Figure 5-1 on page 138) and a Format 

 tab (similar to Figure 5-17). The Edit Vector pane displays on 
the right side of the Pattern Tool main window when a ✓  displays in 
front of its command in the View menu. This is the central location in 
which all editing of vectors takes place. Editing done is this pane is 
applied to the hardware immediately but can be undone/redone 
through the Edit menu.

The Vector  tab (Figure 5-16) displays the sequencer 
instructions.
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Figure 5-16.  Vector Tab in Editor Vector Pane  
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Figure 5-17. Format Tab in Edit Vector Pane  

The Format  tab (similar to Figure 5-17) displays the pin and pin 
group format and data information and the combined format and data 
information. Its information comes from the .VEC file.

The order the pin groups and pins display is the same as the order they 
are defined in the .APG file and resulting .VEC file.

The combined PE drive and compare format/data characters are listed 
below in Table 5-1. Note that these are the same characters that are 
used for the format pattern language vector command’s binary 
format:

format <group or pin> bin = $xxx...

where bin=$ indicates that each character following the $ (and 
before a comma if one is present at the end to specify another 
operation in the vector) specifies one of the combined PE 
Versatest Series IDE User’s Guide 159

Revision D, May 2005



Chapter 5  Pattern Tool

Pattern Tool Main Window
format/data characters listed in Table 5-1. See the Command 
Reference Volume 1 for detailed information about the format 
bin pattern language vector command.

Registers Command (View Menu)

Displays or hides the Registers pane (similar to Figure 5-18 and Figure 
5-1 on page 138). The Output pane displays on the bottom right corner 
of the Pattern Tool main window when a ✓  displays in front of its 
command in the View menu. 

Displays the current counters (A, B, and C), data generators (Dl and 
Dh), and address generators (X, Y, and Z) register information (similar 
to Figure 5-18). For example, the current value of the C match register 
for the current vector can be found in column “C,” row “match.”

Table 5-1. Combined PE Drive and Compare Format/Data Characters

Drive PE Format Characters Compare PE Format Characters

Combined Drive
Format Character

Drive 
Format = PEL1 Level

Combined Compare
Format Character

Compare 
Format = PEL* Level

0

1

NR = 0

NR = 1

l

h

CN = 0

CN = 1

m

w

SC = 0

SC = 1

k

g

CL = 0

CL = 1

r

u

RTO = 0

RTO = 1

t

T

CZ = 0

CZ = 1

d

c

RZ = 0

RZ = 1

x

y

NC = 0

NC = 1 

Drive 
Format = PEL* Level

Combined Drive
Format Character

Compare 
Format = PEL* Level

Combined Compare
Format Character

NR = 0

NR = 1

0

1

CN = 0

CN = 1

l

h

SC = 0

SC = 1

m

w

CL = 0

CL = 1

k

g

RTO = 0

RTO = 1

r

u

CZ = 0

CZ = 1

t

T

RZ = 0

RZ = 1

d

c

NC = 0

NC = 1

x

y

1 PEL (pin electronics logic) level = 0 or 1.
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You can edit the contents of a counter or generator register by clicking 
on its cell in the Registers pane, typing a value in decimal or 
hexadecimal, and pressing  to write the change to hardware. The 
new value displays in hexadecimal. Changes can be viewed in the VK 
Test Station main window by entering the dvec (display vector) VOS 
terminal command in the Datalog window of a test site. Note that the 
change is immediately written to hardware, but can be undone/redone 
through the Edit menu.

Figure 5-18. Registers Pane  

Tools Menu

Selecting Tools in the menu bar opens the menu in Figure 5-19.

Figure 5-19. Tools Menu  

The Tools menu contains the following commands:

• Options command on page 161

• Properties command on page 163

Options Command (Tools Menu)

Displays the Options submenu shown in Figure 5-20.

Enter
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Figure 5-20. Options Submenu  

The Options command submenu contains the following commands:

• Ide Options command on page 162

• TPIParser Options command on page 162

• TesterTool Options command on page 162

• StaticScopeTool Options command on page 162

• StaticPinTool Options command on page 162

• StaticTPT Options command on page 162

• PatternTool Options command on page 163

Ide Options Command (Options Command Submenu)

Not currently supported by the IDE.

TPIParser Options Command (Options Command Submenu)

Not currently supported by the IDE.

TesterTool Options Command (Options Command Submenu)

Not currently supported by the IDE.

StaticScopeTool Options Command (Options Command Submenu)

Not currently supported by the IDE.

StaticPinTool Options Command (Options Command Submenu)

Not currently supported by the IDE.

StaticTPT Options Command (Options Command Submenu)

Not currently supported by the IDE.
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PatternTool Options Command (Options Command Submenu)

Not currently supported by the IDE.

Properties Command (Tools Menu)

Displays the Properties submenu shown in Figure 5-21.

Figure 5-21. Properties Submenu  

The Properties command submenu contains the following commands:

• Ide Properties command on page 163

• TPIParser Properties command on page 163

• TesterTool Properties command on page 163

• StaticScopeTool Properties command on page 164

• StaticPinTool Properties command on page 164

• StaticTPT Properties command on page 164

• PatternTool Properties command on page 164

Ide Properties Command (Properties Command Submenu)

Not currently supported by the IDE.

TPIParser Properties Command (Properties Command Submenu)

Not currently supported by the IDE.

TesterTool Properties Command (Properties Command Submenu)

Not currently supported by the IDE.
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StaticScopeTool Properties Command (Properties Command 
Submenu)

Not currently supported by the IDE.

StaticPinTool Properties Command (Properties Command Submenu)

Not currently supported by the IDE.

StaticTPT Properties Command (Properties Command Submenu)

Not currently supported by the IDE.

PatternTool Properties Command (Properties Command Submenu)

Displays the Pattern Tool Properties dialog box (similar to Figure 5-22) 
that has the following four tabs:

• General tab on page 164

• Conditional Stepping tab on page 165

• Logicview tab on page 166

• Vector Unrolling tab on page 167

General Tab (Pattern Tool Properties Dialog Box)

Contains the following panels (Figure 5-22):

• Editing panel: When you modify a vector instruction, it 
automatically applies the changes to the hardware. Currently, the 
Manual option button is not supported.The Record edit 
History option check box specifies whether the Output Pane’s 
Vector Unroll tab (similar to Figure 5-13 on page 155) will log 
changes.

• DUT disconnect panel: Enables the disconnection of the DUT 
when you are stepping through a pattern to prevent damaging the 
device.

• Failures panel: Enables the tracking of errors in the Output Pane’s 
Failures tab (similar to Figure 5-14 on page 156).
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Figure 5-22. Pattern Tool Properties Dialog Box General Tab  

Conditional Stepping Tab (Pattern Tool Properties Dialog Box)

Selecting the Enable/Disable check box activates the other fields. 
When you do conditional stepping, you set the conditions you want to 
stop on. When you run a pattern, it steps through the pattern vector-
by-vector until it reaches one of the specified conditions or a quit.
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Figure 5-23. Pattern Tool Properties Dialog Box Conditional Stepping 
Tab  

Logicview Tab (Pattern Tool Properties Dialog Box)

Configures what logic columns that will display in the Logic View 
Display Pane (similar to Figure 5-35 on page 179). The Logic View Grid 
is only available for logic patterns.
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Figure 5-24. Pattern Tool Properties Dialog Logicview Tab  

Vector Unrolling Tab (Pattern Tool Properties Dialog Box)

Configures what registers, counters, and flags (Figure 5-25) you want 
to display for each vector in the Output window’s Vector Unroll tab 
(similar to Figure 5-13 on page 155). Selecting the Enable Vector 
Unrolling check box and from the Available fields panel 
specifies what displays for each vector in the Output window.
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Figure 5-25. Pattern Tool Properties Dialog Box Vector Unrolling Tab  

Tester Menu

Selecting Tester in the menu bar opens the menu in Figure 5-26.
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Figure 5-26. Tester Menu  

The Tester menu contains the following commands:

•  Set Online command on page 169

•  Set Offline command on page 169

•  Acquire Data command on page 170

•  Apply Changes command on page 170

•  Abort Acquire command on page 170

•  Tester Power On command on page 170

•  Tester Power Off command on page 170

Set Online Command (Tester Menu)

 Connects the IDE to the tester for the following tools that support 
online mode:

• C Program Debugger (currently has no offline capability)

• Pattern Tool (currently has no offline capability)

• Waveform Tool

• Timing Tool

Set Offline Command (Tester Menu)

 Disconnects the IDE from the tester. The following tools support 
offline mode:

• Pin Tool (currently has no online capability)

• Waveform Tool (viewing saved files only)

• Timing Tool (viewing saved files only)

• Bitmap Tool (currently has no online capability)
Versatest Series IDE User’s Guide 169

Revision D, May 2005



Chapter 5  Pattern Tool

Pattern Tool Main Window
Acquire Data Command (Tester Menu)

 Not currently supported by the Pattern Tool. The Timing Tool 
supports this command.

Apply Changes Command (Tester Menu)

 Not currently supported by the Pattern Tool. The Timing Tool 
supports this command.

Abort Acquire Command (Tester Menu)

 Not currently supported by the Pattern Tool. The Timing Tool 
supports this command.

Tester Power On Command (Tester Menu)

 Same as the VK Test Station main window Utilities > Power 
On command and its corresponding  toolbar button. Resets and 
powers up the test sites (Test Head).

Tester Power Off Command (Tester Menu)

 Same as the VK Test Station main window Utilities > Power 
Off command and its corresponding  toolbar button. Turns off 
power to the test sites (Test Head).

Program Menu

Selecting Program in the menu bar opens the menu in Figure 5-27. The 
Program menu is not currently supported by the IDE.

Figure 5-27. Program Menu  

The Program menu contains the following commands:

• Set Active Test Program command on page 171

• Add Files to Test Program command on page 171

• Remove from Test Program command on page 171
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Set Active Test Program Command (Program Menu)

Not currently supported by the IDE.

Add Files to Test Program Command (Program Menu)

Not currently supported by the IDE.

Remove from Test Program Command (Program Menu)

Not currently supported by the IDE.

Build Menu

Selecting Debug in the menu bar opens the menu in Figure 5-28. The 
Build menu is not currently supported by the IDE.

Figure 5-28. Build Menu  

The Build menu contains the following commands:

• Build command on page 171

• Compile Patterns command on page 171

• Compile C Sources command on page 172

• Rebuild All command on page 172

• Stop Build command on page 172

• Clean Build command on page 172

Build Command (Build Menu)

Not currently supported by the IDE.

Compile Patterns Command (Build Menu)

Not currently supported by the IDE.
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Compile C Sources Command (Build Menu)

Not currently supported by the IDE.

Rebuild All Command (Build Menu)

Not currently supported by the IDE.

Stop Build Command (Build Menu)

Not currently supported by the IDE.

Clean Build Command (Build Menu)

Not currently supported by the IDE.

Debug Menu

Selecting Debug in the menu bar opens the menu in Figure 5-29.

Figure 5-29. Debug Menu  

The Debug menu contains the following commands:

•  Run command on page 173.

•  Continue command on page 173

•  Continue ‘n’ command on page 173

•  Step Into command on page 173.

•  Step ‘n’ command on page 173.
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•  Step Over command on page 174

•  Insert/Remove Breakpoint command on page 174

•  Enable/Disable Break Points command on page 174

•  Step to Next Error command on page 174

•  Step to Previous Error command on page 174

•  Undo Vector Edit command on page 174

•  Redo Vector Edit command page 174

Run Command (Debug Menu)

 Runs the pattern beginning at the entry point within the pattern. 
Runs to the end of the pattern or a quit. It will stop on a vector with a 
break point.

Continue Command (Debug Menu)

 From the current vector, runs to the end of the pattern or a quit. It 
will stop on a vector with a break point.

Continue ‘n’ Command (Debug Menu)

 Continues the APG after hitting break points “N” times. Displays a 
Step Count dialog box. Typing the number of break points in the 
Steps text box and selecting  continues the APG after hitting that 
number of break points (or until it encounters a quit). This command 
does not currently display in the Debug menu.

Step Into Command (Debug Menu)

 Steps to the next vector in the pattern and displays a yellow arrow 
pointing to the vector in the Pattern Source Code pane that indicates it 
is the vector where the hardware is currently stopped. The difference 
between the Step Over and the Step Into commands is that if you are 
on a vector that does a call, the Step Into command will bring you to 
the first vector of the entry point in the subroutine where Step Over 
will execute the subroutine and end up at the next vector in the 
pattern.

Step ‘n’ Command (Debug Menu)

 Displays a Step Count dialog box. Typing in the number of vectors 
to step in the Steps text box and selecting  steps that number of 
vectors (or until it encounters a quit) and displays a yellow arrow 
pointing to the vector in the Pattern Source Code Pane where the 
hardware is currently stopped. It will stop on a vector with a break 
point.

OK

OK
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Step Over Command (Debug Menu)

 Jumps to the next vector in the pattern and displays a yellow 
arrow pointing to the vector in the Pattern Source Code pane that 
indicates it is the vector where the hardware is currently stopped. The 
difference between the Step Over and the Step Into commands is that 
if you are on a vector that does a call, the Step Into command will bring 
you to the first vector of the entry point in the subroutine where Step 
Over will execute the subroutine and end up at the next vector in the 
pattern.

Insert/Remove Breakpoint Command (Debug Menu)

 Inserts or removes a break point at the current APG location.

Enable/Disable Break Points Command (Debug Menu)

 Toggles enable/disable break points.

Step to Next Error Command (Debug Menu)

 Jumps to the next failing vector. It does not execute any vectors or 
make the vector the current vector. A green arrow points to the vector 
in the Pattern Source Code Pane and currently displayed in the Edit 
Vector Pane.

Step to Previous Error Command (Debug Menu)

 Jumps to the next previous failing vector. It does not execute any 
vectors or make the vector the current vector. A green arrow points to 
the vector in the Pattern Source Code Pane and currently displayed in 
the Edit Vector Pane.

Undo Vector Edit Command (Debug Menu)

 Allows you to undo vector editing that has been entered in the Edit 
Vector pane.

Redo Vector Edit Command (Debug Menu)

 Allows you to redo vector editing that has been entered in the Edit 
Vector pane.

Window Menu

Selecting Window in the menu bar opens the menu in Figure 5-30.
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Figure 5-30. Window Menu  

The Window menu contains the following commands:

• New Window command on page 175

• Close command on page 175

• Close All command on page 175

• Cascade command on page 175

• Tile command on page 175

• Minimize All command on page 175

New Window Command (Window Menu)

Displays a duplicate Pattern Source window.

Close Command (Window Menu)

Closes the active tool document window.

Close All Command (Window Menu)

Closes all tool document windows with their corresponding tabs.

Cascade Command (Window Menu)

Arranges the currently displayed Pattern Source windows one on top of 
another with the title bar of each visible.

Tile Command (Window Menu)

Arranges the currently displayed Pattern Source windows so that each 
is fully visible.

Minimize All Command (Window Menu)

Not currently supported by the IDE.
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Help Menu

Selecting Help in the menu bar opens the menu in Figure 5-31.

Figure 5-31. Help Menu  

The Help menu contains the following two commands:

Help Topics Command (Help Menu)

 Not currently supported.

About V4400 Software Command (Help Menu)

 Displays the About V4400 Series Tester Software dialog box that 
contains software component version and copyright information 
(similar to Figure 5-32).

Figure 5-32. About V4400 Software Dialog Box   
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Pattern Source Code Pane

The Pattern Source Code Pane (similar to Figure 5-33) displays the 
pattern source code for the pattern that is double-clicked in the 
Patterns tab  in the Navigator Pane (similar to Figure 5-1 on page 
138).

Figure 5-33. Pattern Source Code Pane   

The green arrow indicates which vector data is currently displaying in 
the Edit Vector Pane (see the View > Edit Vector command on 
page 157). A yellow arrow points to the vector where the hardware is 
currently stopped.

Right-clicking over a vector in the Pattern Source Code Pane displays 
the pop-up menu shown in Figure 5-34.

Pattern Source Code

Yellow Arrow Where Hardware Stopped

Document Tabs

Green Arrow Indicates Vector Data
Displaying in the Edit Vector Pane
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Figure 5-34. Pattern Source Code Pop-Up Menu  

Selecting the Display Logic View command displays a logic view 
of the pattern (Figure 5-35). This logic view is only available for logic 
patterns. The command is grayed out and inactive for other patterns. 
Vectors are represented in a grid format. In the grid, each row 
represents a different logic vector.

The sequencer column headings at the top (break_pt, inv_en, 
pmustb, and so forth) are selected in the Tools > Properties > 
PatternTool Properties > Pattern Tools Properties dialog box > 
Logicview tab (Figure 5-24 on page 167). The pins and pin groups are 
selected in the View > Edit Vector > Format  tab (similar to 
Figure 5-17 on page 159). The current vector displays green in the 
Logic View Display Pane and is the vector where the right-click 
occurred to display the pop-up menu. Failed vectors display red.
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Figure 5-35. Logic View Display Pane  

Tools > Properties > PatternTool Properties > 
Pattern Tools Properties Dialog Box > 
Logicview Tab Selected Display Fields

Logic View Display Pane
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Pattern Tool Getting Started

The Pattern Tool allows management of APG patterns through the 
IDE graphical user interface. Its debugging environment gives the 
ability to analyze run-time characteristics of any pattern loaded in 
system hardware. Developers can view and modify, on-the-fly, various 
hardware states, such as registers or memory content. It is an efficient 
way of testing and analyzing written code for the purpose of making 
improvements or corrections.

This Getting Started demonstrates how to use the Pattern Tool to 
retrieve pattern information and view and debug failures. For 
additional information about the Pattern Tool, see the “Pattern Tool 
Main Window” section on page 138 that provides descriptions of all the 
menus, menu commands, and dialog boxes that make up the tool’s 
interface.

Getting Started Contents

This Getting Started contains the following examples:

• “Loading the Test Program” on page 181

• “Using the C Program Debugger to Control Program Execution” on 
page 187

• “Displaying the Pattern Tool and Retrieving Pattern and Vector 
Information” on page 194

• “Running the APG and Viewing Failures” on page 199

• “Using the Pattern Tool to Correct Failures” on page 201

NOTE The actual colors displayed in this manual can be viewed from its 
Acrobat Reader PDF file on the Versatest Series Manuals CD-ROM. If 
you are viewing the PDF file, you can use Acrobat Reader’s View > 
Zoom In and View > Zoom Out menu bar commands to adjust the 
display magnification to help you see graphics such as waveforms.
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Loading the Test Program

In this section of the Getting Started we will perform the following 
tasks in preparation to use the C Program Debugger and Pattern Tool 
to retrieve pattern information, and run the APG to view and debug 
failures:

• Launch the VK Test Station application and display its VK Test 
Station main window.

• Load a plan file, power on the test sites (test head), and download 
the test program files specified in the plan file to the test sites.

1 Selecting  > All Programs > Versatest Test System 
Software > VK Test Station displays the VK Test Station main 
window (similar to Figure 5-36). Note that the Status Bar displays 
Station Status: Idle Ready NO PHYSICAL SITE CONFIGURED 
that indicates the test sites are powered off and no plan file is loaded.

Figure 5-36. VK Test Station Main Window  

Menu Bar Toolbar Testing Status Window

Datalog Window

Status Bar
Versatest Series IDE User’s Guide 181

Revision D, May 2005



Chapter 5  Pattern Tool

Pattern Tool Getting Started
2 In the menu bar, selecting Init Lot > Enter Lot Information 
displays the Initialize Test Station Setup dialog box (Figure 5-37) that 
is used to set up each lot for testing.

Figure 5-37. Initialize Test Station Setup Dialog Box  

3 Selecting the  button displays the Open dialog box (Figure 5-38) 
that lists the available plan files. Test plan files define the tester setup 
that is used. The TestDrive_scope_gui.PLN plan file will be used 
for this example.

Test Plan
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Figure 5-38. Select Test Plan Dialog Box  

4 Selecting the TestDrive_scope_gui.PLN plan file and then 
selecting  displays the Initialize Test Station Setup dialog box 
with the plan file displayed in the Test Plan field (Figure 5-36 on page 
181).

5 Selecting the  button in the dialog box displays a Red Hand Alert 
dialog box that warns about the loss of summary data (Figure 5-39). 
The TEST_PLAN_WARNING plan file configuration switch controls 
whether this dialog box displays. The default is for it to display.

Open

Save
Versatest Series IDE User’s Guide 183

Revision D, May 2005



Chapter 5  Pattern Tool

Pattern Tool Getting Started
Figure 5-39. Red Hand Alert Are You Sure Dialog Box  

6 Selecting  displays another Red Hand Alert dialog box (Figure 5-40) 
that warns to Z down the wafer and disconnect all DUTs prior to 
initialization of the test sites. The TEST_PLAN_WARNING plan file 
switch also controls whether this dialog box displays.

OK
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Figure 5-40. Red Hand Alert Z-Down Dialog Box  

7 Selecting  displays the Test Plan Validation dialog box 
(Figure 5-41). The VALIDATE 0x10 plan file test switch controls 
whether this dialog box displays. It displays the corresponding 
checksums and adds them to the summary file.

Figure 5-41. Test Plan Validation Dialog Box  

OK
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8 Selecting  begins the test head power on and downloads the 
Versatest Operating System (VOS) and the test program files specified 
in the plan file. The power on is complete when the terminal prompt 
A1> displays in the Datalog window (Figure 5-42). Note that the 
Status Bar displays Station Status: Ready DISPLAYING LOG 
FOR TEST SITE: 1 (A1) that indicates the test sites are powered on 
and ready to run the downloaded test program.

Figure 5-42. VK Test Station Main Window After Power On  

OK

Menu Bar Toolbar Testing Status Window

Datalog Window

Status Bar

A1 Site Status Window

A1 Terminal Prompt
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Using the C Program Debugger to Control Program 
Execution

The C Program Debugger allows you to control the execution and 
inspect the status at the C language source code level. In this section of 
the Getting Started, we will use the C Program Debugger to perform 
the following tasks in preparation to use the Pattern Tool to retrieve 
pattern information, and run the APG to view and debug failures:

• Set a break point right before running a pattern.

• Run the test program to the break point.

1 Selecting  > All Programs > Versatest Test System 
Software > Integrated Development Environment displays 
the default V4400 Series Tester Software main window that contains 
the Integrated Development Environment or IDE (similar to 
Figure 5-43). The Menu bar and Toolbar are context sensitive and 
change for the selected active tool or document. The menus and 
Toolbar show and enable only the commands and buttons that are 
relevant to the tool or document you have selected.
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Figure 5-43. V4400 Series Tester Software IDE Main Window  

2 Selecting the yellow light bulb Set Online  toolbar button or 
corresponding Tester > Set Online command enables the IDE to 
connect to the tester when the Site Connect Status drop-down list box 
Site: A1  is enabled as shown in the toolbar in Figure 5-44.

Navigator Pane Menu Bar Toolbar

Tool Document Window

Output Pane

Workspace Tab

Tools Tab

Status Bar
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Figure 5-44. IDE Main Window Set Online  

3 Choosing the site that the IDE connects to is done by selecting the 
down-arrow  button on the right side of the Site Connect Status drop-
down list box to display the available sites and selecting from the list 
(similar to Figure 5-45). Selecting a tool makes the connection to that 
site and disables the Site Connect Status drop-down list box.

Figure 5-45. Site Connect Status Drop-Down List Box  

4 In the Navigator Pane, selecting the Tools tab  icon displays its tab 
(Figure 5-46).

Output Pane

Site Connect Status drop-down list box

Navigator Pane

Workspace Tab

Tools Tab

Pattern Tool Icon
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Figure 5-46. Navigator Pane Tools Tab  

5 Double-clicking CDebugger under Debug Tools (Figure 5-46) 
displays the C Debugger as the active tool in the Tool Document 
window (Figure 5-47). Selecting the tool makes the connection to that 
site and disables the Site Connect Status drop-down list box. This also 
adds the C Debugger  (Cdeb) tab to the Navigator pane, its menu 
bar and toolbar, and displays the Workspace in the Navigator Pane.

Navigator Pane

Workspace Tab

Tools Tab
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Figure 5-47. IDE Displaying C Debugger  

6 Selecting the Cdeb  tab in the Navigator pane displays its tab that 
lists all the source code file names and function names for the loaded 
test program (similar to Figure 5-48).

Site Connect Status drop-down list box

C Debugger Document Tab

Cdeb Tab

Navigator Pane

Output Pane

Tool Document Window

Workspace Tab
Tools Tab
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Figure 5-48. C Debugger Cdeb Tab  

7 Navigating to and double-clicking the LOGICTEST.C > 
logicDEEP_COUNT function displays it in a window in the Tool 
Document Window (similar to Figure 5-49).
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Figure 5-49. C Debugger Displaying Break Point  

8 Before using the Pattern Tool, the test program has to be loaded and 
the break point needs to be set right before the run_apg command. 
Positioning the cursor in the source line shown in Figure 5-49 and 
selecting the Debug > Break command, the  key, or the Break 
Point  button in the toolbar inserts a break point that displays as a 
red diamond tag in the gray margin on the left side of the source code. 
Note that the Status bar at the bottom of the window displays the line 
number (Ln) and column (Col) the cursor is active.

9 Selecting the Debug > Run command or the Run  toolbar button 
launches the program and causes it to run to the break point 
(Figure 5-50). A green arrow displays over the break point where the 
program stops.

Break
Point

logicDEEP_COUNT
Function

F9

Navigator Pane Menu Bar Toolbar

Tool Document Window

Output Pane

Workspace Tab
Tools Tab

Status Bar
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Figure 5-50. Run Test Program to Break Point  

Displaying the Pattern Tool and Retrieving Pattern 
and Vector Information

In this section we use the Pattern Tool to perform the following tasks 
in preparation to run the APG to view and debug failures:

• Upload and display the pattern information in the Pattern Tool.

• Navigate to the pattern source code of an entry point.

1 Selecting the Workspace tab  in the Navigator Pane displays its 
tab that contains the Pattern icon (Figure 5-51).

Figure 5-51. Navigator Pane’s Workspace Tab  

2 Double-clicking the Pattern icon displays a new Pattern Tool 
document with all the Pattern Tool window panes, menu bar, toolbar, 

Pattern Tool
Icon

Navigator Pane

Workspace Tab
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and other objects associated with the tool. Selecting its window’s 
maximize  button displays the IDE full-window (Figure 5-52).

Figure 5-52. New Pattern Tool Document Window  

3 Selecting the Patterns tab  in the Navigator Pane displays the list 
of patterns currently in memory (similar to Figure 5-53). Under each 
pattern is a list of entry points.

Navigator Pane

Menu Bar Toolbar

Pattern Source Code Pane

Edit Vector Pane

Patterns Tab

Workspace Tab

Output Pane
Pattern Tool Tabs

Status Bar Registers Pane
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Figure 5-53. Patterns Tab Displaying Memory Contents  

4 Double-clicking on the DEEP_COUNT entry point displays its source 
code in the Pattern Source Code Pane (similar to Figure 5-54). The 
yellow arrow in the Pattern Source Code Pane identifies the next 
vector to be executed. The green arrow indicates the vector we have 
navigated to.

Memory Patterns in @pattern Blocks

Subroutine Patterns in @subroutine Blocks
Logic Patterns in @logic Blocks
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Figure 5-54. Pattern Tool Main Window  

5 Positioning the cursor in a vector and right-clicking displays a pop-up 
menu with commands that are available in the Pattern Source Code 
Pane (Figure 5-55).
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Displaying Data in Edit Vector Pane
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Document Tabs

Output Pane
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Figure 5-55. Pattern Source Code Pane Pop-Up Menu  

6 Selecting the Display Vector command in the pop-up menu 
displays a green arrow at that vector and displays that vector’s 
contents in the Edit Vector Pane (Figure 5-56).
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Figure 5-56. Displaying a Vector’s Contents in the Edit Vector Pane  

Running the APG and Viewing Failures

This section demonstrates how to run the APG and view pattern 
failures in preparation to debug and correct failures using the Pattern 
Tool.

1 Selecting the Debug > Run command or the Run  toolbar button 
runs the APG from the current vector in the DEEP_COUNT entry point 
where the hardware is stopped at the yellow arrow.

2 Selecting the Failures tab  in the Output Pane displays its tab 
showing a failure occurred executing the pattern (Figure 5-57). The 
Failures tab displays the entry point, offset, and failing pins for each 
failing vector.

Selected Vector
Entry Point Vector Offset

Edit Vector
Pane

Displaying Data in Edit Vector Pane
Green Arrow Points to Vector

Yellow Arrow Where Hardware Stopped

Vector Editor HW Contents
Current Vector

Pattern Source Code Pane
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Figure 5-57. Output Pane Failures Tab  

3 Clicking with the left mouse button on the failure # 0 button 
navigates to a failing vector. The default behavior of navigating to 
failures in the Pattern Tool is to bring up the Pattern Source Code 
Pane view with the green arrow pointing at the selected vector and the 
contents of that vector displaying in the Edit Vector Pane (similar to 
Figure 5-58). 

The failure points to the following vector:

t=10, DRIVE nr=0x4, COMPARE cn=0x5; //4

The pin is failing because of the mismatch in the drive and compare 
data for the vector.

Clicking Failure # button displays corresponding vector
data in Pattern Source Code pane and Edit Vector pane

Failed Vectors and Offset Failures tab

Failed Pin
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Figure 5-58. Pattern Source Code Pane Displaying Failed Vector  

Using the Pattern Tool to Correct Failures

This section demonstrates how to view failures in the Logic View 
Display Pane with logic vectors, display the failing pin vector data on 
the Format tab  in the Edit Vector Pane, correct the failing vector 
data, and rerun the pattern with no failures.

1 With the default behavior of navigating to failures being to bring up 
the Pattern Source Code Pane view (Figure 5-58), different views (logic 
and source code) can be selected by right clicking on a vector in the 
source code window to display a pop-up menu (Figure 5-59).

Green Arrow Points to Failing Vector
Displaying Data in Edit Vector Pane

Pattern Source Code Pane

Selected Vector Entry Point and Offset
Vector Editor HW Contents

Current Vector

Edit Vector Pane
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Figure 5-59. Pattern Source Code Pane Pop-Up Menu  

2 If the current vector is a logic vector, then the Display Logic View 
command can be selected in the pop-up menu to display the Logic View 
Display Pane (Figure 5-60). The failing vector displays with a red 
boarder.
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Figure 5-60. Logic View Display Grid  

3 Selecting the Format  tab in the Edit Vector Pane displays its tab 
(similar to Figure 5-61).

Tools > Properties > PatternTool Properties > 
Pattern Tools Properties Dialog Box > 
Logicview Tab Selected Display Fields

Logic View Display Pane
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Figure 5-61. Edit Vector Pane Blank Format Tab  

4 Selecting the <Select Pin Display> drop-down list box lists the 
available options (Figure 5-62).
204 Versatest Series IDE User’s Guide

Revision D, May 2005



Chapter 5  Pattern Tool

Pattern Tool Getting Started
Figure 5-62. Edit Vector Pane Format Tab Drop-Down List Box  

5 Selecting AllPinGrp displays the pin and pin group format and data 
information and the combined format and data information (similar to 
Figure 5-63). Its information comes from the .VEC file. The failing pin 
is in the apg_outpins group.
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Figure 5-63. Edit Vector Pane Displaying Failure in apg_outpins 
Group  

6 The failure is removed by changing the Data (hex) field 5 to a 4 
(to match the drive data for that vector).

7 In the Patterns tab  in the Navigator Pane, double-clicking the 
DEEP_COUNT entry point displays it once again in the Pattern Source 
Code Pane (similar to Figure 5-54 on page 197).

8 Selecting the Run  toolbar button runs the APG from the current 
vector in the DEEP_COUNT entry point where the hardware is stopped 
at the yellow arrow.

9 Viewing the Failures tab  in the Output Pane, the failure is gone 
(Figure 5-64).

Changing Data (hex)
5 to 4 removes the error
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Figure 5-64. Output Pane Failures Tab  
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Chapter 6  Waveform Tool

Introduction
Introduction

This chapter provides information for the Versatest Series Waveform 
Tool. This tool displays the input patterns and the actual and expected 
output signals with pass/fail information. Its purpose is to help the test 
program developer to quickly debug patterns and analyze DUT 
behavior.

The Waveform Tool has online and offline modes. In online mode, the 
VK Test Station software must be running. In offline mode, the 
Waveform Tool can run as a stand-alone application within the IDE.

This chapter contains the following information about the Waveform 
Tool:

• “Waveform Tool Main Window” on page 211: Provides descriptions 
of the Waveform Tool main window and the Waveform Setup 
window functional areas, menus, menu commands, and dialog 
boxes.

• “Waveform Tool Getting Started” on page 255: Describes how to 
setup, capture, and display waveforms for analysis.

NOTE The actual colors displayed in this manual can be viewed from its 
Acrobat Reader PDF file on the Versatest Series Manuals CD-ROM. If 
you are viewing the PDF file, you can use Acrobat Reader’s View > 
Zoom In and View > Zoom Out menu bar commands to adjust the 
display magnification to help you see graphics such as waveforms.
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Waveform Tool Main Window

The Waveform Tool consists of a Waveform Tool main window for 
displaying waveforms (similar to Figure 6-1) and a Waveform Setup 
window for setting up capture parameters (Figure 6-2 on page 212).

The Workspace tab in the Navigator pane displays two Waveform Tool 
icons (similar to Figure 6-1): WaveformTool and 
WaveformToolSetup. Double-clicking the WaveformTool icon 
displays the Waveform Tool main window. Double-clicking the 
WaveformToolSetup icon displays the default Waveform Setup 
window (Figure 6-2).

Figure 6-1. Waveform Tool Main Window  

Navigator Pane

WaveformTool Icon

WaveformToolSetup Icon

Toolbar Menu Bar Tool Document Window

Waveform Tool Document Window

Waveform Display Pane

Document Tab (Waveform Tool)

Output Pane

Workspace
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Figure 6-2. Waveform Setup Window  

See the “Waveform Setup Window” section on page 244 for information 
about how to configure the waveform capture settings in preparation to 
capture the waveform in online mode.

The Waveform Tool main window (Figure 6-1) is composed of the 
following functional areas:

• Navigator Pane: See the View > Navigator Pane command on 
page 227

• Toolbar: See the View > Toolbar command on page 224

• Menu bar on page 213

• Tool Document Window (on page 242): Displays the following 
Waveform Tool components:

• Tree View Pane on page 242

• Waveform Display Pane page 243

WaveformToolSetup Icon Waveform Setup Window

Loop Command

Query Valid APG Patern List

Waveform Setup Document Tab

Workspace Tab

Navigator
Pane
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• Document Tabs: See the View > Document Tabs command 
on page 227

• Output Pane: See the View > Output Pane command on 
page 227

• Status Bar: See the View > Status Bar command on page 226

Menu Bar

The menu bar at the top of the Waveform Tool main window (Figure 
6-1 on page 211) contains the following 12 pull-down menus from 
which you select commands for controlling functionality such as 
capturing waveforms and changing display features:

• File menu on page 213

• Edit menu on page 220

• View menu on page 223

• Tools menu on page 231

• Tester menu on page 234

• Program menu on page 235

• Build menu on page 236

• Setup menu on page 237

• Capture menu on page 239

• Recapture menu on page 239

• Window menu on page 240

• Help menu on page 241

File Menu

Selecting File in the menu bar opens the menu in Figure 6-3.
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Figure 6-3. File Menu  

The File menu contains the following commands:

•  New command on page 215

•  Open command on page 217

• Close command on page 219

• Close All command on page 219

•  Save command on page 219

• Save As command on page 219

• Open Workspace command on page 219

• Save Workspace command on page 219

• Close Workspace Command on page 220

•  Print command on page 220

• Print Preview command on page 220

• Print Setup command on page 220

• Recent Workspaces on page 220

• Exit command on page 220
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New Command (File Menu)

 Displays the New command submenu (Figure 6-4) that allows you 
to display a new Workspace or create new IDE documents. The New  
toolbar button displays a New dialog box that lists the same items to 
select as the submenu.

Figure 6-4. File > New Command Submenu  

The New command submenu contains the following commands:

• Workspace command on page 215

• C Debugger Document command on page 216

• Pin Tool Document command on page 216

• Waveform Document command on page 216

• Waveform Setup Document command on page 216

• Test Program Document command on page 216

• Timing Tool Document command on page 216

• Pattern Tool Document command on page 216

• Bitmap Tool DUT Document command on page 216

• File command on page 216

Workspace Command (New Command Submenu)

Displays as the active Workspace its default with its corresponding 
Menu bar, Toolbar, Navigator pane, Output pane, and Status bar.
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C Debugger Document Command (New Command Submenu)

Displays as the active document a blank C Debugger document with its 
corresponding Menu bar, Toolbar, Navigator pane, Document tab (and 
window), Output pane, and Status bar.

PinTool Document Command (New Command Submenu)

Displays as the active document a blank PinTool document with its 
corresponding Menu bar, Toolbar, Navigator pane, Document tab (and 
window), Output pane, and Status bar.

Waveform Document Command (New Command Submenu)

Displays as the active document a blank Waveform Tool document 
with its corresponding Menu bar, Toolbar, Navigator pane, Document 
tab (and window), Output pane, and Status bar.

Waveform Setup Document Command (New Command Submenu)

Displays as the active document a blank Waveform Setup Tool 
document with its corresponding Menu bar, Toolbar, Navigator pane, 
Document tab (and window), Output pane, and Status bar.

Test Program Document Command (New Command Submenu)

Note currently supported by the IDE.

Timing Tool Document Command (New Command Submenu)

Displays as the active document a blank Timing Tool document with 
its corresponding Menu bar, Toolbar, Navigator pane, Document tab 
(and graphical display window), Output pane, and Status bar.

Pattern Tool Document Command (New Command Submenu)

Displays as the active document a blank Pattern Tool document with 
its corresponding Menu bar, Toolbar, Navigator pane, Document tab 
(and window), Output pane, and Status bar.

Bitmap Tool DUT Document Command (New Command Submenu)

Displays an Open dialog box from which you open a DUT Description 
file (.dut) to display a blank Bitmap Tool document with the loaded 
DUT file and corresponding Menu bar, Toolbar, Navigator pane, 
Document tab (and window), Output pane, and Status bar.

File Command (New Command Submenu)

Not currently supported by the IDE.
216 Versatest Series IDE User’s Guide

Revision D, May 2005



Chapter 6  Waveform Tool

Waveform Tool Main Window
Open Command (File Menu)

 Displays the Open command submenu (Figure 6-5) that allows you 
to open a Workspace or IDE documents from the submenu list. The 
Open  toolbar button displays a generic Open dialog box from which 
you can open a selection listed in the submenu.

Figure 6-5. Open Command Submenu  

The Open command submenu contains the following commands that 
display an Open dialog box similar to Figure 6-6:

• C Debugger Document command on page 218

• PinTool Document command on page 218

• Waveform Document command on page 218

• Waveform Setup Document command on page 218

• Test Program Document command on page 218

• Timing Tool Document command on page 218

• Pattern Tool Document command on page 219

• Bitmap Tool DUT Document command on page 219

• File command on page 219
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Figure 6-6. File > Open Dialog Box  

C Debugger Document Command (Open Command Submenu)

Displays an Open dialog box (Figure 6-6) to select a previously saved C 
Debugger Tool document file with a *.cof extension.

PinTool Document Command (Open Command Submenu)

Displays an Open dialog box (similar to Figure 6-6) to select a 
previously saved PinTool document file with a *.pin file extension.

Waveform Document Command (Open Command Submenu)

Displays an Open dialog box (similar to Figure 6-6) to select a 
previously saved Waveform document file with a *.dnc file extension.

Waveform Setup Document Command (Open Command Submenu)

Displays an Open dialog box (similar to Figure 6-6) to select a 
previously saved Waveform Setup document file with a *.stp file 
extension.

Test Program Document Command (Open Command Submenu)

Note currently supported by the IDE.

Timing Tool Document Command (Open Command Submenu)

Displays an Open dialog box (similar to Figure 6-6) to select a 
previously saved Timing Tool document file with a *.vtt file extension.
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Pattern Tool Document Command (Open Command Submenu)

Displays an Open dialog box (similar to Figure 6-6) to select a 
previously saved Pattern Tool document file with an *.apg2 file 
extension.

Bitmap Tool DUT Document Command (Open Command Submenu)

Displays an Open dialog box (similar to Figure 6-6) to select a 
previously saved Bitmap Tool DUT definition document file with a 
*.dut file extension.

File Command (Open Command Submenu)

Note currently supported by the IDE.

Close Command (File Menu)

Closes the active tool document.

Close All Command (File Menu)

Closes all tool documents.

Save Command (File Menu)

 Saves the active document file.

Save As Command (File Menu)

Displays the Save As dialog box to save the active tool document file.

Open Workspace Command (File Menu)

Displays an Open Workspace dialog box with a *.wsp extension. If 
changes have been made to the current workspace, you will be asked if 
you would like to save the changes before closing the current 
workspace and opening another. The Workspace consists of the tools, 
layout, and open documents.

Save Workspace Command (File Menu)

Saves the current workspace with a *.wsp extension. The Workspace 
consists of the tools, layout, and open documents. This command 
enables you to save the tools, layout, and open documents’ current 
state, and later resume with the same Workspace by using the File > 
Open Workspace command.
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Close Workspace Command (File Menu)

Closes the current workspace. If changes have been made to the 
current workspace, you will be asked if you would like to save the 
changes before closing the current workspace.

Print Command (File Menu)

 Prints the waveform in the active waveform document window

Print Preview Command (File Menu)

Not supported by the Waveform Tool.

Print Setup Command (File Menu)

Displays a printer setup dialog box that allows you to select and 
configure a printer.

Recent Workspaces Command (File Menu)

Displays a Recent Workspaces submenu from which you can select a 
workspace.

Exit Command (File Menu)

Closes the IDE. If the workspace or any other tool document files have 
changed, you will be asked if you would like to save them.

Edit Menu

Selecting Edit in the menu bar opens the menu in Figure 6-7.

Figure 6-7. Edit Menu  
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The Edit menu contains the following commands:

• Undo command on page 221

• Redo command on page 221

•  Cut command on page 221

•  Copy command on page 221

•  Paste command on page 221

• Find command on page 221

• Replace command on page 221

• Find in Files command on page 222

Undo Command (Edit Menu)

Not currently supported by the Waveform Tool.

Redo Command (Edit Menu)

Not currently supported by the Waveform Tool.

Cut Command (Edit Menu)

 Cuts the selected waveform from the Waveform Tool Document 
window. The waveform can only be cut when it has been defined as an 
individual pin in the APG code and in the Waveform Setup window. It 
can not be part of a bus of pins (group).

Copy Command (Edit Menu)

 Copies the waveform in the in the Waveform Tool Document 
window (similar to Figure 6-1 on page 211) to the Clipboard so it can be 
pasted into a Word document or other application.

Paste Command (Edit Menu)

 Not currently supported by the Waveform Tool.

Find Command (Edit Menu)

Not currently supported by the Waveform Tool.

Replace Command (Edit Menu)

Not currently supported by the Waveform Tool.
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Find in Files Command (Edit Menu)

Displays the Find in Files dialog box (Figure 6-8) that provides search 
capability based on the criteria you specify.

The dialog box contains the following fields:

• Find What – Enter the name of symbol or text you would like to 
find.

• In files/file types – The type of files to look in (referenced by 
extension), or specific files that you would like to search (for 
example, "*.c" or ".apg", or "p:\src\myprogram\file1"). If you would 
like to specify multiple types of files, separate each term by a space, 
for example, "*.c *.apg p:\src\myprogram\file1".

• In folder – Enter the name of the directories you would like to 
search in. If you click on the button next to this field (labeled "…"), 
you can select a folder through a GUI file dialog interface.

• Match whole word only – If you check this box, only the lines 
containing the target as a whole (and not as part of another word) 
will be displayed.

• Match case  – If you check this box, the lines containing the target 
will be displayed only if the cases match.

• Regular Expressions – If you check this box, the text in the 
Find What field will be interpreted as a regular expression,

• Look in subfolders  – If you check this box, in addition to 
searching the folders specified in the In Folder field, the 
subdirectories of the folders specified in the In Folder field will 
be searched.

• Find in Workspace – If you check this box, only the files 
contained in the workspace will be searched. The "In Folder" field 
will be ignored.

After clicking on the  button, the Find in Files output tab will be 
brought to the front in the Output Pane, the results from the search 
process will be displayed as they are generated. If you double-click on 
any of the lines, the file specified on that line will be opened, and the 
file window will be scrolled to the location specified by the line you 
double-clicked.

Find
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Figure 6-8. Find in Files Dialog Box  

View Menu

Selecting View in the menu bar opens the menu in Figure 6-9.

Figure 6-9. View Menu  
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The View menu contains the following commands:

• Toolbar command on page 224

• Status Bar command on page 226

• Navigator Pane command on page 227

• Output Pane command on page 227

• Document Tabs command on page 227

• Cursor mode command on page 227

• Cursor Floating command on page 228

• Toggle Cursor command on page 228

• Show Legend command on page 229

• Zoom In X command on page 229

• Zoom Out X command on page 229

• Zoom In Y command on page 229

• Zoom Out Y command on page 229

• Auto Scale command on page 229

• Original Scale command on page 229

• Decrease V/DIV command on page 229

• Increase V/DIV command on page 229

• Vector Grid command on page 230

• Set Bus Value Radix command on page 230

• Capture Mode Tooltip command on page 230

• Append Mode command on page 231

Toolbar Command (View Menu)

Displays or hides the toolbar shown in Figure 6-10. The toolbar 
displays at the top of the Waveform Tool main window when a ✓  
displays in front of its command in the View menu. Clicking on the 
buttons in the toolbar give you quick access to many of the menu bar 
commands. Clicking in the Display pane activates the associated 
toolbar buttons.
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Figure 6-10. Waveform Tool Toolbar  

The toolbar contains the following command buttons:

New

Open

Save

Cut

Copy

Paste

Print

Help About

Help

Set Online

Set Offline

Acquire
  Data

Apply
Changes

Abort 
Acquire

Site Connect
Status

Power Off

Power On

Recapture

  

Waveform Setup File

Start

Abort

Capture

Trigger 
cursor 
on/off

Analyzer
mode

Recapture
Scope
mode

Decrease
V/DIV

Increase
V/DIV

Turn vector
grid on/off 

Enable
capture

mode tooltip

Zoom 
in X

Zoom
out X

Zoom 
in Y

Zoom
out Y

Auto scale

Original
scale

Toggle

mode 
cursor

Toggle
cursor

Toggle

floating
cursors

Toggle 
show

legend

 File > New on page 215  Tester > Set Online on page 234

 File > Open on page 217  Tester > Set Offline on page 235

 File > Save on page 219  Tester > Acquire Data on page 235 (not supported by 
Waveform Tool)

 Edit > Cut on page 221  Tester > Apply Changes on page 235 (not supported 
by Waveform Tool)
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Status Bar Command (View Menu)

Displays or hides the Status Bar (Figure 6-1 on page 211). The Status 
Bar displays at the bottom of the Waveform Tool main window when a 
✓  displays in front of its command in the View menu. The Status Bar 
provides information about the current state of what you are viewing 
in the window and any other status-oriented information.

 Edit > Copy the plot on page 221  Tester > Abort Acquire on page 235 (not supported by 
Waveform Tool)

 Edit > Paste on page 221  IDE Site Connect Status

 File > Print on page 220  Tester > Power On on page 235

 Help > About on page 241  Tester > Power Off on page 235

 Help > Help on page 241

 Waveform Setup File  View > Zoom In X on page 229

 Capture > Start capture on page 239  View > Zoom Out X on page 229

 Capture > Abort on page 239  View > Zoom In Y on page 229

 Setup > Recapture setting (Trigger 
cursor on/off) on page 238

 View > Zoom Out Y on page 229

 Recapture > Recapture with Logic 
Analyzer mode on page 240

 View > Auto scale on page 229

 Recapture > Recapture with Scope 
mode on page 240

 View > Original scale on page 229

 View > Decrease V/DIV on page 229  View > Toggle cursor mode on page 227

 View > Increase V/DIV on page 229  View > Toggle cursor on page 228

 View > Turn vector grid on/off on 
page 230

 View > Toggle cursors floating on page 228

 View > Enable capture mode tooltip on 
page 230

 View > Toggle show legend on page 229
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Navigator Pane Command (View Menu)

Displays the Navigator Pane (similar to Figure 6-1 on page 211) when 
a ✓  displays in front of its command in the View menu.

The Waveform Tool is associated with the WaveformTool and 
WaveformToolSetup icons on the Workspace Tab  in the 
Navigator Pane.

Output Pane Command (View Menu)

Displays the Output Pane (similar to Figure 6-1 on page 211) when a ✓  
displays in front of its command in the View menu. The Waveform Tool 
is associated with the following tabs in the Output Pane:

• VOS Command tab: The VOS Command tab is enabled when the 
IDE is set online by the selecting the yellow Set Online  toolbar 
button or the corresponding Tester > Set Online command. 
The VOS Command tab allows you to enter VOS terminal 
commands and display the results on the tab and in the 
corresponding test site window in the VK Test Station main 
window. See the “VOS Terminal Commands” chapter in the 
Command Reference Volume 2 for the available commands.

• Find in Files tab: This tab displays output from a Find In Files 
process as it is generated from the results of the Edit > Find In 
Files command dialog box (Figure 6-8 on page 223).

Document Tabs Command (View Menu)

Displays the Document Tabs at the bottom of the Tool Document 
Window (similar to Figure 6-1 on page 211) when a ✓  displays in front 
of its command in the View menu.

Cursor Mode Command (View Menu)

 Displays a red horizontal cursor line (y = voltage) and a red 
vertical cursor line (x = time) through the waveform plot (similar to 
Figure 6-11). It also displays in white text in the lower left corner of the 
document window the voltage and time at the plot coordinates where 
the two lines intersect. Pressing the left  and right  arrow keys 
moves the red vertical cursor line, and pressing the up  and down  
arrow keys moves the horizontal red cursor line, and the voltage/time 
values displayed in the lower left change as the cursors move.

Selecting a waveform to highlight it moves the red horizontal and 
vertical cursors to beginning of that waveform. Pressing the  key 
and clicking and dragging the mouse cursor allows you to zoom in on 
the selected region.

Ctrl
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Figure 6-11. Waveform Tool Display Features  

Cursor Floating Command (View Menu)

 Floats the various horizontal and vertical cursors that can display 
in the document window (Figure 6-11) when a ✓  displays in front of the 
command. Otherwise, the cursors attach to waveform capture data 
points.

Toggle Cursor Command (View Menu)

 Displays a broken white horizontal cursor line and a broken white 
vertical line through the plot (similar to Figure 6-11 on page 228). The 
corresponding x/y delta from the red horizontal lines displays in white 
text in the lower right corner of the document window.

View > Toggle Cursor >
Displays Broken White X/Y Cursors

View > Cursor Mode >
Displays Red X/Y Cursors

View > Vector Grid

View > Cursor Mode >
Displays Voltage/Timing 

at  Red X/Y Cursors

View > Show Legend >
Displays Waveform Legend

View > Toggle Cursor >
Displays X/Y Delta 
White/Red Cursors

Failures Display
in Red
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Show Legend Command (View Menu)

 Displays the legend for all of the waveforms at the bottom of the 
document window that identifies the channels with the corresponding 
channel number (similar to Figure 6-11 on page 228). Selected 
waveforms display with white lines in the legend.

Zoom In X Command (View Menu)

 Zooms in on the waveform document window to magnify the 
waveform X axis

Zoom Out X Command (View Menu)

 Zooms out in the waveform document window to reduce the 
magnification of the waveform X axis

Zoom In Y Command (View Menu)

 Zooms in on the waveform document window to magnify the 
waveform Y axis V/DIV.

Zoom Out Y Command (View Menu)

 Zooms out in the waveform document window to reduce the 
magnification of the waveform Y axis V/DIV.

Auto Scale Command (View Menu)

 Displays all waveform data in the waveform document window.

Original Scale Command (View Menu)

 Returns the waveform document window to its original scale when 
the plot was captured.

Decrease V/DIV Command (View Menu)

 Decreases the voltage/division for a selected waveform.

Increase V/DIV Command (View Menu)

 Increases the voltage/division for a selected waveform.
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Vector Grid Command (View Menu)

 Toggles the X-axis scale display at the bottom of the waveform 
document window to display in either a time scale in ns or vectors. The 
X axis displays in vectors when a ✓  displays in front of the command 
(similar to Figure 6-11 on page 228). The first vector on the left end of 
the X axis is the entry point in the pattern, and the vectors to the right 
on the X axis are offset from the entry point. The X axis displays a time 
scale in ns when a ✓  does not display in front of the command (similar 
to Figure 6-1 on page 211).

Set Bus Value Radix Command (View Menu)

Displays the Set Bus Value Radix submenu (Figure 6-12). The 
selection in this submenu specifies whether bus values in the 
waveform document window display in hex, binary, or octal.

Figure 6-12. Set Bus Value Radix Submenu  

Capture Mode Tooltip Command (View Menu)

 Displays a small blue diamond-shaped vector boundary and 
ground marker on each waveform plot, and also displays the capture 
mode for a waveform vector when you position the cursor over a blue 
marker (Figure 6-13).

Figure 6-13. Capture Mode Tooltip  

View > Capture Mode Tooltip
displays blue vector boundary 

and ground markers

Mouse cursor
over blue marker
displays vector's
capture mode
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Append Mode Command (View Menu)

Appends by adding to the bottom of an existing waveform document 
window its next waveform capture, rather than clearing the existing 
capture and replacing it with the new capture. You can scroll up and 
down to see multiple waveform captures in the same waveform 
document window.

Tools Menu

Selecting Tools in the menu bar opens the menu in Figure 6-14. The 
commands in the Tools menu are only for Agilent-internal use for the 
Waveform Tool.

Figure 6-14. Tools Menu  

The Tools menu contains the following commands:

• Options command on page 231

• Properties command on page 232

Options Command (Tools Menu)

Displays the Options submenu shown in Figure 6-15.

Figure 6-15. Options Submenu  

The Options command submenu contains the following commands:
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• Ide Options command on page 232

• TPIParser Options command on page 232

• TesterTool Options command on page 232

• StaticScopeTool Options command on page 232

• StaticPinTool Options command on page 232

• StaticTPT Options command on page 232

• WaveformTool Options command on page 232

Ide Options Command (Options Command Submenu)

Not currently supported by the IDE.

TPIParser Options Command (Options Command Submenu)

Not currently supported by the IDE.

TesterTool Options Command (Options Command Submenu)

Not currently supported by the IDE.

StaticScopeTool Options Command (Options Command Submenu)

Not currently supported by the IDE.

StaticPinTool Options Command (Options Command Submenu)

Not currently supported by the IDE.

StaticTPT Options Command (Options Command Submenu)

Not currently supported by the IDE.

WaveformTool Options Command (Options Command Submenu)

Not currently supported by the IDE.

Properties Command (Tools Menu)

Displays the Properties submenu shown in Figure 6-16.
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Figure 6-16. Properties Submenu  

The Properties command submenu contains the following commands:

• Ide Properties command on page 233

• TPIParser Properties command on page 233

• TesterTool Properties command on page 233

• StaticScopeTool Properties command on page 233

• StaticPinTool Properties command on page 233

• StaticTPT Properties command on page 234

• WaveformTool Properties command on page 234

Ide Properties Command (Properties Command Submenu)

Not currently supported by the IDE.

TPIParser Properties Command (Properties Command Submenu)

Not currently supported by the IDE.

TesterTool Properties Command (Properties Command Submenu)

Not currently supported by the IDE.

StaticScopeTool Properties Command (Properties Command 
Submenu)

Not currently supported by the IDE.

StaticPinTool Properties Command (Properties Command Submenu)

Not currently supported by the IDE.
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StaticTPT Properties Command (Properties Command Submenu)

Not currently supported by the IDE.

WaveformTool Properties Command (Properties Command 
Submenu)

Not currently supported by the IDE.

Tester Menu

Selecting Tester in the menu bar opens the menu in Figure 6-17.

Figure 6-17. Tester Menu  

The Tester menu contains the following commands:

•  Set Online command on page 234

•  Set Offline command on page 235

•  Acquire Data command on page 235

•  Apply Changes command on page 235

•  Abort Acquire command on page 235

•  Tester Power On command on page 235

•  Tester Power Off command on page 235

Set Online Command (Tester Menu)

 Connects the IDE to the tester for the following tools that support 
online mode:

• C Program Debugger (currently has no offline capability)

• Pattern Tool (currently has no offline capability)

• Waveform Tool

• Timing Tool
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Set Offline Command (Tester Menu)

 Disconnects the IDE from the tester. The following tools support 
offline mode:

• Pin Tool (currently has no online capability)

• Waveform Tool (viewing saved files only)

• Timing Tool (viewing saved files only)

• Bitmap Tool (currently has no online capability)

Acquire Data Command (Tester Menu)

 Not supported by the Waveform Tool. The Timing Tool supports 
this command.

Apply Changes Command (Tester Menu)

 Not supported by the Waveform Tool. The Timing Tool supports 
this command.

Abort Acquire Command (Tester Menu)

 Not supported by the Waveform Tool. The Timing Tool supports 
this command.

Tester Power On Command (Tester Menu)

 Same as the VK Test Station main window Utilities > Power 
On command and its corresponding  toolbar button. Resets and 
powers up the test sites (Test Head).

Tester Power Off Command (Tester Menu)

 Same as the VK Test Station main window Utilities > Power 
Off command and its corresponding  toolbar button. Turns off 
power to the test sites (Test Head).

Program Menu

Selecting Program in the menu bar opens the menu in Figure 6-18. The 
Program menu is not currently supported by the IDE.
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Figure 6-18. Program Menu  

The Program menu contains the following commands:

• Set Active Test Program command on page 236

• Add Files to Test Program command on page 236

• Remove from Test Program command on page 236

Set Active Test Program Command (Program Menu)

Not currently supported by the IDE.

Add Files to Test Program Command (Program Menu)

Not currently supported by the IDE.

Remove from Test Program Command (Program Menu)

Not currently supported by the IDE.

Build Menu

Selecting Build in the menu bar opens the menu in Figure 6-19. The 
Build menu is not currently supported by the IDE.

Figure 6-19. Build Menu  

The Build menu contains the following commands:

• Build command on page 237

• Compile command on page 237
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• Compile Patterns command on page 237

• Compile C Sources command on page 237

• Rebuild All command on page 237

• Stop Build command on page 237

• Clean Build command on page 237

Build Command (Build Menu)

Not currently supported by the IDE.

Compile Command (Build Menu)

Not currently supported by the IDE.

Compile Patterns Command (Build Menu)

Not currently supported by the IDE.

Compile C Sources Command (Build Menu)

Not currently supported by the IDE.

Rebuild All Command (Build Menu)

Not currently supported by the IDE.

Stop Build Command (Build Menu)

Not currently supported by the IDE.

Clean Build Command (Build Menu)

Not currently supported by the IDE.

Setup Menu

Selecting Setup in the menu bar opens the menu in Figure 6-20.

Figure 6-20. Setup Menu  

The Setup menu contains the following commands:
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• Recapture Setting command on page 238

• Offline Mode command on page 238

• Generate Log File command on page 239

Recapture Setting Command (Setup Menu)

 Displays the Recapture Setting cursors in the waveform tool 
window (similar to Figure 6-21 that shows no previous waveform 
capture) when a ✓  displays in front of the command. These cursors set 
the boundaries for recapturing a selected waveform using the 
Recapture > Logic Analyzer Mode command (on page 240) or the 
Recapture > Scope Mode command (on page 240). The cursors can 
be moved by placing the mouse cursor over a handle, pressing the 
middle mouse button to select it, and dragging the cursor using the 
mouse ball.

Figure 6-21. Recapture Setting Cursors  

Offline Mode Command (Setup Menu)

For internal Agilent use.

Mouse cursor over handle displays green
rectangle to drag recapture cursors

Setup > ✓ Recapture Setting command
purple vertical cursors
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Generate Log File Command (Setup Menu)

For internal Agilent use.

Capture Menu

Selecting Capture in the menu bar opens the menu in Figure 6-22.

Figure 6-22. Capture Menu  

The Capture menu contains the following commands:

•  Start command on page 239

•  Abort command on page 239

Start Command (Capture Menu)

 Captures and displays the waveform plot. Prior to executing the 
Capture > Start command, see the “Waveform Setup Window” on 
page 244 or “Configuring the Waveform Tool Setup” on page 270 for 
details about how to configure the capture settings, trigger conditions, 
capture modes, and display settings in preparation to capture a 
waveform plot in online mode.

Abort Command (Capture Menu)

 After selecting the Capture > Start command, stops the 
capture if you would like to stop it before it is complete.

Recapture Menu

Selecting Recapture in the menu bar opens the menu in Figure 6-23. 
This menu is enabled when a waveform is selected and the Setup > 
Recapture Setup command (on page 238) is selected.

Figure 6-23. Recapture Menu  

The Recapture menu contains the following commands:
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•  Logic Analyzer Mode command on page 240

•  Scope Mode command on page 240

Logic Analyzer Mode Command (Recapture Menu)

 Recaptures the plot of the selected waveform in the waveform 
document window using Logic Analyzer mode. This command is 
enabled when a waveform is selected and the Setup > Recapture 
Setup command (on page 238) is selected. The section of the selected 
waveform that is recaptured is between the Setup > Recapture 
Setting command cursors (similar to Figure 6-21 on page 238).

Scope Mode Command (Recapture Menu)

 Recaptures the plot of the selected waveform in the waveform 
document window using Scope mode. This command is enabled when a 
waveform is selected and the Setup > Recapture Setup command 
(on page 238) is selected. The section of the selected waveform that is 
recaptured is between the Setup > Recapture Setting command 
cursors (similar to Figure 6-21 on page 238).

Window Menu

Selecting Window in the menu bar opens the menu in Figure 6-24.

Figure 6-24. Window Menu  

The Window menu contains the following commands:

• New Window command on page 241

• Close command on page 241

• Close All command on page 241

• Cascade command on page 241

• Tile command on page 241

• Minimize All command on page 241
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New Window Command (Window Menu)

Displays a blank copy of the active waveform tool window with the 
same waveform setup.

Close Command (Window Menu)

Closes the active tool document window.

Close All Command (Window Menu)

Closes all tool document windows with their corresponding tabs.

Cascade Command (Window Menu)

Cascades all open tool document windows in an overlapping fashion 
one on top of another with the title bar of each visible.

Tile Command (Window Menu)

Tiles all open tool document windows in a non-overlapping fashion.

Minimize All Command (Window Menu)

Not currently supported by the IDE.

Help Menu

Selecting Help in the menu bar opens the menu in Figure 6-25.

Figure 6-25. Help Menu  

The Help menu contains the following two commands:

Help Topics Command (Help Menu)

 Not currently supported.

About V4400 Software Command (Help Menu)

 Displays the About V4400 Series Tester Software dialog box that 
contains software component version and copyright information 
(similar to Figure 6-26).
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Figure 6-26. About V4400 Software Dialog Box   

Tool Document Pane

The Tool Document Pane for the Waveform Tool is the Waveform Tool 
Document Window (Figure 6-1 on page 211). The Waveform Tool 
Document Window consists of two parts. The left part contains the 
Tree View Pane and the right part is the Waveform Display Pane.

Tree View Pane

The Tree View Pane (Figure 6-1 on page 211) displays the pin group 
list defined in the Waveform Setup Window (Figure 6-28 on page 244). 

In the Tree View Pane, selecting the  button for a pin group causes 
the tree for that group to collapse to display just the pin group name, 
and the Waveform Display Pane also collapses to display only the 
waveform for the group (bus), rather than for the group and each 
individual channel in the group. Similarly, selecting the  button for a 
collapsed group causes that group’s tree to expand, and the 
corresponding individual channel waveforms are added to the display 
pane.

Clicking to select one or multiple pins (  + click) in the Channel List 
Tree pane and then pressing the right mouse button displays a pop-up 
menu (Figure 6-27) that allows you to perform the waveform display 
actions listed in the menu for the selected pins.

–

+

Ctrl
242 Versatest Series IDE User’s Guide

Revision D, May 2005



Chapter 6  Waveform Tool

Waveform Tool Main Window
Figure 6-27. Selected Pins Pop-Up Menu  

Waveform Display Pane

The Waveform Display Pane on the right side of Figure 6-1 on page 211 
displays the captured waveform plots. After completing the setup 
parameters in the Waveform Setup Window, selecting the Capture > 
Start command or the Start Capture  toolbar button captures and 
displays the waveform plot. Waveform green color indicates pass 
vectors and red indicates fail vectors.

Selecting the View > Vector Grid command toggles the X-axis 
scale display at the bottom of the document window to display in either 
a time scale in ns or vectors. The X axis displays in vectors when a ✓  
displays in front of the command. The first vector on the left end of the 
X axis is the entry point in the pattern, and the vectors to the right on 
the X axis are offset from the entry point. The X axis displays a time 
scale in ns when a ✓  does not display in front of the command.

Selecting a channel’s waveform to highlight it and then selecting 
View > Increase V/DIV increases the voltage/division for that 
waveform. Similarly, selecting a channel’s waveform to highlight it and 
then selecting View > Decrease V/DIV decreases the 
voltage/division for that waveform.

Selecting View > Show Legend displays the legend for all of the 
waveforms at the bottom of the document window that identifies the 
channels with the corresponding PE channel numbers. Selected 
waveforms display in white in both the plot and the legend. To select 
channels, run the cursor over the V/DIV label at the beginning of each 
waveform. The label becomes highlighted with a rectangular box. Left 
click here and an asterisk ( * ) will appear. This indicates that 
channel has been selected. Multiple channels can be selected this way.
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To move a waveform, right-click on the V/DIV label and drag the 
mouse.

Waveform Setup Window

The default Waveform Setup Window is shown in Figure 6-28. This 
window is used to configure capture settings.

Figure 6-28. Waveform Setup Window  

The Waveform Setup Window contains the following fields:

• Capture Trigger By (Figure 6-29 on page 245): Trigger by the 
scope vector command in the pattern file is always required. It 
means the waveform capture (when activated by selecting 
Capture > Start) is triggered by the next scope instruction in 
the pattern file.

Capture trigger by Setup Loop Command

Loop Command

Query Valid APG Patern List

Custom

Waveform Setup Document Tab

Name, Capture Mode, Show P/F, Level Scale, and Label

Select/Edit Pin Setup Name

Capture Setting
244 Versatest Series IDE User’s Guide

Revision D, May 2005



Chapter 6  Waveform Tool

Waveform Tool Main Window
• APG register: Triggering by the APG register is optional. 
Selecting this check box and its button displays the Trigger 
Condition Setting dialog box (Figure 6-30 on page 246) that 
allows you to also specify triggering by the contents of the x, y, 
and z address generators, the a, b, and c counters, and/or the dlo 
and dhi data generators. It supports multiple choices and the 
"AND" operation will be applied to the multiple choices. A value 
must be specified for a register whose check box is selected. For 
example, if x=0, y=3, and z=0 are the selected conditions, this 
means the waveform capture is started when 
(x=0)&(y=3)&(z=0).

NOTE When using generator conditions to gate a scope trigger, unless you 
need to "scope" the vectors at the beginning of the pattern where initial 
generator conditions are established, you should put the scope 
command after all initial generator condition commands are 
completed. Successive entries into the pattern with unknown generator 
values can result in unexpected triggers and data display.  

• Delay by Vector: Specifies the number of vectors to delay 
from where the scope vector command before triggering.

Figure 6-29. Waveform Setup Capture Trigger By Pane  
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Figure 6-30. Trigger Condition Setting Dialog Box  

• Capture Setting (Waveform Setup window Figure 6-31 on page 
246):

• Vector: Specifies the number of vectors you want to capture.

• Timing Resolution: For Scope mode and Logic Analyzer 
mode, specifies the timing resolution of the sampling rate.

• Level Resolution: Specifies the voltage resolution of the 
sampling.

• Logic Hi (V): For display purposes only, specifies the voltage 
level that will display for PEL level = 1 (pin electronics logic 
level).

• Logic Lo (V): For display purposes only, specifies the voltage 
level that will display for PEL level = 0.

Figure 6-31. Waveform Setup Capture Setting Pane  
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• Setup Loop Command (Waveform Setup window: Figure 6-34 on 
page 248):

• Loop Command: Tells the tool which APG patterns and C 
atomics will be looped in order to capture the waveform. You 
can type in the APG pattern name here or press the 

 button to give you a selection list of the APG 
patterns.

You can type atomics and pattern names into the Loop Command 
pane (Figure 6-34) to setup for the pattern you want to capture the 
waveform. To loop on the pattern you want to capture the 
waveform, the scope vector command must be included where the 
waveform capture will be triggered (similar to Figure 6-32).

Figure 6-32. APG Pattern Scope Vector Command Entry

The following C code shown in Figure 6-33 is an example of code to 
enter into the Loop Command pane to setup with atomics and a 
pattern and then loop on the FORMAT pattern shown in 
Figure 6-32.

Figure 6-33. Example Loop Command Pane C Code

Query Valid APG Pattern List

@pattern logic_patterns
{
FORMAT: entry //Waveform Tool

NS200, vec, rerr, scope,
format apg_inpins nr=0x00000000, format apg_outpins cn=0x00000000;  // 1

NS200, vec, format apg_inpins nr=0xffffffff, format apg_outpins cn=0xffffffff;  // 2
NS200, vec, format apg_inpins nr=0x00000000, format apg_outpins cn=0x00000000;  // 3
NS200, vec, format apg_inpins nr=0xffffffff, format apg_outpins cn=0xffffffff;  // 4
NS100, vec, format apg_inpins nr=0x00000000, format apg_outpins cn=0x00000000;  // 5
NS100, vec, format apg_inpins nr=0x55555555, format apg_outpins cn=0x55555555;  // 6
NS100, vec, format apg_inpins nr=0xaaaaaaaa, format apg_outpins cn=0xaaaaaaaa;  // 7
NS100, vec, format apg_inpins nr=0x00000000, format apg_outpins cn=0x00000000;  // 8
NS100, vec, format apg_inpins nr=0x00000000, format apg_outpins cn=0x00000000;  // 9

.

.

.

atomic;
atomic;

.

.

.
run_apg(“setup”);

atomic;
atomic;

.

.

.
run_apg(“FORMAT”);
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Figure 6-34. Waveform Setup Loop Command  

• Select/Edit Pin Setup Name and  button (Waveform 
Setup window: Figure 6-35):

Figure 6-35. Waveform Setup Select/Edit Pin Setup Name  

To select pins for display, first specify the pin set name to be shared by 
all the other tools by typing a name in the Select/Edit Pin Setup 
Name text box and then selecting the  button to display a window 
with a list of the pin groups defined in the test program in the Valid 
Selection List (similar to panel on the right of Figure 6-36). This 
example types pinset1 in the Select/Edit Pin Setup Name 
text box and then selects the  button.

Custom

Custom

Custom

Custom
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Figure 6-36. Pin Selection List  

Scrolling down the Valid Selection List and double-clicking on a 
pin or group adds and displays it in the Define Display Pin Group 
List panel on the left (similar to Figure 6-37).

Define Display Pin Group List

pinset1

Valid Selection
List
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Figure 6-37. Adding Pins or Groups for Display  

You can also filter out pins you do not want by first selecting them, 
right-clicking to display a pop-up menu, and then selecting the 
Delete command in the menu (similar to Figure 6-38).

Valid Selection
List

Double-click
apg_outpins

pinset1

Define Display Pin Group List
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Figure 6-38. Cutting Pins from the Define Display Pin Group List  

• Name (similar to Waveform Setup window Figure 6-39): Selecting 
the Waveform Setup Document tab displays the Waveform Setup 
window with the pin or group Name (+apg_outpins) added to the 
bottom of the setup window (Figure 6-39). The + (plus) symbol 
indicates that it is a pin group that can be opened to display the 
pins in the group.

Figure 6-39. Pin Group Added to Waveform Setup  

Placing the cursor next to the added pin group (+apg_outpins) 
changes the cursor to a right arrow (Figure 6-39) that you can left-click 
and open +apg_outpins group to display all of the pins in the group 
(Figure 6-40). Note that when the group name opens to display all of 
the pins in the group, the +apg_outpins changes to –apg_outpins 
to indicate the branch has expanded. You can close the 
–apg_outpins group by placing the cursor at one of the pins in the 
group to display the right arrow again and left-click the pin.
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Figure 6-40. Waveform Setup Displaying Individual Group Pins   

• Capture Mode (Waveform Setup window Figure 6-41): Selecting 
the Capture Mode column down arrow in the drop-down list box 
displays the following six different waveform capture modes 
(Figure 6-68):

Figure 6-41. Waveform Setup Capture Modes   

• Reconstruction mode: Can be used only for input pins. The 
tool gets the logic values by translating the pattern files and the 
values are categorized at four levels: VHH, VIH, VIL and HiZ. 
This draws a digital waveform that illustrates what the DUT 
inputs should be seeing.

• High Speed mode: Can be used only for output pins. This 
mode constructs the waveform by a single-shot capture based on 
the captured value during the strobe edge/period. The main 
reason to use this mode is for high speed. This draws a digital 
waveform created by examining the pattern for expected 
behavior and running the pattern to gather actual pass/fail 
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information at comparisons to illustrate the DUT output 
behavior.

• Expected Data mode: Can be used only for output pins. The 
tool gets the programmed expected data from the test program. 
This draws a digital waveform that illustrates what the DUT 
outputs are expected to be driving (not what they are actually 
driving). Think of this mode as drawing a picture of the compare 
cycles in the pattern.

• Rcnst/HS (Reconstruction and High Speed) mode: A 
combination of these two modes to capture both input and 
output pins simultaneously.

• Logic Analyzer mode: Available for both input pins and 
output pins. The signals captured in this mode are the 
measured signals (applied to both input and output pins). They 
are constructed by multiple samples per cycle based on the 
timing resolution that is set. For the output pins, the waveforms 
are the logic values using VOH and VOL as thresholds. For the 
input pins, the waveform data are categorized as four levels: 
VHH, VIH, VIL and HiZ. This mode provides the speed between 
High Speed mode and Scope mode. It provides more information 
about the waveform transition timing, but does not display the 
real voltage. It is scope mode with special voltage thresholds 
used to create a digitized-analog waveform in a shorter amount 
of time but sacrificing voltage accuracy.

• Scope mode: This mode is used for both DUT input pins and 
output pins, but it is important to note that the measurement is 
made at the tester comparator not at the DUT. This mode 
constructs the waveforms with the actual voltage levels and 
timing. It is high resolution and slow speed. It draws an analog 
waveform that runs the pattern numerous times, measuring 
voltage at the comparator at discreet times and voltage 
resolutions defined by the user.

• Show P/F (Waveform Setup window Figure 6-42): Selecting the 
Show P/F column down arrow in the drop-down list box displays 
the following two display options:

• Show pass/fail: Displays failures in red.

• Not show pass/fail: No display change for failures.
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Figure 6-42. Waveform Setup Show Pass/Fail  

• Level Scale: Specifies the level scale per division.

• Label (Waveform Setup window Figure 6-43): Specifies a label for 
the selected channel settings.

• Enter the Note (Waveform Setup window Figure 6-43): Allows 
you to record notes about this waveform plot that are saved with 
the waveform file.

Figure 6-43. Waveform Setup Enter the Note Text Box  

Label Column

Enter the Note Text Box
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Waveform Tool Getting Started

Waveform Tool is to capture, display, and analyze waveforms in a 
fashion similar to oscilloscopes and logic analyzers for test program 
debugging. It supports both online and offline modes. Waveform 
capture has to be performed online. Offline capability gives you the 
convenience to review and analyzing the waveform without connecting 
to the tester.

This section demonstrates how to setup, capture, and display 
waveforms for analysis. For additional information about the 
Waveform Tool, see the “Waveform Tool Main Window” section on 
page 211 that provides descriptions of all the menus, menu commands, 
and dialog boxes that make up the tool’s interface.

Getting Started Contents

This Getting Started contains the following examples:

• “Loading the Test Program” on page 256

• “Using the C Program Debugger to Control Program Execution” on 
page 262

• “Displaying the Waveform Tool Document Window” on page 268

• “Configuring the Waveform Tool Setup” on page 270

• “Capturing the Waveform Plot” on page 280

• “Using the Display Features” on page 283

NOTE The actual colors displayed in this manual can be viewed from its 
Acrobat Reader PDF file on the Versatest Series Manuals CD-ROM. If 
you are viewing the PDF file, you can use Acrobat Reader’s View > 
Zoom In and View > Zoom Out menu bar commands to adjust the 
display magnification to help you see graphics such as waveforms.
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Loading the Test Program

In this section of the Getting Started we will perform the following 
tasks in preparation to capture waveforms and debug failing vectors 
using the C Program Debugger and Waveform Tool:

• Launch the VK Test Station application and display its VK Test 
Station main window.

• Load a plan file, power on the test sites (test head), and download 
the test program files specified in the plan file to the test sites.

1 Selecting  > All Programs > Versatest Test System 
Software > VK Test Station displays the VK Test Station main 
window (similar to Figure 6-44). Note that the Status Bar displays 
Station Status: Idle Ready NO PHYSICAL SITE CONFIGURED 
that indicates the test sites are powered off and no plan file is loaded.

Figure 6-44. VK Test Station Main Window  

Menu Bar Toolbar Testing Status Window

Datalog Window

Status Bar
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2 In the menu bar, selecting Init Lot > Enter Lot Information 
displays the Initialize Test Station Setup dialog box (Figure 6-45) that 
is used to set up each lot for testing.

Figure 6-45. Initialize Test Station Setup Dialog Box  

3 Selecting the  button displays the Open dialog box (Figure 6-46) 
that lists the available plan files. Test plan files define the tester setup 
that is used. The TestDrive_scope_gui.PLN plan file will be used 
for this example.

Test Plan
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Figure 6-46. Select Test Plan Dialog Box  

4 Selecting the TestDrive_scope_gui.PLN plan file and then 
selecting  displays the Initialize Test Station Setup dialog box 
with the plan file displayed in the Test Plan field (Figure 6-44 on page 
256).

5 Selecting the  button in the dialog box displays a Red Hand Alert 
dialog box that warns about the loss of summary data (Figure 6-47). 
The TEST_PLAN_WARNING plan file configuration switch controls 
whether this dialog box displays. The default is for it to display.

Open

Save
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Figure 6-47. Red Hand Alert Are You Sure Dialog Box  

6 Selecting  displays another Red Hand Alert dialog box (Figure 6-48) 
that warns to Z down the wafer and disconnect all DUTs prior to 
initialization of the test sites. The TEST_PLAN_WARNING plan file 
switch also controls whether this dialog box displays.

OK
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Figure 6-48. Red Hand Alert Z-Down Dialog Box  

7 Selecting  displays the Test Plan Validation dialog box 
(Figure 6-49). The VALIDATE 0x10 plan file test switch controls 
whether this dialog box displays. It displays the corresponding 
checksums and adds them to the summary file.

Figure 6-49. Test Plan Validation Dialog Box  

OK
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8 Selecting  begins the test head power on and downloads the 
Versatest Operating System (VOS) and the test program files specified 
in the plan file. The power on is complete when the terminal prompt 
A1> displays in the Datalog window (Figure 6-50). Note that the 
Status Bar displays Station Status: Ready DISPLAYING LOG 
FOR TEST SITE: 1 (A1) that indicates the test sites are powered on 
and ready to run the downloaded test program.

Figure 6-50. VK Test Station Main Window After Power On  

OK

Menu Bar Toolbar Testing Status Window

Datalog Window

Status Bar

A1 Site Status Window

A1 Terminal Prompt
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Using the C Program Debugger to Control Program 
Execution

The C Program Debugger allows you to control the execution and 
inspect the status at the C language source code level. In this section of 
the Getting Started, we will use the C Program Debugger to perform 
the following tasks:

• Download a device test program.

• Set a break point.

1 Selecting  > All Programs > Versatest Test System 
Software > Integrated Development Environment displays 
the default V4400 Series Tester Software main window that contains 
the Integrated Development Environment or IDE (similar to 
Figure 6-51). The Menu bar and Toolbar are context sensitive and 
change for the selected active tool or document. The menus and 
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Toolbar show and enable only the commands and buttons that are 
relevant to the tool or document you have selected.

Figure 6-51. V4400 Series Tester Software IDE Main Window  

2 Selecting the yellow light bulb Set Online  toolbar button or 
corresponding Tester > Set Online command enables the IDE to 
connect to the tester when the Site Connect Status drop-down list box 
Site: A1  is enabled as shown in the toolbar in Figure 6-52.

Navigator Pane Menu Bar Toolbar

Tool Document Window

Output Pane

Workspace Tab

Tools Tab

Status Bar
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Figure 6-52. IDE Main Window Set Online  

3 Choosing the site that the IDE connects to is done by selecting the 
down-arrow  button on the right side of the Site Connect Status drop-
down list box to display the available sites and selecting from the list 
(similar to Figure 6-53). Selecting a tool makes the connection to that 
site and disables the Site Connect Status drop-down list box.

Figure 6-53. Site Connect Status Drop-Down List Box  

4 Selecting the Navigator pane Tools tab  icon displays its tab 
(Figure 6-54).

Output Pane

Site Connect Status drop-down list box

Navigator Pane

Workspace Tab

Tools Tab

Pattern Tool Icon
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Figure 6-54. Navigator Pane Tools Tab  

5 Double-clicking CDebugger under Debug Tools (Figure 6-54) 
displays the C Debugger as the active tool in the Tool Document 
window (Figure 6-55). Selecting the tool makes the connection to that 
site and disables the Site Connect Status drop-down list box. This also 
adds the C Debugger  (Cdeb) tab to the Navigator pane, its menu 
bar and toolbar, and displays the Workspace in the Navigator Pane.

Navigator Pane

Workspace Tab

Tools Tab
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Figure 6-55. IDE Displaying C Debugger  

6 Selecting the Cdeb  tab in the Navigator pane displays its tab that 
lists all the source code file names and function names for the loaded 
test program (similar to Figure 6-56).

Site Connect Status drop-down list box

C Debugger Document Tab

Cdeb Tab

Navigator Pane

Output Pane

Tool Document Window

Workspace Tab
Tools Tab
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Figure 6-56. C Debugger Cdeb Tab  

7 Navigating to and double-clicking the LOGICTEST.C > logicFORMAT 
function displays it in a window in the Tool Document Window (similar 
to Figure 6-57).
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Figure 6-57. C Debugger Displaying Break Point  

8 Before using the Waveform Tool, the test program has to be loaded and 
the break point needs to be set right before the run_apg command. 
Positioning the cursor in the source line shown in Figure 6-57 and 
selecting the Debug > Break command, the  key, or the Break 
Point  button in the toolbar inserts a break point that displays as a 
red diamond tag in the gray margin on the left side of the source code. 
Note that the Status bar at the bottom of the window displays the line 
number (Ln) and column (Col) the cursor is active.

Displaying the Waveform Tool Document Window

The Workspace tab in the Navigator pane displays two Waveform Tool 
icons (similar to Figure 6-58): WaveformTool and 
WaveformToolSetup. The WaveformTool icon displays the main 
interface for displaying waveforms. The WaveformToolSetup icon 
displays an interface for setting up capture parameters.

Double-clicking the WaveformTool icon displays the default 
Waveform Tool document tab window (Figure 6-58). Selecting its 
window’s maximize  button displays it full-window.

logicFORMAT Function

Break
Point

run_apg(FORMAT);

F9
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Figure 6-58. Default Waveform Tool Document Tab Window  

Setting Up the Waveform Capture Trigger

A scope entry needs to be set in the APG patterns you would like to 
analyze. This is where the waveform capture will be triggered. Before 
using the Waveform Tool, the test program has to be loaded and the 
break point needs to be set right before the run_apg command. The 
following APG pattern code (Figure 6-59) shows the scope vector 
command entry set for this example. This is where the waveform 
capture will be triggered.

WaveformTool Icon

WaveformTool Setup Icon

Waveform Tool Document Tab Window

Navigator
Pane

Workspace Tab

Waveform Tool Document Tab

Output Pane
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Figure 6-59. APG Pattern Scope Vector Command Entry

Configuring the Waveform Tool Setup

This section describes how to configure the waveform capture settings 
using the Waveform Tool Setup in preparation for capturing the 
waveform plot in online mode using the Waveform Tool.

1 Double-clicking the WaveformToolSetup icon displays the default 
Waveform Tool Setup document tab window called Waveform Setup 
(similar to Figure 6-60).

@pattern logic_patterns
{
FORMAT: entry //Waveform Tool

NS200, vec, rerr, scope,
format apg_inpins nr=0x00000000, format apg_outpins cn=0x00000000;  // 1

NS200, vec, format apg_inpins nr=0xffffffff, format apg_outpins cn=0xffffffff;  // 2
NS200, vec, format apg_inpins nr=0x00000000, format apg_outpins cn=0x00000000;  // 3
NS200, vec, format apg_inpins nr=0xffffffff, format apg_outpins cn=0xffffffff;  // 4
NS100, vec, format apg_inpins nr=0x00000000, format apg_outpins cn=0x00000000;  // 5
NS100, vec, format apg_inpins nr=0x55555555, format apg_outpins cn=0x55555555;  // 6
NS100, vec, format apg_inpins nr=0xaaaaaaaa, format apg_outpins cn=0xaaaaaaaa;  // 7
NS100, vec, format apg_inpins nr=0x00000000, format apg_outpins cn=0x00000000;  // 8
NS100, vec, format apg_inpins nr=0x00000000, format apg_outpins cn=0x00000000;  // 9

.

.

.
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Figure 6-60. Default Waveform Setup Document Tab Window  

2 One of the more important parameters in the Waveform Setup is the 
Loop Command (Figure 6-60). This tells the tool which APG patterns 
and C modules will be looped in order to capture the waveform. You 
can type in the APG pattern name in the text box or press the 

 button to display a selection list of the APG 
patterns. For this example, we will select the  
button to display the list and then select the FORMAT pattern to 
display it in the Loop Command text box (similar to Figure 6-61): 
run_apg(FORMAT).

WaveformToolSetup Icon Waveform Setup Window

Loop Command

Query Valid APG Patern List

Waveform Setup Document Tab

Workspace Tab

Navigator
Pane

Query Valid APG Pattern List

Query Valid APG Pattern List
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Figure 6-61. Waveform Setup Displaying Selected APG Pattern  

3 To select pins for display, first specify the pin set name to be shared by 
all the other tools by typing pinset1 in the Select/Edit Pin 
Setup Name text box (Figure 6-61).

4 Selecting the  button displays a window with a list of the pin 
groups defined in the test program in the Valid Selection List 
(panel on the right of Figure 6-62).

Waveform Setup Window

run(FORMAT)

Query Valid APG
Pattern List 

FORMAT 

Select/Edit Pin
Setup Name

Type pinset1 and Select Custom

Custom

Custom
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Figure 6-62. Pin Selection List  

5 Scrolling down the Valid Selection List and double-clicking on 
the apg_outpins group adds and displays that pin group to 
pinset1 in the Define Display Pin Group List panel on the 
left (Figure 6-63).

Define Display Pin Group List

pinset1

Valid Selection
List
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Figure 6-63. Adding apg_outpins to pinset1 for Display  

6 You can also filter out pins you do not want by first selecting them, 
right-clicking to display a pop-up menu, and then selecting the 
Delete command in the menu (Figure 6-64).

Valid Selection
List

Double-click
apg_outpins

pinset1

Define Display Pin Group List
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Figure 6-64. Deleting Pins from the pinset1 Display Group  

7 Selecting the Waveform Setup Document tab displays the Waveform 
Setup Window with the +apg_outpins added to the botton of the 
setup window (Figure 6-65). The + (plus) symbol indicates that this is 
a pin group that can be opened to display the pins in the group.
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Figure 6-65. Waveform Setup Window Displaying apg_outpins Group  

8 Placing the cursor next to the +apg_outpins changes the cursor to a 
right arrow (Figure 6-66) that you can left-click and open 
+apg_outpins group to display all of the pins in the group 
(Figure 6-67). Note that when the group name opens to display all of 
the pins in the group, the +apg_outpins changes to –apg_outpins 
to indicate the branch has expanded. You can close the 
–apg_outpins group by placing the cursor at one of the pins in the 
group to display the right arrow again and left-click the pin.

Waveform Setup Window

pinset1

+apg_outpins Waveform Setup Document Tab

Capture Setting Panel
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Figure 6-66. Cursor Displays Right Arrow Next to apg_outpins Group  

Figure 6-67. Displaying –apg_outpins Group Individual Pins  
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9 Selecting the Capture Mode column down-arrow in the 
+apg_outpins drop-down list box displays the following six different 
waveform capture modes (Figure 6-68):

• Reconstruction mode: Can be used only for input pins. The tool gets 
the logic values by translating the pattern files and the values are 
categorized at four levels: VHH, VIH, VIL and HiZ. This draws a 
digital waveform that illustrates what the DUT inputs should be 
seeing.

• High Speed mode: Can be used only for output pins. This mode 
constructs the waveform by a single-shot capture based on the 
captured value during the strobe edge/period. The main reason to 
use this mode is for high speed. This draws a digital waveform 
created by examining the pattern for expected behavior and 
running the pattern to gather actual pass/fail information at 
comparisons to illustrate the DUT output behavior.

• Expected Data mode: Can be used only for output pins. The tool 
gets the programmed expected data from the test program. This 
draws a digital waveform that illustrates what the DUT outputs 
are expected to be driving (not what they are actually driving). 
Think of this mode as drawing a picture of the compare cycles in 
the pattern.

• Rcnst/HS (Reconstruction and High Speed) mode: A combination of 
these two modes to capture both input and output pins 
simultaneously.

• Logic Analyzer mode: Available for both input pins and output pins. 
The signals captured in this mode are the measured signals 
(applied to both input and output pins). They are constructed by 
multiple samples per cycle based on the timing resolution that is 
set. For the output pins, the waveforms are the logic values using 
VOH and VOL as thresholds. For the input pins, the waveform data 
are categorized as four levels: VHH, VIH, VIL and HiZ. This mode 
provides the speed between High Speed mode and Scope mode. It 
provides more information about the waveform transition timing, 
but does not display the real voltage. It is scope mode with special 
voltage thresholds used to create a digitized-analog waveform in a 
shorter amount of time but sacrificing voltage accuracy.

• Scope mode: This mode is used for both DUT input pins and output 
pins, but it is important to note that the measurement is made at the 
tester comparator not at the DUT. This mode constructs the 
waveforms with the actual voltage levels and timing. It is high 
resolution and slow speed. It draws an analog waveform that runs 
the pattern numerous times, measuring voltage at the comparator 
at discreet times and voltage resolutions defined by the user.
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Figure 6-68. Displaying the +apg_outpins Capture Modes  

10 To get a rough idea of the failure analysis, it is recommended that 
Reconstruction, High Speed, or Reconstruction/High Speed mode be 
used. Reconstruction mode is for the pure input pins. High Speed mode 
is for pure output pins. The Reconstruction/High speed mode is for IO 
pins. In general these modes are faster but the timing and levels 
measurements will not be as accurate. To get more accurate timing 
information, you could use Logic Analyzer mode. And to get accurate 
timing and level information, you could use Scope mode. The Expected 
Data mode is purely for output cycles.

It is recommended starting with the default Rcnst/HS 
(Reconstruction and High Speed) mode and leave the default Show 
Pass/Fail in its column to give you a quick view (Figure 6-69).

Figure 6-69. Show Pass/Fail Drop-Down List Box  

11 In the Capture Setting panel (Figure 6-65 on page 276), the following 
fields are changed from their defaults (Figure 6-70):

• Vector: 30 – Specifies the number of vectors to capture.

• Timing Resolution: 10 ns – For Scope mode and Logic Analyzer 
mode, specifies the timing resolution of the sampling rate.
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Figure 6-70. Waveform Setup Capture Setting Panel  

Capturing the Waveform Plot

This section describes how to capture the waveform plot in online mode 
after configuring the waveform setup.

After configuring the waveform setup, the C Debugger is used to run 
the test program to the break point that was set (Figure 6-57 on page 
268).

1 Selecting the LOGICTEST.C document tab displays the C Debugger 
document window with its context-sensitive menu bar and toolbar 
(Figure 6-57 on page 268).

2 Selecting the Debug > Run command or the Run  toolbar button 
launches the program and causes it to run to the break point 
(Figure 6-71). A green arrow displays over the break point where the 
program stops.
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Figure 6-71. Run Program to Break Point  

3 Selecting the Waveform Tool Document tab displays its window with 
its corresponding menus and toolbars (Figure 6-72).

Selecting Debug > Run to Break Point
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Figure 6-72. Waveform Tool Document Window Prior to Capture  

4 Selecting the Capture > Start command or the Start Capture  
toolbar button captures and displays the waveform plot (similar to 
Figure 6-73).

Start Capture Button

Waveform Tool Document Window
Navigator

Pane

Workspace Tab

Waveform Tool Document Tab

Output Pane
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Figure 6-73. Captured Waveform Plot  

Using the Display Features

This section describes some of the Waveform Tool display features that 
can be used for viewing and analyzing waveform data.

View > Toggle Cursor >
Displays Broken White X/Y Cursors

View > Cursor Mode >
Displays Red X/Y Cursors

View > Vector Grid

View > Cursor Mode >
Displays Voltage/Timing 

at  Red X/Y Cursors

View > Show Legend >
Displays Waveform Legend

View > Toggle Cursor >
Displays X/Y Delta 
White/Red Cursors

Failures Display
in Red
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1 Selecting  button for the apg_outpins group causes the tree to 
collapse to display just the pin group name, and the waveform 
document plot also collapses to display only the waveform for the group 
(bus) and displays the bus value for all the individual pins, rather than 
for the group and each individual channel in the group. Similarly, 
selecting the  button for a collapsed group causes that group’s tree to 
expand, and the corresponding individual channel waveforms are 
added to the waveform document plot.

2 Selecting the View > Vector Grid command toggles the X-axis 
scale display at the bottom of the document window to display in either 
a time scale in ns or vectors. The X axis displays in vectors when a ✓  
displays in front of the command. The first vector on the left end of the 
X axis is the entry point in the pattern, and the vectors to the right on 
the X axis are offset from the entry point. The X axis displays a time 
scale in ns when a ✓  does not display in front of the command (similar 
to Figure 6-73).

3 Selecting View > Cursor Mode displays a red horizontal cursor line 
(y = voltage) and a red vertical cursor line (x = time) through the plot 
(Figure 6-73). It also displays in white text in the lower left corner of 
the document window the voltage and time at the plot coordinates 
where the two lines intersect. Pressing the left  and right  arrow 
keys moves the red vertical cursor line, and pressing the up  and 
down  arrow keys moves the horizontal red cursor line, and the 
voltage/time values displayed in the lower left change as the cursors 
move.

4 Selecting View > Toggle Cursor displays a broken white 
horizontal cursor line and a broken white vertical line through the plot 
(Figure 6-73). The corresponding x/y delta from the red horizontal lines 
displays in white text in the lower right corner of the document 
window.

5 Selecting View > Show Legend displays the legend for all of the 
waveforms at the bottom of the document window that identifies the 
channels with the corresponding PE channel numbers (Figure 6-73). 
Selected waveforms display in white in both the plot and the legend. To 
select channels, run the cursor over the V/DIV label at the beginning 
of each waveform. The label becomes highlighted with a rectangular 
box. Left click here and an asterisk ( * ) will appear. This indicates 
that channel has been selected. Multiple channels can be selected this 
way.

–

+
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6 Selecting a channel’s waveform to highlight it and then selecting 
View > Increase V/DIV increases the voltage/division for that 
waveform. Similarly, selecting a channel’s waveform to highlight it and 
then selecting View > Decrease V/DIV decreases the 
voltage/division for that waveform.

7 Moving waveforms is also supported. To move a waveform, right-click 
on the V/DIV label and drag the mouse.

8 Selecting items in the tree view pane displays a pop-up menu that 
provides additional display options (Figure 6-74).

Figure 6-74. Selected Pins Pop-Up Menu  
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Introduction
Introduction

This chapter provides information for the Versatest Series Timing 
Tool. This tool displays global time set (GTS), local time set (LTS), and 
timing edge information in a graphical and tabular format. Its purpose 
is to help the test program developer to quickly debug timing patterns.

Chapter Contents

This chapter contains the following information about the Timing Tool:

• “Timing Tool Overview” on page 289: Provides a summary of the 
features, display information, the data used, pattern rule checking 
capabilities, online and offline modes, and related test program and 
VOS terminal commands.

• “Timing Tool Main Window” on page 291: Provides descriptions of 
the application interface functional areas, display formats, menus, 
menu commands, and dialog boxes.

• “Timing Tool Getting Started” on page 323: Describes how to load a 
test program, launch the IDE, connect to a test site, display the 
Timing Tool Document Window, and acquire and display the timing 
data in the Timing Tool graphical and tabular views. It also 
describes how to run the Timing Tool in offline mode.

NOTE The actual colors displayed in this manual can be viewed from its 
Acrobat Reader PDF file on the Versatest Series Manuals CD-ROM. If 
you are viewing the PDF file, you can use Acrobat Reader’s View > 
Zoom In and View > Zoom Out menu bar commands to adjust the 
display magnification to help you see graphics such as waveforms.
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The Timing Tool displays GTS, LTS, and timing edge information in a 
graphical and tabular format.

The graphical display currently shows all of the theoretical vector 
information related to timing that includes the global time sets, 
formats, cycle times, and the following six edge settings:

• IO Start

• IO End

• Drive Start

• Drive End

• Strobe Start

• Strobe End

The tabular format displays selected pins in a tabular format. It shows 
the GTS currently set up for the selected pins and the corresponding 
LTS mapped to the GTS.

The Timing Tool also provides the capability to test the given timing 
data for Pattern Language Programming Rules violations and display 
errors in both the graphical and tabular views.

The Timing Tool has online and offline modes. In online mode, the 
timing data is acquired from the a specified physical test site and the 
vector data is from the current test program. In offline mode, the data 
comes from a previously saved Timing Tool file. The Timing Tool file is 
created in online mode after the data has been acquired. After the data 
is acquired in online mode or the Timing Tool file is opened in offline 
mode, the features are currently the same for both modes, except 
offline mode can not interact with the hardware.

The following commands set up timing in the test program. See the 
Versatest Series Command Reference Volume 1 for command 
descriptions.

• get_drive_time_ps 

• get_io_time_ps 

• get_strobe_time_ps 

• set_cycle_time 

• set_cycle_time_ps 
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• set_drive_time 

• set_drive_time_ns 

• set_drive_time_ps 

• set_io_time 

• set_io_time_ns 

• set_io_time_ps 

• set_strobe_time 

• set_strobe_time_ns 

• set_strobe_time_ps 

• set_tsmap 

The following VOS terminal commands are used for timing debug. See 
the Versatest Series Command Reference Volume 2 for command 
descriptions.

• dgts 

• dt

• dtw 

• mtde 

• mtds

• mtie 

• mtis 

• mtse 

• mtss 

• mtswin 

• sts 

The initial release of the Timing Tool does not support all of the menu 
commands and features described in this chapter. The application’s 
capabilities are being released in phases. The initial phase focuses on 
debug. This phase will have little development capability. Later 
releases will incorporate features to assist in developing of test 
program timing as well as additional enhancements to debug resulting 
from tools integration.
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The Timing Tool graphical view is similar to that shown in Figure 7-1. 
The Timing Tool tabular view is similar to that shown in Figure 7-2 on 
page 293.

Selecting View > Mode > Graphical displays Figure 7-1 as the 
active view.

Selecting View > Mode > Tabular displays Figure 7-2 as the active 
view.

These two views of the Timing Tool are the application interface. The 
interface is composed of the following functional areas:

• Navigator Pane: See the View > Navigator Pane command on 
page 304

• Menu bar on page 293

• File menu on page 294

• Edit menu on page 299

• View menu on page 301

• Tools menu on page 311

• Tester menu on page 314

• Data menu on page 317

• Window menu on page 320

• Help menu on page 321

• Toolbar: See the View > Toolbar command on page 302

• Pin List Tree Pane on page 322

• Tool Document Window: Displays the following Timing Tool views:

• Graphical View Pane: See the View > Mode > Graphical 
command on page 306

• Tabular View Pane: See the View > Mode > Tabular 
command on page 305

• Output Pane: See the View > Output Pane command on 
page 304

• Status Bar: See the View > Status Bar command on page 304
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Figure 7-1. Timing Tool Main Window Graphical View Pane  
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View > Loads >

(Sawtooth Symbol)
Show Loads Format

Cycle Number
Document Tab (Timing Tool)

Output Pane

Entry Point Name
and Vector Offset
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Tools
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Unknown Data
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292 Versatest Series IDE User’s Guide

Revision D, May 2005



Chapter 7  Timing Tool

Timing Tool Main Window
Figure 7-2. Timing Tool Main Window Tabular View Pane  

Menu Bar

The menu bar at the top of the Timing Tool main window (Figure 7-1 
on page 292) contains the following eight pull-down menus from which 
you can select commands:

• File menu on page 294

• Edit menu on page 299

• View menu on page 301

• Tools menu on page 311

• Tester menu on page 314

Output Pane

Menu Bar Toolbar Tool Document Window

Clicking Pin Group/
Name Expands and

Collapses Row

Tabular View Pane

Entry Point Label and Pattern NameStatus Bar

Document Tab (Timing Tool)

Navigator Pane

Pin
List
Tree
Pane
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• Data menu on page 317

• Window menu on page 320

• Help menu on page 321

File Menu

Selecting File in the menu bar opens the menu in Figure 7-3.

Figure 7-3. File Menu  

The File menu contains the following commands:

•  New command on page 295

•  Open command on page 296

• Close command on page 298

• Close All command on page 298

•  Save command on page 298

• Save As command on page 298

• Open Workspace command on page 298

• Save Workspace command on page 298

• Close Workspace Command on page 298

•  Print command on page 298
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• Print Preview command on page 299

• Print Setup command on page 299

• Recent Workspaces on page 299

• Recent File command on page 299

• Exit command on page 299

New Command (File Menu)

 Displays the New command submenu (Figure 7-4) that allows you 
to display a new Workspace or create new IDE documents. The New  
toolbar button displays a New dialog box that lists the same items to 
select as the submenu.

Figure 7-4. File > New Command Submenu  

The New command submenu contains the following commands:

• Workspace command on page 295

• PinTool Document command on page 295

• Waveform Document command on page 296

• Waveform Setup Document command on page 296

• Timing Tool Document command on page 296

Workspace Command (New Command Submenu)

Displays as the active Workspace its default with its corresponding 
Menu bar, Toolbar, Navigator pane, Output pane, and Status bar.

PinTool Document Command (New Command Submenu)

Displays as the active document a blank PinTool document with its 
corresponding Menu bar, Toolbar, Navigator pane, Document tab (and 
window), Output pane, and Status bar.
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Waveform Document Command (New Command Submenu)

Displays as the active document a blank Waveform Tool document 
with its corresponding Menu bar, Toolbar, Navigator pane, Document 
tab (and window), Output pane, and Status bar.

Waveform Setup Document Command (New Command Submenu)

Displays as the active document the default Waveform Setup Tool 
document with its corresponding Menu bar, Toolbar, Navigator pane, 
Document tab (and window), Output pane, and Status bar.

Timing Tool Document Command (New Command Submenu)

Displays as the active document a blank Timing Tool document with 
its corresponding Menu bar, Toolbar, Navigator pane, Document tab 
(and graphical display window), Output pane, and Status bar.

Open Command (File Menu)

 Displays the Open command submenu (Figure 7-5) that allows you 
to open a Workspace or IDE documents from the submenu list. The 
Open  toolbar button displays a generic Open dialog box from which 
you can open a selection listed in the submenu.

Figure 7-5. Open Command Submenu  

The Open command submenu contains the following commands that 
display an Open dialog box similar to Figure 7-6:

• C Debugger Document command on page 297

• PinTool Document command on page 297

• Waveform Document command on page 297

• Waveform Setup Document command on page 297

• Timing Tool Document command on page 297
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• Pattern Tool Document command on page 298

• Bitmap Tool DUT Document command on page 298

Figure 7-6. File > Open Dialog Box  

C Debugger Document Command (Open Command Submenu)

Displays an Open dialog box (similar to Figure 7-6) to select a 
previously saved C Debugger Tool document file with a *.cof extension.

PinTool Document Command (Open Command Submenu)

Displays an Open dialog box (similar to Figure 7-6) to select a 
previously saved PinTool document file with a *.pin file extension.

Waveform Document Command (Open Command Submenu)

Displays an Open dialog box (similar to Figure 7-6) to select a 
previously saved Waveform document file with a *.dnc file extension.

Waveform Setup Document Command (Open Command Submenu)

Displays an Open dialog box (similar to Figure 7-6) to select a 
previously saved Waveform Setup document file with a *.stp file 
extension.

Timing Tool Document Command (Open Command Submenu)

Displays an Open dialog box (similar to Figure 7-6) to select a 
previously saved Timing Tool document file with a *.vtt file extension.
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Pattern Tool Document Command (Open Command Submenu)

Displays an Open dialog box (Figure 7-6) to select a previously saved 
Pattern Tool document file with an *.apg2 file extension.

Bitmap Tool DUT Document Command (Open Command Submenu)

Displays an Open dialog box (similar to Figure 7-6) to select a 
previously saved Bitmap Tool DUT definition document file with a 
*.dut file extension.

Close Command (File Menu)

Closes the active tool document.

Close All Command (File Menu)

Closes all tool documents and displays the default IDE main window.

Save Command (File Menu)

 Saves the active document file.

Save As Command (File Menu)

Displays the Save As dialog box to save the active tool document file.

Open Workspace Command (File Menu)

Displays an Open Workspace dialog box with a *.wsp extension. If 
changes have been made to the current workspace, you will be asked if 
you would like to save the changes before closing the current 
workspace and opening another. The Workspace consists of the tools, 
layout, and open documents.

Save Workspace Command (File Menu)

Saves the current workspace with a *.wsp extension. The Workspace 
consists of the tools, layout, and open documents.

Close Workspace Command (File Menu)

Closes the current workspace. If changes have been made to the 
current workspace, you will be asked if you would like to save the 
changes before closing the current workspace.

Print Command (File Menu)

 Prints the Pin List Tree Pane that lists the displaying pin 
groups/labels of the active Timing Tool document window.
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Print Preview Command (File Menu)

Displays a print preview window of the Pin List Tree Pane that lists 
the displaying pin groups/labels of the active Timing Tool document 
window.

Print Setup Command (File Menu)

Displays a printer setup dialog box that allows you to select and 
configure a printer.

Recent Workspaces Command (File Menu)

Displays a Recent Workspaces submenu from which you can select a 
workspace.

Recent File Command (File Menu)

Not currently supported by the IDE.

Exit Command (File Menu)

Closes the IDE. If the workspace or any other tool document files have 
changed, you will be asked if you would like to save them.

Edit Menu

Selecting Edit in the menu bar opens the menu in Figure 7-3.

Figure 7-7. Edit Menu  

The Edit menu contains the following commands:

• Undo command below on page 300

• Redo command on page 300
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•  Cut command on page 300

•  Copy command below on page 300

•  Paste command on page 300

• Find command on page 300

• Replace command on page 301

• Find in Workspace on page 301

Undo Command (Edit Menu)

Allows you to undo any text editing in the Tabular View Pane.

Redo Command (Edit Menu)

Allows you to redo any text editing in the Tabular View Pane.

Cut Command (Edit Menu)

 Cuts the currently selected timing/vector information for insertion 
elsewhere.

Copy Command (Edit Menu)

 Copies the currently selected timing/vector information for 
insertion elsewhere.

Paste Command (Edit Menu)

 Inserts the last copied/cut timing data at the current spot in the 
vector sequence.

Find Command (Edit Menu)

Not supported by the Timing Tool. Displays the Find dialog box 
(Figure 7-8) used for text searching.

Figure 7-8. Find Command Dialog Box  
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Replace Command (Edit Menu)

Not supported by the Timing Tool. Displays the Replace dialog box 
(Figure 7-9) that provides text replacement capability based on the 
criteria you specify.

Figure 7-9. Replace Dialog Box  

Find in Workspace Command (Edit Menu)

Not currently supported by the IDE.

View Menu

Selecting View in the menu bar opens the menu in Figure 7-10.

Figure 7-10. View Menu  

The View menu contains the following commands:
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• Toolbar command on page 302

• Status Bar command on page 304

• Navigator Pane command on page 304

• Output Pane command on page 304

• Document Tabs command on page 305

• Mode command on page 305

• Edges command on page 308

• Units command on page 309

• Loads command on page 310

• Zoom In command on page 310

• Zoom Out command on page 310

• Zoom Reset command on page 311

Toolbar Command (View Menu)

Displays or hides the toolbar shown in Figure 7-11. The toolbar 
displays at the top of the Timing Tool main window when a ✓  displays 
in front of its command in the View menu. Clicking on the buttons in 
the toolbar give you quick access to many of the menu bar commands. 
Clicking in the Display pane activates the associated toolbar buttons. 
Positioning the mouse cursor over a toolbar button displays tooltip text 
with the corresponding command description.
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Figure 7-11. Timing Tool Toolbar  
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 File > New on page 295  Help > Help on page 321

 File > Open on page 296  Tester > Connect to VersaStation on page 315

 File > Save on page 298  Tester > Disconnect from VersaStation on 
page 315

 Edit > Cut on page 300  Tester > Power On on page 317

 Edit > Copy on page 300  Tester > Power Off on page 317
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Status Bar Command (View Menu)

Displays the Status Bar (similar to Figure 7-1 on page 292) in either 
the graphical or tabular display when a ✓  displays in front of its 
command in the View menu. The Status Bar displays the status of the 
active view window (for example, ready), the entry point of the 
displaying pattern, and the pattern name.

Navigator Pane Command (View Menu)

Displays the Navigator Pane (similar to Figure 7-1 on page 292) when 
a ✓  displays in front of its command in the View menu.

The Timing Tool is associated with the TimingTool icon on the Tools 
Tab  in the Navigator Pane.

Output Pane Command (View Menu)

Displays the Output Pane (similar to Figure 7-1 on page 292) when a ✓  
displays in front of its command in the View menu.

The Timing Tool is associated with the VOS Command tab in the 
Output Pane. The VOS Command tab is enabled when the IDE is set 
online by the selecting the yellow Set Online  toolbar button or the 
corresponding Tester > Set Online command. The VOS 

 Edit > Paste on page 300  Tester > Set Online on page 315

 File > Print on page 298  Tester > Set Offline on page 315

 Help > About on page 321  IDE Site Connect Status

 Tester > Acquire Data on page 316  View > Zoom In on page page 310

 Tester > Apply Changes on page 317  View > Zoom Out on page 310

 Tester > Abort Acquire on page 317  View > Reset Zoom on page 311

 View > Mode > Show Tabular View on 
page 305

 Data > Check Timing Rules on page 318

 View > Mode > Show Graphical View on page 
page 306
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Command tab allows you to enter VOS terminal commands and 
display the results on the tab and in the corresponding test site 
window in the VK Test Station main window. See the “VOS Terminal 
Commands” chapter in the Command Reference Volume 2 for the 
available commands.  

Document Tabs Command (View Menu)

Displays the Document Tabs at the bottom of the Tool Document 
Window (similar to Figure 7-1 on page 292) when a ✓  displays in front 
of its command in the View menu.

Mode Command (View Menu)

Displays the Mode submenu (Figure 7-12) that allows you to select 
either Tabular view in the active view window or Graphical view in the 
active view window.

Figure 7-12. Mode Submenu  

The Mode submenu contains the following two commands:

• View > Mode > Tabular below on page 305

• View > Mode > Graphical on page 306

Tabular Command (Mode Command Submenu)

 Displays the Tabular View Pane in the active document window 
(similar to Figure 7-2 on page 293) when a ✓  is displayed in front of its 
command in the Mode command submenu (Figure 7-12). It displays the 
selected pins in a tabular format. It shows the global time sets (GTS) 
currently set up for the selected pins and the corresponding local time 
sets (LTS) mapped to the GTS.

The tabular view (or grid view) consists of a header row, a row with the 
global timeset periods, followed by a row with the set of global timesets 
for each of the selected pin groups/pins being shown. Each pin row can 
be expanded or collapsed by clicking on the pin group/pin name (in the 
first column) to show the local timeset and edge settings for that pin.

Each pin row also has some columns dedicated to changing return 
mode and compare mode settings for that pin group/pin.
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When a pin row is expanded it will show a row for each local timeset 
used for that pin or pin group. Each local timeset row will show the 
global timeset(s) that use that local timeset, the edge settings for each 
of the six edges, and a column of APG rules violations. If there is a 
rules violation for a local timeset edge set, it will show up highlighted 
in red.

Global timeset values, local timesets, and edge settings can all be 
modified by clicking in the grid at the appropriate value and changing 
the setting in that cell. Rules violations that result from changing a 
value will immediately appear upon setting the value.

Graphical Command (Mode Command Submenu)

 Displays the Graphical View Pane in the active document window 
(similar to Figure 7-1 on page 292) when a ✓  is displayed in front of its 
command in the Mode command submenu (Figure 7-12).

The graphical view consists of the pin group or pin labels on the left, 
the vector or cycle information at the bottom, and details of the timing 
data in the middle.

The Graphical View Pane shows the following information that 
includes all of the theoretical vector information related to timing such 
as the global time sets, formats, cycle times, and six edge settings:

• A waveform showing the graphical representation of what the data 
will do. The green line indicates PEL =1 and a yellow line indicates 
a PEL = 0. Red indicates that the data is unknown. Gray displays 
for ambiguous data.

• Drive or compare format for the current cycle.

• Blue vertical lines showing cycle separation.

• Selectable blue diamond cycle marker that can be dragged or 
clicked on to change the cycle duration.

• Solid white lines separating pin group or pins.

• The following six edge settings with cycle numbers and edge 
designators that can be dragged to change their settings:

• IO Start (IS)

• IO End (IE)

• Drive Start (DS)

• Drive End (DE)

• Strobe Start (SS)

• Strobe End (SE)
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The vector information at the bottom of the Graphical View Pane 
shows the following:

• Accumulated time

• Global timeset name and number for the cycle starting

• Entry point name and offset for the cycle starting

• Cycle number

The following settings and parameters can be changed by double-
clicking on objects or areas on in the Graphical View Pane:

• Double-clicking on an edge marker displays an Edit Edge Value 
dialog box that allows you to edit the edge marker value (similar to 
Figure 7-13).

Figure 7-13. Edit Edge Dialog Box  

• Double-clicking on a blue diamond cycle marker displays an Edit 
Global Timeset dialog box that allows you to change the global 
timeset for that cycle (similar to Figure 7-14).
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Figure 7-14. Edit Global Timeset Dialog Box  

• Double-clicking anywhere else in the pin group or pin area displays 
an Edit Pin Attributes dialog box that allows you to change the 
channel mode and the pin mode (similar to Figure 7-15).

Figure 7-15. Edit Pin Attributes Dialog Box  

Edges Command (View Menu)

Displays the Edges submenu (Figure 7-16) that allows you to select 
displaying of Edges only or Edges with Formatting information in the 
Timing Tool main window Graphical Display (similar to Figure 7-1 on 
page 292).
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Figure 7-16. Edges Submenu  

The Edges submenu contains the following two commands:

Edges Only Command (Edges Command Submenu)

Displays the edges only without formatting information in the 
graphical view when a ✓  is displayed in front of its command in the 
Edges command submenu (Figure 7-16).

Edges With Formatting Command (Edges Command Submenu)

Displays the edges with formatting information in the graphical view 
(similar to Figure 7-1 on page 292) when a ✓  is displayed in front of its 
command in the Edges command submenu (Figure 7-16). For example, 
FMT = NC.

Units Command (View Menu)

Displays the Units submenu (Figure 7-17) that allows showing all 
timing values in one of the allowed units. All values being shown either 
in the tabular display or the graphical display change to reflect the 
unit choice.

Figure 7-17. Units Submenu  

The Units submenu contains the following two commands:

NanoSeconds Command (Units Command Submenu)

Shows all values displaying in either the tabular view or the graphical 
view in nanoseconds when a ✓  is displayed in front of its command in 
the Units command submenu (Figure 7-17).

PicoSeconds Command (Units Command Submenu)

Shows all values displaying in either the tabular view or the graphical 
view in picoseconds when a ✓  is displayed in front of its command in 
the Units command submenu (Figure 7-17).
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Loads Command (View Menu)

Displays the Loads submenu (Figure 7-18) that controls displaying of 
the active load format in the graphical view (similar to Figure 7-1 on 
page 292).

Figure 7-18. Loads Submenu  

The Loads submenu contains the following two commands:

Show Load Format Command (Units Command Submenu)

Displays the active load format in the graphical view (similar to Figure 
7-1 on page 292) when a ✓  is displayed in front of its command in the 
Loads command submenu (Figure 7-17).

The active load format sawtooth symbol in the graphical view 
represents the following:

• A dotted line means the load is driven by data.

• A solid line means the load is enabled.

• A broken line means it is ambiguous when showing a pin group 
when the active status is different for pins in the group.

Hide Load Format Command (Units Command Submenu)

Hides the active load format in the graphical view when a ✓  is 
displayed in front of its command in the Loads command submenu 
(Figure 7-17).

Zoom In Command (View Menu)

 Zooms in on the graphical view in the active window. When the 
display mode is showing in the tabular format, this command is 
disabled.

Zoom Out Command (View Menu)

 Zooms out on the graphical view in the active window. When the 
display mode is showing in the tabular format, this command is 
disabled.
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Zoom Reset Command (View Menu)

 Resets to the original zoom factor in the graphical view of the 
active window. When the display mode is showing in the tabular 
format, this command is disabled.

Tools Menu

Selecting Tools in the menu bar opens the menu in Figure 7-19.

Figure 7-19. Tools Menu  

The Tools menu contains the following commands:

• Options command on page 311

• Properties command on page 311

Options Command (Tools Menu)

Displays the Options submenu shown in Figure 7-20.

Figure 7-20. Options Submenu  

The Options command submenu contains the following command:

• TimingTool Options command on page 311

TimingTool Options Command (Options Command Submenu)

Not currently supported by the IDE.

Properties Command (Tools Menu)

Displays the Properties submenu shown in Figure 7-21.
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Figure 7-21. Properties Submenu  

The Properties command submenu contains the following command:

• TimingTool Properties command on page 312

TimingTool Properties Command (Properties Command Submenu)

Displays the Set Data Options dialog box (similar to Figure 7-22) that 
has the following two tabs:

• Pin Groups tab (Figure 7-22): Lists all pin groups for the current 
set of vectors that can be selected or de-selected to display and then 
select the  button.

• Global Timesets tab (similar to Figure 7-23): Lists all global time 
set for the current set of vectors that can be selected or de-selected 
to display and then select the  button.

OK

OK
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Figure 7-22. Set Options Dialog Box Pin Groups Tab  
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Figure 7-23. Set Options Dialog Box Global Timesets Tab  

Tester Menu

Selecting Tester in the menu bar opens the menu in Figure 7-24.

Figure 7-24. Tester Menu  

The Tester menu contains the following commands:
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•  Connect to VersaStation on page 315

•  Disconnect from VersaStation on page 315

•  Set Online command on page 315

•  Set Offline command on page 315

•  Acquire Data command on page 316

•  Apply Changes command on page 317

•  Abort Acquire command on page 317

•  Tester Power On command on page 317

•  Tester Power Off command on page 317

Connect to VersaStation Command (Tester Menu)

 Connects the IDE to VersaStation (formerly called PCM). The IDE 
must be connected to VersaStation (PCM) before it can be connected to 
a specific tester test site.

Disconnect from VersaStation Command (Tester Menu)

 Disconnects the IDE from VersaStation (formerly called PCM).

Set Online Command (Tester Menu)

 Connects the IDE to the tester for the following tools that support 
online mode. The IDE must be connected to VersaStation (formerly 
PCM) before it can be connected to a specific test site.

• C Program Debugger (currently has no offline capability)

• Pattern Tool (currently has no offline capability)

• Waveform Tool

• Timing Tool

Set Offline Command (Tester Menu)

 Disconnects the IDE from the tester. The following tools support 
offline mode:

• Pin Tool (currently has no online capability)

• Waveform Tool (viewing saved files only)

• Timing Tool (viewing saved files only)

• Bitmap Tool (currently has no online capability)
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Select the Open  toolbar button or the File > Open command to 
display an open dialog box from which a Timing Tool file with a .VTT 
(Versatest Timing Tool) extension is opened. The .VTT file is created by 
selecting File > Save after timing data is acquired in online mode 
by selecting Tester > Acquire Data.

Acquire Data Command (Tester Menu)

 Displays the Acquire Timing Data dialog box (similar to 
Figure 7-25) that specifies that data to be acquired and displayed. The 
timing data acquired is from the physical site specified in the toolbar 
Site Connect Status  drop-down list box and the vector data is 
from the current test program. Selecting the yellow Set Online  
toolbar button or corresponding Tester > Set Online command 
connects the IDE to the tester site A1 as shown in the toolbar 

 drop-down list box.

Figure 7-25. Acquire Timing Data Dialog Box  

The Acquire Timing Data dialog box contains the following fields:

• Vector Display Data panel:

• Patterns: Displays the patterns in the acquired timing data.
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• Entry Points: Displays the entry point for the selected 
pattern.

• Number of Vectors: Specifies the number of vectors in the 
selected pattern to display. The initial value is the number of 
vectors in the pattern.

• Offset from Entry: Specifies the offset from the entry point 
from which the data acquire begins.

• Current Vector Data panel:

• Pattern: Displays name of the selected pattern.

• Entry: Displays the name of the selected entry point.

• Size: Displays the number of vectors in the selected pattern.

• Offset: Displays the offset in the selected pattern.

•  button: Acquires the specified data and displays it in 
the Timing Tool graphical view (similar to Figure 7-1 on page 292).

Apply Changes Command (Tester Menu)

 Downloads edited timing data back to the hardware.

Abort Acquire Command (Tester Menu)

 After selecting the  button in the Acquire Timing Data 
Dialog Box (similar to Figure 7-25), stops the capture if you would like 
to stop it before it is complete.

Tester Power On Command (Tester Menu)

 Same as the VK Test Station main window Utilities > Power 
On command and its corresponding  toolbar button. Resets and 
powers up the test sites (Test Head).

Tester Power Off Command (Tester Menu)

 Same as the VK Test Station main window Utilities > Power 
Off command and its corresponding  toolbar button. Turns off 
power to the test sites (Test Head).

Data Menu

Selecting Data in the menu bar opens the menu in Figure 7-26.

Get Vector Data

Get Vector Data
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Figure 7-26. Data Menu  

The Data menu contains the following commands:

• Compile command on page 318

• Create Code Fragment command on page 318

• Check Timing Rules command on page 318

Compile Command (Data Menu)

Allows saving of edited timing data in a compact file format (file 
extension .VTTC) that can be read by a new (yet to be defined) VOS 
command in order to set all of the timing from within a test program.

Create Code Fragment Command (Data Menu)

Allows creation of a code fragment (a subroutine, actually) containing 
all of the information needed to set up the hardware timing as 
described by the timing data. This subroutine can be compiled in with 
and called from within the test program.

Check Timing Rules Command (Data Menu)

 Displays the Check Timing Rules dialog box (similar to 
Figure 7-27) for the pins selected in the Pin List Tree pane. The APG 
Rules Checker is an off-line tool that is used for checking patterns to 
identify when Pattern Language Programming Rules have been 
violated. The APG operates properly if, and only if, you adhere to these 
pattern language rules. The Timing Tool will test the given timing data 
for rules violation. See appendix A, “Pattern Language Programming 
Rules,” in the Command Reference Volume 1 for detailed information 
about the rules. For the V4400 test system, see appendix B, “APG 
Rules Checker,” in the V4400 Command Reference Volume 1 for 
additional information about the rules checker.   

As shown in the Type of Rules Checking panel (Figure 7-27), this 
dialog box provides the following two modes for running the APG Rules 
Checker:

• Check Edges Only: Checks the rules in the tabular view.
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• Check Vectors: Checks the rules in graphical view. Those rules that 
apply only to cycle-to-cycle timing, or that require knowledge of the 
channel format, will only be tested in the graphical timing view, not 
in the tabular view.

Figure 7-27. Check Timing Rules Dialog Box  

Leaving the default Check Edges Only option button selected and 
selecting the Check Rules  button, checks the rules and displays 
the results (similar to Figure 7-27). The results contain the following 
fields:

• Pin Names: Displays the pin group or pin name failing.

• Local Timeset: Displays the LTS that has the error.

• Error Id: Displays the APG rule number violated. This number is 
used to reference the rule in the Pattern Language Programming 
Rules.

• Rules Error Description: Displays the number of errors for 
the selected pin or pin group and a brief summary of each violation.
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Selecting the Check Vectors option button in the Check Timing 
Rules dialog box (Figure 7-27) returns to displaying the Graphical 
Display, and selecting the Check Rules  button displays the 
results in the Graphical Display with the Check Timing Rules dialog 
box displaying. The failing edge marker labels display in red in the 
Graphical Display. These labels display in red whenever there is an 
error, not only when you run the rules checker.

Double-clicking on a particular violation in the dialog box, or by 
highlighting the violation row and selecting the  button, the 
graphical or tabular view will show the specific violation.

Window Menu

Selecting Window in the menu bar opens the menu in Figure 7-28.

Figure 7-28. Window Menu  

The Window menu contains the following commands:

• New Window command on page 320

• Close command on page 320

• Close All command on page 321

• Cascade command on page 321

• Tile command on page 321

• Minimize All command on page 321

New Window Command (Window Menu)

Displays a blank copy of the active timing tool document window.

Close Command (Window Menu)

Closes the active tool document window.
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Close All Command (Window Menu)

Closes all tool document windows with their corresponding tabs.

Cascade Command (Window Menu)

Cascades all open tool document windows in an overlapping fashion 
one on top of another with the title bar of each visible.

Tile Command (Window Menu)

Tiles all open tool document windows in a non-overlapping fashion.

Minimize All Command (Window Menu)

Not currently supported.

Help Menu

Selecting Help in the menu bar opens the menu in Figure 7-29.

Figure 7-29. Help Menu  

The Help menu contains the following two commands:

Help Topics Command (Help Menu)

 Not currently supported.

About Versatest Integrated Development Environment Command 
(Help Menu)

 Displays the About Versatest Integrated Development 
Environment dialog box that contains software component version and 
copyright information (similar to Figure 7-30).
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Figure 7-30. About Versatest Integrated Development Environment  

Pin List Tree Pane

The Pin List Tree pane (similar to Figure 7-1 on page 292) displays the 
defined pin groups. Selecting the expand  button for a pin group 
opens the tree to display the component pin channels. Similarly, 
selecting the collapse  button for a pin group causes the tree for that 
group to collapse to display just the pin group name.

Clicking to select one or multiple pin channels (  + click) displays the 
corresponding timing plots in either the graphical or tabular display. 
You can also select multiple pins by clicking on a pin to highlight it and 
then pressing the  +  keys or  +  keys to select pins in 
sequence.

+

–

Ctrl

Shift Shift
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Timing Tool Getting Started

The Timing Tool displays GTS, LTS, and timing edge information in a 
graphical and tabular format.

The graphical display currently shows all of the theoretical vector 
information related to timing that includes the global time sets, 
formats, cycle times, and the following six edge settings:

• IO Start

• IO End

• Drive Start

• Drive End

• Strobe Start

• Strobe End

The tabular format displays selected pins in a tabular format. It shows 
the GTS currently set up for the selected pins and the corresponding 
LTS mapped to the GTS.

The Timing Tool also provides the capability to test the given timing 
data for Pattern Language Programming Rules violations and display 
errors in both the graphical and tabular views.

The Timing Tool has online and offline modes. In online mode, the 
timing data is acquired from the a specified physical test site and the 
vector data is from the current test program. In offline mode, the data 
comes from a previously saved Timing Tool file. The Timing Tool file is 
created in online mode after the data has been acquired. After the data 
is acquired in online mode or the Timing Tool file is opened in offline 
mode, the features are currently the same for both modes, except 
offline mode can not interact with the hardware.

This section demonstrates how to setup, capture, and display Timing 
Tool data for analysis. For additional information about the Timing 
Too, see the “Timing Tool Main Window” section on page 291 that 
provides descriptions of all the menus, menu commands, and dialog 
boxes that make up the tool’s interface.

Getting Started Contents

This Getting Started contains the following examples:

• “Loading the Test Program” on page 324
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• “Launching the IDE and Displaying the Timing Tool Document 
Window” on page 332

• “Using the Timing Tool in Offline and Online Modes” on page 336

NOTE The actual colors displayed in this manual can be viewed from its 
Acrobat Reader PDF file on the Versatest Series Manuals CD-ROM. If 
you are viewing the PDF file, you can use Acrobat Reader’s View > 
Zoom In and View > Zoom Out menu bar commands to adjust the 
display magnification to help you see graphics such as waveforms.

Loading the Test Program

In this section of the Getting Started, we will perform the following 
tasks in preparation for launching the IDE, Timing Tool, and acquiring 
and displaying the timing data in the Timing Tool graphical and 
tabular views.

• Launch the VK Test Station application and display its VK Test 
Station main window.

• Load a plan file, power on the test sites (test head), and download 
the test program files specified in the plan file to the test sites.
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1 Selecting  > Programs > Versatest Test System 
Software > VK Test Station displays the VK Test Station main 
window (similar to Figure 7-31).

Figure 7-31. VK Test Station Main Window  

2 In the menu bar, selecting Init Lot > Enter Lot Information 
displays the Initialize Test Station Setup dialog box (Figure 7-32) that 
is used to set up each lot for testing.

Menu Bar Toolbar Testing Status Window

Datalog Window

Status Bar
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Figure 7-32. Initialize Test Station Setup Dialog Box  

3 Selecting the  button displays the Open dialog box (Figure 7-33) 
that lists the available plan files. Test plan files define the tester setup 
that is used. The v4k_adv_lab_ide_demo.pln plan file will be used 
for this example.

Test Plan
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Figure 7-33. Select Test Plan Dialog Box  

4 Selecting the v4k_adv_lab_ide_demo.pln plan file to highlight it, 
and selecting  displays the Initialize Test Station Setup dialog box 
with the plan file displayed in the Test Plan field (Figure 7-32 on page 
326).

5 Selecting the  button in the dialog box displays a Red Hand Alert 
dialog box that warns about the loss of summary data (Figure 7-34). 
The TEST_PLAN_WARNING plan file configuration switch controls 
whether this dialog box displays. The default is for it to display.

Open

Save
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Figure 7-34. Red Hand Alert Are You Sure Dialog Box  

6 Selecting  displays another Red Hand Alert dialog box (Figure 7-35) 
that warns to Z down the wafer and disconnect all DUTs prior to 
initialization of the test sites. The TEST_PLAN_WARNING plan file 
switch also controls whether this dialog box displays.

OK
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Figure 7-35. Red Hand Alert Z-Down Dialog Box  

7 Selecting  displays the Test Plan Validation dialog box 
(Figure 7-36). The VALIDATE 0x10 plan file test switch controls 
whether this dialog box displays. It displays the corresponding 
checksums and adds them to the summary file.

OK
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Figure 7-36. Test Plan Validation Dialog Box  

8 Selecting  begins the test head power on and downloads the 
Versatest Operating System (VOS) and the test program files specified 
in the plan file. The power on is complete when the terminal prompt 
A1> displays in the Datalog window (Figure 7-37).

OK
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Figure 7-37. VK Test Station Main Window After Power On  

Menu Bar Toolbar Testing Status Window

Datalog Window

Status Bar

A1 Site Status Window

A1 Terminal Prompt
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Launching the IDE and Displaying the Timing Tool 
Document Window

This section demonstrates how to launch IDE and display the Timing 
Tool Document Window in preparation to connect to a test site in 
online mode and display the timing data in the Timing Tool graphical 
and tabular views.

1 Selecting  > Programs > Versatest Test System 
Software > Integrated Development Environment displays its 
default main window (Figure 7-38).

Figure 7-38. Versatest Integrated Development Environment Main Window  

2 Selecting the green starlight Connect to VersaStation  toolbar 
button or the Tester > Connect to VersaStation command 
connects the IDE to VersaStation (formerly PCM) as indicated in the 

Navigator Pane Menu Bar Toolbar

Tool Document Window

Output Pane

Tools Tab

Status Bar

Workspace
Tab

Connect to VersaStation Button
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Output Pane in Figure 7-39. The IDE must be connected to 
VersaStation (PCM) before it can be connected to a specific tester test 
site.

Figure 7-39.  IDE Connected to VersaStation   

3 Selecting the yellow light bulb Set Online  toolbar button or 
corresponding Tester > Set Online command enables the IDE to 
connect to the tester when the Site Connect Status drop-down list box 
A1  is enabled as shown in the toolbar in (Figure 7-40).

Set Online Button

Output Pane
Connected to VersaStation
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Figure 7-40. IDE Main Window Set Online  

4 Choosing the site that the IDE connects to is done by selecting the 
down-arrow  button on the right side of the Site Connect Status drop-
down list box to display the available sites and selecting from the list 
(similar to Figure 7-41). Selecting a tool makes the connection to that 
site and disables the Site Connect Status drop-down list box.

Figure 7-41. Site Connect Status Drop-Down List Box  

5 Double-clicking the TimingTool icon under Debug Tools 
(Figure 7-40) displays the Timing Tool as the active tool in the Tool 
Document window (Figure 7-42). Selecting the tool makes the 
connection to that site and disables the Site Connect Status drop-down 

Output Pane

Site Connect Status drop-down list box

Navigator Pane

Tools Tab

Timing Tool Icon

Workspace
Tab

Tool Document Window
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list box. This also adds the Timing Tool Document  tab at the 
bottom of the Timing Tool Document window, and its menu bar and 
toolbar.

Figure 7-42. Timing Tool Default Graphical View  

Site Connect Status drop-down list box

Tool Document Window

Navigator Pane

Timing Tool Document Tab

Output Pane

Workspace
Tools Tab

Tab
Versatest Series IDE User’s Guide 335

Revision D, May 2005



Chapter 7  Timing Tool

Timing Tool Getting Started
Using the Timing Tool in Offline and Online Modes

Online mode requires that the VK Test Station software be running 
with the appropriate plan file loaded. In offline mode, the Timing Tool 
can run as a stand-alone application.

1 In offline mode, selecting File > Open > Timing Tool Document 
displays an Open Dialog box from which a Timing Tool file with a .VTT 
(Versatest Timing Tool) extension is opened. The .VTT file is created by 
selecting File > Save after timing data is acquired in online mode 
by selecting Tester > Acquire Data.

In online mode, selecting the Acquire Data  toolbar button or its 
corresponding Tester > Acquire Data command displays the 
Acquire Timing Data dialog box (similar to Figure 7-43) that specifies 
the data to be acquired and displayed. The timing data acquired is 
from the physical site specified in the toolbar Site Connect Status 

 drop-down list box and the vector data is from the current 
test program. As done previously, selecting the yellow Set Online  
toolbar button or corresponding Tester > Set Online command 
connects the IDE to the tester A1 as shown in the toolbar  
drop-down list box.

Figure 7-43. Acquire Timing Data Dialog Box  
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The Acquire Timing Data dialog box contains the following fields:

• Vector Display Data panel:

• Patterns: Displays the patterns in the acquired timing data.

• Entry Points: Displays the entry point for the selected 
pattern.

• Number of Vectors: Specifies the number of vectors in the 
selected pattern to display. The initial value is the number of 
vectors in the pattern.

• Offset from Entry: Specifies the offset from the entry point 
from which the data acquire begins.

• Current Vector Data panel:

• Pattern: Displays name of the selected pattern.

• Entry: Displays the name of the selected entry point.

• Size: Displays the number of vectors in the selected pattern.

• Offset: Displays the offset in the selected pattern.

•  button: Acquires the specified data and displays it in 
the Timing Tool graphical view (similar to Figure 7-44).

2 Selecting the  button in the Acquire Timing Data dialog box 
(similar to Figure 7-43) acquires the specified data and displays it in 
the Timing Tool graphical view (similar to Figure 7-44).

Get Vector Data

Get Vector Data
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Figure 7-44. Timing Tool Main Window Graphical View Pane  

3 Selecting the Show Tabular View  toolbar button or its 
corresponding View > Mode > Tabular command displays the 
tabular view (similar to Figure 7-45).
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Figure 7-45. Timing Tool Main Window Tabular View Pane  
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Introduction
Introduction

This chapter provides information about the optional Versatest Series 
Bitmap Tool. This tool allows you to view and compare multiple bitmap 
files.

Using the optional Bitmap Tool has licensing requirements. See the 
“Software Installation” chapter in the User’s Guide for more 
information.

Chapter Contents

This chapter contains the following information about the Timing Tool:

• “Bitmap Tool Overview” on page 343: Provides information about 
what the Bitmap Tool is and does, its purpose, and a listing of all C 
language commands and plan file switches used for bitmap 
programming.

• “Bitmap Tool Main Window” on page 349: Provides descriptions of 
the application interface functional areas, menus, menu 
commands, and dialog boxes.

• “Bitmap Tool Getting Started” on page 382: Describes how to create 
and load DUT definition files, and load and view bitmap files.

• “DUT Definition File” on page 424: Describes with several 
examples about how to create DUT definition files.

NOTE The actual colors displayed in this manual can be viewed from its 
Acrobat Reader PDF file on the Versatest Series Manuals CD-ROM. If 
you are viewing the PDF file, you can use Acrobat Reader’s View > 
Zoom In and View > Zoom Out menu bar commands to adjust the 
display magnification to help you see graphics such as waveforms.
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Bitmap Tool Overview

The Bitmap Tool is an application that allows you to view and compare 
multiple failed bitmap files. Using the Bitmap Tool, you can pinpoint 
specific locations where memory bits pass and fail tests.

Figure 8-1. Taking a Closer Look at Test Samples 

Organizations that manufacture memory devices or use them in 
product development suffer high costs related to testing them for 
defects or failures.

As the demand for these products increases, testing and scrap costs 
also increase. As cost increases, it becomes necessary to find ways to 
reduce testing costs, reduce scrap, and increase the yield of usable 
product.

It also becomes necessary to swiftly but logically attack the highest 
costs of measurable failures first, then move on to less expensive issues 
until your product reaches a zero-defect level of quality.

To achieve this end, sophisticated test equipment and teams of 
engineers and technicians test memory arrays and analyze test results 
in an attempt to find the causes of failures.

The Bitmap Tool moves toward automating some of these processes 
with a software application that analyzes data from silicon wafer test 
equipment.

Wafer #1

Memory
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Figure 8-2. Translating Test Results 

The Agilent Versatest Series test equipment produce bitmap files that 
result from test findings. After the test equipment collects failure data 
from a memory array, that information is stored in a logical or physical 
bitmap file. The Bitmap Tool translates the file into a visual 
representation, providing a surprisingly usable method of visually 
querying for failure locations.

The Bitmap Tool provides a means of analyzing bitmap files in many 
ways. For example, use the Bitmap Tool to analyze multiple bitmap 
files from a single memory array to study and compare results from 
different kinds of tests. You can also apply the Bitmap Tool to analyze 
multiple bitmap files from multiple memory arrays to compare the 
results of the same test performed on multiple memory arrays.

The Bitmap Tool allows you to visualize a stack of bitmaps for an easy, 
straightforward method of comparison and analysis. This dramatically 
reduces the labor cost of analyzing the test results, and allows you to 
review more results at higher speeds.

The Bitmap Tool provides a visual representation of multiple bitmap 
files for comparison and analysis. It is able to analyze and store the 
condition of each bit from bitmap files generated during testing. The 
two possible conditions for each bit are pass or fail. The Versatest 
Series test equipment Error Catch RAM (ECR) bitmap files store bits 
that pass as 1s and failing bits as 0s (zeros). Versatest bitmap files 
have a .hbm extension.

The Bitmap Tool looks for four basic characteristics about the bitmap 
files stored.

• Failing bits found in the same location on different bitmaps

• Failing bits found in different locations on different bitmaps

• Passing bits found in the same location on different bitmaps 
different bitmaps

• Passing bits found in different locations on different bitmaps

Memory Area #1 Memory Area #3 Memory Area #5Memory Area #2 Memory Area #4 Memory Area #6

Bitmap 1 Bitmap 3 Bitmap 5Bitmap 2 Bitmap 4 Bitmap 6

Test Equipment
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Figure 8-3. Paper Card Example 

For example, think of a bitmap as though it were a paper card with 
holes punched in locations where failed bits are placed (see Figure 8-3). 
If you stacked several of these cards upon one another, you could note:

• The location of all failed bits on all of the cards.

• The locations of each failed bit where those bits appear in the same 
location as failed bits on other cards.

• The locations where failed bits appear, but do not match with the 
same location on other cards.

Figure 8-4. Stacking the Deck - Accumulating Bitmaps 

If you inverted your test by punching holes in locations where passing 
bits are located, you could compare results of passing bits on the cards. 
This would allow you to note:

• The location of all passing bits on all of the cards.

• The locations of each passing bit where those bits appear in the 
same location as passing bits on other cards.

• The locations where passing bits appear, but do not match with the 
same location as passing bits on other cards.
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Logical Operations

The Bitmap Tool provides the capability to use logical operations to 
visualize other characteristics of failed and passing bits.

Selecting the Bitmap Tool’s OR logical operation allows you to analyze 
all of the failed bits on selected bitmaps from those loaded. It ignores 
the locations of all passing bit locations. Figure 8-5 illustrates how all 
failed bit locations are selected for display on the view pane.

Figure 8-5. “OR” Operations Show All Failed Bits 

In the inverted state, it allows you to see the locations of all passing 
bits on all bitmaps, ignoring the location of all failed bits.

If you want to expose locations where bits fail in the same location on 
all loaded bitmaps, you can select the AND operator (see the Action 
> Logical Operations command on page 372) to provide this 
output. Figure 8-6 illustrates how failed bits in common locations 
(circled) are chosen for display on the view pane.

Figure 8-6. “AND” Displays Only Matching Bits 
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If you want to expose only failed bits when they appear in different 
locations, and ignore failed bits in common locations, select the XOR 
operator (see the Action > Logical Operations command on 
page 372). Figure 8-7 illustrates how locations where the condition 
differs (circled) are chosen for display on the view pane.

Figure 8-7. “XOR” Displays Only Non-Matching Locations

To use this feature, select the first bitmap, then add that bitmap to a 
second bitmap using the XOR function. This allows you to obtain the 
resulting union of the bitmaps. Next, pair the result from the union 
with another bitmap.

Using this paper card analogy, you would select the first card and hold 
it up to a second card (Figure 8-7). Locations where both cards have 
holes would be ignored. Locations where holes appear differently in 
same places would be collected onto a third paper card called a result. 
This result creates a logical operation file that you can use just as 
though it were a card or bitmap.

Figure 8-8. Using the “XOR” Function

Display “XOR”
Result

1

11

12

2

1

11

12

2 1

12

2

Card 1 Card 2

1

11

1 Add
with
XOR

= =
LogOper#Result
Versatest Series IDE User’s Guide 347

Revision D, May 2005



Chapter 8  Bitmap Tool

Bitmap Tool Overview
C Language Commands and Plan File Switches

The following C language commands are used for writing bitmap files 
that are compatible with the Bitmap Tool. See the Versatest Series 
Command Reference Volume 1 for command descriptions.

• get_bitmap_num_param 

• get_bitmap_str_param 

• read_bmecr_bitmap 

• set_bitmap_num_param 

• set_bitmap_str_param 

• write_bmecr_bitmap 

The following plan file and configuration file switches are available for 
use with the write_bmecr_bitmap command. See the Versatest 
Series Command Reference Volume 2 for the switch descriptions.

• BITMAP_FILE_REV

• BITMAP_NUM_DUT

• BITMAP_NUM_DUT_MASK

• BITMAP_NUM_IO

• BITMAP_XMAX

• BITMAP_XMIN

• BITMAP_YMAX

• BITMAP_YMIN

• BITMAP_ZMAX

• BITMAP_ZMIN
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Bitmap Tool Main Window

The Bitmap Tool main window shown in Figure 8-9 is the application 
interface.

Figure 8-9. Bitmap Tool Main Window  

The Bitmap Tool interface consists of the following unique functional 
areas in the IDE:

• Navigator Pane: See the View > Navigator Pane command on 
page 363

• Bitmap Navigation pane on page 381

Bitmap Navigation Pane Menu Bar Toolbar Scroll Bar

View Pane

Crosshairs

Logical Thumbnail Pane

Physical Thumbnail Pane

Output Pane

Status Bar

Document Tab

Bitmap
Navigation

Tree

Navigator
Pane

Scroll Bar
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• Menu bar on page 350

• Toolbar: See the View > Toolbar command on page 360

• View Pane on page 380

• Thumbnail pane on page 381

• Bitmap Navigation Tree on page 381

• Output Pane: See the View > Output Pane command on 
page 363

• Status Bar: See the View > Status Bar command on page 362

Menu Bar

The menu bar at the top of the Bitmap Tool main window (Figure 8-9 
on page 349) contains the following 10 pull-down menus from which 
you can select commands:

• File menu on page 350

• Edit menu on page 357

• View menu on page 359

• Tools menu on page 365

• Tester menu on page 367

• Program menu on page 369

• Build menu on page 370

• Action menu on page 371

• Window menu on page 378

• Help menu on page 379

File Menu

Selecting File in the menu bar opens the menu in Figure 8-10.
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Figure 8-10. File Menu  

The File menu contains the following commands:

•  New command on page 352

•  Open command on page 354

• Close command on page 356

• Close All command on page 356

•  Save command on page 356

• Save As command on page 356

• Open Workspace on page 356

• Save Workspace (Save All) command on page 356

• Close Workspace on page 357

•  Print command on page 357

• Print Preview command on page 357

• Print Setup command on page 357

• Recent Workspaces on page 357

• Exit command on page 357
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New Command (File Menu)

 Displays the New command submenu (Figure 8-11) that allows you 
to display a new Workspace or create new IDE documents. The New  
toolbar button displays a New dialog box that lists the same items to 
select as the submenu.

Figure 8-11. File > New Command Submenu  

The New command submenu contains the following commands:

• Workspace command on page 352

• C Debugger Document command on page 353

• Pin Tool Document command on page 353

• Waveform Document command on page 353

• Waveform Setup Document command on page 353

• Test Program Document command on page 353

• Timing Tool Document command on page 353

• Pattern Tool Document command (Pattern Tool) on page 353

• Bitmap Tool DUT Document command on page 353

• File command on page 353

Workspace Command (New Command Submenu)

Displays as the active Workspace its default with its corresponding 
Menu bar, Toolbar, Navigator pane, Output pane, and Status bar.
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C Debugger Document Command (New Command Submenu)

Displays as the active document a blank C Debugger document with its 
corresponding Menu bar, Toolbar, Navigator pane, Document tab (and 
window), Output pane, and Status bar.

Pin Tool Document Command (New Command Submenu)

Displays as the active document a blank PinTool document with its 
corresponding Menu bar, Toolbar, Navigator pane, Document tab (and 
window), Output pane, and Status bar.

Waveform Document Command (New Command Submenu)

Displays as the active document a blank Waveform Tool document 
with its corresponding Menu bar, Toolbar, Navigator pane, Document 
tab (and window), Output pane, and Status bar.

Waveform Setup Document Command (New Command Submenu)

Displays as the active document a blank Waveform Setup Tool 
document with its corresponding Menu bar, Toolbar, Navigator pane, 
Document tab (and window), Output pane, and Status bar.

Test Program Document Command (New Command Submenu)

Note currently supported by the IDE.

Timing Tool Document Command (New Command Submenu)

Displays as the active document a blank Timing Tool document with 
its corresponding Menu bar, Toolbar, Navigator pane, Document tab 
(and graphical display window), Output pane, and Status bar.

Pattern Tool Document Command (New Command Submenu)

Displays as the active document a blank Pattern Tool document with 
its corresponding Menu bar, Toolbar, Navigator pane, Document tab 
(and window), Output pane, and Status bar.

Bitmap Tool DUT Document Command (New Command Submenu)

Displays an Open dialog box from which you open a DUT Description 
file (.dut) to display a blank Bitmap Tool document with the loaded 
DUT file and corresponding Menu bar, Toolbar, Navigator pane, 
Document tab (and window), Output pane, and Status bar.

File Command (New Command Submenu)

Not currently supported by the IDE.
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Open Command (File Menu)

 Displays the Open command submenu (Figure 8-12) that allows 
you to open a Workspace or IDE documents from the submenu list. The 
Open  toolbar button displays a generic Open dialog box from which 
you can open a selection listed in the submenu.

Figure 8-12. Open Command Submenu  

The Open command submenu contains the following commands that 
display an Open dialog box similar to Figure 8-13:

• C Debugger Document command on page 355

• Pin Tool Document command on page 355

• Waveform Document command on page 355

• Waveform Setup Document command on page 355

• Test Program Document command on page 355

• Timing Tool Document command on page 355

• Pattern Tool Document command on page 356

• Bitmap Tool DUT Document command on page 356

• File command on page 356
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Figure 8-13. File > Open Dialog Box  

C Debugger Document Command (Open Command Submenu)

Displays an Open dialog box (Figure 8-13) to select a previously saved 
C Debugger Tool document file with a *.cof extension.

Pin Tool Document Command (Open Command Submenu)

Displays an Open dialog box (similar to Figure 8-13) to select a 
previously saved PinTool document file with a *.pin file extension.

Waveform Document Command (Open Command Submenu)

Displays an Open dialog box (similar to Figure 8-13) to select a 
previously saved Waveform document file with a *.dnc file extension.

Waveform Setup Document Command (Open Command Submenu)

Displays an Open dialog box (similar to Figure 8-13) to select a 
previously saved Waveform Setup document file with a *.stp file 
extension.

Test Program Document Command (Open Command Submenu)

Note currently supported by the IDE.

Timing Tool Document Command (Open Command Submenu)

Displays an Open dialog box (similar to Figure 8-13) to select a 
previously saved Timing Tool document file with a *.vtt file extension.
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Pattern Tool Document Command (Open Command Submenu)

Displays an Open dialog box (similar to Figure 8-13) to select a 
previously saved Pattern Tool document file with an *.apg2 file 
extension.

Bitmap Tool DUT Document Command (Open Command Submenu)

Displays an Open dialog box (similar to Figure 8-13) to select a 
previously saved Bitmap Tool DUT definition document file with a 
*.dut file extension.

File Command (Open Command Submenu)

Not currently supported by the IDE.

Close Command (File Menu)

Closes the active tool document.

Close All Command (File Menu)

Closes all tool documents and displays the default IDE main window.

Save Command (File Menu)

 Saves the active document file.

Save As Command (File Menu)

Displays the Save As dialog box to save the active tool document file.

Open Workspace Command (File Menu)

Displays an Open Workspace dialog box with a *.wsp extension. If 
changes have been made to the current workspace, you will be asked if 
you would like to save the changes before closing the current 
workspace and opening another. The Workspace consists of the tools, 
layout, and open documents.

Save Workspace Command (File Menu)

Saves the current workspace with a *.wsp extension. The Workspace 
consists of the tools, layout, and open documents. This command 
enables you to save the tools, layout, and open documents’ current 
state, and later resume with the same Workspace by using the File > 
Open Workspace command.
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Close Workspace Command (File Menu)

Closes the current workspace. If changes have been made to the 
current workspace, you will be asked if you would like to save the 
changes before closing the current workspace.

Print Command (File Menu)

 Prints the current contents of the Bitmap Navigation Tree (see 
Figure 8-9 on page 349).

Print Preview Command (File Menu)

Displays a Print Preview window of the Bitmap Navigation Tree 
contents before printing. Pressing the  key returns to the Bitmap 
Tool main window.

Print Setup Command (File Menu)

Displays a printer setup dialog box that allows you to select and 
configure a printer.

Recent Workspaces Command (File Menu)

Displays a Recent Workspaces submenu from which you can select a 
workspace.

Exit Command (File Menu)

Closes the IDE. If the workspace or any other tool document files have 
changed, you will be asked if you would like to save them.

Edit Menu

Selecting Edit in the menu bar opens the menu in Figure 8-14.

Esc
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Figure 8-14. Edit Menu  

The Edit menu contains the following commands:

• Undo command on page 358

• Redo command on page 358

•  Cut command on page 358

•  Copy command on page 358

•  Paste command on page 358

• Find command on page 359

• Replace command on page 359

• Find in Files command on page 359

Undo Command (Edit Menu)

Not supported by the Bitmap Tool.

Redo Command (Edit Menu)

Not supported by the Bitmap Tool.

Cut Command (Edit Menu)

 Not supported by the Bitmap Tool.

Copy Command (Edit Menu)

 Not supported by the Bitmap Tool.

Paste Command (Edit Menu)

 Not supported by the Bitmap Tool.
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Find Command (Edit Menu)

Not supported by the Bitmap Tool.

Replace Command (Edit Menu)

Not supported by the Bitmap Tool.

Find in Files Command (Edit Menu)

Displays the Find in Files dialog box that provides search capability 
based on the criteria you specify.

Figure 8-15. Find in Files Dialog Box  

View Menu

Selecting View in the menu bar opens the menu in Figure 8-16.
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Figure 8-16. View Menu  

The View menu contains the following commands:

• Toolbar command on page 360

• Status Bar command on page 362

• Navigator Pane command on page 363

• Output Pane command on page 363

• Document Tabs command on page 363

•  Logical View command on page 363

•  Physical View command on page 363

• Display Grid command on page 363

• Grid Setup command on page 364

• Units command on page 364

•  Zoom In command on page 364

•  Zoom Out command on page 364

Toolbar Command (View Menu)

Displays or hides the toolbar shown in Figure 8-17. The toolbar 
displays at the top of the Bitmap Tool main window when a ✓  displays 
in front of its command in the View menu. Clicking on the buttons in 
the toolbar give you quick access to many of the menu bar commands. 
Positioning the mouse cursor over a toolbar button displays tooltip text 
with the corresponding command description.
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Figure 8-17. Bitmap Tool Toolbar  
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The toolbar contains the following command buttons:

Status Bar Command (View Menu)

Displays the Status Bar (similar to Figure 8-9 on page 349) when a ✓  
displays in front of its command in the View menu. The Status Bar 
displays the following:

• Bitmap Type: FLAT for a single bitmap, or OVERLAY, XOR, 
MULTI-LEVEL, and so forth for the logical operations displaying.

 File > New (Load DUT File) on page 352  Tester > Set Online on page 368

 File > Open on page 354  Tester > Set Offline on page 368

 File > Save on page 356  Tester > Acquire Data on page 369 (not 
supported by Bitmap Tool)

 Edit > Cut on page 358  Tester > Apply Changes on page 369 (not 
supported by Bitmap Tool)

 Edit > Copy on page 358  Tester > Abort Acquire on page 369 (not 
supported by Bitmap Tool)

 Edit > Paste on page 358  IDE Site Connect Status. Bitmap Tool 
currently supports only Offline mode.

 File > Print on page 357  Tester > Power On on page 369

 Help > About V4400 Software on page 380  Tester > Power Off on page 369

 Help > Help Topics on page 380

 Action > Load Bitmap File on page 371  View > Display Grid on page 363

 View > Zoom In on page 364  Action > Overlay Bitmaps on page 374

 View > Zoom Out on page 364  Action > Logical Operation on page 372

 View > Physical View on page 363  Action > Jump to Location on page 375

 View > Logical View on page 363  Action > Set Error Color on page 376
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• View Showing: LOGICAL or PHYSICAL.

• Zoom Factor

• Cursor: UNLOCKED or LOCKED

Navigator Pane Command (View Menu)

Displays the IDE Navigator Pane (similar to Figure 8-9 on page 349) 
when a ✓  displays in front of its command in the View menu.

Output Pane Command (View Menu)

Displays the Output Pane (similar to Figure 8-9 on page 349) when a ✓  
displays in front of its command in the View menu.

The Bitmap Tool is associated with the VOS Command tab in the 
Output Pane. The VOS Command tab is enabled when the IDE is set 
online by the selecting the yellow Set Online  toolbar button or the 
corresponding Tester > Set Online command. The VOS 
Command tab allows you to enter VOS terminal commands and 
display the results on the tab and in the corresponding test site 
window in the VK Test Station main window. See the “VOS Terminal 
Commands” chapter in the Command Reference Volume 2 for the 
available commands.  

Document Tabs Command (View Menu)

Displays the Document Tabs at the bottom of the Tool Document 
Window (similar to Figure 8-9 on page 349) when a ✓  displays in front 
of its command in the View menu.

Logical View Command (View Menu)

 Displays the View pane in the logical format when a • (bullet) 
displays in front of its command in the View menu.

Physical View Command (View Menu)

 Displays the View pane in the physical format when a • (bullet) 
displays in front of its command in the View menu.

Display Grid Command (View Menu)

 Allows you to enable or disable the display of the grid in the View 
pane as specified by the Setup Grid Properties dialog box (Figure 8-18).
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Grid Setup Command (View Menu)

Displays the Setup Grid Properties dialog box (Figure 8-18). When the 
grid displays by selecting the View > Display Grid command, the 
Setup Grid Properties dialog box allows you to customize the grid. For 
example, typing 64 in the Horizontal (Y) Grid Spacing text 
box and 32 in the Vertical (X) Grid Spacing text box and 
selecting  would display a gray grid with those properties.

Figure 8-18. Setup Grid Properties Dialog Box  

Units Command (View Menu)

Displays a Units submenu (Figure 8-19) that allows you to select 
whether to display the View pane and Navigation pane in decimal or 
hexadecimal.

Figure 8-19. Units Submenu  

Zoom In Command (View Menu)

 Increases the magnification of the view of the bitmap displaying in 
the View pane.

Zoom Out Command (View Menu)

 Decreases the magnification of the view of the bitmap displaying in 
the View pane.

OK
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Tools Menu

Selecting Tools in the menu bar opens the menu in Figure 8-20. The 
commands in the Tools menu are only for Agilent-internal use for the 
Bitmap Tool.

Figure 8-20. Tools Menu  

The Tools menu contains the following commands:

• Options command on page 365

• Properties command on page 365

Options Command (Tools Menu)

Displays the Options submenu shown in Figure 8-21.

Figure 8-21. Options Submenu  

The Options command submenu contains the following commands:

• Ide Options command on page 366

• TPIParser Options command on page 366

• TesterTool Options command on page 366

• StaticScopeTool Options command on page 366

• StaticPinTool Options command on page 366

• StaticTPT Options command on page 366
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• BitmapTool Options command on page 366

Ide Options Command (Options Command Submenu)

Not currently supported by the IDE.

TPIParser Options Command (Options Command Submenu)

Not currently supported by the IDE.

TesterTool Options Command (Options Command Submenu)

Not currently supported by the IDE.

StaticScopeTool Options Command (Options Command Submenu)

Not currently supported by the IDE.

StaticPinTool Options Command (Options Command Submenu)

Not currently supported by the IDE.

StaticTPT Options Command (Options Command Submenu)

Not currently supported by the IDE.

BitmapTool Options Command (Options Command Submenu)

Not currently supported by the IDE.

Properties Command (Tools Menu)

Displays the Properties submenu shown in Figure 8-22.

Figure 8-22. Properties Submenu  

The Properties command submenu contains the following commands:
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• Ide Properties command on page 367

• TPIParser Properties command on page 367

• TesterTool Properties command on page 367

• StaticScopeTool Properties command on page 367

• StaticPinTool Properties command on page 367

• StaticTPT Properties command on page 367

• BitmapTool Properties command on page 367

Ide Properties Command (Properties Command Submenu)

Not currently supported by the IDE.

TPIParser Properties Command (Properties Command Submenu)

Not currently supported by the IDE.

TesterTool Properties Command (Properties Command Submenu)

Not currently supported by the IDE.

StaticScopeTool Properties Command (Properties Command 
Submenu)

Not currently supported by the IDE.

StaticPinTool Properties Command (Properties Command Submenu)

Not currently supported by the IDE.

StaticTPT Properties Command (Properties Command Submenu)

Not currently supported by the IDE.

BitmapTool Properties Command (Properties Command Submenu)

Not currently supported by the IDE.

Tester Menu

Selecting Tester in the menu bar opens the menu in Figure 8-23.
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Figure 8-23. Tester Menu  

The Tester menu contains the following commands:

•  Set Online command on page 368

•  Set Offline command on page 368

•  Acquire Data command on page 369

•  Apply Changes command on page 369

•  Abort Acquire command on page 369

•  Power On command on page 369

•  Power Off command on page 369

Set Online Command (Tester Menu)

 Connects the IDE to the tester for the following tools that support 
online mode (currently the Bitmap Tool supports only offline mode):

• C Program Debugger (currently has no offline capability)

• Pattern Tool (currently has no offline capability)

• Waveform Tool

• Timing Tool

Set Offline Command (Tester Menu)

 Disconnects the IDE from the tester. Currently the Bitmap Tool 
supports only offline mode. The following tools support offline mode:

• Pin Tool (currently has no online capability)

• Waveform Tool (viewing saved files only)

• Timing Tool (viewing saved files only)

• Bitmap Tool (currently has no online capability)
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Acquire Data Command (Tester Menu)

 Not currently supported by the Pattern Tool. The Timing Tool 
supports this command.

Apply Changes Command (Tester Menu)

 Not currently supported by the Pattern Tool. The Timing Tool 
supports this command.

Abort Acquire Command (Tester Menu)

 Not currently supported by the Pattern Tool. The Timing Tool 
supports this command.

Tester Power On Command (Tester Menu)

 Same as the VK Test Station main window Utilities > Power 
On command and its corresponding  toolbar button. Resets and 
powers up the test sites (Test Head).

Tester Power Off Command (Tester Menu)

 Same as the VK Test Station main window Utilities > Power 
Off command and its corresponding  toolbar button. Turns off 
power to the test sites (Test Head).

Program Menu

Selecting Program in the menu bar opens the menu in Figure 8-24. The 
Program menu is not currently supported by the IDE.

Figure 8-24. Program Menu  

The Program menu contains the following commands:

• Set Active Test Program command on page 370

• Add Files to Test Program command on page 370

• Remove from Test Program command on page 370
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Set Active Test Program Command (Program Menu)

Not currently supported by the IDE.

Add Files to Test Program Command (Program Menu)

Not currently supported by the IDE.

Remove from Test Program Command (Program Menu)

Not currently supported by the IDE.

Build Menu

Selecting Build in the menu bar opens the menu in Figure 8-25. The 
Build menu is not currently supported by the IDE.

Figure 8-25. Build Menu  

The Build menu contains the following commands:

• Build command on page 370

• Compile Patterns command on page 370

• Compile C Sources command on page 371

• Rebuild All command on page 371

• Stop Build command on page 371

• Clean Build command on page 371

Build Command (Build Menu)

Not currently supported by the IDE.

Compile Patterns Command (Build Menu)

Not currently supported by the IDE.
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Compile C Sources Command (Build Menu)

Not currently supported by the IDE.

Rebuild All Command (Build Menu)

Not currently supported by the IDE.

Stop Build Command (Build Menu)

Not currently supported by the IDE.

Clean Build Command (Build Menu)

Not currently supported by the IDE.

Action Menu

Selecting Action in the menu bar opens the menu in Figure 8-26.

Figure 8-26. Action Menu  

The Action menu contains the following commands:

•  Load Bitmap command on page 371

•  Logical Operation command on page 372

•  Overlay command on page 374

•  Jump to Location command on page 375

•  Set Error Color command on page 376

Load Bitmap Command (Action Menu)

 Displays a Load Bitmap File Open dialog box to select bitmap files 
(similar to Figure 8-27).
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Figure 8-27. Load Bitmap File Open Dialog Box  

Logical Operation Command (Action Menu)

 Displays the Logical Operation dialog box (similar to Figure 8-28). 
The list box displays the currently loaded bitmaps or operations that 
are listed in the Bitmap Navigation Tree. Selecting bitmaps or 
operations to highlight them and then one of the Select Logical 
Operation option buttons defines the logical operation. Typing a 
name in the Enter Bitmap Name text box and then selecting  
closes the dialog box and displays the Bitmap Navigation Tree with the 
created logical operation (Figure 8-29) and also displays it in the View 
pane.

The available operations are illustrated in Figure 8-30 on page 374.

OK
372 Versatest Series IDE User’s Guide

Revision D, May 2005



Chapter 8  Bitmap Tool

Bitmap Tool Main Window
Figure 8-28. Logical Operation Dialog Box  

Figure 8-29. Bitmap Navigation Tree Displaying Logical Operation  

Created Logical Operation
Bitmap

Navigation
Tree
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Figure 8-30. Logical Operations  

Overlay Command (Action Menu)

 Displays the Overlay Bitmaps dialog box (similar to Figure 8-31). 
The Loaded Bitmaps list box displays the currently loaded bitmaps. 
Selecting bitmaps and then the  button adds the selected bitmap to 
display in the Bitmaps to Overlay list box. Typing the name in the 
Enter Overlay Name text box gives it a name. Selecting  closes 
the dialog box and displays the Bitmap Navigation Tree with the 

INVERT: Inverts pass/fails

AND: Highlights bits that failed on both bitmaps

AND

OR: Highlights bits that failed on at least one bitmap

OR

XOR: Highlights bits that failed on only one bitmap

XOR

Add

OK
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created Overlay operation (Figure 8-32) and also displays it in the 
View pane. For Overlay operations using the default colors, bits where 
only one bitmap failed are dark red and bits where both bitmaps failed 
are bright red.

Figure 8-31. Overlay Bitmaps Dialog Box  

Figure 8-32. Bitmap Navigation Tree Displaying Overlay Operation  

Jump to Location Command (Action Menu)

 Displays the Jump to Location dialog box (similar to Figure 8-33). 
Entering the coordinates in the dialog box and selecting  causes the 
cross hairs to locate at the address that you specify.

Created Overlay Operation
Bitmap

Navigation
Tree

OK
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Figure 8-33. Jump to Location Dialog Box  

Set Error Color Command (Action Menu)

 Displays the Select System Colors tab on the Set Bitmap Colors 
dialog box (Figure 8-34). This tab allows you to set the pass and fail 
colors for the bitmaps. The defaults are black for pass and red for fail. 
The colors can be changed by selecting the corresponding drop-down 
list box to display a Color dialog box palette from which additional 
colors can be selected or created.

The Select Multi-Level Colors tab (Figure 8-35) allows you to select 
colors to distinguish a single bit’s status for multi level displays.
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Figure 8-34. Select System Colors Tab on Set Bitmap Colors Dialog 
Box  
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Figure 8-35. Select Multi-Level Colors Tab on Set Bitmap Colors 
Dialog Box  

Window Menu

Selecting Window in the menu bar opens the menu in Figure 8-36.

Figure 8-36. Window Menu  
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The Window menu contains the following commands:

• New Window command on page 379

• Close command on page 379

• Close All command on page 379

• Cascade command on page 379

• Tile command on page 379

• Minimize All command on page 379

New Window Command (Window Menu)

Displays another Bitmap Tool document tab window that has no DUT 
file loaded.

Close Command (Window Menu)

Closes the active document window.

Close All Command (Window Menu)

Closes all tool document windows with their corresponding tabs.

Cascade Command (Window Menu)

Cascades all open tool document windows in an overlapping fashion 
one on top of another with the title bar of each visible.

Tile Command (Window Menu)

Tiles all open tool document windows in a non-overlapping fashion.

Minimize All Command (Window Menu)

Not currently supported by the IDE.

Help Menu

Selecting Help in the menu bar opens the menu in Figure 8-37.

Figure 8-37. Help Menu  
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The Help menu contains the following two commands:

Help Topics Command (Help Menu)

 Not currently supported.

About V4400 Software Command (Help Menu)

 Displays the About V4400 Series Tester Software dialog box that 
contains software component version and copyright information 
(similar to Figure 8-38).

Figure 8-38. About V4400 Software Dialog Box   

View Pane

The View Pane (Figure 8-9 on page 349) displays the bitmaps, overlays, 
and logical operations selected in the Bitmap List. This allows you to 
view and compare bitmap failure locations within single or multiple 
bitmaps. The View Pane provides scroll bars on the right-hand side 
and bottom edge when the magnification of the bitmap within is set to 
cause the area of the bitmap to be larger than the pane size.
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Bitmap Navigation Pane

The Control Pane (Figure 8-9 on page 349) offers information about the 
coordinates associated with the mouse pointer location. This lists the 
Logical and Physical address location for selected locations on the 
bitmap.

The Logical Z shows the number of layers of the logical bitmap. 
(Currently only one layer is supported.) This means that each bit in the 
logical bitmap has three address coordinates: X, Y and Z.

There is also a Total Failures section that displays the total 
number of failed bits for the displayed bitmaps or logical operations in 
the View pane.

Thumbnail Pane

The Thumbnail Pane (Figure 8-9 on page 349) shows a thumbnail of 
the logical and physical layouts of the device. The highlighted area in 
the thumbnail indicates the current coverage area you are seeing in 
the View Pane.

Bitmap Navigation Tree

The Bitmap List (Figure 8-9 on page 349) contains a list of the DUT file 
and all bitmaps loaded in the program, and overlay and logical 
operations that have been created. The list allows you to show, hide, 
and remove bitmaps, overlays, and logical operations shown on the 
View pane.
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Bitmap Tool Getting Started

This section demonstrates how to load, view, compare, and analyze 
Agilent Versatest Series bitmap files. The example files consist of a 
DUT definition file and two simulated bitmap files for a 16 Mb device 
with 16 I/Os. For additional information about the Bitmap Tool, see the 
“Bitmap Tool Main Window” section on page 349 that provides 
descriptions of all the menus, menu commands, and dialog boxes that 
make up the tool’s interface.

Getting Started Contents

This Getting Started contains the following examples:

• “Creating a DUT Definition File” on page 383

• “Loading a DUT Definition File and Displaying the Bitmap Tool 
Main Window” on page 408

• “Loading and Viewing Bitmap Files” on page 411

• “Creating an Overlay” on page 414

• “Creating Logical Operations” on page 417

• “Selecting Bitmap Error Colors” on page 421
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Creating a DUT Definition File

To view files in the Bitmap Tool, you must first create and load a DUT 
definition file. This file supplies the Bitmap Tool with the information 
it requires about the memory array’s rows, columns, I/Os, and 
scrambling information. The file is loaded from the File > Open > DUT 
Description Document > Open dialog box. You will be shown later in 
this chapter how to load the file in the “Loading a DUT Definition File 
and Displaying the Bitmap Tool Main Window” section on page 408.

The DUT definition file used for this example is shown in Figure 8-39 
through Figure 8-50. For additional information and examples, see the 
“DUT Definition File” section starting on page 424.

NOTE Currently the Bitmap Tool DUT definition file requires a carriage 
return before the “DestinationX” row scrambling header. After loading 
a DUT definition file without the carriage return, results in an 
application error and the program terminates without warning.  

A DUT definition file must be saved as an ASCII text file with a .dut 
extension. The file consists of the following sections. Each section is 
described following the DUT definition file, starting on page 396.

• Header Section

• Pinout Section

• Scrambling Section
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Figure 8-39. DUT Definition File (1 of 12)

BEGIN DUT
DATE=05/04/03
USER=CSTD
COMPANY=Agilent Technologies
DEVICE=16IO 
PROTOCOL=parallel
TECHNOLOGY=FLASH
COLUMNS=4096 // Number of physical bit columns.
ROWS=4096 // Number of physical rows.
i/oS=16 // Number of i/os.
PINS=48 // Number of pins device has that is specified in “PINOUT” section.

END DUT

BEGIN MISC
anything=5 // Field is required but not currently used.

END MISC

BEGIN PINOUT
P1=x7,a15
P2=x6,a14
P3=x5,a13
P4=x4,a12
P5=x3,a11
P6=x2,a10
P7=x1,a9
P8=x0,a8
P9=x11,a19
P10=unused
P11=WE
P12=unused
P13=unused
P14=unused
P15=unused
P16=x10,a18
P17=x9,a17
P18=y7,a7
P19=y6,a6
P20=y5,a5
P21=y4,a4
P22=y3,a3
P23=y2,a2
P24=y1,a1
P25=y0,a0
P26=CE
P27=VSS
P28=OE
P29=IO0
P30=IO8
P31=IO1
P32=IO9
P33=IO2
P34=IO10
P35=IO3
P36=IO11
P37=VDD
P38=IO4
P39=IO12
P40=IO5
P41=IO13
P42=IO6
P43=IO14
P44=IO7
P45=IO15
P46=VSS
P47=unused
P48=x8,a16

END PINOUT
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Figure 8-40. DUT Definition File (2 of 12)

BEGIN SCRAMBLING Logical
BEGIN REGION

MINX=0 // Min physical X
MAXX=4095 // Max physical X
MINY=0 // Min physical Y
MAXY=4095 // Max physical Y

DestinationY io0 io1 io2 io3 io4 io5 io6 io7 io8 io9 io10 io11 io12 io13 io14 io15
0 0 256 512 768 1024 1280 1536 1792 2048 2304 2560 2816 3072 3328 3584 3840
1 1 257 513 769 1025 1281 1537 1793 2049 2305 2561 2817 3073 3329 3585 3841
2 2 258 514 770 1026 1282 1538 1794 2050 2306 2562 2818 3074 3330 3586 3842
3 3 259 515 771 1027 1283 1539 1795 2051 2307 2563 2819 3075 3331 3587 3843
4 4 260 516 772 1028 1284 1540 1796 2052 2308 2564 2820 3076 3332 3588 3844
5 5 261 517 773 1029 1285 1541 1797 2053 2309 2565 2821 3077 3333 3589 3845
6 6 262 518 774 1030 1286 1542 1798 2054 2310 2566 2822 3078 3334 3590 3846
7 7 263 519 775 1031 1287 1543 1799 2055 2311 2567 2823 3079 3335 3591 3847
8 8 264 520 776 1032 1288 1544 1800 2056 2312 2568 2824 3080 3336 3592 3848
9 9 265 521 777 1033 1289 1545 1801 2057 2313 2569 2825 3081 3337 3593 3849
10 10 266 522 778 1034 1290 1546 1802 2058 2314 2570 2826 3082 3338 3594 3850
11 11 267 523 779 1035 1291 1547 1803 2059 2315 2571 2827 3083 3339 3595 3851
12 12 268 524 780 1036 1292 1548 1804 2060 2316 2572 2828 3084 3340 3596 3852
13 13 269 525 781 1037 1293 1549 1805 2061 2317 2573 2829 3085 3341 3597 3853
14 14 270 526 782 1038 1294 1550 1806 2062 2318 2574 2830 3086 3342 3598 3854
15 15 271 527 783 1039 1295 1551 1807 2063 2319 2575 2831 3087 3343 3599 3855
16 16 272 528 784 1040 1296 1552 1808 2064 2320 2576 2832 3088 3344 3600 3856
17 17 273 529 785 1041 1297 1553 1809 2065 2321 2577 2833 3089 3345 3601 3857
18 18 274 530 786 1042 1298 1554 1810 2066 2322 2578 2834 3090 3346 3602 3858
19 19 275 531 787 1043 1299 1555 1811 2067 2323 2579 2835 3091 3347 3603 3859
20 20 276 532 788 1044 1300 1556 1812 2068 2324 2580 2836 3092 3348 3604 3860
21 21 277 533 789 1045 1301 1557 1813 2069 2325 2581 2837 3093 3349 3605 3861
22 22 278 534 790 1046 1302 1558 1814 2070 2326 2582 2838 3094 3350 3606 3862
23 23 279 535 791 1047 1303 1559 1815 2071 2327 2583 2839 3095 3351 3607 3863
24 24 280 536 792 1048 1304 1560 1816 2072 2328 2584 2840 3096 3352 3608 3864
25 25 281 537 793 1049 1305 1561 1817 2073 2329 2585 2841 3097 3353 3609 3865
26 26 282 538 794 1050 1306 1562 1818 2074 2330 2586 2842 3098 3354 3610 3866
27 27 283 539 795 1051 1307 1563 1819 2075 2331 2587 2843 3099 3355 3611 3867
28 28 284 540 796 1052 1308 1564 1820 2076 2332 2588 2844 3100 3356 3612 3868
29 29 285 541 797 1053 1309 1565 1821 2077 2333 2589 2845 3101 3357 3613 3869
30 30 286 542 798 1054 1310 1566 1822 2078 2334 2590 2846 3102 3358 3614 3870
31 31 287 543 799 1055 1311 1567 1823 2079 2335 2591 2847 3103 3359 3615 3871
32 32 288 544 800 1056 1312 1568 1824 2080 2336 2592 2848 3104 3360 3616 3872
33 33 289 545 801 1057 1313 1569 1825 2081 2337 2593 2849 3105 3361 3617 3873
34 34 290 546 802 1058 1314 1570 1826 2082 2338 2594 2850 3106 3362 3618 3874
35 35 291 547 803 1059 1315 1571 1827 2083 2339 2595 2851 3107 3363 3619 3875
36 36 292 548 804 1060 1316 1572 1828 2084 2340 2596 2852 3108 3364 3620 3876
37 37 293 549 805 1061 1317 1573 1829 2085 2341 2597 2853 3109 3365 3621 3877
38 38 294 550 806 1062 1318 1574 1830 2086 2342 2598 2854 3110 3366 3622 3878
39 39 295 551 807 1063 1319 1575 1831 2087 2343 2599 2855 3111 3367 3623 3879
40 40 296 552 808 1064 1320 1576 1832 2088 2344 2600 2856 3112 3368 3624 3880
41 41 297 553 809 1065 1321 1577 1833 2089 2345 2601 2857 3113 3369 3625 3881
42 42 298 554 810 1066 1322 1578 1834 2090 2346 2602 2858 3114 3370 3626 3882
43 43 299 555 811 1067 1323 1579 1835 2091 2347 2603 2859 3115 3371 3627 3883
44 44 300 556 812 1068 1324 1580 1836 2092 2348 2604 2860 3116 3372 3628 3884
45 45 301 557 813 1069 1325 1581 1837 2093 2349 2605 2861 3117 3373 3629 3885
46 46 302 558 814 1070 1326 1582 1838 2094 2350 2606 2862 3118 3374 3630 3886
47 47 303 559 815 1071 1327 1583 1839 2095 2351 2607 2863 3119 3375 3631 3887
48 48 304 560 816 1072 1328 1584 1840 2096 2352 2608 2864 3120 3376 3632 3888
49 49 305 561 817 1073 1329 1585 1841 2097 2353 2609 2865 3121 3377 3633 3889
50 50 306 562 818 1074 1330 1586 1842 2098 2354 2610 2866 3122 3378 3634 3890
51 51 307 563 819 1075 1331 1587 1843 2099 2355 2611 2867 3123 3379 3635 3891
52 52 308 564 820 1076 1332 1588 1844 2100 2356 2612 2868 3124 3380 3636 3892
53 53 309 565 821 1077 1333 1589 1845 2101 2357 2613 2869 3125 3381 3637 3893
54 54 310 566 822 1078 1334 1590 1846 2102 2358 2614 2870 3126 3382 3638 3894
55 55 311 567 823 1079 1335 1591 1847 2103 2359 2615 2871 3127 3383 3639 3895
56 56 312 568 824 1080 1336 1592 1848 2104 2360 2616 2872 3128 3384 3640 3896
57 57 313 569 825 1081 1337 1593 1849 2105 2361 2617 2873 3129 3385 3641 3897
58 58 314 570 826 1082 1338 1594 1850 2106 2362 2618 2874 3130 3386 3642 3898
59 59 315 571 827 1083 1339 1595 1851 2107 2363 2619 2875 3131 3387 3643 3899
60 60 316 572 828 1084 1340 1596 1852 2108 2364 2620 2876 3132 3388 3644 3900
61 61 317 573 829 1085 1341 1597 1853 2109 2365 2621 2877 3133 3389 3645 3901
62 62 318 574 830 1086 1342 1598 1854 2110 2366 2622 2878 3134 3390 3646 3902
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Figure 8-41. DUT Definition File (3 of 12)

63 63 319 575 831 1087 1343 1599 1855 2111 2367 2623 2879 3135 3391 3647 3903
64 64 320 576 832 1088 1344 1600 1856 2112 2368 2624 2880 3136 3392 3648 3904
65 65 321 577 833 1089 1345 1601 1857 2113 2369 2625 2881 3137 3393 3649 3905
66 66 322 578 834 1090 1346 1602 1858 2114 2370 2626 2882 3138 3394 3650 3906
67 67 323 579 835 1091 1347 1603 1859 2115 2371 2627 2883 3139 3395 3651 3907
68 68 324 580 836 1092 1348 1604 1860 2116 2372 2628 2884 3140 3396 3652 3908
69 69 325 581 837 1093 1349 1605 1861 2117 2373 2629 2885 3141 3397 3653 3909
70 70 326 582 838 1094 1350 1606 1862 2118 2374 2630 2886 3142 3398 3654 3910
71 71 327 583 839 1095 1351 1607 1863 2119 2375 2631 2887 3143 3399 3655 3911
72 72 328 584 840 1096 1352 1608 1864 2120 2376 2632 2888 3144 3400 3656 3912
73 73 329 585 841 1097 1353 1609 1865 2121 2377 2633 2889 3145 3401 3657 3913
74 74 330 586 842 1098 1354 1610 1866 2122 2378 2634 2890 3146 3402 3658 3914
75 75 331 587 843 1099 1355 1611 1867 2123 2379 2635 2891 3147 3403 3659 3915
76 76 332 588 844 1100 1356 1612 1868 2124 2380 2636 2892 3148 3404 3660 3916
77 77 333 589 845 1101 1357 1613 1869 2125 2381 2637 2893 3149 3405 3661 3917
78 78 334 590 846 1102 1358 1614 1870 2126 2382 2638 2894 3150 3406 3662 3918
79 79 335 591 847 1103 1359 1615 1871 2127 2383 2639 2895 3151 3407 3663 3919
80 80 336 592 848 1104 1360 1616 1872 2128 2384 2640 2896 3152 3408 3664 3920
81 81 337 593 849 1105 1361 1617 1873 2129 2385 2641 2897 3153 3409 3665 3921
82 82 338 594 850 1106 1362 1618 1874 2130 2386 2642 2898 3154 3410 3666 3922
83 83 339 595 851 1107 1363 1619 1875 2131 2387 2643 2899 3155 3411 3667 3923
84 84 340 596 852 1108 1364 1620 1876 2132 2388 2644 2900 3156 3412 3668 3924
85 85 341 597 853 1109 1365 1621 1877 2133 2389 2645 2901 3157 3413 3669 3925
86 86 342 598 854 1110 1366 1622 1878 2134 2390 2646 2902 3158 3414 3670 3926
87 87 343 599 855 1111 1367 1623 1879 2135 2391 2647 2903 3159 3415 3671 3927
88 88 344 600 856 1112 1368 1624 1880 2136 2392 2648 2904 3160 3416 3672 3928
89 89 345 601 857 1113 1369 1625 1881 2137 2393 2649 2905 3161 3417 3673 3929
90 90 346 602 858 1114 1370 1626 1882 2138 2394 2650 2906 3162 3418 3674 3930
91 91 347 603 859 1115 1371 1627 1883 2139 2395 2651 2907 3163 3419 3675 3931
92 92 348 604 860 1116 1372 1628 1884 2140 2396 2652 2908 3164 3420 3676 3932
93 93 349 605 861 1117 1373 1629 1885 2141 2397 2653 2909 3165 3421 3677 3933
94 94 350 606 862 1118 1374 1630 1886 2142 2398 2654 2910 3166 3422 3678 3934
95 95 351 607 863 1119 1375 1631 1887 2143 2399 2655 2911 3167 3423 3679 3935
96 96 352 608 864 1120 1376 1632 1888 2144 2400 2656 2912 3168 3424 3680 3936
97 97 353 609 865 1121 1377 1633 1889 2145 2401 2657 2913 3169 3425 3681 3937
98 98 354 610 866 1122 1378 1634 1890 2146 2402 2658 2914 3170 3426 3682 3938
99 99 355 611 867 1123 1379 1635 1891 2147 2403 2659 2915 3171 3427 3683 3939
100 100 356 612 868 1124 1380 1636 1892 2148 2404 2660 2916 3172 3428 3684 3940
101 101 357 613 869 1125 1381 1637 1893 2149 2405 2661 2917 3173 3429 3685 3941
102 102 358 614 870 1126 1382 1638 1894 2150 2406 2662 2918 3174 3430 3686 3942
103 103 359 615 871 1127 1383 1639 1895 2151 2407 2663 2919 3175 3431 3687 3943
104 104 360 616 872 1128 1384 1640 1896 2152 2408 2664 2920 3176 3432 3688 3944
105 105 361 617 873 1129 1385 1641 1897 2153 2409 2665 2921 3177 3433 3689 3945
106 106 362 618 874 1130 1386 1642 1898 2154 2410 2666 2922 3178 3434 3690 3946
107 107 363 619 875 1131 1387 1643 1899 2155 2411 2667 2923 3179 3435 3691 3947
108 108 364 620 876 1132 1388 1644 1900 2156 2412 2668 2924 3180 3436 3692 3948
109 109 365 621 877 1133 1389 1645 1901 2157 2413 2669 2925 3181 3437 3693 3949
110 110 366 622 878 1134 1390 1646 1902 2158 2414 2670 2926 3182 3438 3694 3950
111 111 367 623 879 1135 1391 1647 1903 2159 2415 2671 2927 3183 3439 3695 3951
112 112 368 624 880 1136 1392 1648 1904 2160 2416 2672 2928 3184 3440 3696 3952
113 113 369 625 881 1137 1393 1649 1905 2161 2417 2673 2929 3185 3441 3697 3953
114 114 370 626 882 1138 1394 1650 1906 2162 2418 2674 2930 3186 3442 3698 3954
115 115 371 627 883 1139 1395 1651 1907 2163 2419 2675 2931 3187 3443 3699 3955
116 116 372 628 884 1140 1396 1652 1908 2164 2420 2676 2932 3188 3444 3700 3956
117 117 373 629 885 1141 1397 1653 1909 2165 2421 2677 2933 3189 3445 3701 3957
118 118 374 630 886 1142 1398 1654 1910 2166 2422 2678 2934 3190 3446 3702 3958
119 119 375 631 887 1143 1399 1655 1911 2167 2423 2679 2935 3191 3447 3703 3959
120 120 376 632 888 1144 1400 1656 1912 2168 2424 2680 2936 3192 3448 3704 3960
121 121 377 633 889 1145 1401 1657 1913 2169 2425 2681 2937 3193 3449 3705 3961
122 122 378 634 890 1146 1402 1658 1914 2170 2426 2682 2938 3194 3450 3706 3962
123 123 379 635 891 1147 1403 1659 1915 2171 2427 2683 2939 3195 3451 3707 3963
124 124 380 636 892 1148 1404 1660 1916 2172 2428 2684 2940 3196 3452 3708 3964
125 125 381 637 893 1149 1405 1661 1917 2173 2429 2685 2941 3197 3453 3709 3965
126 126 382 638 894 1150 1406 1662 1918 2174 2430 2686 2942 3198 3454 3710 3966
127 127 383 639 895 1151 1407 1663 1919 2175 2431 2687 2943 3199 3455 3711 3967
128 128 384 640 896 1152 1408 1664 1920 2176 2432 2688 2944 3200 3456 3712 3968
129 129 385 641 897 1153 1409 1665 1921 2177 2433 2689 2945 3201 3457 3713 3969
130 130 386 642 898 1154 1410 1666 1922 2178 2434 2690 2946 3202 3458 3714 3970
131 131 387 643 899 1155 1411 1667 1923 2179 2435 2691 2947 3203 3459 3715 3971
132 132 388 644 900 1156 1412 1668 1924 2180 2436 2692 2948 3204 3460 3716 3972
133 133 389 645 901 1157 1413 1669 1925 2181 2437 2693 2949 3205 3461 3717 3973
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134 134 390 646 902 1158 1414 1670 1926 2182 2438 2694 2950 3206 3462 3718 3974
135 135 391 647 903 1159 1415 1671 1927 2183 2439 2695 2951 3207 3463 3719 3975
136 136 392 648 904 1160 1416 1672 1928 2184 2440 2696 2952 3208 3464 3720 3976
137 137 393 649 905 1161 1417 1673 1929 2185 2441 2697 2953 3209 3465 3721 3977
138 138 394 650 906 1162 1418 1674 1930 2186 2442 2698 2954 3210 3466 3722 3978
139 139 395 651 907 1163 1419 1675 1931 2187 2443 2699 2955 3211 3467 3723 3979
140 140 396 652 908 1164 1420 1676 1932 2188 2444 2700 2956 3212 3468 3724 3980
141 141 397 653 909 1165 1421 1677 1933 2189 2445 2701 2957 3213 3469 3725 3981
142 142 398 654 910 1166 1422 1678 1934 2190 2446 2702 2958 3214 3470 3726 3982
143 143 399 655 911 1167 1423 1679 1935 2191 2447 2703 2959 3215 3471 3727 3983
144 144 400 656 912 1168 1424 1680 1936 2192 2448 2704 2960 3216 3472 3728 3984
145 145 401 657 913 1169 1425 1681 1937 2193 2449 2705 2961 3217 3473 3729 3985
146 146 402 658 914 1170 1426 1682 1938 2194 2450 2706 2962 3218 3474 3730 3986
147 147 403 659 915 1171 1427 1683 1939 2195 2451 2707 2963 3219 3475 3731 3987
148 148 404 660 916 1172 1428 1684 1940 2196 2452 2708 2964 3220 3476 3732 3988
149 149 405 661 917 1173 1429 1685 1941 2197 2453 2709 2965 3221 3477 3733 3989
150 150 406 662 918 1174 1430 1686 1942 2198 2454 2710 2966 3222 3478 3734 3990
151 151 407 663 919 1175 1431 1687 1943 2199 2455 2711 2967 3223 3479 3735 3991
152 152 408 664 920 1176 1432 1688 1944 2200 2456 2712 2968 3224 3480 3736 3992
153 153 409 665 921 1177 1433 1689 1945 2201 2457 2713 2969 3225 3481 3737 3993
154 154 410 666 922 1178 1434 1690 1946 2202 2458 2714 2970 3226 3482 3738 3994
155 155 411 667 923 1179 1435 1691 1947 2203 2459 2715 2971 3227 3483 3739 3995
156 156 412 668 924 1180 1436 1692 1948 2204 2460 2716 2972 3228 3484 3740 3996
157 157 413 669 925 1181 1437 1693 1949 2205 2461 2717 2973 3229 3485 3741 3997
158 158 414 670 926 1182 1438 1694 1950 2206 2462 2718 2974 3230 3486 3742 3998
159 159 415 671 927 1183 1439 1695 1951 2207 2463 2719 2975 3231 3487 3743 3999
160 160 416 672 928 1184 1440 1696 1952 2208 2464 2720 2976 3232 3488 3744 4000
161 161 417 673 929 1185 1441 1697 1953 2209 2465 2721 2977 3233 3489 3745 4001
162 162 418 674 930 1186 1442 1698 1954 2210 2466 2722 2978 3234 3490 3746 4002
163 163 419 675 931 1187 1443 1699 1955 2211 2467 2723 2979 3235 3491 3747 4003
164 164 420 676 932 1188 1444 1700 1956 2212 2468 2724 2980 3236 3492 3748 4004
165 165 421 677 933 1189 1445 1701 1957 2213 2469 2725 2981 3237 3493 3749 4005
166 166 422 678 934 1190 1446 1702 1958 2214 2470 2726 2982 3238 3494 3750 4006
167 167 423 679 935 1191 1447 1703 1959 2215 2471 2727 2983 3239 3495 3751 4007
168 168 424 680 936 1192 1448 1704 1960 2216 2472 2728 2984 3240 3496 3752 4008
169 169 425 681 937 1193 1449 1705 1961 2217 2473 2729 2985 3241 3497 3753 4009
170 170 426 682 938 1194 1450 1706 1962 2218 2474 2730 2986 3242 3498 3754 4010
171 171 427 683 939 1195 1451 1707 1963 2219 2475 2731 2987 3243 3499 3755 4011
172 172 428 684 940 1196 1452 1708 1964 2220 2476 2732 2988 3244 3500 3756 4012
173 173 429 685 941 1197 1453 1709 1965 2221 2477 2733 2989 3245 3501 3757 4013
174 174 430 686 942 1198 1454 1710 1966 2222 2478 2734 2990 3246 3502 3758 4014
175 175 431 687 943 1199 1455 1711 1967 2223 2479 2735 2991 3247 3503 3759 4015
176 176 432 688 944 1200 1456 1712 1968 2224 2480 2736 2992 3248 3504 3760 4016
177 177 433 689 945 1201 1457 1713 1969 2225 2481 2737 2993 3249 3505 3761 4017
178 178 434 690 946 1202 1458 1714 1970 2226 2482 2738 2994 3250 3506 3762 4018
179 179 435 691 947 1203 1459 1715 1971 2227 2483 2739 2995 3251 3507 3763 4019
180 180 436 692 948 1204 1460 1716 1972 2228 2484 2740 2996 3252 3508 3764 4020
181 181 437 693 949 1205 1461 1717 1973 2229 2485 2741 2997 3253 3509 3765 4021
182 182 438 694 950 1206 1462 1718 1974 2230 2486 2742 2998 3254 3510 3766 4022
183 183 439 695 951 1207 1463 1719 1975 2231 2487 2743 2999 3255 3511 3767 4023
184 184 440 696 952 1208 1464 1720 1976 2232 2488 2744 3000 3256 3512 3768 4024
185 185 441 697 953 1209 1465 1721 1977 2233 2489 2745 3001 3257 3513 3769 4025
186 186 442 698 954 1210 1466 1722 1978 2234 2490 2746 3002 3258 3514 3770 4026
187 187 443 699 955 1211 1467 1723 1979 2235 2491 2747 3003 3259 3515 3771 4027
188 188 444 700 956 1212 1468 1724 1980 2236 2492 2748 3004 3260 3516 3772 4028
189 189 445 701 957 1213 1469 1725 1981 2237 2493 2749 3005 3261 3517 3773 4029
190 190 446 702 958 1214 1470 1726 1982 2238 2494 2750 3006 3262 3518 3774 4030
191 191 447 703 959 1215 1471 1727 1983 2239 2495 2751 3007 3263 3519 3775 4031
192 192 448 704 960 1216 1472 1728 1984 2240 2496 2752 3008 3264 3520 3776 4032
193 193 449 705 961 1217 1473 1729 1985 2241 2497 2753 3009 3265 3521 3777 4033
194 194 450 706 962 1218 1474 1730 1986 2242 2498 2754 3010 3266 3522 3778 4034
195 195 451 707 963 1219 1475 1731 1987 2243 2499 2755 3011 3267 3523 3779 4035
196 196 452 708 964 1220 1476 1732 1988 2244 2500 2756 3012 3268 3524 3780 4036
197 197 453 709 965 1221 1477 1733 1989 2245 2501 2757 3013 3269 3525 3781 4037
198 198 454 710 966 1222 1478 1734 1990 2246 2502 2758 3014 3270 3526 3782 4038
199 199 455 711 967 1223 1479 1735 1991 2247 2503 2759 3015 3271 3527 3783 4039
200 200 456 712 968 1224 1480 1736 1992 2248 2504 2760 3016 3272 3528 3784 4040
201 201 457 713 969 1225 1481 1737 1993 2249 2505 2761 3017 3273 3529 3785 4041
202 202 458 714 970 1226 1482 1738 1994 2250 2506 2762 3018 3274 3530 3786 4042
203 203 459 715 971 1227 1483 1739 1995 2251 2507 2763 3019 3275 3531 3787 4043
204 204 460 716 972 1228 1484 1740 1996 2252 2508 2764 3020 3276 3532 3788 4044
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205 205 461 717 973 1229 1485 1741 1997 2253 2509 2765 3021 3277 3533 3789 4045
206 206 462 718 974  1230 1486 1742 1998 2254 2510 2766 3022 3278 3534 3790 4046
207 207 463 719 975 1231 1487 1743 1999 2255 2511 2767 3023 3279 3535 3791 4047
208 208 464 720 976 1232 1488 1744 2000 2256 2512 2768 3024 3280 3536 3792 4048
209 209 465 721 977 1233 1489 1745 2001 2257 2513 2769 3025 3281 3537 3793 4049
210 210 466 722 978 1234 1490 1746 2002 2258 2514 2770 3026 3282 3538 3794 4050
211 211 467 723 979 1235 1491 1747 2003 2259 2515 2771 3027 3283 3539 3795 4051
212 212 468 724 980 1236 1492 1748 2004 2260 2516 2772 3028 3284 3540 3796 4052
213 213 469 725 981 1237 1493 1749 2005 2261 2517 2773 3029 3285 3541 3797 4053
214 214 470 726 982 1238 1494 1750 2006 2262 2518 2774 3030 3286 3542 3798 4054
215 215 471 727 983 1239 1495 1751 2007 2263 2519 2775 3031 3287 3543 3799 4055
216 216 472 728 984 1240 1496 1752 2008 2264 2520 2776 3032 3288 3544 3800 4056
217 217 473 729 985 1241 1497 1753 2009 2265 2521 2777 3033 3289 3545 3801 4057
218 218 474 730 986 1242 1498 1754 2010 2266 2522 2778 3034 3290 3546 3802 4058
219 219 475 731 987 1243 1499 1755 2011 2267 2523 2779 3035 3291 3547 3803 4059
220 220 476 732 988 1244 1500 1756 2012 2268 2524 2780 3036 3292 3548 3804 4060
221 221 477 733 989 1245 1501 1757 2013 2269 2525 2781 3037 3293 3549 3805 4061
222 222 478 734 990 1246 1502 1758 2014 2270 2526 2782 3038 3294 3550 3806 4062
223 223 479 735 991 1247 1503 1759 2015 2271 2527 2783 3039 3295 3551 3807 4063
224 224 480 736 992 1248 1504 1760 2016 2272 2528 2784 3040 3296 3552 3808 4064
225 225 481 737 993 1249 1505 1761 2017 2273 2529 2785 3041 3297 3553 3809 4065
226 226 482 738 994 1250 1506 1762 2018 2274 2530 2786 3042 3298 3554 3810 4066
227 227 483 739 995 1251 1507 1763 2019 2275 2531 2787 3043 3299 3555 3811 4067
228 228 484  740  996 1252 1508 1764 2020 2276 2532 2788 3044 3300 3556 3812 4068
229 229 485 741 997 1253 1509 1765 2021 2277 2533 2789 3045 3301 3557 3813 4069
230 230 486 742  998 1254 1510 1766 2022 2278 2534 2790 3046 3302 3558 3814 4070
231 231 487 743  999  1255 1511 1767 2023 2279 2535 2791 3047 3303 3559 3815 4071
232 232 488 744 1000 1256 1512 1768 2024 2280 2536 2792 3048 3304 3560 3816 4072
233 233 489 745 1001 1257 1513 1769 2025 2281 2537 2793 3049 3305 3561 3817 4073
234 234 490 746 1002 1258 1514 1770 2026 2282 2538 2794 3050 3306 3562 3818 4074
235 235  491 747 1003 1259 1515 1771 2027 2283 2539 2795 3051 3307 3563 3819 4075
236 236 492 748 1004 1260 1516 1772 2028 2284 2540 2796 3052 3308 3564 3820 4076
237 237 493 749 1005 1261 1517 1773 2029 2285 2541 2797 3053 3309 3565 3821 4077
238 238 494  750 1006 1262 1518 1774 2030 2286 2542 2798 3054 3310 3566 3822 4078
239 239  495 751 1007 1263 1519 1775 2031 2287 2543 2799 3055 3311 3567 3823 4079
240 240 496 752 1008 1264 1520 1776 2032 2288 2544 2800 3056 3312 3568 3824 4080
241 241 497 753 1009 1265 1521 1777 2033 2289 2545 2801 3057 3313 3569 3825 4081
242 242 498 754 1010 1266 1522 1778 2034 2290 2546 2802 3058 3314 3570 3826 4082
243 243 499 755 1011 1267 1523 1779 2035 2291 2547 2803 3059 3315 3571 3827 4083
244 244 500 756 1012 1268 1524 1780 2036 2292 2548 2804 3060 3316 3572 3828 4084
245 245 501 757 1013 1269 1525 1781 2037 2293 2549 2805 3061 3317 3573 3829 4085
246 246 502 758 1014 1270 1526 1782 2038 2294 2550 2806 3062 3318 3574 3830 4086
247 247 503 759 1015 1271 1527 1783 2039 2295 2551 2807 3063 3319 3575 3831 4087
248 248 504 760 1016 1272 1528 1784 2040 2296 2552 2808 3064 3320 3576 3832 4088
249 249 505 761 1017 1273 1529 1785 2041 2297 2553 2809 3065 3321 3577 3833 4089
250 250 506 762 1018 1274 1530 1786 2042 2298 2554 2810 3066 3322 3578 3834 4090
251 251 507 763 1019 1275 1531 1787 2043 2299 2555 2811 3067 3323 3579 3835 4091
252 252 508 764 1020 1276 1532 1788 2044 2300 2556 2812 3068 3324 3580 3836 4092
253 253 509 765 1021 1277 1533 1789 2045 2301 2557 2813 3069 3325 3581 3837 4093
254 254 510 766 1022 1278 1534 1790 2046 2302 2558 2814 3070 3326 3582 3838 4094
255 255 511 767 1023 1279 1535 1791 2047 2303 2559 2815 3071 3327 3583 3839 4095

DestinationX 0 1 2 3 4 5 6 7
0 0 1 2 3 4 5 6 7
8 8 9 10 11 12 13 14 15
16 16 17 18 19 20 21 22 23
24 24 25 26 27 28 29 30 31
32 32 33 34 35 36 37 38 39
40 40 41 42 43 44 45 46 47
48 48 49 50 51 52 53 54 55
56 56 57 58 59 60 61 62 63
64 64 65 66 67 68 69 70 71
72 72 73 74 75 76 77 78 79
80 80 81 82 83 84 85 86 87
88 88 89 90 91 92 93 94 95
96 96 97 98 99 100 101 102 103
104 104 105 106 107 108 109 110 111
112 112 113 114 115 116 117 118 119
120 120 121 122 123 124 125 126 127
128 128 129 130 131 132 133 134 135
136 136 137 138 139 140 141 142 143
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144 144 145 146 147 148 149 150 151
152 152 153 154 155 156 157 158 159
160 160 161 162 163 164 165 166 167
168 168 169 170 171 172 173 174 175
176 176 177 178 179 180 181 182 183
184 184 185 186 187 188 189 190 191
192 192 193 194 195 196 197 198 199
200 200 201 202 203 204 205 206 207
208 208 209 210 211 212 213 214 215
216 216 217 218 219 220 221 222 223
224 224 225 226 227 228 229 230 231
232 232 233 234 235 236 237 238 239
240 240 241 242 243 244 245 246 247
248 248 249 250 251 252 253 254 255
256 256 257 258 259 260 261 262 263
264 264 265 266 267 268 269 270 271
272 272 273 274 275 276 277 278 279
280 280 281 282 283 284 285 286 287
288 288 289 290 291 292 293 294 295
296 296 297 298 299 300 301 302 303
304 304 305 306 307 308 309 310 311
312 312 313 314 315 316 317 318 319
320 320 321 322 323 324 325 326 327
328 328 329 330 331 332 333 334 335
336 336 337 338 339 340 341 342 343
344 344 345 346 347 348 349 350 351
352 352 353 354 355 356 357 358 359
360 360 361 362 363 364 365 366 367
368 368 369 370 371 372 373 374 375
376 376 377 378 379 380 381 382 383
384 384 385 386 387 388 389 390 391
392 392 393 394 395 396 397 398 399
400 400 401 402 403 404 405 406 407
408 408 409 410 411 412 413 414 415
416 416 417 418 419 420 421 422 423
424 424 425 426 427 428 429 430 431
432 432 433 434 435 436 437 438 439
440 440 441 442 443 444 445 446 447
448 448 449 450 451 452 453 454 455
456 456 457 458 459 460 461 462 463
464 464 465 466 467 468 469 470 471
472 472 473 474 475 476 477 478 479
480 480 481 482 483 484 485 486 487
488 488 489 490 491 492 493 494 495
496 496 497 498 499 500 501 502 503
504 504 505 506 507 508 509 510 511
512 512 513 514 515 516 517 518 519
520 520 521 522 523 524 525 526 527
528 528 529 530 531 532 533 534 535
536 536 537 538 539 540 541 542 543
544 544 545 546 547 548 549 550 551
552 552 553 554 555 556 557 558 559
560 560 561 562 563 564 565 566 567
568 568 569 570 571 572 573 574 575
576 576 577 578 579 580 581 582 583
584 584 585 586 587 588 589 590 591
592 592 593 594 595 596 597 598 599
600 600 601 602 603 604 605 606 607
608 608 609 610 611 612 613 614 615
616 616 617 618 619 620 621 622 623
624 624 625 626 627 628 629 630 631
632 632 633 634 635 636 637 638 639
640 640 641 642 643 644 645 646 647
648 648 649 650 651 652 653 654 655
656 656 657 658 659 660 661 662 663
664 664 665 666 667 668 669 670 671
672 672 673 674 675 676 677 678 679
680 680 681 682 683 684 685 686 687
688 688 689 690 691 692 693 694 695
696 696 697 698 699 700 701 702 703
704 704 705 706 707 708 709 710 711
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712 712 713 714 715 716 717 718 719
720 720 721 722 723 724 725 726 727
728 728 729 730 731 732 733 734 735
736 736 737 738 739 740 741 742 743
744 744 745 746 747 748 749 750 751
752 752 753 754 755 756 757 758 759
760 760 761 762 763 764 765 766 767
768 768 769 770 771 772 773 774 775
776 776 777 778 779 780 781 782 783
784 784 785 786 787 788 789 790 791
792 792 793 794 795 796 797 798 799
800 800 801 802 803 804 805 806 807
808 808 809 810 811 812 813 814 815
816 816 817 818 819 820 821 822 823
824 824 825 826 827 828 829 830 831
832 832 833 834 835 836 837 838 839
840 840 841 842 843 844 845 846 847
848 848 849 850 851 852 853 854 855
856 856 857 858 859 860 861 862 863
864 864 865 866 867 868 869 870 871
872 872 873 874 875 876 877 878 879
880 880 881 882 883 884 885 886 887
888 888 889 890 891 892 893 894 895
896 896 897 898 899 900 901 902 903
904 904 905 906 907 908 909 910 911
912 912 913 914 915 916 917 918 919
920 920 921 922 923 924 925 926 927
928 928 929 930 931 932 933 934 935
936 936 937 938 939 940 941 942 943
944 944 945 946 947 948 949 950 951
952 952 953 954 955 956 957 958 959
960 960 961 962 963 964 965 966 967
968 968 969 970 971 972 973 974 975
976 976 977 978 979 980 981 982 983
984 984 985 986 987 988 989 990 991
992 992 993 994 995 996 997 998 999
1000 1000 1001 1002 1003 1004 1005 1006 1007
1008 1008 1009 1010 1011 1012 1013 1014 1015
1016 1016 1017 1018 1019 1020 1021 1022 1023
1024 1024 1025 1026 1027 1028 1029 1030 1031
1032 1032 1033 1034 1035 1036 1037 1038 1039
1040 1040 1041 1042 1043 1044 1045 1046 1047
1048 1048 1049 1050 1051 1052 1053 1054 1055
1056 1056 1057 1058 1059 1060 1061 1062 1063
1064 1064 1065 1066 1067 1068 1069 1070 1071
1072 1072 1073 1074 1075 1076 1077 1078 1079
1080 1080 1081 1082 1083 1084 1085 1086 1087
1088 1088 1089 1090 1091 1092 1093 1094 1095
1096 1096 1097 1098 1099 1100 1101 1102 1103
1104 1104 1105 1106 1107 1108 1109 1110 1111
1112 1112 1113 1114 1115 1116 1117 1118 1119
1120 1120 1121 1122 1123 1124 1125 1126 1127
1128 1128 1129 1130 1131 1132 1133 1134 1135
1136 1136 1137 1138 1139 1140 1141 1142 1143
1144 1144 1145 1146 1147 1148 1149 1150 1151
1152 1152 1153 1154 1155 1156 1157 1158 1159
1160 1160 1161 1162 1163 1164 1165 1166 1167
1168 1168 1169 1170 1171 1172 1173 1174 1175
1176 1176 1177 1178 1179 1180 1181 1182 1183
1184 1184 1185 1186 1187 1188 1189 1190 1191
1192 1192 1193 1194 1195 1196 1197 1198 1199
1200 1200 1201 1202 1203 1204 1205 1206 1207
1208 1208 1209 1210 1211 1212 1213 1214 1215
1216 1216 1217 1218 1219 1220 1221 1222 1223
1224 1224 1225 1226 1227 1228 1229 1230 1231
1232 1232 1233 1234 1235 1236 1237 1238 1239
1240 1240 1241 1242 1243 1244 1245 1246 1247
1248 1248 1249 1250 1251 1252 1253 1254 1255
1256 1256 1257 1258 1259 1260 1261 1262 1263
1264 1264 1265 1266 1267 1268 1269 1270 1271
1272 1272 1273 1274 1275 1276 1277 1278 1279
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1280 1280 1281 1282 1283 1284 1285 1286 1287
1288 1288 1289 1290 1291 1292 1293 1294 1295
1296 1296 1297 1298 1299 1300 1301 1302 1303
1304 1304 1305 1306 1307 1308 1309 1310 1311
1312 1312 1313 1314 1315 1316 1317 1318 1319
1320 1320 1321 1322 1323 1324 1325 1326 1327
1328 1328 1329 1330 1331 1332 1333 1334 1335
1336 1336 1337 1338 1339 1340 1341 1342 1343
1344 1344 1345 1346 1347 1348 1349 1350 1351
1352 1352 1353 1354 1355 1356 1357 1358 1359
1360 1360 1361 1362 1363 1364 1365 1366 1367
1368 1368 1369 1370 1371 1372 1373 1374 1375
1376 1376 1377 1378 1379 1380 1381 1382 1383
1384 1384 1385 1386 1387 1388 1389 1390 1391
1392 1392 1393 1394 1395 1396 1397 1398 1399
1400 1400 1401 1402 1403 1404 1405 1406 1407
1408 1408 1409 1410 1411 1412 1413 1414 1415
1416 1416 1417 1418 1419 1420 1421 1422 1423
1424 1424 1425 1426 1427 1428 1429 1430 1431
1432 1432 1433 1434 1435 1436 1437 1438 1439
1440 1440 1441 1442 1443 1444 1445 1446 1447
1448 1448 1449 1450 1451 1452 1453 1454 1455
1456 1456 1457 1458 1459 1460 1461 1462 1463
1464 1464 1465 1466 1467 1468 1469 1470 1471
1472 1472 1473 1474 1475 1476 1477 1478 1479
1480 1480 1481 1482 1483 1484 1485 1486 1487
1488 1488 1489 1490 1491 1492 1493 1494 1495
1496 1496 1497 1498 1499 1500 1501 1502 1503
1504 1504 1505 1506 1507 1508 1509 1510 1511
1512 1512 1513 1514 1515 1516 1517 1518 1519
1520 1520 1521 1522 1523 1524 1525 1526 1527
1528 1528 1529 1530 1531 1532 1533 1534 1535
1536 1536 1537 1538 1539 1540 1541 1542 1543
1544 1544 1545 1546 1547 1548 1549 1550 1551
1552 1552 1553 1554 1555 1556 1557 1558 1559
1560 1560 1561 1562 1563 1564 1565 1566 1567
1568 1568 1569 1570 1571 1572 1573 1574 1575
1576 1576 1577 1578 1579 1580 1581 1582 1583
1584 1584 1585 1586 1587 1588 1589 1590 1591
1592 1592 1593 1594 1595 1596 1597 1598 1599
1600 1600 1601 1602 1603 1604 1605 1606 1607
1608 1608 1609 1610 1611 1612 1613 1614 1615
1616 1616 1617 1618 1619 1620 1621 1622 1623
1624 1624 1625 1626 1627 1628 1629 1630 1631
1632 1632 1633 1634 1635 1636 1637 1638 1639
1640 1640 1641 1642 1643 1644 1645 1646 1647
1648 1648 1649 1650 1651 1652 1653 1654 1655
1656 1656 1657 1658 1659 1660 1661 1662 1663
1664 1664 1665 1666 1667 1668 1669 1670 1671
1672 1672 1673 1674 1675 1676 1677 1678 1679
1680 1680 1681 1682 1683 1684 1685 1686 1687
1688 1688 1689 1690 1691 1692 1693 1694 1695
1696 1696 1697 1698 1699 1700 1701 1702 1703
1704 1704 1705 1706 1707 1708 1709 1710 1711
1712 1712 1713 1714 1715 1716 1717 1718 1719
1720 1720 1721 1722 1723 1724 1725 1726 1727
1728 1728 1729 1730 1731 1732 1733 1734 1735
1736 1736 1737 1738 1739 1740 1741 1742 1743
1744 1744 1745 1746 1747 1748 1749 1750 1751
1752 1752 1753 1754 1755 1756 1757 1758 1759
1760 1760 1761 1762 1763 1764 1765 1766 1767
1768 1768 1769 1770 1771 1772 1773 1774 1775
1776 1776 1777 1778 1779 1780 1781 1782 1783
1784 1784 1785 1786 1787 1788 1789 1790 1791
1792 1792 1793 1794 1795 1796 1797 1798 1799
1800 1800 1801 1802 1803 1804 1805 1806 1807
1808 1808 1809 1810 1811 1812 1813 1814 1815
1816 1816 1817 1818 1819 1820 1821 1822 1823
1824 1824 1825 1826 1827 1828 1829 1830 1831
1832 1832 1833 1834 1835 1836 1837 1838 1839
1840 1840 1841 1842 1843 1844 1845 1846 1847
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1848 1848 1849 1850 1851 1852 1853 1854 1855
1856 1856 1857 1858 1859 1860 1861 1862 1863
1864 1864 1865 1866 1867 1868 1869 1870 1871
1872 1872 1873 1874 1875 1876 1877 1878 1879
1880 1880 1881 1882 1883 1884 1885 1886 1887
1888 1888 1889 1890 1891 1892 1893 1894 1895
1896 1896 1897 1898 1899 1900 1901 1902 1903
1904 1904 1905 1906 1907 1908 1909 1910 1911
1912 1912 1913 1914 1915 1916 1917 1918 1919
1920 1920 1921 1922 1923 1924 1925 1926 1927
1928 1928 1929 1930 1931 1932 1933 1934 1935
1936 1936 1937 1938 1939 1940 1941 1942 1943
1944 1944 1945 1946 1947 1948 1949 1950 1951
1952 1952 1953 1954 1955 1956 1957 1958 1959
1960 1960 1961 1962 1963 1964 1965 1966 1967
1968 1968 1969 1970 1971 1972 1973 1974 1975
1976 1976 1977 1978 1979 1980 1981 1982 1983
1984 1984 1985 1986 1987 1988 1989 1990 1991
1992 1992 1993 1994 1995 1996 1997 1998 1999
2000 2000 2001 2002 2003 2004 2005 2006 2007
2008 2008 2009 2010 2011 2012 2013 2014 2015
2016 2016 2017 2018 2019 2020 2021 2022 2023
2024 2024 2025 2026 2027 2028 2029 2030 2031
2032 2032 2033 2034 2035 2036 2037 2038 2039
2040 2040 2041 2042 2043 2044 2045 2046 2047
2048 2048 2049 2050 2051 2052 2053 2054 2055
2056 2056 2057 2058 2059 2060 2061 2062 2063
2064 2064 2065 2066 2067 2068 2069 2070 2071
2072 2072 2073 2074 2075 2076 2077 2078 2079
2080 2080 2081 2082 2083 2084 2085 2086 2087
2088 2088 2089 2090 2091 2092 2093 2094 2095
2096 2096 2097 2098 2099 2100 2101 2102 2103
2104 2104 2105 2106 2107 2108 2109 2110 2111
2112 2112 2113 2114 2115 2116 2117 2118 2119
2120 2120 2121 2122 2123 2124 2125 2126 2127
2128 2128 2129 2130 2131 2132 2133 2134 2135
2136 2136 2137 2138 2139 2140 2141 2142 2143
2144 2144 2145 2146 2147 2148 2149 2150 2151
2152 2152 2153 2154 2155 2156 2157 2158 2159
2160 2160 2161 2162 2163 2164 2165 2166 2167
2168 2168 2169 2170 2171 2172 2173 2174 2175
2176 2176 2177 2178 2179 2180 2181 2182 2183
2184 2184 2185 2186 2187 2188 2189 2190 2191
2192 2192 2193 2194 2195 2196 2197 2198 2199
2200 2200 2201 2202 2203 2204 2205 2206 2207
2208 2208 2209 2210 2211 2212 2213 2214 2215
2216 2216 2217 2218 2219 2220 2221 2222 2223
2224 2224 2225 2226 2227 2228 2229 2230 2231
2232 2232 2233 2234 2235 2236 2237 2238 2239
2240 2240 2241 2242 2243 2244 2245 2246 2247
2248 2248 2249 2250 2251 2252 2253 2254 2255
2256 2256 2257 2258 2259 2260 2261 2262 2263
2264 2264 2265 2266 2267 2268 2269 2270 2271
2272 2272 2273 2274 2275 2276 2277 2278 2279
2280 2280 2281 2282 2283 2284 2285 2286 2287
2288 2288 2289 2290 2291 2292 2293 2294 2295
2296 2296 2297 2298 2299 2300 2301 2302 2303
2304 2304 2305 2306 2307 2308 2309 2310 2311
2312 2312 2313 2314 2315 2316 2317 2318 2319
2320 2320 2321 2322 2323 2324 2325 2326 2327
2328 2328 2329 2330 2331 2332 2333 2334 2335
2336 2336 2337 2338 2339 2340 2341 2342 2343
2344 2344 2345 2346 2347 2348 2349 2350 2351
2352 2352 2353 2354 2355 2356 2357 2358 2359
2360 2360 2361 2362 2363 2364 2365 2366 2367
2368 2368 2369 2370 2371 2372 2373 2374 2375
2376 2376 2377 2378 2379 2380 2381 2382 2383
2384 2384 2385 2386 2387 2388 2389 2390 2391
2392 2392 2393 2394 2395 2396 2397 2398 2399
2400 2400 2401 2402 2403 2404 2405 2406 2407
2408 2408 2409 2410 2411 2412 2413 2414 2415
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Figure 8-48. DUT Definition File (10 of 12)

2416 2416 2417 2418 2419 2420 2421 2422 2423
2424 2424 2425 2426 2427 2428 2429 2430 2431
2432 2432 2433 2434 2435 2436 2437 2438 2439
2440 2440 2441 2442 2443 2444 2445 2446 2447
2448 2448 2449 2450 2451 2452 2453 2454 2455
2456 2456 2457 2458 2459 2460 2461 2462 2463
2464 2464 2465 2466 2467 2468 2469 2470 2471
2472 2472 2473 2474 2475 2476 2477 2478 2479
2480 2480 2481 2482 2483 2484 2485 2486 2487
2488 2488 2489 2490 2491 2492 2493 2494 2495
2496 2496 2497 2498 2499 2500 2501 2502 2503
2504 2504 2505 2506 2507 2508 2509 2510 2511
2512 2512 2513 2514 2515 2516 2517 2518 2519
2520 2520 2521 2522 2523 2524 2525 2526 2527
2528 2528 2529 2530 2531 2532 2533 2534 2535
2536 2536 2537 2538 2539 2540 2541 2542 2543
2544 2544 2545 2546 2547 2548 2549 2550 2551
2552 2552 2553 2554 2555 2556 2557 2558 2559
2560 2560 2561 2562 2563 2564 2565 2566 2567
2568 2568 2569 2570 2571 2572 2573 2574 2575
2576 2576 2577 2578 2579 2580 2581 2582 2583
2584 2584 2585 2586 2587 2588 2589 2590 2591
2592 2592 2593 2594 2595 2596 2597 2598 2599
2600 2600 2601 2602 2603 2604 2605 2606 2607
2608 2608 2609 2610 2611 2612 2613 2614 2615
2616 2616 2617 2618 2619 2620 2621 2622 2623
2624 2624 2625 2626 2627 2628 2629 2630 2631
2632 2632 2633 2634 2635 2636 2637 2638 2639
2640 2640 2641 2642 2643 2644 2645 2646 2647
2648 2648 2649 2650 2651 2652 2653 2654 2655
2656 2656 2657 2658 2659 2660 2661 2662 2663
2664 2664 2665 2666 2667 2668 2669 2670 2671
2672 2672 2673 2674 2675 2676 2677 2678 2679
2680 2680 2681 2682 2683 2684 2685 2686 2687
2688 2688 2689 2690 2691 2692 2693 2694 2695
2696 2696 2697 2698 2699 2700 2701 2702 2703
2704 2704 2705 2706 2707 2708 2709 2710 2711
2712 2712 2713 2714 2715 2716 2717 2718 2719
2720 2720 2721 2722 2723 2724 2725 2726 2727
2728 2728 2729 2730 2731 2732 2733 2734 2735
2736 2736 2737 2738 2739 2740 2741 2742 2743
2744 2744 2745 2746 2747 2748 2749 2750 2751
2752 2752 2753 2754 2755 2756 2757 2758 2759
2760 2760 2761 2762 2763 2764 2765 2766 2767
2768 2768 2769 2770 2771 2772 2773 2774 2775
2776 2776 2777 2778 2779 2780 2781 2782 2783
2784 2784 2785 2786 2787 2788 2789 2790 2791
2792 2792 2793 2794 2795 2796 2797 2798 2799
2800 2800 2801 2802 2803 2804 2805 2806 2807
2808 2808 2809 2810 2811 2812 2813 2814 2815
2816 2816 2817 2818 2819 2820 2821 2822 2823
2824 2824 2825 2826 2827 2828 2829 2830 2831
2832 2832 2833 2834 2835 2836 2837 2838 2839
2840 2840 2841 2842 2843 2844 2845 2846 2847
2848 2848 2849 2850 2851 2852 2853 2854 2855
2856 2856 2857 2858 2859 2860 2861 2862 2863
2864 2864 2865 2866 2867 2868 2869 2870 2871
2872 2872 2873 2874 2875 2876 2877 2878 2879
2880 2880 2881 2882 2883 2884 2885 2886 2887
2888 2888 2889 2890 2891 2892 2893 2894 2895
2896 2896 2897 2898 2899 2900 2901 2902 2903
2904 2904 2905 2906 2907 2908 2909 2910 2911
2912 2912 2913 2914 2915 2916 2917 2918 2919
2920 2920 2921 2922 2923 2924 2925 2926 2927
2928 2928 2929 2930 2931 2932 2933 2934 2935
2936 2936 2937 2938 2939 2940 2941 2942 2943
2944 2944 2945 2946 2947 2948 2949 2950 2951
2952 2952 2953 2954 2955 2956 2957 2958 2959
2960 2960 2961 2962 2963 2964 2965 2966 2967
2968 2968 2969 2970 2971 2972 2973 2974 2975
2976 2976 2977 2978 2979 2980 2981 2982 2983
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Figure 8-49. DUT Definition File (11 of 12)

2984 2984 2985 2986 2987 2988 2989 2990 2991
2992 2992 2993 2994 2995 2996 2997 2998 2999
3000 3000 3001 3002 3003 3004 3005 3006 3007
3008 3008 3009 3010 3011 3012 3013 3014 3015
3016 3016 3017 3018 3019 3020 3021 3022 3023
3024 3024 3025 3026 3027 3028 3029 3030 3031
3032 3032 3033 3034 3035 3036 3037 3038 3039
3040 3040 3041 3042 3043 3044 3045 3046 3047
3048 3048 3049 3050 3051 3052 3053 3054 3055
3056 3056 3057 3058 3059 3060 3061 3062 3063
3064 3064 3065 3066 3067 3068 3069 3070 3071
3072 3072 3073 3074 3075 3076 3077 3078 3079
3080 3080 3081 3082 3083 3084 3085 3086 3087
3088 3088 3089 3090 3091 3092 3093 3094 3095
3096 3096 3097 3098 3099 3100 3101 3102 3103
3104 3104 3105 3106 3107 3108 3109 3110 3111
3112 3112 3113 3114 3115 3116 3117 3118 3119
3120 3120 3121 3122 3123 3124 3125 3126 3127
3128 3128 3129 3130 3131 3132 3133 3134 3135
3136 3136 3137 3138 3139 3140 3141 3142 3143
3144 3144 3145 3146 3147 3148 3149 3150 3151
3152 3152 3153 3154 3155 3156 3157 3158 3159
3160 3160 3161 3162 3163 3164 3165 3166 3167
3168 3168 3169 3170 3171 3172 3173 3174 3175
3176 3176 3177 3178 3179 3180 3181 3182 3183
3184 3184 3185 3186 3187 3188 3189 3190 3191
3192 3192 3193 3194 3195 3196 3197 3198 3199
3200 3200 3201 3202 3203 3204 3205 3206 3207
3208 3208 3209 3210 3211 3212 3213 3214 3215
3216 3216 3217 3218 3219 3220 3221 3222 3223
3224 3224 3225 3226 3227 3228 3229 3230 3231
3232 3232 3233 3234 3235 3236 3237 3238 3239
3240 3240 3241 3242 3243 3244 3245 3246 3247
3248 3248 3249 3250 3251 3252 3253 3254 3255
3256 3256 3257 3258 3259 3260 3261 3262 3263
3264 3264 3265 3266 3267 3268 3269 3270 3271
3272 3272 3273 3274 3275 3276 3277 3278 3279
3280 3280 3281 3282 3283 3284 3285 3286 3287
3288 3288 3289 3290 3291 3292 3293 3294 3295
3296 3296 3297 3298 3299 3300 3301 3302 3303
3304 3304 3305 3306 3307 3308 3309 3310 3311
3312 3312 3313 3314 3315 3316 3317 3318 3319
3320 3320 3321 3322 3323 3324 3325 3326 3327
3328 3328 3329 3330 3331 3332 3333 3334 3335
3336 3336 3337 3338 3339 3340 3341 3342 3343
3344 3344 3345 3346 3347 3348 3349 3350 3351
3352 3352 3353 3354 3355 3356 3357 3358 3359
3360 3360 3361 3362 3363 3364 3365 3366 3367
3368 3368 3369 3370 3371 3372 3373 3374 3375
3376 3376 3377 3378 3379 3380 3381 3382 3383
3384 3384 3385 3386 3387 3388 3389 3390 3391
3392 3392 3393 3394 3395 3396 3397 3398 3399
3400 3400 3401 3402 3403 3404 3405 3406 3407
3408 3408 3409 3410 3411 3412 3413 3414 3415
3416 3416 3417 3418 3419 3420 3421 3422 3423
3424 3424 3425 3426 3427 3428 3429 3430 3431
3432 3432 3433 3434 3435 3436 3437 3438 3439
3440 3440 3441 3442 3443 3444 3445 3446 3447
3448 3448 3449 3450 3451 3452 3453 3454 3455
3456 3456 3457 3458 3459 3460 3461 3462 3463
3464 3464 3465 3466 3467 3468 3469 3470 3471
3472 3472 3473 3474 3475 3476 3477 3478 3479
3480 3480 3481 3482 3483 3484 3485 3486 3487
3488 3488 3489 3490 3491 3492 3493 3494 3495
3496 3496 3497 3498 3499 3500 3501 3502 3503
3504 3504 3505 3506 3507 3508 3509 3510 3511
3512 3512 3513 3514 3515 3516 3517 3518 3519
3520 3520 3521 3522 3523 3524 3525 3526 3527
3528 3528 3529 3530 3531 3532 3533 3534 3535
3536 3536 3537 3538 3539 3540 3541 3542 3543
3544 3544 3545 3546 3547 3548 3549 3550 3551
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Figure 8-50. DUT Definition File (12 of 12)

3552 3552 3553 3554 3555 3556 3557 3558 3559
3560 3560 3561 3562 3563 3564 3565 3566 3567
3568 3568 3569 3570 3571 3572 3573 3574 3575
3576 3576 3577 3578 3579 3580 3581 3582 3583
3584 3584 3585 3586 3587 3588 3589 3590 3591
3592 3592 3593 3594 3595 3596 3597 3598 3599
3600 3600 3601 3602 3603 3604 3605 3606 3607
3608 3608 3609 3610 3611 3612 3613 3614 3615
3616 3616 3617 3618 3619 3620 3621 3622 3623
3624 3624 3625 3626 3627 3628 3629 3630 3631
3632 3632 3633 3634 3635 3636 3637 3638 3639
3640 3640 3641 3642 3643 3644 3645 3646 3647
3648 3648 3649 3650 3651 3652 3653 3654 3655
3656 3656 3657 3658 3659 3660 3661 3662 3663
3664 3664 3665 3666 3667 3668 3669 3670 3671
3672 3672 3673 3674 3675 3676 3677 3678 3679
3680 3680 3681 3682 3683 3684 3685 3686 3687
3688 3688 3689 3690 3691 3692 3693 3694 3695
3696 3696 3697 3698 3699 3700 3701 3702 3703
3704 3704 3705 3706 3707 3708 3709 3710 3711
3712 3712 3713 3714 3715 3716 3717 3718 3719
3720 3720 3721 3722 3723 3724 3725 3726 3727
3728 3728 3729 3730 3731 3732 3733 3734 3735
3736 3736 3737 3738 3739 3740 3741 3742 3743
3744 3744 3745 3746 3747 3748 3749 3750 3751
3752 3752 3753 3754 3755 3756 3757 3758 3759
3760 3760 3761 3762 3763 3764 3765 3766 3767
3768 3768 3769 3770 3771 3772 3773 3774 3775
3776 3776 3777 3778 3779 3780 3781 3782 3783
3784 3784 3785 3786 3787 3788 3789 3790 3791
3792 3792 3793 3794 3795 3796 3797 3798 3799
3800 3800 3801 3802 3803 3804 3805 3806 3807
3808 3808 3809 3810 3811 3812 3813 3814 3815
3816 3816 3817 3818 3819 3820 3821 3822 3823
3824 3824 3825 3826 3827 3828 3829 3830 3831
3832 3832 3833 3834 3835 3836 3837 3838 3839
3840 3840 3841 3842 3843 3844 3845 3846 3847
3848 3848 3849 3850 3851 3852 3853 3854 3855
3856 3856 3857 3858 3859 3860 3861 3862 3863
3864 3864 3865 3866 3867 3868 3869 3870 3871
3872 3872 3873 3874 3875 3876 3877 3878 3879
3880 3880 3881 3882 3883 3884 3885 3886 3887
3888 3888 3889 3890 3891 3892 3893 3894 3895
3896 3896 3897 3898 3899 3900 3901 3902 3903
3904 3904 3905 3906 3907 3908 3909 3910 3911
3912 3912 3913 3914 3915 3916 3917 3918 3919
3920 3920 3921 3922 3923 3924 3925 3926 3927
3928 3928 3929 3930 3931 3932 3933 3934 3935
3936 3936 3937 3938 3939 3940 3941 3942 3943
3944 3944 3945 3946 3947 3948 3949 3950 3951
3952 3952 3953 3954 3955 3956 3957 3958 3959
3960 3960 3961 3962 3963 3964 3965 3966 3967
3968 3968 3969 3970 3971 3972 3973 3974 3975
3976 3976 3977 3978 3979 3980 3981 3982 3983
3984 3984 3985 3986 3987 3988 3989 3990 3991
3992 3992 3993 3994 3995 3996 3997 3998 3999
4000 4000 4001 4002 4003 4004 4005 4006 4007
4008 4008 4009 4010 4011 4012 4013 4014 4015
4016 4016 4017 4018 4019 4020 4021 4022 4023
4024 4024 4025 4026 4027 4028 4029 4030 4031
4032 4032 4033 4034 4035 4036 4037 4038 4039
4040 4040 4041 4042 4043 4044 4045 4046 4047
4048 4048 4049 4050 4051 4052 4053 4054 4055
4056 4056 4057 4058 4059 4060 4061 4062 4063
4064 4064 4065 4066 4067 4068 4069 4070 4071
4072 4072 4073 4074 4075 4076 4077 4078 4079
4080 4080 4081 4082 4083 4084 4085 4086 4087
4088 4088 4089 4090 4091 4092 4093 4094 4095

END REGION

END SCRAMBLING
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Header Section

The file begins with header information (Figure 8-51). This includes 
the creation date, user's name, company name, device name, protocol, 
technology, number of columns, number of rows, number of I/Os, and 
number of package pins.

Figure 8-51. Header Section

The DATE, USER, COMPANY, DEVICE, PROTOCOL, and 
TECHNOLOGY fields can be completed with entries of your choice.

The number of COLUMNS is determined by the number of physical 
columns in the device. It is the same as the maximum number of 
physical columns (+1) in the DestinationY column scrambling section 
(4095 + 1).

The number of ROWS is the number of physical rows in the device. It is 
the same as the maximum number of physical rows (+1) in the 
DestinationX row scrambling section (4095 + 1).

The number of PINS you specify must match the maximum number 
defined in the Pinout section. Typically this is the total number of pins.

Pinout Section

After the header and miscellaneous sections is the DUT definition 
itself. This includes the pinout and scrambling tables. Every pin on the 
device must be named, even if it is a not connect (NC).

Use the following rules when assigning names to the pins on the device 
(see Figure 8-52):

• The names of the data and address pins are predetermined to be 
IOn, and Xn and Yn, respectively.

BEGIN DUT
DATE=05/04/03
USER=CSTD
COMPANY=Agilent Technologies
DEVICE=16IO 
PROTOCOL=parallel
TECHNOLOGY=FLASH
COLUMNS=4096 // Number of physical bit columns.
ROWS=4096 // Number of physical rows.
i/oS=16 // Number of i/os.
PINS=48 // Number of pins device has that is specified in “PINOUT” section.

END DUT

BEGIN MISC
anything=5 // Field is required but not currently used.

END MISC
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• The clocks can be assigned any name which is not of the data or 
address name format.

• Data pins that are used for control instead of data may be given a 
non-data name.

• If a device has 16 I/Os then it should have 16 system I/Os connected 
to 16 pins on the device with the labels IO0, IO1, IO2, IO3, ... IO15.

• The same logic applies to the addresses. In other words, only pins 
called IOn are assumed to be true data pins, and only pins called 
Xn or Yn are assumed to be address pins.

Figure 8-52. Pinout Section

BEGIN PINOUT
P1=x7,a15
P2=x6,a14
P3=x5,a13
P4=x4,a12
P5=x3,a11
P6=x2,a10
P7=x1,a9
P8=x0,a8
P9=x11,a19
P10=unused
P11=WE
P12=unused
P13=unused
P14=unused
P15=unused
P16=x10,a18
P17=x9,a17
P18=y7,a7
P19=y6,a6
P20=y5,a5
P21=y4,a4
P22=y3,a3
P23=y2,a2
P24=y1,a1
P25=y0,a0
P26=CE
P27=VSS
P28=OE
P29=IO0
P30=IO8
P31=IO1
P32=IO9
P33=IO2
P34=IO10
P35=IO3
P36=IO11
P37=VDD
P38=IO4
P39=IO12
P40=IO5
P41=IO13
P42=IO6
P43=IO14
P44=IO7
P45=IO15
P46=VSS
P47=unused
P48=x8,a16

END PINOUT
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Scrambling Section

The scrambling section can be thought of as converting from logical 
(source) to physical format (destination) as illustrated for this example 
in Figure 8-53. Address bits A0–A7 are fed to a Y column decoder that 
controls column select lines Y0–Y7. Address bits A8–A19 are fed to an X 
row decoder that controls row select lines X0–X11. The physical 
configuration of the device deter-mines the X row and Y column 
scrambling.

Figure 8-53. Logical to Physical Format  

The scrambling section in the DUT definition file is defined in terms of 
rectangular regions, each of which has its own two sub-tables: 
DestinationY, DestinationX. One table is for the columns 
(DestinationY), and the other is for the rows (DestinationX). Devices 
that have more than one mapping of logical to physical addresses 
require scrambling tables with multiple regions so the Bitmap Tool can 
correctly display their bitmaps. This example has one region. See the 
“DUT Definition File” section on page 424 for additional examples with 
one and two regions and an example that demonstrates how regions 
can be copied to create multiple regions that make the DUT definition 
less tedious and error-prone.

Scrambling Table Definition

Each region needs a min X, max X, min Y, and max Y value as shown 
in Figure 8-54. This information should be the same as that found in 
the scrambling table itself.
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Figure 8-54. Region Max and Min Values

Table 8-1 summarizes the physical scrambling information for this 
example.

As a cross-check, multiply the number of physical columns by the 
number of physical rows (4096 × 4096 = 16777216) which should equal 
the total number of bits in the array (that is, 16 Mbit).

Column Scrambling Table

Across the top of the DestinationY column scrambling table 
(Figure 8-55) are the headers for the I/O pins (io0–io15). Down the first 
column on the left are the logical columns (0–255). On the right for 
each logical address and I/O pair is the corresponding physical column 
address. For example:

• Logical address 0 and io0 map to physical column 0.

• Logical address 0 and io4 map to physical column 1024.

• Logical address 7 and io0 map to physical column 7.

• Logical address 6 and io7 map to physical column 1798.

BEGIN SCRAMBLING Logical
BEGIN REGION

MINX=0 // Min physical X
MAXX=4095 // Max physical X
MINY=0 // Min physical Y
MAXY=4095 // Max physical Y

Table 8-1. Physical Scrambling Summary

Array Dimension Value Notes

Physical X Min 0

Max 4095 Equals: 
the number of row addresses – 1 =
212 – 1 = 4095

Physical Y Min 0

Max 4095 Equals: 
the number of column addresses × 
the number of I/Os per address =
28 × 16 – 1 = 4095
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Figure 8-55. Column Scrambling Table

DestinationY io0 io1 io2 io3 io4 io5 io6 io7 io8 io9 io10 io11 io12 io13 io14 io15
0 0 256 512 768 1024 1280 1536 1792 2048 2304 2560 2816 3072 3328 3584 3840
1 1 257 513 769 1025 1281 1537 1793 2049 2305 2561 2817 3073 3329 3585 3841
2 2 258 514 770 1026 1282 1538 1794 2050 2306 2562 2818 3074 3330 3586 3842
3 3 259 515 771 1027 1283 1539 1795 2051 2307 2563 2819 3075 3331 3587 3843
4 4 260 516 772 1028 1284 1540 1796 2052 2308 2564 2820 3076 3332 3588 3844
5 5 261 517 773 1029 1285 1541 1797 2053 2309 2565 2821 3077 3333 3589 3845
6 6 262 518 774 1030 1286 1542 1798 2054 2310 2566 2822 3078 3334 3590 3846
7 7 263 519 775 1031 1287 1543 1799 2055 2311 2567 2823 3079 3335 3591 3847
8 8 264 520 776 1032 1288 1544 1800 2056 2312 2568 2824 3080 3336 3592 3848
9 9 265 521 777 1033 1289 1545 1801 2057 2313 2569 2825 3081 3337 3593 3849
10 10 266 522 778 1034 1290 1546 1802 2058 2314 2570 2826 3082 3338 3594 3850
11 11 267 523 779 1035 1291 1547 1803 2059 2315 2571 2827 3083 3339 3595 3851
12 12 268 524 780 1036 1292 1548 1804 2060 2316 2572 2828 3084 3340 3596 3852
13 13 269 525 781 1037 1293 1549 1805 2061 2317 2573 2829 3085 3341 3597 3853
14 14 270 526 782 1038 1294 1550 1806 2062 2318 2574 2830 3086 3342 3598 3854
15 15 271 527 783 1039 1295 1551 1807 2063 2319 2575 2831 3087 3343 3599 3855
16 16 272 528 784 1040 1296 1552 1808 2064 2320 2576 2832 3088 3344 3600 3856
17 17 273 529 785 1041 1297 1553 1809 2065 2321 2577 2833 3089 3345 3601 3857
18 18 274 530 786 1042 1298 1554 1810 2066 2322 2578 2834 3090 3346 3602 3858
19 19 275 531 787 1043 1299 1555 1811 2067 2323 2579 2835 3091 3347 3603 3859
20 20 276 532 788 1044 1300 1556 1812 2068 2324 2580 2836 3092 3348 3604 3860
21 21 277 533 789 1045 1301 1557 1813 2069 2325 2581 2837 3093 3349 3605 3861
22 22 278 534 790 1046 1302 1558 1814 2070 2326 2582 2838 3094 3350 3606 3862
23 23 279 535 791 1047 1303 1559 1815 2071 2327 2583 2839 3095 3351 3607 3863
24 24 280 536 792 1048 1304 1560 1816 2072 2328 2584 2840 3096 3352 3608 3864
25 25 281 537 793 1049 1305 1561 1817 2073 2329 2585 2841 3097 3353 3609 3865
26 26 282 538 794 1050 1306 1562 1818 2074 2330 2586 2842 3098 3354 3610 3866
27 27 283 539 795 1051 1307 1563 1819 2075 2331 2587 2843 3099 3355 3611 3867
28 28 284 540 796 1052 1308 1564 1820 2076 2332 2588 2844 3100 3356 3612 3868
29 29 285 541 797 1053 1309 1565 1821 2077 2333 2589 2845 3101 3357 3613 3869
30 30 286 542 798 1054 1310 1566 1822 2078 2334 2590 2846 3102 3358 3614 3870
31 31 287 543 799 1055 1311 1567 1823 2079 2335 2591 2847 3103 3359 3615 3871
32 32 288 544 800 1056 1312 1568 1824 2080 2336 2592 2848 3104 3360 3616 3872

.

.

.
223 223 479 735 991 1247 1503 1759 2015 2271 2527 2783 3039 3295 3551 3807 4063
224 224 480 736 992 1248 1504 1760 2016 2272 2528 2784 3040 3296 3552 3808 4064
225 225 481 737 993 1249 1505 1761 2017 2273 2529 2785 3041 3297 3553 3809 4065
226 226 482 738 994 1250 1506 1762 2018 2274 2530 2786 3042 3298 3554 3810 4066
227 227 483 739 995 1251 1507 1763 2019 2275 2531 2787 3043 3299 3555 3811 4067
228 228 484  740  996 1252 1508 1764 2020 2276 2532 2788 3044 3300 3556 3812 4068
229 229 485 741 997 1253 1509 1765 2021 2277 2533 2789 3045 3301 3557 3813 4069
230 230 486 742  998 1254 1510 1766 2022 2278 2534 2790 3046 3302 3558 3814 4070
231 231 487 743  999  1255 1511 1767 2023 2279 2535 2791 3047 3303 3559 3815 4071
232 232 488 744 1000 1256 1512 1768 2024 2280 2536 2792 3048 3304 3560 3816 4072
233 233 489 745 1001 1257 1513 1769 2025 2281 2537 2793 3049 3305 3561 3817 4073
234 234 490 746 1002 1258 1514 1770 2026 2282 2538 2794 3050 3306 3562 3818 4074
235 235  491 747 1003 1259 1515 1771 2027 2283 2539 2795 3051 3307 3563 3819 4075
236 236 492 748 1004 1260 1516 1772 2028 2284 2540 2796 3052 3308 3564 3820 4076
237 237 493 749 1005 1261 1517 1773 2029 2285 2541 2797 3053 3309 3565 3821 4077
238 238 494  750 1006 1262 1518 1774 2030 2286 2542 2798 3054 3310 3566 3822 4078
239 239  495 751 1007 1263 1519 1775 2031 2287 2543 2799 3055 3311 3567 3823 4079
240 240 496 752 1008 1264 1520 1776 2032 2288 2544 2800 3056 3312 3568 3824 4080
241 241 497 753 1009 1265 1521 1777 2033 2289 2545 2801 3057 3313 3569 3825 4081
242 242 498 754 1010 1266 1522 1778 2034 2290 2546 2802 3058 3314 3570 3826 4082
243 243 499 755 1011 1267 1523 1779 2035 2291 2547 2803 3059 3315 3571 3827 4083
244 244 500 756 1012 1268 1524 1780 2036 2292 2548 2804 3060 3316 3572 3828 4084
245 245 501 757 1013 1269 1525 1781 2037 2293 2549 2805 3061 3317 3573 3829 4085
246 246 502 758 1014 1270 1526 1782 2038 2294 2550 2806 3062 3318 3574 3830 4086
247 247 503 759 1015 1271 1527 1783 2039 2295 2551 2807 3063 3319 3575 3831 4087
248 248 504 760 1016 1272 1528 1784 2040 2296 2552 2808 3064 3320 3576 3832 4088
249 249 505 761 1017 1273 1529 1785 2041 2297 2553 2809 3065 3321 3577 3833 4089
250 250 506 762 1018 1274 1530 1786 2042 2298 2554 2810 3066 3322 3578 3834 4090
251 251 507 763 1019 1275 1531 1787 2043 2299 2555 2811 3067 3323 3579 3835 4091
252 252 508 764 1020 1276 1532 1788 2044 2300 2556 2812 3068 3324 3580 3836 4092
253 253 509 765 1021 1277 1533 1789 2045 2301 2557 2813 3069 3325 3581 3837 4093
254 254 510 766 1022 1278 1534 1790 2046 2302 2558 2814 3070 3326 3582 3838 4094
255 255 511 767 1023 1279 1535 1791 2047 2303 2559 2815 3071 3327 3583 3839 4095
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The scrambling tables are generally computed in a spreadsheet 
application. Based on the fact that the columns have a certain 
periodicity associated with them, you need only define the one or two 
columns that form the base of the algorithm and the algorithm itself. 
Once the starting point is determined, you can see that each cell is 
offset by an amount from the cell above it or next to it. You can use the 
computational power of a spreadsheet application to fill in the table. 
After the table is generated using the spreadsheet application, it can be 
exported as a text file (.txt) and pasted into the DUT definition file.

Row Scrambling Table

The table shown in Figure 8-56 contains a partial listing of the 
DestinationX row scrambling. Down the first column on the left are the 
logical row addresses. The numbers across the first row at the top are 
offsets from the logical row addresses. This table is described in a by 8 
fashion, that is, the logical row addresses increment by 8. The logical 
address for a given cell is equal to the value in the first column plus the 
value of the offset in the first row. The corresponding physical address 
appears in the cell. For example:

• Logical row 0 + 2 = 2 maps to physical row 2.

• Logical row 0 + 7 = 7 maps to physical row 7.

• Logical row 176 + 2 = 178 maps to physical row 178.

NOTE Currently the Bitmap Tool DUT definition file requires a carriage 
return before the “DestinationX” row scrambling header. After loading 
a DUT definition file without the carriage return, results in an 
application error and the program terminates without warning.  
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Figure 8-56. Row Scrambling Table

DestinationX 0 1 2 3 4 5 6 7
0 0 1 2 3 4 5 6 7
8 8 9 10 11 12 13 14 15
16 16 17 18 19 20 21 22 23
24 24 25 26 27 28 29 30 31
32 32 33 34 35 36 37 38 39
40 40 41 42 43 44 45 46 47
48 48 49 50 51 52 53 54 55
56 56 57 58 59 60 61 62 63
64 64 65 66 67 68 69 70 71
72 72 73 74 75 76 77 78 79
80 80 81 82 83 84 85 86 87
88 88 89 90 91 92 93 94 95
96 96 97 98 99 100 101 102 103
104 104 105 106 107 108 109 110 111
112 112 113 114 115 116 117 118 119
120 120 121 122 123 124 125 126 127
128 128 129 130 131 132 133 134 135
136 136 137 138 139 140 141 142 143
144 144 145 146 147 148 149 150 151
152 152 153 154 155 156 157 158 159
160 160 161 162 163 164 165 166 167
168 168 169 170 171 172 173 174 175
176 176 177 178 179 180 181 182 183
184 184 185 186 187 188 189 190 191
192 192 193 194 195 196 197 198 199
200 200 201 202 203 204 205 206 207
208 208 209 210 211 212 213 214 215
216 216 217 218 219 220 221 222 223
224 224 225 226 227 228 229 230 231
232 232 233 234 235 236 237 238 239
240 240 241 242 243 244 245 246 247
248 248 249 250 251 252 253 254 255

.

.

.
3848 3848 3849 3850 3851 3852 3853 3854 3855
3856 3856 3857 3858 3859 3860 3861 3862 3863
3864 3864 3865 3866 3867 3868 3869 3870 3871
3872 3872 3873 3874 3875 3876 3877 3878 3879
3880 3880 3881 3882 3883 3884 3885 3886 3887
3888 3888 3889 3890 3891 3892 3893 3894 3895
3896 3896 3897 3898 3899 3900 3901 3902 3903
3904 3904 3905 3906 3907 3908 3909 3910 3911
3912 3912 3913 3914 3915 3916 3917 3918 3919
3920 3920 3921 3922 3923 3924 3925 3926 3927
3928 3928 3929 3930 3931 3932 3933 3934 3935
3936 3936 3937 3938 3939 3940 3941 3942 3943
3944 3944 3945 3946 3947 3948 3949 3950 3951
3952 3952 3953 3954 3955 3956 3957 3958 3959
3960 3960 3961 3962 3963 3964 3965 3966 3967
3968 3968 3969 3970 3971 3972 3973 3974 3975
3976 3976 3977 3978 3979 3980 3981 3982 3983
3984 3984 3985 3986 3987 3988 3989 3990 3991
3992 3992 3993 3994 3995 3996 3997 3998 3999
4000 4000 4001 4002 4003 4004 4005 4006 4007
4008 4008 4009 4010 4011 4012 4013 4014 4015
4016 4016 4017 4018 4019 4020 4021 4022 4023
4024 4024 4025 4026 4027 4028 4029 4030 4031
4032 4032 4033 4034 4035 4036 4037 4038 4039
4040 4040 4041 4042 4043 4044 4045 4046 4047
4048 4048 4049 4050 4051 4052 4053 4054 4055
4056 4056 4057 4058 4059 4060 4061 4062 4063
4064 4064 4065 4066 4067 4068 4069 4070 4071
4072 4072 4073 4074 4075 4076 4077 4078 4079
4080 4080 4081 4082 4083 4084 4085 4086 4087
4088 4088 4089 4090 4091 4092 4093 4094 4095

END REGION

END SCRAMBLING
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The DestinationX row scrambling table could have been designed in a 
number of different ways. It could have been described in by 1 fashion, 
by 2, by 3, and so forth. Anything less than 8 columns would have made 
the table longer with more rows, and anything more than 8 columns 
would have made it wider with more columns and less rows.

Figure 8-57 shows a partial listing of the physical row scrambling table 
if it were by 16. The same mapping still applies:

• Logical row 0 + 2 = 2 maps to physical row 2.

• Logical row 0 + 7 = 7 maps to physical row 7.

• Logical row 176 + 2 = 178 maps to physical row 178.

Figure 8-57. Row Scrambling Table with By 16 Format

Bitmap Tool’s View Pane Display with This DUT Definition File

After loading this DUT definition file and compatible bitmap files, the 
Bitmap Tool’s View pane would display the defined region as shown in 
Figure 8-58 on page 405.

Each I/O has 256 logical and physical address columns. The logical 
column addresses are the same for each I/O (0–255). The physical 
column addresses are unique for each I/O.

Therefore, each I/O has the same logical column and row addressing 
but unique physical addressing. This means that, for a 16-bit data 
word being accessed by the external address lines, a bit would come 
from the same logical address for each I/O but a unique physical 
address. This is illustrated with the logical and physical coordinates of 
the different bits identified in Figure 8-58.

DestinationX 0 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15
0 0 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15
16 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31
32 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47
48 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63
64 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79
80 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95
96 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111
112 112 113 114 115 116 117 118 119 120 121 122 123 124 125 126 127
128 128 129 130 131 132 133 134 135 136 137 138 139 140 141 142 143
144 144 145 146 147 148 149 150 151 152 153 154 155 156 157 158 159
160 160 161 162 163 164 165 166 167 168 169 170 171 172 173 174 175
176 176 177 178 179 180 181 182 183 184 185 186 187 188 189 190 191

.

.

.
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Notice how the Bitmap Tool configures physical column 0 and physical 
row 0 in the top left corner of the display. With physical column 0 in 
IO0, IO0 is the first I/O on the left side of the display. This also means 
that the DUT word least significant bit (LSB) will be on the left side of 
the display, and the DUT word most significant bit (MSB) will be on 
the right side of the display. This could lead to some confusion where 
AAAA16 (1010 1010 1010 10102) could be mistaken for 555516 (0101 
0101 0101 01012) on the View pane display.
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Physical Columns Effect on Bitmap Tool’s View Display

If physical column 0 had been associated with IO15, then IO15 and the 
DUT word MSB would be on the left side of the View pane display, and 
IO0 and the DUT word LSB would be on the right side of the display. 
Figure 8-59 is an example of this device scramble. Figure 8-60 would 
produce the same results as Figure 8-59, but its I/Os are listed across 
the top of the table from io15 to io0 rather than io0 to io15. Figure 8-61 
shows another way of creating the actual column scrambling table 
shown in Figure 8-55 on page 400, but it has io15 to io0 across the top 
rather than io0 to io15.

Figure 8-59. Column Scrambling Table that Configures IO15 on View Pane Left Side

Figure 8-60. Another Column Scrambling Table that Configures IO15 on View Pane Left 
Side

DestinationY io0 io1 io2 io3 io4 io5 io6 io7 io8 io9 io10 io11 io12 io13 io14 io15
0 3840 3584 3328 3072 2816 2560 2304 2048 1792 1536 1280 1024 768 512 256 0
1 3841 3585 3329 3073 2817 2561 2305 2049 1793 1537 1281 1025 769 513 257 1
2 3842 3586 3330 3074 2818 2562 2306 2050 1794 1538 1282 1026 770 514 258 2
3 3843 3587 3331 3075 2819 2563 2307 2051 1795 1539 1283 1027 771 515 259 3
4 3844 3588 3332 3076 2820 2564 2308 2052 1796 1540 1284 1028 772 516 260 4
5 3845 3589 3333 3077 2821 2565 2309 2053 1797 1541 1285 1029 773 517 261 5
6 3846 3590 3334 3078 2822 2566 2310 2054 1798 1542 1286 1030 774 518 262 6
7 3847 3591 3335 3079 2823 2567 2311 2055 1799 1543 1287 1031 775 519 263 7
8 3848 3592 3336 3080 2824 2568 2312 2056 1800 1544 1288 1032 776 520 264 8
9 3849 3593 3337 3081 2825 2569 2313 2057 1801 1545 1289 1033 777 521 265 9
10 3850 3594 3338 3082 2826 2570 2314 2058 1802 1546 1290 1034 778 522 266 10
11 3851 3595 3339 3083 2827 2571 2315 2059 1803 1547 1291 1035 779 523 267 11
12 3852 3596 3340 3084 2828 2572 2316 2060 1804 1548 1292 1036 780 524 268 12

.

.

.

DestinationY io15 io14 io13 io12 io11 io10 io9 io8 io7 io6 io5 io4 io3 io2 io1 io0
0 0 256 512 768 1024 1280 1536 1792 2048 2304 2560 2816 3072 3328 3584 3840
1 1 257 513 769 1025 1281 1537 1793 2049 2305 2561 2817 3073 3329 3585 3841
2 2 258 514 770 1026 1282 1538 1794 2050 2306 2562 2818 3074 3330 3586 3842
3 3 259 515 771 1027 1283 1539 1795 2051 2307 2563 2819 3075 3331 3587 3843
4 4 260 516 772 1028 1284 1540 1796 2052 2308 2564 2820 3076 3332 3588 3844
5 5 261 517 773 1029 1285 1541 1797 2053 2309 2565 2821 3077 3333 3589 3845
6 6 262 518 774 1030 1286 1542 1798 2054 2310 2566 2822 3078 3334 3590 3846
7 7 263 519 775 1031 1287 1543 1799 2055 2311 2567 2823 3079 3335 3591 3847
8 8 264 520 776 1032 1288 1544 1800 2056 2312 2568 2824 3080 3336 3592 3848
9 9 265 521 777 1033 1289 1545 1801 2057 2313 2569 2825 3081 3337 3593 3849
10 10 266 522 778 1034 1290 1546 1802 2058 2314 2570 2826 3082 3338 3594 3850
11 11 267 523 779 1035 1291 1547 1803 2059 2315 2571 2827 3083 3339 3595 3851
12 12 268 524 780 1036 1292 1548 1804 2060 2316 2572 2828 3084 3340 3596 3852

.

.

.

406 Versatest Series IDE User’s Guide

Revision D, May 2005



Chapter 8  Bitmap Tool

Bitmap Tool Getting Started
Figure 8-61. Another Way of Creating the Actual Column Scrambling Table

DestinationY io15 io14 io13 io12 io11 io10 io9 io8 io7 io6 io5 io4 io3 io2 io1 io0
0 3840 3584 3328 3072 2816 2560 2304 2048 1792 1536 1280 1024 768 512 256 0
1 3841 3585 3329 3073 2817 2561 2305 2049 1793 1537 1281 1025 769 513 257 1
2 3842 3586 3330 3074 2818 2562 2306 2050 1794 1538 1282 1026 770 514 258 2
3 3843 3587 3331 3075 2819 2563 2307 2051 1795 1539 1283 1027 771 515 259 3
4 3844 3588 3332 3076 2820 2564 2308 2052 1796 1540 1284 1028 772 516 260 4
5 3845 3589 3333 3077 2821 2565 2309 2053 1797 1541 1285 1029 773 517 261 5
6 3846 3590 3334 3078 2822 2566 2310 2054 1798 1542 1286 1030 774 518 262 6
7 3847 3591 3335 3079 2823 2567 2311 2055 1799 1543 1287 1031 775 519 263 7
8 3848 3592 3336 3080 2824 2568 2312 2056 1800 1544 1288 1032 776 520 264 8
9 3849 3593 3337 3081 2825 2569 2313 2057 1801 1545 1289 1033 777 521 265 9
10 3850 3594 3338 3082 2826 2570 2314 2058 1802 1546 1290 1034 778 522 266 10
11 3851 3595 3339 3083 2827 2571 2315 2059 1803 1547 1291 1035 779 523 267 11
12 3852 3596 3340 3084 2828 2572 2316 2060 1804 1548 1292 1036 780 524 268 12

.

.

.
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Loading a DUT Definition File and Displaying the 
Bitmap Tool Main Window

1 From the V4400 Series Tester Software IDE main window, selecting 
the File > Open > Bitmap Tool DUT Document command or  
toolbar button displays its Open dialog box (similar to Figure 8-62).

Figure 8-62. Load DUT Definition File Open Dialog Box  

2 Selecting a .dut file and then the  button displays the IDE main 
window with the DUT file loaded (Figure 8-63).

Open
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Figure 8-63. Bitmap Tool Main Window with DUT File Loaded  

3 Selecting the View > Navigator Pane command and then the 
View > Output Pane command hides those panes and displays the 
Bitmap Tool main window full-screen (Figure 8-64).
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Figure 8-64. Bitmap Tool Main Window Displaying Full-Screen  

Navigation Pane Menu Bar View Pane Toolbar

Physical Thumbnail Pane

Crosshairs
Logical Thumbnail Pane

Bitmap Navigation Tree Status Bar
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Loading and Viewing Bitmap Files

1 Selecting the Action > Load Bitmap command or  toolbar 
button displays the Load Bitmap File Open dialog box (similar to 
Figure 8-65).

Figure 8-65. Load Bitmap File Open Dialog Box  

2 Selecting the diagonals.HBM file and then  displays the bitmap 
file in the default logical format (Figure 8-66). This bitmap was created 
to display diagonal failures. The passing bits are in black, and the 
failing bits are red.

The Bitmap Tool main window contains the following unique 
functional areas:

• Navigation Pane: Shows the logical and physical coordinates of the 
device layout. It also lists the total number of errors in this bitmap.

• Thumbnail Pane: Shows a thumbnail of the logical and physical 
layouts of the device. The highlighted area in the thumbnail 
indicates the current coverage area you are seeing in the View Pane 
(Figure 8-66). You can view other areas in the bitmap by using the 
scroll bars or clicking on an area in the Thumbnail pane.

Open
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• View Pane: Displays the bitmaps, overlays, and logical operations 
selected in the Bitmap Navigation Tree. The View Pane provides 
scroll bars on the right-hand side and bottom edge when the 
magnification of the bitmap within is set to cause the area of the 
bitmap to be larger than the pane size. By default the coordinate 
crosshairs follow the mouse cursor. You can freeze (lock) or 
unfreeze (unlock) the crosshairs by pressing the  key. You can 
also click and drag over a region in the View pane to zoom in and 
display that region in the View pane and make the corresponding 
display changes in the Navigation and Thumbnail panes.

• Status Bar: Displays the following information:

• Bitmap Type: FLAT for a single bitmap, or OVERLAY, XOR, 
MULTI-LEVEL, and so forth for the logical operations 
displaying.

• View Showing: LOGICAL or PHYSICAL.

• Zoom Factor: The Zoom Factor: 1X shown in the Status Bar 
in Figure 8-66 means every pixel you see represents one pass or 
fail bit.

• Cursor: UNLOCKED or LOCKED

Ctrl
412 Versatest Series IDE User’s Guide

Revision D, May 2005



Chapter 8  Bitmap Tool

Bitmap Tool Getting Started
Figure 8-66. Bitmap File Loaded Displaying Logical Format  

3 Selecting the Action > Load Bitmap command or  toolbar 
button again displays the Load Bitmap File Open dialog box (similar to 
Figure 8-65 on page 411).

4 Loading the checkers.HBM file displays the bitmap as shown in 
Figure 8-67. This bitmap was created to display checkerboard failures.

Navigation Pane Menu Bar View Pane Toolbar

Logical Thumbnail Pane

Crosshairs

Physical Thumbnail Pane

Bitmap
Navigation

Tree

Scroll Bars

displaying location of View Pane

Status Bar

Loaded Bitmap file
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Figure 8-67. Main Window Displaying Second Bitmap File  

Creating an Overlay

An overlay can be created when two or more bitmaps are loaded. This 
allows examination of failure patterns for multiple tests run on the 
same device. Besides plain overlays, multi-level overlays can be 
created for multi-dut mode. This example uses the loaded 
diagonals.HBM and checker.HBM bitmaps to create a simple two 
bitmap overlay.

Logical Thumbnail Pane
displaying location of View Pane

View Pane

Checkers Bitmap
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1 Selecting the Action > Overlay command or  toolbar button 
displays the Overlay Bitmaps dialog box (similar to Figure 8-68).

Figure 8-68. Overlay Bitmaps Dialog Box  

2 Selecting diagonals in the Loaded Bitmaps pane and then the 
 button adds it to the Bitmaps to Overlay pane. Repeating the 

process with the checkers bitmap adds it also to the Bitmaps to 
Overlay pane (similar to Figure 8-68).

3 Typing demo overlay in the Enter Overlay Name text box and 
then selecting  displays the overlay in the main window 
(Figure 8-69). By default, bits where only one bitmap failed are dark 
red. Bits where both bitmaps failed are bright red.

Add

OK
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Figure 8-69. Main Window Displaying Overlay Bitmaps  

demo overlay
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Creating Logical Operations

The Bitmap Tool provides the capability to use logical operations to 
visualize other characteristics of failed and passing bits.

1 Selecting the Logical Operation  button in the toolbar or the 
Action > Logical Operation command displays its dialog box 
(Figure 8-70).

Figure 8-70. Logical Operation Dialog Box  

The available operations are illustrated in Figure 8-71.
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Figure 8-71. Logical Operations  

2 For this example, we will use the AND operation (similar to 
Figure 8-72):

1. Selecting the diagonals and then the checkers bitmap in the 
dialog box highlights the bitmaps for the logical operation.

2. Selecting the AND option button specifies the type of logical 
operation.

INVERT: Inverts pass/fails

AND: Highlights bits that failed on both bitmaps

AND

OR: Highlights bits that failed on at least one bitmap

OR

XOR: Highlights bits that failed on only one bitmap

XOR
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3. Typing demo and in the Enter Bitmap Name text box specifies 
the name that will display in the main window Bitmap Navigation 
Tree.

4. Selecting the  button closes the dialog box and displays the 
logical operation in the main window (Figure 8-73).

Figure 8-72. Logical Operation Dialog Box AND Operation  

OK
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Figure 8-73. Main Window Displaying AND Logical Operation  

demo and Logical Operation
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Selecting Bitmap Error Colors

All bitmaps can be assigned different colors. This procedure will 
change the pass color from black to white for the demo and logical 
operation.

1 Selecting the Action > Set Error Color command or  toolbar 
button displays the Select System Colors tab on the Set Bitmap Colors 
dialog box (Figure 8-74). This tab allows you to set the pass and fail 
colors for the bitmaps. The defaults are black for pass and red for fail. 
The colors can be changed by selecting the corresponding drop-down 
list box to display a color palette from which additional colors can be 
selected or created.

Figure 8-74. Set Bitmap Colors Dialog Box  

2 Selecting the Pass Color drop-down list box displays its color 
palette and selecting the white color box in the palette changes the 
Pass Color to white (Figure 8-75).
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Figure 8-75. Set Bitmap Colors Dialog Box White Passing Bits  

3 Selecting the  button closes the dialog box and changes the 
demo and logical operation to display passing bits in white in the 
main window (Figure 8-76). Compare the white passing bits for the 
demo and logical operation with the black passing bits shown in 
Figure 8-73 on page 420.

OK
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Figure 8-76. Main Window Displaying White Passing Bits  

Logical Thumbnail Pane
displaying location of View Pane

Red Failing Bits

Crosshairs

demo and Logical Operation
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DUT Definition File

This section contains the information you need to create DUT (device 
under test) definition files. To view files with the Bitmap Tool, you 
must first create and load a DUT definition file. The file supplies the 
Bitmap Tool with the information it requires about the memory array’s 
rows, columns, I/Os, and scrambling information. The file is loaded 
from the File > Open > Bitmap Tool DUT Document > DUT 
Definition File Open dialog box.

This section contains the following information:

• “DUT Definition File Limitations” on page 424 lists the current 
requirements that must be followed when creating a DUT 
definition file.

• “Creating a DUT Definition File with Two Regions Example” on 
page 425 describes a two-region DUT definition file and how it 
would display in the Bitmap Tool’s View pane.

• “Creating a DUT Definition File with One Region Example” on 
page 443 illustrates a one-region DUT definition file and how it 
would display in the Bitmap Tool’s View pane.

DUT Definition File Limitations

Currently the Bitmap Tool DUT definition file imposes the following 
limitations:

• Columns, rows, and I/Os must be a power of 2.

• Only one Z address block is currently supported.

• I/Os can be a function only of the Y column address.

• If specified, the number of Z address blocks must be set to 1 
(ZBLOCKS=1).

NOTE Currently the Bitmap Tool DUT definition file requires a carriage 
return before the “DestinationX” row scrambling header. After loading 
a DUT definition file without the carriage return, results in an 
application error and the program terminates without warning.  
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Creating a DUT Definition File with Two Regions 
Example

This section describes a DUT definition file that is broken down into its 
component sections and how to create each section. The entire file is 
shown in Figure 8-77 through Figure 8-81. A DUT definition file must 
be saved as an ASCII text file with a .dut extension.

Structure

The DUT definition file consists of the following sections:

• Header Section

• Pinout Section

• Scrambling Section

Each section is described following the DUT definition file starting 
with the “Header Section” on page 431.
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Figure 8-77. DUT Definition File with Two Regions Example (1 of 5)

BEGIN DUT
DATE=10/12/2002
USER=John Doe
COMPANY=Agilent Technologies
DEVICE=256 Kbit DRAM Example
PROTOCOL=parallel
TECHNOLOGY=DRAM
COLUMNS=512 // Number of physical bit columns.
ROWS=512  // Number of physical rows.
i/oS=8 // Number of i/os.
PINS=28 // Number of pins device has that is

END DUT //  specified in “PINOUT” section.

BEGIN MISC
anything=5 // Field is required but not currently used.

END MISC

BEGIN PINOUT
P1=gnd
P2=CE
P3=R/!W
P4=x0,a0
P5=x1,a1
P6=x2,a2
P7=x3,a3
P8=x4,a4
P9=x5,a5
P10=x6,a6
P11=x7,a7
P12=x8,a8
P13=unused
P14=unused
P15=y0,a9
P16=y1,a10
P17=y2,a11
P18=y3,a12
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Figure 8-78. DUT Definition File with Two Regions Example (2 of 5)

P19=y4,a13
P20=y5,a14
P21=IO0
P22=IO1
P23=IO2
P24=IO3
P25=IO4
P26=IO5
P27=IO6
P28=IO7

END PINOUT

BEGIN SCRAMBLING Logical
BEGIN REGION

MINX=0 // Min physical X
MAXX=511 // Max physical X
MINY=0 // Min physical Y
MAXY=255 // Max physical Y

Destination Y io7 io6 io5 io4 io3 io2 io1 io0
0 31 63 95 127 159 191 223 255
1 30 62 94 126 158 190 222 254
2 29 61 93 125 157 189 221 253
3 28 60 92 124 156 188 220 252
4 27 59 91 123 155 187 219 251
5 26 58 90 122 154 186 218 250
6 25 57 89 121 153 185 217 249
7 24 56 88 120 152 184 216 248
8 23 55 87 119 151 183 215 247
9 22 54 86 118 150 182 214 246
10 21 53 85 117 149 181 213 245
11 20 52 84 116 148 180 212 244
12 19 51 83 115 147 179 211 243
13 18 50 82 114 146 178 210 242
14 17 49 81 113 145 177 209 241
15 16 48 80 112 144 176 208 240
16 15 47 79 111 143 175 207 239
17 14 46 78 110 142 174 206 238
18 13 45 77 109 141 173 205 237
19 12 44 76 108 140 172 204 236
20 11 43 75 107 139 171 203 235
21 10 42 74 106 138 170 202 234
22 9 41 73 105 137 169 201 233
23 8 40 72 104 136 168 200 232
24 7 39 71 103 135 167 199 231
25 6 38 70 102 134 166 198 230
26 5 37 69 101 133 165 197 229
27 4 36 68 100 132 164 196 228
28 3 35 67 99 131 163 195 227
29 2 34 66 98 130 162 194 226
30 1 33 65 97 129 161 193 225
31 0 32 64 96 128 160 192 224

Destination X 0 1 2 3 4 5 6 7
0 511 510 509 508 507 506 505 504
8 503 502 501 500 499 498 497 496
16 495 494 493 492 491 490 489 488
Versatest Series IDE User’s Guide 427

Revision D, May 2005



Chapter 8  Bitmap Tool

DUT Definition File
Figure 8-79. DUT Definition File with Two Regions Example (3 of 5)

24 487 486 485 484 483 482 481 480
32 479 478 477 476 475 474 473 472
40 471 470 469 468 467 466 465 464
48 463 462 461 460 459 458 457 456
56 455 454 453 452 451 450 449 448
64 447 446 445 444 443 442 441 440
72 439 438 437 436 435 434 433 432
80 431 430 429 428 427 426 425 424
88 423 422 421 420 419 418 417 416
96 415 414 413 412 411 410 409 408
104 407 406 405 404 403 402 401 400
112 399 398 397 396 395 394 393 392
120 391 390 389 388 387 386 385 384
128 383 382 381 380 379 378 377 376
136 375 374 373 372 371 370 369 368
144 367 366 365 364 363 362 361 360
152 359 358 357 356 355 354 353 352
160 351 350 349 348 347 346 345 344
168 343 342 341 340 339 338 337 336
176 335 334 333 332 331 330 329 328
184 327 326 325 324 323 322 321 320
192 319 318 317 316 315 314 313 312
200 311 310 309 308 307 306 305 304
208 303 302 301 300 299 298 297 296
216 295 294 293 292 291 290 289 288
224 287 286 285 284 283 282 281 280
232 279 278 277 276 275 274 273 272
240 271 270 269 268 267 266 265 264
248 263 262 261 260 259 258 257 256
256 255 254 253 252 251 250 249 248
264 247 246 245 244 243 242 241 240
272 239 238 237 236 235 234 233 232
280 231 230 229 228 227 226 225 224
288 223 222 221 220 219 218 217 216
296 215 214 213 212 211 210 209 208
304 207 206 205 204 203 202 201 200
312 199 198 197 196 195 194 193 192
320 191 190 189 188 187 186 185 184
328 183 182 181 180 179 178 177 176
336 175 174 173 172 171 170 169 168
344 167 166 165 164 163 162 161 160
352 159 158 157 156 155 154 153 152
360 151 150 149 148 147 146 145 144
368 143 142 141 140 139 138 137 136
376 135 134 133 132 131 130 129 128
384 127 126 125 124 123 122 121 120
392 119 118 117 116 115 114 113 112
400 111 110 109 108 107 106 105 104
408 103 102 101 100 99 98 97 96
416 95 94 93 92 91 90 89 88
424 87 86 85 84 83 82 81 80
432 79 78 77 76 75 74 73 72
440 71 70 69 68 67 66 65 64
448 63 62 61 60 59 58 57 56
456 55 54 53 52 51 50 49 48
464 47 46 45 44 43 42 41 40
472 39 38 37 36 35 34 33 32
480 31 30 29 28 27 26 25 24
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Figure 8-80. DUT Definition File with Two Regions Example (4 of 5)

488 23 22 21 20 19 18 17 16
496 15 14 13 12 11 10 9 8
504 7 6 5 4 3 2 1 0

END REGION

BEGIN REGION
MINX = 0 // min physical X
MAXX = 511 // max physical X
MINY = 256 // min physical Y
MAXY = 511 // max physical Y

DestinationY IO7 IO6 IO5 IO4 IO3 IO2 IO1 IO0
32 480 448 416 384 352 320 288 256
33 481 449 417 385 353 321 289 257
34 482 450 418 386 354 322 290 258
35 483 451 419 387 355 323 291 259
36 484 452 420 388 356 324 292 260
37 485 453 421 389 357 325 293 261
38 486 454 422 390 358 326 294 262
39 487 455 423 391 359 327 295 263
40 488 456 424 392 360 328 296 264
41 489 457 425 393 361 329 297 265
42 490 458 426 394 362 330 298 266
43 491 459 427 395 363 331 299 267
44 492 460 428 396 364 332 300 268
45 493 461 429 397 365 333 301 269
46 494 462 430 398 366 334 302 270
47 495 463 431 399 367 335 303 271
48 496 464 432 400 368 336 304 272
49 497 465 433 401 369 337 305 273
50 498 466 434 402 370 338 306 274
51 499 467 435 403 371 339 307 275
52 500 468 436 404 372 340 308 276
53 501 469 437 405 373 341 309 277
54 502 470 438 406 374 342 310 278
55 503 471 439 407 375 343 311 279
56 504 472 440 408 376 344 312 280
57 505 473 441 409 377 345 313 281
58 506 474 442 410 378 346 314 282
59 507 475 443 411 379 347 315 283
60 508 476 444 412 380 348 316 284
61 509 477 445 413 381 349 317 285
62 510 478 446 414 382 350 318 286
63 511 479 447 415 383 351 319 287

DestinationX 0 1 2 3 4 5 6 7
0 511 510 509 508 507 506 505 504
8 503 502 501 500 499 498 497 496
16 495 494 493 492 491 490 489 488
24 487 486 485 484 483 482 481 480
32 479 478 477 476 475 474 473 472
40 471 470 469 468 467 466 465 464
48 463 462 461 460 459 458 457 456
56 455 454 453 452 451 450 449 448
64 447 446 445 444 443 442 441 440
72 439 438 437 436 435 434 433 432
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Figure 8-81. DUT Definition File with Two Regions Example (5 of 5)

80 431 430 429 428 427 426 425 424
88 423 422 421 420 419 418 417 416
96 415 414 413 412 411 410 409 408
104 407 406 405 404 403 402 401 400
112 399 398 397 396 395 394 393 392
120 391 390 389 388 387 386 385 384
128 383 382 381 380 379 378 377 376
136 375 374 373 372 371 370 369 368
144 367 366 365 364 363 362 361 360
152 359 358 357 356 355 354 353 352
160 351 350 349 348 347 346 345 344
168 343 342 341 340 339 338 337 336
176 335 334 333 332 331 330 329 328
184 327 326 325 324 323 322 321 320
192 319 318 317 316 315 314 313 312
200 311 310 309 308 307 306 305 304
208 303 302 301 300 299 298 297 296
216 295 294 293 292 291 290 289 288
224 287 286 285 284 283 282 281 280
232 279 278 277 276 275 274 273 272
240 271 270 269 268 267 266 265 264
248 263 262 261 260 259 258 257 256
256 255 254 253 252 251 250 249 248
264 247 246 245 244 243 242 241 240
272 239 238 237 236 235 234 233 232
280 231 230 229 228 227 226 225 224
288 223 222 221 220 219 218 217 216
296 215 214 213 212 211 210 209 208
304 207 206 205 204 203 202 201 200
312 199 198 197 196 195 194 193 192
320 191 190 189 188 187 186 185 184
328 183 182 181 180 179 178 177 176
336 175 174 173 172 171 170 169 168
344 167 166 165 164 163 162 161 160
352 159 158 157 156 155 154 153 152
360 151 150 149 148 147 146 145 144
368 143 142 141 140 139 138 137 136
376 135 134 133 132 131 130 129 128
384 127 126 125 124 123 122 121 120
392 119 118 117 116 115 114 113 112
400 111 110 109 108 107 106 105 104
408 103 102 101 100 99 98 97 96
416 95 94 93 92 91 90 89 88
424 87 86 85 84 83 82 81 80
432 79 78 77 76 75 74 73 72
440 71 70 69 68 67 66 65 64
448 63 62 61 60 59 58 57 56
456 55 54 53 52 51 50 49 48
464 47 46 45 44 43 42 41 40
472 39 38 37 36 35 34 33 32
480 31 30 29 28 27 26 25 24
488 23 22 21 20 19 18 17 16
496 15 14 13 12 11 10 9 8
504 7 6 5 4 3 2 1 0

END REGION
END SCRAMBLING
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Header Section

The file begins with header information (Figure 8-82). This includes 
the creation date, user's name, company name, device name, protocol, 
technology, number of columns, number of rows, number of I/Os, and 
number of package pins.

Figure 8-82. Version 1.0 Header Section

The DATE, USER, COMPANY, DEVICE, PROTOCOL and 
TECHNOLOGY fields can be completed with entries of your choice.

The number of COLUMNS is determined by the number of physical bit 
columns in the device. It is the same as the maximum number of 
physical columns (+1) in the DestinationY column scrambling section 
(511 + 1).

The number of ROWS is the number of physical rows in the device. It is 
the same as the maximum number of physical rows (+1) in the 
DestinationX row scrambling section (511 + 1).

The number of PINS you specify must match the maximum number 
defined in the Pinout section. Typically this is the total number of pins.

Pinout Section

After the header and miscellaneous sections is the DUT definition 
itself. This includes the pinout and scrambling tables. Every pin on the 
device must be named, even if it is not connect (NC).

Use the following rules when assigning names to the pins on the device 
(Figure 8-83):

• The names of the data and address pins are predetermined to be 
IOn, Xn, and Yn, respectively.

BEGIN DUT
DATE=10/12/2002
USER=John Doe
COMPANY=Agilent Technologies
DEVICE=256 Kbit DRAM Example
PROTOCOL=parallel
TECHNOLOGY=DRAM
COLUMNS=512 // Number of physical bit columns.
ROWS=512  // Number of physical rows.
i/oS=8 // Number of i/os.
PINS=28 // Number of pins device has that is

END DUT //  specified in “PINOUT” section.

BEGIN MISC
anything=5 // Field is required but not currently used.

END MISC
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• The clocks can be assigned any name which is not of the data or 
address name format.

• Data pins that are used for control instead of data may be given a 
non-data name.

• The same logic applies to the addresses. In other words, only pins 
called IOn are assumed to be true data pins, and only pins called 
Xn or Yn are assumed to be address pins.

Figure 8-83. DUT File Pinout Section

Scrambling Section

This scrambling table can be thought of as converting from logical 
(source) to physical format (destination) as illustrated for this example 
in Figure 8-84. Address bits A0–A8 are fed to an X row decoder that 
controls row select lines X0–X8. Address bits A9–A14 are fed to a Y 
column decoder that controls column select lines Y0–Y5. The physical 
configuration of the device determines the X row and Y column 
scrambling.

BEGIN PINOUT
P1=gnd
P2=CE
P3=R/!W
P4=x0,a0
P5=x1,a1
P6=x2,a2
P7=x3,a3
P8=x4,a4
P9=x5,a5
P10=x6,a6
P11=x7,a7
P12=x8,a8
P13=unused
P14=unused
P15=y0,a9
P16=y1,a10
P17=y2,a11
P18=y3,a12
P19=y4,a13
P20=y5,a14
P21=IO0
P22=IO1
P23=IO2
P24=IO3
P25=IO4
P26=IO5
P27=IO6
P28=IO7

END PINOUT
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Figure 8-84. Logical to Physical Format

The scrambling section in the DUT definition file is defined in terms of 
rectangular regions, each of which has its own two sub-tables: 
DestinationY and DestinationX. One table is for the columns 
(DestinationY), and the other is for the rows (DestinationX). Devices 
that have more than one mapping of logical to physical addresses 
require scrambling tables with multiple regions so BitMapView can 
correctly display their bitmaps.

This example has two regions. See “Creating a DUT Definition File 
with One Region Example” on page 443 for an example with one 
region. The column scrambling tables of Region 1 and 2 are mirror 
images of each other. The Region 1 physical columns decrement from 
IO0 to IO7 (255–0), and the Region 2 physical columns increment from 
IO0 to IO7 (256–511).

The number of logical columns (for both regions A9–A14 [Y0–Y5] = 26 = 
64) times the I/Os per DUT word (IO0–IO7 = 8) times the number of 
rows (A0–A8 [X0–X8] = 29 = 512) should be equal to the total number of 
bits in the device (256 Kbits). (Note that each I/O in both regions has 
32 logical and physical columns.) The equivalent is the total number of 
physical columns (256 + 256 = 512) times the number of physical rows 
(512) for the total number of bits (256 Kbits).

Region 1 Scrambling Table Definition

The first region is defined below in Figure 8-85, and the second region 
is defined in Figure 8-90 on page 439. A contiguous physical region of 
the device is specified. Each region needs a min X, max X, min Y, and 
max Y value. This information should be the same as that found in the 
scrambling table itself.
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Figure 8-85. Region 1 Max and Min Values

Region 1 Column Scrambling Table

The DestinationY column scrambling table for region 1 is shown in 
Figure 8-86. Across the top of the table are the headers for the I/O pins 
(io7–io0). Down the first column on the left side are the logical columns 
(0–31). On the right for each logical address and I/O pair is the 
corresponding physical column address. For example:

• Logical address 0 and io0 map to physical column 255.

• Logical address 0 and io4 map to physical column 127.

• Logical address 7 and io0 map to physical column 248.

• Logical address 6 and io7 map to physical column 25.

• Logical address 10 and io4 map to physical column 117.

BEGIN SCRAMBLING Logical
BEGIN REGION

MINX=0 // Min physical X
MAXX=511 // Max physical X
MINY=0 // Min physical Y
MAXY=255 // Max physical Y
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Figure 8-86. Region 1 Column Scrambling Table

The scrambling tables are generally computed in a spreadsheet 
application. Based on the fact that the columns have a certain 
periodicity associated with them, you need only define the one or two 
columns that form the base of the algorithm and the algorithm itself. 
Once the starting point is determined, you can see that each cell is 
offset by an amount from the cell above it or next to it. You can use the 
computational power of a spreadsheet application to fill in the table. 
After the table is generated using the spreadsheet application, it can be 
exported as a text file (.txt) and pasted into the DUT definition file.

Region 1 Row Scrambling Table

The table shown in Figure 8-87 and Figure 8-88 contains the 
DestinationX row scrambling. Down the first column on the left are the 
logical row addresses. The numbers across the first row at the top are 
offsets from the logical row addresses. The table is described in a by 8 

Destination Y io7 io6 io5 io4 io3 io2 io1 io0
0 31 63 95 127 159 191 223 255
1 30 62 94 126 158 190 222 254
2 29 61 93 125 157 189 221 253
3 28 60 92 124 156 188 220 252
4 27 59 91 123 155 187 219 251
5 26 58 90 122 154 186 218 250
6 25 57 89 121 153 185 217 249
7 24 56 88 120 152 184 216 248
8 23 55 87 119 151 183 215 247
9 22 54 86 118 150 182 214 246
10 21 53 85 117 149 181 213 245
11 20 52 84 116 148 180 212 244
12 19 51 83 115 147 179 211 243
13 18 50 82 114 146 178 210 242
14 17 49 81 113 145 177 209 241
15 16 48 80 112 144 176 208 240
16 15 47 79 111 143 175 207 239
17 14 46 78 110 142 174 206 238
18 13 45 77 109 141 173 205 237
19 12 44 76 108 140 172 204 236
20 11 43 75 107 139 171 203 235
21 10 42 74 106 138 170 202 234
22 9 41 73 105 137 169 201 233
23 8 40 72 104 136 168 200 232
24 7 39 71 103 135 167 199 231
25 6 38 70 102 134 166 198 230
26 5 37 69 101 133 165 197 229
27 4 36 68 100 132 164 196 228
28 3 35 67 99 131 163 195 227
29 2 34 66 98 130 162 194 226
30 1 33 65 97 129 161 193 225
31 0 32 64 96 128 160 192 224
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fashion, that is, the logical row addresses increment by 8. The logical 
address for a given cell is equal to the value in the first column plus the 
value of the offset in the first row. The corresponding physical address 
appears in the cell. For example:

• Logical row 0 + 2 = 2 maps to physical row 509.

• Logical row 0 + 7 = 7 maps to physical row 504.

• Logical row 176 + 2 = 178 maps to physical row 333.

Figure 8-87. Region 1 Row Scrambling Table (1 of 2)

Destination X 0 1 2 3 4 5 6 7
0 511 510 509 508 507 506 505 504
8 503 502 501 500 499 498 497 496
16 495 494 493 492 491 490 489 488
24 487 486 485 484 483 482 481 480
32 479 478 477 476 475 474 473 472
40 471 470 469 468 467 466 465 464
48 463 462 461 460 459 458 457 456
56 455 454 453 452 451 450 449 448
64 447 446 445 444 443 442 441 440
72 439 438 437 436 435 434 433 432
80 431 430 429 428 427 426 425 424
88 423 422 421 420 419 418 417 416
96 415 414 413 412 411 410 409 408
104 407 406 405 404 403 402 401 400
112 399 398 397 396 395 394 393 392
120 391 390 389 388 387 386 385 384
128 383 382 381 380 379 378 377 376
136 375 374 373 372 371 370 369 368
144 367 366 365 364 363 362 361 360
152 359 358 357 356 355 354 353 352
160 351 350 349 348 347 346 345 344
168 343 342 341 340 339 338 337 336
176 335 334 333 332 331 330 329 328
184 327 326 325 324 323 322 321 320
192 319 318 317 316 315 314 313 312
200 311 310 309 308 307 306 305 304
208 303 302 301 300 299 298 297 296
216 295 294 293 292 291 290 289 288
224 287 286 285 284 283 282 281 280
232 279 278 277 276 275 274 273 272
240 271 270 269 268 267 266 265 264
248 263 262 261 260 259 258 257 256
256 255 254 253 252 251 250 249 248
264 247 246 245 244 243 242 241 240
272 239 238 237 236 235 234 233 232
280 231 230 229 228 227 226 225 224
288 223 222 221 220 219 218 217 216
296 215 214 213 212 211 210 209 208
304 207 206 205 204 203 202 201 200
312 199 198 197 196 195 194 193 192
320 191 190 189 188 187 186 185 184
328 183 182 181 180 179 178 177 176
336 175 174 173 172 171 170 169 168
344 167 166 165 164 163 162 161 160
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Figure 8-88. Region 1 Row Scrambling Table (2 of 2)

The DestinationX row scrambling table could have been designed in a 
number of different ways. It could have been described in by 1 fashion, 
by 2, by 3, and so forth. Anything less than 8 columns would have made 
the table longer with more rows, and anything more than 8 columns 
would have made it wider with more columns and less rows.

Figure 8-89 shows a partial listing of the physical row scrambling table 
if it were by 16. The same mapping still applies:

• Logical row 0 + 2 = 2 maps to physical row 509.

• Logical row 0 + 7 = 7 maps to physical row 504.

• Logical row 176 + 2 = 178 maps to physical row 333.

Figure 8-89. Row Scrambling Table with By 16 Format

352 159 158 157 156 155 154 153 152
360 151 150 149 148 147 146 145 144
368 143 142 141 140 139 138 137 136
376 135 134 133 132 131 130 129 128
384 127 126 125 124 123 122 121 120
392 119 118 117 116 115 114 113 112
400 111 110 109 108 107 106 105 104
408 103 102 101 100 99 98 97 96
416 95 94 93 92 91 90 89 88
424 87 86 85 84 83 82 81 80
432 79 78 77 76 75 74 73 72
440 71 70 69 68 67 66 65 64
448 63 62 61 60 59 58 57 56
456 55 54 53 52 51 50 49 48
464 47 46 45 44 43 42 41 40
472 39 38 37 36 35 34 33 32
480 31 30 29 28 27 26 25 24
488 23 22 21 20 19 18 17 16
496 15 14 13 12 11 10 9 8
504 7 6 5 4 3 2 1 0

END REGION

DestinationX 0 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15
0 511 510 509 508 507 506 505 504 503 502 501 500 499 498 497 496
16 495 494 493 492 491 490 489 488 487 486 485 484 483 482 481 480
32 479 478 477 476 475 474 473 472 471 470 469 468 467 466 465 464
48 463 462 461 460 459 458 457 456 455 454 453 452 451 450 449 448
64 447 446 445 444 443 442 441 440 439 438 437 436 435 434 433 432
80 431 430 429 428 427 426 425 424 423 422 421 420 419 418 417 416
96 415 414 413 412 411 410 409 408 407 406 405 404 403 402 401 400
112 399 398 397 396 395 394 393 392 391 390 389 388 387 386 385 384
128 383 382 381 380 379 378 377 376 375 374 373 372 371 370 369 368
144 367 366 365 364 363 362 361 360 359 358 357 356 355 354 353 352
160 351 350 349 348 347 346 345 344 343 342 341 340 339 338 337 336
176 335 334 333 332 331 330 329 328 327 326 325 324 323 322 321 320
...
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Region 2 Scrambling Section

Figure 8-90 and Figure 8-91 show the second region within the device. 
Again, the main reason for having multiple regions is to correctly 
display devices that have more than one mapping of logical to physical 
addresses. Two regions may have duplicate physical x addresses, but it 
is not possible to have duplicate physical y addresses in multiple 
regions. The column address mapping of region 2 is essentially a 
mirror image of region 1 for the second 128 Kbits.

NOTE Currently the Bitmap Tool DUT definition file requires a carriage 
return before the “DestinationX” row scrambling header. After loading 
a DUT definition file without the carriage return, results in an 
application error and the program terminates without warning.  
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Figure 8-90. Region 2 Scrambling Section (1 of 2)

BEGIN REGION
MINX = 0
MAXX = 511
MINY = 256
MAXY = 511

DestinationY IO7 IO6 IO5 IO4 IO3 IO2 IO1 IO0
32 480 448 416 384 352 320 288 256
33 481 449 417 385 353 321 289 257
34 482 450 418 386 354 322 290 258
35 483 451 419 387 355 323 291 259
36 484 452 420 388 356 324 292 260
37 485 453 421 389 357 325 293 261
38 486 454 422 390 358 326 294 262
39 487 455 423 391 359 327 295 263
40 488 456 424 392 360 328 296 264
41 489 457 425 393 361 329 297 265
42 490 458 426 394 362 330 298 266
43 491 459 427 395 363 331 299 267
44 492 460 428 396 364 332 300 268
45 493 461 429 397 365 333 301 269
46 494 462 430 398 366 334 302 270
47 495 463 431 399 367 335 303 271
48 496 464 432 400 368 336 304 272
49 497 465 433 401 369 337 305 273
50 498 466 434 402 370 338 306 274
51 499 467 435 403 371 339 307 275
52 500 468 436 404 372 340 308 276
53 501 469 437 405 373 341 309 277
54 502 470 438 406 374 342 310 278
55 503 471 439 407 375 343 311 279
56 504 472 440 408 376 344 312 280
57 505 473 441 409 377 345 313 281
58 506 474 442 410 378 346 314 282
59 507 475 443 411 379 347 315 283
60 508 476 444 412 380 348 316 284
61 509 477 445 413 381 349 317 285
62 510 478 446 414 382 350 318 286
63 511 479 447 415 383 351 319 287

DestinationX 0 1 2 3 4 5 6 7
0 511 510 509 508 507 506 505 504
8 503 502 501 500 499 498 497 496
16 495 494 493 492 491 490 489 488
24 487 486 485 484 483 482 481 480
32 479 478 477 476 475 474 473 472
40 471 470 469 468 467 466 465 464
48 463 462 461 460 459 458 457 456
56 455 454 453 452 451 450 449 448
64 447 446 445 444 443 442 441 440
72 439 438 437 436 435 434 433 432
80 431 430 429 428 427 426 425 424
88 423 422 421 420 419 418 417 416
96 415 414 413 412 411 410 409 408
104 407 406 405 404 403 402 401 400
112 399 398 397 396 395 394 393 392
120 391 390 389 388 387 386 385 384
128 383 382 381 380 379 378 377 376
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Figure 8-91. Region 2 Scrambling Section (2 of 2)

View Pane Display with This DUT Definition File

After loading this DUT definition file and compatible bitmap files, the 
Bitmap Tool’s View pane would display regions 1 and 2 of the bitmaps 
side by side. Figure 8-92 and Figure 8-93 illustrate the format how 
each region would display in the physical format.

136 375 374 373 372 371 370 369 368
144 367 366 365 364 363 362 361 360
152 359 358 357 356 355 354 353 352
160 351 350 349 348 347 346 345 344
168 343 342 341 340 339 338 337 336
176 335 334 333 332 331 330 329 328
184 327 326 325 324 323 322 321 320
192 319 318 317 316 315 314 313 312
200 311 310 309 308 307 306 305 304
208 303 302 301 300 299 298 297 296
216 295 294 293 292 291 290 289 288
224 287 286 285 284 283 282 281 280
232 279 278 277 276 275 274 273 272
240 271 270 269 268 267 266 265 264
248 263 262 261 260 259 258 257 256
256 255 254 253 252 251 250 249 248
264 247 246 245 244 243 242 241 240
272 239 238 237 236 235 234 233 232
280 231 230 229 228 227 226 225 224
288 223 222 221 220 219 218 217 216
296 215 214 213 212 211 210 209 208
304 207 206 205 204 203 202 201 200
312 199 198 197 196 195 194 193 192
320 191 190 189 188 187 186 185 184
328 183 182 181 180 179 178 177 176
336 175 174 173 172 171 170 169 168
344 167 166 165 164 163 162 161 160
352 159 158 157 156 155 154 153 152
360 151 150 149 148 147 146 145 144
368 143 142 141 140 139 138 137 136
376 135 134 133 132 131 130 129 128
384 127 126 125 124 123 122 121 120
392 119 118 117 116 115 114 113 112
400 111 110 109 108 107 106 105 104
408 103 102 101 100 99 98 97 96
416 95 94 93 92 91 90 89 88
424 87 86 85 84 83 82 81 80
432 79 78 77 76 75 74 73 72
440 71 70 69 68 67 66 65 64
448 63 62 61 60 59 58 57 56
456 55 54 53 52 51 50 49 48
464 47 46 45 44 43 42 41 40
472 39 38 37 36 35 34 33 32
480 31 30 29 28 27 26 25 24
488 23 22 21 20 19 18 17 16
496 15 14 13 12 11 10 9 8
504 7 6 5 4 3 2 1 0

END REGION
END SCRAMBLING
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Each I/O in both regions has 32 logical and physical address columns. 
The logical column addresses are the same for the I/Os in their 
respective regions (Region 1: 31–0, Region 2: 32–63). The physical 
column addresses are unique for each I/O. The I/Os in both regions 
have the same logical and physical row addresses. This is consistent 
with both regions having the same row scrambling table.

Therefore, each region has the same logical column and row addressing 
for each I/O but unique physical addressing. This means that, for an 8-
bit data word being accessed by the external address lines, a bit would 
come from the same logical address for each I/O but a unique physical 
address. This is illustrated with the logical and physical coordinates of 
the different bits identified in Figure 8-92 and Figure 8-93.

Figure 8-92. Region 1 Display in View Pane
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Region 1 Display in View Pane
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Figure 8-93. Region 2 Display in View Pane
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Creating a DUT Definition File with One Region 
Example

Figure 8-94 and Figure 8-95 display an example of a DUT definition 
file with one region. Figure 8-96 illustrates the format how compatible 
bitmaps would display in the Bitmap Tool’s View pane with this DUT 
definition file in the physical format. Figure 8-97 shows an alternate 
way of laying out the column and row scrambling tables that would 
achieve the same results. The alternate DestinationY column 
scrambling table displays the I/Os across the top from io0 to io7 rather 
than io7 to io0. The alternate DestinationX row scrambling table shows 
the equivalent table in a by 4 format.

Figure 8-94. DUT Definition File with One Region Example (1 of 2)

BEGIN DUT
DATE=10/12/2002
USER=John Doe
COMPANY=Agilent Technologies
DEVICE=1 KByte Example
PROTOCOL=parallel
TECHNOLOGY=FLASH
COLUMNS=64 // number of physical bit columns.
ROWS=128 // number of physical rows.
i/oS=8 // number os i/os. 
PINS=18 // The max number found in the

//  “PINOUT” section.
END DUT

BEGIN MISC
anything=5 // Field is required but not currently used.

END MISC

BEGIN PINOUT
P1=y0,a7
P2=y1,a8
P3=y2,a9
P4=x0,a0
P5=x1,a1
P6=x2,a2
P7=x3,a3
P8=x4,a4
P9=x5,a5
P10=x6,a6
P11=IO0
P12=IO1
P13=IO2
P14=IO3
P15=IO4
P16=IO5
P17=IO6
P18=IO7

END PINOUT
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Figure 8-95. DUT Definition File with One Region Example (2 of 2)

NOTE Currently the Bitmap Tool DUT definition file requires a carriage 
return before the “DestinationX” row scrambling header. After loading 
a DUT definition file without the carriage return, results in an 
application error and the program terminates without warning.  

BEGIN SCRAMBLING Logical
BEGIN REGION 

MINX=0 // min physical X
MAXX=127 // max physical X
MINY=0 // min physical Y
MAXY=63 // max physical Y

DestinationY io7 io6 io5 io4 io3 io2 io1 io0
0 56 48 40 32 24 16 8 0
1 57 49 41 33 25 17 9 1
2 58 50 42 34 26 18 10 2
3 59 51 43 35 27 19 11 3
4 60 52 44 36 28 20 12 4
5 61 53 45 37 29 21 13 5
6 62 54 46 38 30 22 14 6
7 63 55 47 39 31 23 15 7

DestinationX 0 1 2 3 4 5 6 7
0 0 1 2 3 4 5 6 7
8 8 9 10 11 12 13 14 15
16 16 17 18 19 20 21 22 23
24 24 25 26 27 28 29 30 31
32 32 33 34 35 36 37 38 39
40 40 41 42 43 44 45 46 47
48 48 49 50 51 52 53 54 55
56 56 57 58 59 60 61 62 63
64 64 65 66 67 68 69 70 71
72 72 73 74 75 76 77 78 79
80 80 81 82 83 84 85 86 87
88 88 89 90 91 92 93 94 95
96 96 97 98 99 100 101 102 103
104 104 105 106 107 108 109 110 111
112 112 113 114 115 116 117 118 119
120 120 121 122 123 124 125 126 127

END REGION
END SCRAMBLING
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Figure 8-96. View Pane Display for DUT Definition File with One Region Example
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Physical X, Y = 0, 0
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Physical X, Y = 0, 63
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Logical X, Y = 0, 7

Physical X, Y = 127, 0
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Physical X, Y = 127, 31
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1024 Kbits
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Figure 8-97. Alternate Example Column and Row Scrambling Tables

DestinationY io0 io1 io2 io3 io4 io5 io6 io7
0 0 8 16 24 32 40 48 56
1 1 9 17 25 33 41 49 57
2 2 10 18 26 34 42 50 58
3 3 11 19 27 35 43 51 59
4 4 12 20 28 36 44 52 60
5 5 13 21 29 37 45 53 61
6 6 14 22 30 38 46 54 62
7 7 15 23 31 39 47 55 63

DestinationX 0 1 2 3
0 0 1 2 3
4 4 5 6 7
8 8 9 10 11
12 12 13 14 15
16 16 17 18 19
20 20 21 22 23
24 24 25 26 27
28 28 29 30 31
32 32 33 34 35
36 36 37 38 39
40 40 41 42 43
44 44 45 46 47
48 48 49 50 51
52 52 53 54 55
56 56 57 58 59
60 60 61 62 63
64 64 65 66 67
68 68 69 70 71
72 72 73 74 75
76 76 77 78 79
80 80 81 82 83
84 84 85 86 87
88 88 89 90 91
92 92 93 94 95
96 96 97 98 99
100 100 101 102 103
104 104 105 106 107
108 108 109 110 111
112 112 113 114 115
116 116 117 118 119
120 120 121 122 123
124 124 125 126 127
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A
Abort Acquire command (Tester menu, 

Bitmap Tool), 369
Abort Acquire command (Tester menu, C 

Debugger), 103
Abort Acquire command (Tester menu, 

Pattern Tool), 170
Abort Acquire command (Tester menu, 

Pin Tool), 51
Abort Acquire command (Tester menu, 

Timing Tool), 317
Abort Acquire command (Tester menu, 

Waveform Tool), 235
Abort command (Capture menu, 

Waveform Tool), 239
About V4400 Software command (Help 

menu, Bitmap Tool), 380
About V4400 Software command (Help 

menu, C Debugger), 112
About V4400 Software command (Help 

menu, Pattern Tool), 176
About V4400 Software command (Help 

menu, Waveform Tool), 241
About Versatest Integrated Development 

Environment command (Help menu, 
Pin Tool), 53

About Versatest Integrated Development 
Environment command (Help menu, 
Timing Tool), 321

Acquire Data command (Tester menu, 
Bitmap Tool), 369

Acquire Data command (Tester menu, C 
Debugger), 103

Acquire Data command (Tester menu, 
Pattern Tool), 170

Acquire Data command (Tester menu, 
Pin Tool), 51

Acquire Data command (Tester menu, 
Timing Tool), 316

Acquire Data command (Tester menu, 
Waveform Tool), 235

Action menu (Bitmap Tool)
Jump to Location command, 375
Load Bitmap command, 371
Logical Operation command, 372
Overlay command, 374
Set Error Color command, 376

Add Files to Test Program command 
(Program menu, Bitmap Tool), 370

Add Files to Test Program command 
(Program menu, C Debugger), 104

Add Files to Test Program command 
(Program menu, Pattern Tool), 171

Add Files to Test Program command 
(Program menu, Waveform Tool), 236

APG register field, Waveform Setup 
Window (Waveform Tool), 245

Append Mode command (View menu, 
Waveform Tool), 231

Apply Changes command (Tester menu, 
Bitmap Tool), 369

Apply Changes command (Tester menu, C 
Debugger), 103

Apply Changes command (Tester menu, 
Pattern Tool), 170

Apply Changes command (Tester menu, 
Pin Tool), 51

Apply Changes command (Tester menu, 
Timing Tool), 317

Apply Changes command (Tester menu, 
Waveform Tool), 235

Argument command (Debug menu, C 
Debugger), 110

assigning pins to tester resources on the 
Pin Mapping tab, Pin Tool, 61

Attach to Test Program command (File 
menu, C Debugger), 87

Auto Scale command (View menu, 
Waveform Tool), 229

B
bitmap error colors, selecting (Bitmap 

Tool), 421
Bitmap Navigation Pane, Bitmap Tool 

main window, 381
Bitmap Navigation Tree, Bitmap Tool 

main window, 381
Bitmap Tool

C language commands, 348
creating a DUT definition file with one 

region example, 443
creating a DUT definition file with two 

regions example, 425
creating an overlay, 414
creating logical operations, 417
DUT definition files, 424
Getting Started, 382
Introduction, 342
loading a DUT definition file and 

displaying the Bitmap Tool main 
window, 408

loading and viewing bitmap files, 411
logical operations, description, 346
Menu bar, 350
plan file switches, 348
selecting bitmap error colors, 421
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Bitmap Tool DUT definition file
example, 383

Bitmap Tool DUT definition files, 424
creating a DUT definition file with one 

region example, 443
creating a DUT definition file with two 

regions example, 425
Bitmap Tool DUT Document command 

(New command submenu, Bitmap 
Tool), 353

Bitmap Tool DUT Document command 
(New command submenu, C 
Debugger), 83

Bitmap Tool DUT Document command 
(New command submenu, Pattern 
Tool), 142

Bitmap Tool DUT Document command 
(New command submenu, Waveform 
Tool), 216

Bitmap Tool DUT Document command 
(Open command submenu, Bitmap 
Tool), 356

Bitmap Tool DUT Document command 
(Open command submenu, C 
Debugger), 85

Bitmap Tool DUT Document command 
(Open command submenu, Pattern 
Tool), 145

Bitmap Tool DUT Document command 
(Open command submenu, Pin Tool), 41

Bitmap Tool DUT Document command 
(Open command submenu, Timing 
Tool), 298

Bitmap Tool DUT Document command 
(Open command submenu, Waveform 
Tool), 219

Bitmap Tool Getting Started, 382
creating a DUT definition file, 383
creating an overlay, 414
creating logical operations, 417
Getting Started contents, 382
loading a DUT definition file and 

displaying the Bitmap Tool main 
window, 408

loading and viewing bitmap files, 411
logical operations, creating, 417
selecting bitmap error colors, 421

Bitmap Tool main window, 349
Bitmap Navigation Pane, 381
Bitmap Navigation Tree, 381
displaying, 349
Thumbnail pane, 381
View pane, 380

Bitmap Tool main window, 
displaying, 408

Bitmap Tool overview, 343

BitmapTool Options command (Options 
command submenu, Bitmap Tool), 366

BitmapTool Properties command 
(Properties command submenu, Bitmap 
Tool), 367

Break Point command (View menu, C 
Debugger), 98

break points, setting for C Program 
Debugger, 124

Breakpoint, Insert/Remove command 
(Debug menu, C Debugger), 108

Build command (Build menu, Bitmap 
Tool), 370

Build command (Build menu, C 
Debugger), 105

Build command (Build menu, Pattern 
Tool), 171

Build command (Build menu, Waveform 
Tool), 237

Build menu (Bitmap Tool), 370
Build command, 370
Clean Build command, 371
Compile C Sources command, 371
Compile Patterns command, 370
Rebuild All command, 371
Stop Build command, 371

Build menu (C Debugger)
Build command, 105
Clean Build command, 105
Compile C Sources command, 105
Compile command, 105
Compile Patterns command, 105
Rebuild All command, 105
Stop Build command, 105

Build menu (Pattern Tool), 171
Build command, 171
Clean Build command, 172
Compile C Sources command, 172
Compile Patterns command, 171
Rebuild All command, 172
Stop Build command, 172

Build menu (Waveform Tool), 236
Build command, 237
Clean Build command, 237
Compile C Sources command, 237
Compile command, 237
Compile Patterns command, 237
Rebuild All command, 237
Stop Build command, 237

C
C Debugger Document command (New 

command submenu, Bitmap Tool), 353
C Debugger Document command (New 

command submenu, C Debugger), 82
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C Debugger Document command (New 
command submenu, Pattern Tool), 142

C Debugger Document command (New 
command submenu, Waveform 
Tool), 216

C Debugger Document command (Open 
command submenu, Bitmap Tool), 355

C Debugger Document command (Open 
command submenu, C Debugger), 84

C Debugger Document command (Open 
command submenu, Pattern Tool), 144

C Debugger Document command (Open 
command submenu, Waveform 
Tool), 218

C language commands, Bitmap Tool, 348
C Program Debugger

General Variables Watcher Pane, 97
Getting Started, 114
launching a program, 126
launching the C Program Debugger 

application, 118
launching the test program, 126
loading the test program on the 

system, 114
Local Variables Pane, 96
Memory Pane, 97
setting break points, 124
single stepping, 127
Source Code Browser Pane, 111
Stack Pane, 98
test program, loading on the 

system, 114
C Program Debugger Getting 

Started, 114
displaying the C Program Debugger 

main window, 118
Getting Started contents, 114
launching the test program, 126
loading a test program on the 

system, 114
setting break points, 124
single stepping, 127

C Program Debugger main window, 78
menu bar, 79
toolbar, 92

Capture menu (Waveform Tool), 239
Abort command, 239
Start command, 239

Capture Mode field, Waveform Setup 
Window (Waveform Tool), 252

Capture Mode Tooltip command (View 
menu, Waveform Tool), 230

Capture Setting field, Waveform Setup 
Window (Waveform Tool), 246

Capture Trigger By field, Waveform 
Setup Window (Waveform Tool), 244

capturing the waveform plot, Waveform 
Tool, 280, 283

Cascade command (Window menu, 
Bitmap Tool), 379

Cascade command (Window menu, C 
Debugger), 112

Cascade command (Window menu, 
Pattern Tool), 175

Cascade command (Window menu, Pin 
Tool), 53

Cascade command (Window menu, 
Timing Tool), 321

Cascade command (Window menu, 
Waveform Tool), 241

CDebugTool Options command (Options 
command submenu, C Debugger), 101

CDebugTool Properties command 
(Properties command submenu, C 
Debugger), 102

Check Timing Rules command (Data 
menu, Timing Tool), 318

Clean Build command (Build menu, 
Bitmap Tool), 371

Clean Build command (Build menu, C 
Debugger), 105

Clean Build command (Build menu, 
Pattern Tool), 172

Clean Build command (Build menu, 
Waveform Tool), 237

Close All command (File menu, Bitmap 
Tool), 356

Close All command (File menu, C 
Debugger), 85

Close All command (File menu, Pattern 
Tool), 145

Close All command (File menu, Pin 
Tool), 41

Close All command (File menu, Timing 
Tool), 298

Close All command (File menu, Waveform 
Tool), 219

Close All command (Window menu, 
Bitmap Tool), 379

Close All command (Window menu, C 
Debugger), 112

Close All command (Window menu, 
Pattern Tool), 175

Close All command (Window menu, Pin 
Tool), 53

Close All command (Window menu, 
Timing Tool), 321

Close All command (Window menu, 
Waveform Tool), 241

Close command (File menu, Bitmap 
Tool), 356
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Close command (File menu, C 
Debugger), 85

Close command (File menu, Pattern 
Tool), 145

Close command (File menu, Pin Tool), 41
Close command (File menu, Timing 

Tool), 298
Close command (File menu, Waveform 

Tool), 219
Close command (Window menu, Bitmap 

Tool), 379
Close command (Window menu, C 

Debugger), 112
Close command (Window menu, Pattern 

Tool), 175
Close command (Window menu, Pin 

Tool), 53
Close command (Window menu, Timing 

Tool), 320
Close command (Window menu, 

Waveform Tool), 241
Close Workspace command (File menu, 

Bitmap Tool), 357
Close Workspace command (File menu, C 

Debugger), 86
Close Workspace command (File menu, 

Pattern Tool), 146
Close Workspace command (File menu, 

Pin Tool), 42
Close Workspace command (File menu, 

Timing Tool), 298
Close Workspace command (File menu, 

Waveform Tool), 220
commands used to set up timing in test 

programs, 289
get_drive_time_ps, 289
get_io_time_ps, 289
get_strobe_time_ps, 289
set_cycle_time, 289
set_cycle_time_ps, 289
set_drive_time, 290
set_drive_time_ns, 290
set_drive_time_ps, 290
set_io_time, 290
set_io_time_ns, 290
set_io_time_ps, 290
set_strobe_time, 290
set_strobe_time_ns, 290
set_strobe_time_ps, 290
set_tsmap, 290

commands, C language commands 
(Bitmap Tool), 348

commands, VOS terminal used to debug 
timing, 290
dgts, 290
dt, 290

dtw, 290
mtde, 290
mtds, 290
mtie, 290
mtis, 290
mtse, 290
mtss, 290
mtswin, 290
sts, 290

Compile C Sources command (Build 
menu, Bitmap Tool), 371

Compile C Sources command (Build 
menu, C Debugger), 105

Compile C Sources command (Build 
menu, Pattern Tool), 172

Compile C Sources command (Build 
menu, Waveform Tool), 237

Compile command (Build menu, C 
Debugger), 105

Compile command (Build menu, 
Waveform Tool), 237

Compile command (Data menu, Timing 
Tool), 318

Compile Patterns command (Build menu, 
Bitmap Tool), 370

Compile Patterns command (Build menu, 
C Debugger), 105

Compile Patterns command (Build menu, 
Pattern Tool), 171

Compile Patterns command (Build menu, 
Waveform Tool), 237

configuring tester resources on the 
General tab, Pin Tool, 58

configuring the Waveform Tool Setup, 
Waveform Tool, 270

Connect to VersaStation command 
(Tester menu, Pin Tool), 50

Connect to VersaStation command 
(Tester menu, Timing Tool), 315

Continue ‘n’ command (Debug menu, 
Pattern Tool), 173

Continue command (Debug menu, C 
Debugger), 109

Continue command (Debug menu, 
Pattern Tool), 173

Copy command (Edit menu, Bitmap 
Tool), 358

Copy command (Edit menu, C 
Debugger), 89

Copy command (Edit menu, Pattern 
Tool), 148

Copy command (Edit menu, Pin Tool), 44
Copy command (Edit menu, Timing 

Tool), 300
Copy command (Edit menu, Waveform 

Tool), 221
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Create Code Fragment command (Data 
menu, Timing Tool), 318

creating a DUT definition file, Bitmap 
Tool, 383

creating an overlay, Bitmap Tool, 414
creating logical operations, Bitmap 

Tool, 417
Cursor Floating command (View menu, 

Waveform Tool), 228
Cursor Mode command (View menu, 

Waveform Tool), 227
Cut command (Edit menu, Bitmap 

Tool), 358
Cut command (Edit menu, C 

Debugger), 88
Cut command (Edit menu, Pattern 

Tool), 148
Cut command (Edit menu, Pin Tool), 44
Cut command (Edit menu, Timing 

Tool), 300
Cut command (Edit menu, Waveform 

Tool), 221

D
Data Log command (File menu, C 

Debugger), 87
Data menu (Timing Tool), 317

Check Timing Rules command, 318
Compile command, 318
Create Code Fragment command, 318

Debug menu (C Debugger), 105
Argument command, 110
Continue command, 109
Insert/Remove Breakpoint 

command, 108
Run command, 106
Step Into command, 106
Step Out command, 108
Step Over command, 106
Stop command, 109

Debug menu (Pattern Tool), 172
Continue ‘n’ command, 173
Continue command, 173
Enable/Disable Break Points 

command, 174
Insert/Remove Breakpoint 

command, 174
Redo Vector Edit command, 174
Run command, 173
Step ‘n’ command, 173
Step Into command, 173
Step Over command, 174
Step to Next Error command, 174
Step to Previous Error command, 174
Undo Vector Edit command, 174

debugger main window, 78

menu bar, 79
toolbar, 92

Decrease V/DIV command (View menu, 
Waveform Tool), 229

Decreasing pin numbering command (Pin 
Tool menu, Pin Tool), 52

defining pin groups using the Pin Groups 
tab, Pin Tool, 68

Delay by Vector, Waveform Setup 
Window (Waveform Tool), 245

dgts VOS terminal command, 290
Disconnect from VersaStation command 

(Tester menu, Pin Tool), 50
Disconnect from VersaStation command 

(Tester menu, Timing Tool), 315
Display Grid command (View menu, 

Bitmap Tool), 363
displaying the C Program Debugger main 

window, 118
displaying the Pattern Tool and 

retrieving pattern and vector 
information, Pattern Tool, 194

displaying the Waveform Tool document 
window, Waveform Tool, 268

Document Tabs command (View menu, 
Bitmap Tool), 363

Document Tabs command (View menu, C 
Debugger), 96

Document Tabs command (View menu, 
Pattern Tool), 157

Document Tabs command (View menu, 
Pin Tool), 48

Document Tabs command (View menu, 
Timing Tool), 305

Document Tabs command (View menu, 
Waveform Tool), 227

dt VOS terminal command, 290
dtw VOS terminal command, 290
DUT definition file, Bitmap Tool

example, 383
DUT definition files, Bitmap Tool, 424

E
Edges command (View menu, Timing 

Tool), 308
Edges command submenu (View menu, 

Timing Tool)
Edges Only command, 309
Edges With Formatting command, 309

Edges Only command (Edges command 
submenu, Timing Tool), 309

Edges With Formatting command (Edges 
command submenu, Timing Tool), 309

Edit History tab, Output Pane (Pattern 
Tool), 156

Edit menu (Bitmap Tool), 357, 359
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Copy command, 358
Cut command, 358
Find command, 359
Find in Files command, 359
Paste command, 358
Redo command, 358
Replace command, 359
Undo command, 358

Edit menu (C Debugger), 88
Copy command, 89
Cut command, 88
Find command, 89
Find in Files command, 89
Paste command, 89
Redo command, 88
Replace command, 89
Undo command, 88

Edit menu (Pattern Tool), 146
Copy command, 148
Cut command, 148
Find command, 148
Find in Files command, 149
Paste command, 148
Redo command, 147
Redo Vector Edit command, 150
Replace command, 148
Undo command, 147
Undo Vector Edit command, 150

Edit menu (Pin Tool), 43
Copy command, 44
Cut command, 44
Find command, 44
Find in Workspace command, 45
Paste command, 44
Redo command, 44
Replace command, 45
Undo command, 44

Edit menu (Timing Tool), 299
Copy command, 300
Cut command, 300
Find command, 300
Find in Workspace command, 301
Paste command, 300
Redo command, 300
Replace command, 301
Undo command, 300

Edit menu (Waveform Tool), 220
Copy command, 221
Cut command, 221
Find command, 221
Find in Files command, 222
Paste command, 221
Redo command, 221
Replace command, 221
Status Bar command, 226
Toolbar command, 224

Undo command, 221
Edit Vector command (View menu, 

Pattern Tool), 157
Enable/Disable Break Points command 

(Debug menu, Pattern Tool), 174
Enter the Note field, Waveform Setup 

Window (Waveform Tool), 254
Exit command (File menu, Bitmap 

Tool), 357
Exit command (File menu, C 

Debugger), 87
Exit command (File menu, Pattern 

Tool), 146
Exit command (File menu, Pin Tool), 43
Exit command (File menu, Timing 

Tool), 299
Exit command (File menu, Waveform 

Tool), 220
Expected Data mode, Capture Mode field 

Waveform Setup Window (Waveform 
Tool), 253

F
Failures tab, Output Pane (Pattern 

Tool), 156
File command (New command submenu, 

Bitmap Tool), 353
File command (New command submenu, 

C Debugger), 83
File command (New command submenu, 

Waveform Tool), 216
File command (Open command submenu, 

Bitmap Tool), 356
File command (Open command submenu, 

Pattern Tool), 145
File command (Open command submenu, 

Waveform Tool), 219
File Document command (New command 

submenu, Pattern Tool), 142
File menu (Bitmap Tool), 350

Close All command, 356
Close command, 356
Close Workspace command, 357
Exit command, 357
New command, 352
Open command, 354
Open Workspace command, 356
Print command, 357
Print Preview command, 357
Print Setup command, 357
Recent Workspaces command, 357
Save As command, 356
Save command, 356
Save Workspace command, 356

File menu (C Debugger), 80
Attach to Test Program command, 87
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Close All command, 85
Close command, 85
Close Workspace command, 86
Data Log command, 87
Exit command, 87
New command, 81
Open command, 83
Open Workspace command, 86
Print command, 87
Print Preview command, 87
Print Setup command, 87
Recent Workspaces command, 87
Save As command, 86
Save command, 85
Save Workspace command, 86
Test Communication command, 87
Unload Test Program command, 87

File menu (Pattern Tool), 139
Close All command, 145
Close command, 145
Close Workspace command, 146
Exit command, 146
New command, 141
Open command, 143
Open Workspace command, 145
Print command, 146
Print Preview command, 146
Print Setup command, 146
Recent Workspaces command, 146
Save As command, 145
Save command, 145
Save Workspace (Save All) 

command, 145
File menu (Pin Tool), 37

Close All command, 41
Close command, 41
Close Workspace command, 42
Exit command, 43
New command, 38
Open command, 39
Open Workspace command, 42
Print command, 42
Print Preview command, 42
Print Setup command, 43
Recent Workspaces command, 43
Save As command, 42
Save command, 41
Save Workspace command, 42

File menu (Timing Tool), 294
Close All command, 298
Close command, 298
Close Workspace command, 298
Exit command, 299
New command, 295
Open command, 296
Open Workspace command, 298

Print command, 298
Print Preview command, 299
Print Setup command, 299
Recent File command, 299
Recent Workspaces command, 299
Save As command, 298
Save command, 298
Save Workspace command, 298

File menu (Waveform Tool), 213
Close All command, 219
Close command, 219
Close Workspace command, 220
Exit command, 220
New command, 215
Open command, 217
Open Workspace command, 219
Print command, 220
Print Preview command, 220
Print Setup command, 220
Recent Workspaces command, 220
Save As command, 219
Save command, 219
Save Workspace (Save All) 

command, 219
Find command (Edit menu, Bitmap 

Tool), 359
Find command (Edit menu, C 

Debugger), 89
Find command (Edit menu, Pattern 

Tool), 148
Find command (Edit menu, Pin Tool), 44
Find command (Edit menu, Timing 

Tool), 300
Find command (Edit menu, Waveform 

Tool), 221
Find in Files command (Edit menu, 

Bitmap Tool), 359
Find in Files command (Edit menu, C 

Debugger), 89
Find in Files command (Edit menu, 

Pattern Tool), 149
Find in Files command (Edit menu, 

Waveform Tool), 222
Find in Workspace command (Edit menu, 

Pin Tool), 45
Find in Workspace command (Edit menu, 

Timing Tool), 301

G
General tab, configuring tester resources 

(Pin Tool), 58
General tab, Pattern Tool Properties 

dialog box (Pattern Tool), 164
General Variables Watcher Pane, C 

Program Debugger, 97
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Generate Log File command (Setup 
menu, Waveform Tool), 239

get_drive_time_ps C language 
command, 289

get_io_time_ps C language 
command, 289

get_strobe_time_ps C language 
command, 289

Getting Started (Bitmap Tool)
creating a DUT definition file, 383

Getting Started contents, Bitmap 
Tool, 382

Getting Started contents, C Program 
Debugger, 114

Getting Started contents, Pattern 
Tool, 180

Getting Started contents, Pin Tool, 55
Getting Started contents, Timing 

Tool, 323
Getting Started contents, Waveform 

Tool, 255
Getting Started, Bitmap Tool, 382
Getting Started, C Program 

Debugger, 114
Getting Started, Pattern Tool, 180
Getting Started, Pin Tool, 55
Getting Started, Timing Tool, 323
Getting Started, Waveform Tool, 255
global variables watcher, C Program 

Debugger, 97
Graphical command (Mode command 

submenu, Timing Tool), 306
Grid Setup command (View menu, 

Bitmap Tool), 364

H
Help menu (Bitmap Tool), 379

About V4400 Software command, 380
Help Topics command, 380

Help menu (C Debugger), 112
About V4400 Software command, 112
Help Topics command, 112

Help menu (Pattern Tool), 176
About V4400 Software command, 176
Help Topics command, 176

Help menu (Pin Tool), 53
About Versatest Integrated 

Development Environment 
command, 53

Help Topics command, 53
Help menu (Timing Tool), 321

About Versatest Integrated 
Development Environment 
command, 321

Help Topics command, 321
Help menu (Waveform Tool), 241

About V4400 Software command, 241
Help Topics command, 241

Help Topics command (Help menu, 
Bitmap Tool), 380

Help Topics command (Help menu, C 
Debugger), 112

Help Topics command (Help menu, 
Pattern Tool), 176

Help Topics command (Help menu, Pin 
Tool), 53

Help Topics command (Help menu, 
Timing Tool), 321

Help Topics command (Help menu, 
Waveform Tool), 241

High Speed mode, Capture Mode field 
Waveform Setup Window (Waveform 
Tool), 252

I
Ide Options command (Options command 

submenu, Bitmap Tool), 366
Ide Options command (Options command 

submenu, C Debugger), 100
Ide Options command (Options command 

submenu, Pattern Tool), 162
Ide Options command (Options command 

submenu, Waveform Tool), 232
Ide Properties command (Properties 

command submenu, Bitmap Tool), 367
Ide Properties command (Properties 

command submenu, C Debugger), 101
Ide Properties command (Properties 

command submenu, Pattern Tool), 163
Ide Properties command (Properties 

command submenu, Waveform 
Tool), 233

Increase V/DIV command (View menu, 
Waveform Tool), 229

Increasing pin numbering command (Pin 
Tool menu, Pin Tool), 52

Insert/Remove Breakpoint command 
(Debug menu, C Debugger), 108

Insert/Remove Breakpoint command 
(Debug menu, Pattern Tool), 174

Introduction, Bitmap Tool, 342
Introduction, Pattern Tool, 136
Introduction, Pin Tool, 34
Introduction, Timing Tool, 288

J
Jump to Location command (Action 

menu, Bitmap Tool), 375

L
Label field, Waveform Setup Window 

(Waveform Tool), 254
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launching the IDE and displaying the Pin 
Tool document window, Pin Tool, 56

launching the IDE and displaying the 
Timing Tool document window, Timing 
Tool, 332

launching the program, C Program 
Debugger, 126

launching the test program, C Program 
Debugger, 126

Level Scale field, Waveform Setup 
Window (Waveform Tool), 254

Load Bitmap command (Action menu, 
Bitmap Tool), 371

loading a DUT definition file and 
displaying the Bitmap Tool main 
window, Bitmap Tool, 408

loading and viewing bitmap files, Bitmap 
Tool, 411

loading the test program on the system, C 
Program Debugger, 114

Loads command (View menu, Timing 
Tool), 310

Loads command submenu (View menu, 
Timing Tool)
Show Load Format command, 310

Local Variables Pane, C Program 
Debugger, 96

Logic Analyzer Mode command 
(Recapture menu, Waveform Tool), 240

Logic Analyzer mode, Capture Mode field 
Waveform Setup Window (Waveform 
Tool), 253

Logic Document command (Open 
command submenu, C Debugger), 85

Logical Operation command (Action 
menu, Bitmap Tool), 372

logical operations, creating with the 
Bitmap Tool, 417

logical operations, description (Bitmap 
Tool), 346

Logical View command (View menu, 
Bitmap Tool), 363

Logicview tab, Pattern Tool Properties 
dialog box (Pattern Tool), 166

Loop Command, Waveform Tool Setup 
window, 247

M
main window, C Debugger, 78

menu bar, 79
toolbar, 92

main window, Pattern Tool, 138, 139
main window, Waveform Tool, 211, 213
Memory command (View menu, C 

Debugger), 97
Memory Pane, C Program Debugger, 97

Menu bar (Bitmap Tool)
Build menu, 370
Edit menu, 357, 359
File menu, 350
Help menu, 379
Program menu, 369
Tester menu, 367
Tools menu, 365
View menu, 371
Window menu, 378

Menu bar (C Debugger), 79
Debug menu, 105
Edit menu, 88
File menu, 80
Help menu, 112
Program menu, 104
Tester menu, 102
Tools menu, 99
View menu, 91
Window menu, 110

Menu bar (Pattern Tool), 139
Build menu, 171
Debug menu, 172
Edit menu, 146
File menu, 139
Help menu, 176
Program menu, 170
Tester menu, 168
Tools menu, 161
View menu, 150
Window menu, 174

Menu bar (Pin Tool)
Edit menu, 43
File menu, 37
Help menu, 53
Pin Tool menu, 51
Tester menu, 49
Tools menu, 48
View menu, 45
Window menu, 52

Menu bar (Timing Tool)
Data menu, 317
Edit menu, 299
File menu, 294
Help menu, 321
Tester menu, 314
Tools menu, 311
View menu, 301
Window menu, 320

Menu bar (Waveform Tool), 213
Build menu, 236
Capture menu, 239
Edit menu, 220
File menu, 213
Help menu, 241
Program menu, 235
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Recapture menu, 239
Setup menu, 237
Tester menu, 234
Tools menu, 231
View menu, 223
Window menu, 240

Menu bar, Bitmap Tool, 350
menu bar, C Program Debugger main 

window, 79
menu bar, Pattern Tool main 

window, 139
Menu bar, Pin Tool, 36
Menu bar, Timing Tool, 293
menu bar, Waveform Tool main 

window, 213
Minimize All command (Window menu, 

Bitmap Tool), 379
Minimize All command (Window menu, C 

Debugger), 112
Minimize All command (Window menu, 

Pattern Tool), 175
Minimize All command (Window menu, 

Pin Tool), 53
Minimize All command (Window menu, 

Timing Tool), 321
Minimize All command (Window menu, 

Waveform Tool), 241
Mode command (View menu, Timing 

Tool), 305
Mode command submenu (View menu, 

Timing Tool)
Graphical command, 306
Tabular command, 305

mtde VOS terminal command, 290
mtds VOS terminal command, 290
mtie VOS terminal command, 290
mtis VOS terminal command, 290
mtse VOS terminal command, 290
mtswin VOS terminal command, 290

N
Name field, Waveform Setup Window 

(Waveform Tool), 251
NanoSeconds command (Units command 

submenu, Timing Tool), 309
Navigation Pane, Bitmap Tool main 

window, 381
Navigation Tree, Bitmap Tool main 

window, 381
Navigator Pane command (View menu, 

Bitmap Tool), 363
Navigator Pane command (View menu, C 

Debugger), 94
Navigator Pane command (View menu, 

Pattern Tool), 153

Navigator Pane command (View menu, 
Pin Tool), 47

Navigator Pane command (View menu, 
Timing Tool), 304

Navigator Pane command (View menu, 
Waveform Tool), 227

New command (File menu, Bitmap 
Tool), 352

New command (File menu, C 
Debugger), 81

New command (File menu, Pattern 
Tool), 141

New command (File menu, Pin Tool), 38
New command (File menu, Timing 

Tool), 295
New command (File menu, Waveform 

Tool), 215
New command submenu (File menu, 

Bitmap Tool)
Bitmap Tool DUT Document 

command, 353
C Debugger Document command, 353
File command, 353
Pattern Tool Document command, 353
Pin Tool Document command, 353
Test Program Document 

command, 353
Timing Tool Document command, 353
Waveform Document command, 353
Waveform Setup Document 

command, 353
Workspace command, 352

New command submenu (File menu, C 
Debugger)
Bitmap Tool DUT Document 

command, 83
C Debugger Document command, 82
File command, 83
Pattern Tool Document command, 83
Pin Tool Document command, 82
Test Program Document command, 82
Timing Tool Document command, 82
Waveform Document command, 82
Waveform Setup Document 

command, 82
Workspace command, 82

New command submenu (File menu, 
Pattern Tool)
Bitmap Tool DUT Document 

command, 142
C Debugger Document command, 142
File command, 142
Pattern Tool Document command, 142
Pin Tool Document command, 142
Test Program Document 

command, 142
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Timing Tool Document command, 142
Waveform Document command, 142
Waveform Setup Document 

command, 142
Workspace command, 141

New command submenu (File menu, Pin 
Tool)
Pin Tool Document command, 38
Timing Tool Document command, 39
Waveform Document command, 38
Waveform Setup Document 

command, 39
Workspace command, 38

New command submenu (File menu, 
Timing Tool)
Pin Tool Document command, 295
Timing Tool Document command, 296
Waveform Document command, 296
Waveform Setup Document 

command, 296
Workspace command, 295

New command submenu (File menu, 
Waveform Tool)
Bitmap Tool DUT Document 

command, 216
C Debugger Document command, 216
File command, 216
Pattern Tool Document command, 216
Pin Tool Document command, 216
Test Program Document 

command, 216
Timing Tool Document command, 216
Waveform Document command, 216
Waveform Setup Document 

command, 216
Workspace command, 215

New Window command (Window menu, 
Bitmap Tool), 379

New Window command (Window menu, C 
Debugger), 111

New Window command (Window menu, 
Pattern Tool), 175

New Window command (Window menu, 
Pin Tool), 53

New Window command (Window menu, 
Timing Tool), 320

New Window command (Window menu, 
Waveform Tool), 241

O
Offline Mode command (Setup menu, 

Waveform Tool), 238
Open command (File menu, Bitmap 

Tool), 354
Open command (File menu, C 

Debugger), 83

Open command (File menu, Pattern 
Tool), 143

Open command (File menu, Pin Tool), 39
Open command (File menu, Timing 

Tool), 296
Open command (File menu, Waveform 

Tool), 217
Open command submenu (File menu, 

Bitmap Tool)
Bitmap Tool DUT Document 

command, 356
C Debugger Document command, 355
File command, 356
Pattern Tool Document command, 356
Pin Tool Document command, 355
Test Program Document 

command, 355
Timing Tool Document command, 355
Waveform Document command, 355
Waveform Setup Document 

command, 355
Open command submenu (File menu, C 

Debugger)
Bitmap Tool DUT Document 

command, 85
C Debugger Document command, 84
Logic Document command, 85
Pattern Tool Document command, 85
PinTool Document command, 84
Test Program Document command, 85
Timing Tool Document command, 85
Waveform Document command, 85
Waveform Setup Document 

command, 85
Open command submenu (File menu, 

Pattern Tool)
Bitmap Tool DUT Document 

command, 145
C Debugger Document command, 144
File command, 145
Pattern Tool Document command, 145
PinTool Document command, 144
Test Program Document 

command, 144
Timing Tool Document command, 144
Waveform Document command, 144
Waveform Setup Document 

command, 144
Open command submenu (File menu, Pin 

Tool)
Bitmap Tool DUT Document 

command, 41
Pattern Tool Document command, 41
Pdb Document command, 40
PinTool Document command, 40
Timing Tool Document command, 41
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Waveform Document command, 40
Waveform Setup Document 

command, 41
Open command submenu (File menu, 

Timing Tool)
Bitmap Tool DUT Document 

command, 298
Pattern Tool Document command, 298
Pdb Document command, 297
PinTool Document command, 297
Timing Tool Document command, 297
Waveform Document command, 297
Waveform Setup Document 

command, 297
Open command submenu (File menu, 

Waveform Tool)
Bitmap Tool DUT Document 

command, 219
C Debugger Document command, 218
File command, 219
Pattern Tool Document command, 219
PinTool Document command, 218
Test Program Document 

command, 218
Timing Tool Document command, 218
Waveform Document command, 218
Waveform Setup Document 

command, 218
Open Workspace command (File menu, 

Bitmap Tool), 356
Open Workspace command (File menu, C 

Debugger), 86
Open Workspace command (File menu, 

Pattern Tool), 145
Open Workspace command (File menu, 

Pin Tool), 42
Open Workspace command (File menu, 

Timing Tool), 298
Open Workspace command (File menu, 

Waveform Tool), 219
Options command (Tools menu, Bitmap 

Tool), 365
Options command (Tools menu, C 

Debugger), 99
Options command (Tools menu, Pattern 

Tool), 161
Options command (Tools menu, Pin 

Tool), 48
Options command (Tools menu, Timing 

Tool), 311
Options command (Tools menu, 

Waveform Tool), 231
Options command submenu (Tools menu, 

Bitmap Tool)
BitmapTool Options command, 366
Ide Options command, 366

StaticPinTool Options command, 366
StaticScopeTool Options 

command, 366
StaticTPT Options command, 366
TesterTool Options command, 366
TPIParser Options command, 366

Options command submenu (Tools menu, 
C Debugger)
CDebugTool Options command, 101
Ide Options command, 100
StaticPinTool Options command, 100
StaticScopeTool Options 

command, 100
StaticTPT Options command, 101
TesterTool Options command, 100
TPIParser Options command, 100

Options command submenu (Tools menu, 
Pattern Tool)
Ide Options command, 162
PatternTool Options command, 163
StaticPinTool Options command, 162
StaticScopeTool Options 

command, 162
StaticTPT Options command, 162
TesterTool Options command, 162
TPIParser Options command, 162

Options command submenu (Tools menu, 
Pin Tool)
PinTool Options command, 49

Options command submenu (Tools menu, 
Timing Tool)
TimingTool Options command, 311

Options command submenu (Tools menu, 
Waveform Tool)
Ide Options command, 232
StaticPinTool Options command, 232
StaticScopeTool Options 

command, 232
StaticTPT Options command, 232
TesterTool Options command, 232
TPIParser Options command, 232
WaveformTool Options command, 232

Original Scale command (View menu, 
Waveform Tool), 229

Output Pane command (View menu, 
Bitmap Tool), 363

Output Pane command (View menu, C 
Debugger), 95

Output Pane command (View menu, 
Pattern Tool), 155
Edit History tab, 156
Failures tab, 156
Vector Unroll tab, 156
VOS Command tab, 156

Output Pane command (View menu, Pin 
Tool), 48
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Output Pane command (View menu, 
Timing Tool), 304

Output Pane command (View menu, 
Waveform Tool), 227

Overlay command (Action menu, Bitmap 
Tool), 374

overlay, creating with the Bitmap 
Tool, 414

overview, Timing Tool, 289, 343

P
Paste command (Edit menu, Bitmap 

Tool), 358
Paste command (Edit menu, C 

Debugger), 89
Paste command (Edit menu, Pattern 

Tool), 148
Paste command (Edit menu, Pin Tool), 44
Paste command (Edit menu, Timing 

Tool), 300
Paste command (Edit menu, Waveform 

Tool), 221
Pattern Grid (Pattern Tool), 177
Pattern Source Code pane, Pattern 

Tool, 177
Pattern Tool

displaying the Pattern Tool and 
retrieving pattern and vector 
information, 194, 199, 201

Getting Started, 180
Introduction, 136
loading the test program, 181
Registers pane, 160
using the C Program Debugger to 

control program execution, 187
Pattern Tool Document command (New 

command submenu, Bitmap Tool), 353
Pattern Tool Document command (New 

command submenu, C Debugger), 83
Pattern Tool Document command (New 

command submenu, Pattern Tool), 142
Pattern Tool Document command (New 

command submenu, Waveform 
Tool), 216

Pattern Tool Document command (Open 
command submenu, Bitmap Tool), 356

Pattern Tool Document command (Open 
command submenu, C Debugger), 85

Pattern Tool Document command (Open 
command submenu, Pattern Tool), 145

Pattern Tool Document command (Open 
command submenu, Pin Tool), 41

Pattern Tool Document command (Open 
command submenu, Timing Tool), 298

Pattern Tool Document command (Open 
command submenu, Waveform 
Tool), 219

Pattern Tool Getting Started, 180
displaying the Pattern Tool and 

retrieving pattern and vector 
information, 194

Getting Started contents, 180
loading the test program, 181
running the APG and viewing 

failures, 199
using the C Program Debugger to 

control program execution, 187
using the Pattern Tool to correct 

failures, 201
Pattern Tool main window, 138

menu bar, 139
Pattern Source Code pane, 177

PatternTool Options command (Options 
command submenu, Pattern Tool), 163

PatternTool Properties command 
(Properties command submenu, Pattern 
Tool), 164

Pdb Document command (Open command 
submenu, Pin Tool), 40

Pdb Document command (Open command 
submenu, Timing Tool), 297

PicoSeconds command (Units command 
submenu, Timing Tool), 309

Pin Groups tab, defining pin groups (Pin 
Tool), 68

Pin List Tree pane, Timing Tool main 
window, 322

Pin Mapping tab, assigning pins to tester 
resources (Pin Tool), 61

Pin Tool
Getting Started, 55
Introduction, 34
Menu bar, 36

Pin Tool Document command (New 
command submenu, Bitmap Tool), 353

Pin Tool Document command (New 
command submenu, C Debugger), 82

Pin Tool Document command (New 
command submenu, Pattern Tool), 142

Pin Tool Document command (New 
command submenu, Pin Tool), 38

Pin Tool Document command (New 
command submenu, Timing Tool), 295

Pin Tool Document command (New 
command submenu, Waveform 
Tool), 216

Pin Tool Document command (Open 
command submenu, Bitmap Tool), 355

Pin Tool Getting Started, 55
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assigning pins to tester resources on 
the Pin Mapping tab, 61

configuring tester resources on the 
General tab, 58

defining pin groups using the Pin 
Groups tab, 68

Getting Started contents, 55
launching the IDE and displaying the 

Pin Tool document window, 56
Pin Tool main window, 35
Pin Tool menu (Pin Tool), 51

Decreasing pin numbering 
command, 52

Increasing pin numbering 
command, 52

PinTool Document command (Open 
command submenu, C Debugger), 84

PinTool Document command (Open 
command submenu, Pattern Tool), 144

PinTool Document command (Open 
command submenu, Pin Tool), 40

PinTool Document command (Open 
command submenu, Timing Tool), 297

PinTool Document command (Open 
command submenu, Waveform 
Tool), 218

PinTool Options command (Options 
command submenu, Pin Tool), 49

PinTool Properties command (Properties 
command submenu, Pin Tool), 49

plan file switches, Bitmap Tool, 348
Print command (File menu, Bitmap 

Tool), 357
Print command (File menu, C 

Debugger), 87
Print command (File menu, Pattern 

Tool), 146
Print command (File menu, Pin Tool), 42
Print command (File menu, Timing 

Tool), 298
Print command (File menu, Waveform 

Tool), 220
Print Preview command (File menu, 

Bitmap Tool), 357
Print Preview command (File menu, C 

Debugger), 87
Print Preview command (File menu, 

Pattern Tool), 146
Print Preview command (File menu, Pin 

Tool), 42
Print Preview command (File menu, 

Timing Tool), 299
Print Preview command (File menu, 

Waveform Tool), 220
Print Setup command (File menu, Bitmap 

Tool), 357

Print Setup command (File menu, C 
Debugger), 87

Print Setup command (File menu, 
Pattern Tool), 146

Print Setup command (File menu, Pin 
Tool), 43

Print Setup command (File menu, Timing 
Tool), 299

Print Setup command (File menu, 
Waveform Tool), 220

Program menu (Bitmap Tool), 369
Add Files to Test Program 

command, 370
Remove from Test Program 

command, 370
Set Active Test Program 

command, 370
Program menu (C Debugger), 104

Add Files to Test Program 
command, 104

Remove from Test Program 
command, 104

Set Active Test Program 
command, 104

Program menu (Pattern Tool), 170
Add Files to Test Program 

command, 171
Remove from Test Program 

command, 171
Set Active Test Program 

command, 171
Program menu (Waveform Tool), 235

Add Files to Test Program 
command, 236

Remove from Test Program 
command, 236

Set Active Test Program 
command, 236

program, launching for C Program 
Debugger, 126

Properties command (Tools menu, 
Bitmap Tool), 366

Properties command (Tools menu, C 
Debugger), 101

Properties command (Tools menu, 
Pattern Tool), 163
Conditional Stepping tab (Pattern Tool 

Properties dialog box), 165
General tab (Pattern Tool Properties 

dialog box), 164
Logicview tab (Pattern Tool Properties 

dialog box), 166
Vector Unrolling tab (Pattern Tool 

Properties dialog box), 167
Properties command (Tools menu, Pin 

Tool), 49
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Properties command (Tools menu, Timing 
Tool), 311

Properties command (Tools menu, 
Waveform Tool), 232

Properties command submenu (Tools 
menu, Bitmap Tool)
BitmapTool Properties command, 367
Ide Properties command, 367
StaticPinTool Properties 

command, 367
StaticScopeTool Properties 

command, 367
StaticTPT Properties command, 367
TesterTool Properties command, 367
TPIParser Properties command, 367

Properties command submenu (Tools 
menu, C Debugger)
CDebugTool Properties command, 102
Ide Properties command, 101
StaticPinTool Properties 

command, 102
StaticScopeTool Properties 

command, 102
StaticTPT Properties command, 102
TesterTool Properties command, 102
TPIParser Properties command, 101

Properties command submenu (Tools 
menu, Pattern Tool)
Ide Properties command, 163
PatternTool Properties command, 164
StaticPinTool Properties 

command, 164
StaticScopeTool Properties 

command, 164
StaticTPT Properties command, 164
TesterTool Properties command, 163
TPIParser Properties command, 163

Properties command submenu (Tools 
menu, Pin Tool)
PinTool Properties command, 49

Properties command submenu (Tools 
menu, Timing Tool)
TimingTool Properties command, 312

Properties command submenu (Tools 
menu, Waveform Tool)
Ide Properties command, 233
StaticPinTool Properties 

command, 233
StaticScopeTool Properties 

command, 233
StaticTPT Properties command, 234
TesterTool Properties command, 233
TPIParser Properties command, 233
WaveformTool Properties 

command, 234

R
Rebuild All command (Build menu, 

Bitmap Tool), 371
Rebuild All command (Build menu, C 

Debugger), 105
Rebuild All command (Build menu, 

Pattern Tool), 172
Rebuild All command (Build menu, 

Waveform Tool), 237
Recapture menu (Waveform Tool), 239

Logic Analyzer Mode command, 240
Scope Mode command, 240

Recapture Setting command (Setup 
menu, Waveform Tool), 238

Recent File command (File menu, Timing 
Tool), 299

Recent Workspaces command (File menu, 
Bitmap Tool), 357

Recent Workspaces command (File menu, 
C Debugger), 87

Recent Workspaces command (File menu, 
Pattern Tool), 146

Recent Workspaces command (File menu, 
Pin Tool), 43

Recent Workspaces command (File menu, 
Timing Tool), 299

Recent Workspaces command (File menu, 
Waveform Tool), 220

Reconstruction and High Speed mode, 
Capture Mode field Waveform Setup 
Window (Waveform Tool), 253

Reconstruction mode, Capture Mode field 
Waveform Setup Window (Waveform 
Tool), 252

Redo command (Edit menu, Bitmap 
Tool), 358

Redo command (Edit menu, C 
Debugger), 88

Redo command (Edit menu, Pattern 
Tool), 147

Redo command (Edit menu, Pin Tool), 44
Redo command (Edit menu, Timing 

Tool), 300
Redo command (Edit menu, Waveform 

Tool), 221
Redo Vector Edit command (Debug menu, 

Pattern Tool), 174
Redo Vector Edit command (Edit menu, 

Pattern Tool), 150
Registers command (View menu, Pattern 

Tool), 160
Registers pane, Pattern Tool, 160
Remove from Test Program command 

(Program menu, Bitmap Tool), 370
Remove from Test Program command 

(Program menu, C Debugger), 104
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Remove from Test Program command 
(Program menu, Pattern Tool), 171

Remove from Test Program command 
(Program menu, Waveform Tool), 236

Replace command (Edit menu, Bitmap 
Tool), 359

Replace command (Edit menu, C 
Debugger), 89

Replace command (Edit menu, Pattern 
Tool), 148

Replace command (Edit menu, Pin 
Tool), 45

Replace command (Edit menu, Timing 
Tool), 301

Replace command (Edit menu, Waveform 
Tool), 221

Run command (Debug menu, C 
Debugger), 106

Run command (Debug menu, Pattern 
Tool), 173

running the APG and viewing failures, 
Pattern Tool, 199

S
Save As command (File menu, Bitmap 

Tool), 356
Save As command (File menu, C 

Debugger), 86
Save As command (File menu, Pattern 

Tool), 145
Save As command (File menu, Pin 

Tool), 42
Save As command (File menu, Timing 

Tool), 298
Save As command (File menu, Waveform 

Tool), 219
Save command (File menu, Bitmap 

Tool), 356
Save command (File menu, C 

Debugger), 85
Save command (File menu, Pattern 

Tool), 145
Save command (File menu, Pin Tool), 41
Save command (File menu, Timing 

Tool), 298
Save command (File menu, Waveform 

Tool), 219
Save Workspace (Save All) command 

(File menu, Pattern Tool), 145
Save Workspace (Save All) command 

(File menu, Waveform Tool), 219
Save Workspace command (File menu, 

Bitmap Tool), 356
Save Workspace command (File menu, C 

Debugger), 86

Save Workspace command (File menu, 
Pin Tool), 42

Save Workspace command (File menu, 
Timing Tool), 298

Scope Mode command (Recapture menu, 
Waveform Tool), 240

Scope mode, Capture Mode field 
Waveform Setup Window (Waveform 
Tool), 253

Scope Tool, see Waveform Tool, 210
Select/Edit Pin Setup Name field, 

Waveform Setup Window (Waveform 
Tool), 248

selecting bitmap error colors, Bitmap 
Tool, 421

Set Active Test Program command 
(Program menu, Bitmap Tool), 370

Set Active Test Program command 
(Program menu, C Debugger), 104

Set Active Test Program command 
(Program menu, Pattern Tool), 171

Set Active Test Program command 
(Program menu, Waveform Tool), 236

Set Bus Value Radix command (View 
menu, Waveform Tool), 230

Set Error Color command (Action menu, 
Bitmap Tool), 376

Set Offline command (Tester menu, 
Bitmap Tool), 368

Set Offline command (Tester menu, C 
Debugger), 103

Set Offline command (Tester menu, 
Pattern Tool), 169

Set Offline command (Tester menu, Pin 
Tool), 50

Set Offline command (Tester menu, 
Timing Tool), 315

Set Offline command (Tester menu, 
Waveform Tool), 235

Set Online command (Tester menu, 
Bitmap Tool), 368

Set Online command (Tester menu, C 
Debugger), 103

Set Online command (Tester menu, 
Pattern Tool), 169

Set Online command (Tester menu, Pin 
Tool), 50

Set Online command (Tester menu, 
Timing Tool), 315

Set Online command (Tester menu, 
Waveform Tool), 234

set_cycle_time C language command, 289
set_cycle_time_ps C language 

command, 289
set_drive_time C language command, 290
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set_drive_time_ns C language 
command, 290

set_drive_time_ps C language 
command, 290

set_io_time C language command, 290
set_io_time_ns C language 

command, 290
set_io_time_ps C language command, 290
set_strobe_time C language 

command, 290
set_strobe_time_ns C language 

command, 290
set_strobe_time_ps C language 

command, 290
set_tsmap C language command, 290
setting break points, C Program 

Debugger, 124
setting up the waveform capture trigger, 

Waveform Tool Getting Started, 269
Setup Loop Command field, Waveform 

Setup Window (Waveform Tool), 247
Setup menu (Waveform Tool), 237

Generate Log File command, 239
Offline Mode command, 238
Recapture Setting command, 238

Show Legend command (View menu, 
Waveform Tool), 229

Show Load Format command (Loads 
command submenu, Timing Tool), 310

Show P/F field, Waveform Setup Window 
(Waveform Tool), 253

single stepping, C Program 
Debugger, 127

software, use of, 26
Source Code Browser Pane, C Program 

Debugger main window, 111
Stack command (View menu, C 

Debugger), 98
Stack Pane, C Program Debugger, 98
Start command (Capture menu, 

Waveform Tool), 239
StaticPinTool Options command (Options 

command submenu, Bitmap Tool), 366
StaticPinTool Options command (Options 

command submenu, C Debugger), 100
StaticPinTool Options command (Options 

command submenu, Pattern Tool), 162
StaticPinTool Options command (Options 

command submenu, Waveform 
Tool), 232

StaticPinTool Properties command 
(Properties command submenu, Bitmap 
Tool), 367

StaticPinTool Properties command 
(Properties command submenu, C 
Debugger), 102

StaticPinTool Properties command 
(Properties command submenu, Pattern 
Tool), 164

StaticPinTool Properties command 
(Properties command submenu, 
Waveform Tool), 233

StaticScopeTool Options command 
(Options command submenu, Bitmap 
Tool), 366

StaticScopeTool Options command 
(Options command submenu, C 
Debugger), 100

StaticScopeTool Options command 
(Options command submenu, Pattern 
Tool), 162

StaticScopeTool Options command 
(Options command submenu, Waveform 
Tool), 232

StaticScopeTool Properties command 
(Properties command submenu, Bitmap 
Tool), 367

StaticScopeTool Properties command 
(Properties command submenu, C 
Debugger), 102

StaticScopeTool Properties command 
(Properties command submenu, Pattern 
Tool), 164

StaticScopeTool Properties command 
(Properties command submenu, 
Waveform Tool), 233

StaticTPT Options command (Options 
command submenu, Bitmap Tool), 366

StaticTPT Options command (Options 
command submenu, C Debugger), 101

StaticTPT Options command (Options 
command submenu, Pattern Tool), 162

StaticTPT Options command (Options 
command submenu, Waveform 
Tool), 232

StaticTPT Properties command 
(Properties command submenu, Bitmap 
Tool), 367

StaticTPT Properties command 
(Properties command submenu, C 
Debugger), 102

StaticTPT Properties command 
(Properties command submenu, Pattern 
Tool), 164

StaticTPT Properties command 
(Properties command submenu, 
Waveform Tool), 234

Status Bar command (Edit menu, 
Waveform Tool), 226

Status Bar command (View menu, 
Bitmap Tool), 362
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Status Bar command (View menu, C 
Debugger), 93

Status Bar command (View menu, 
Pattern Tool), 153

Status Bar command (View menu, Pin 
Tool), 47

Status Bar command (View menu, Timing 
Tool), 304

Step ‘n’ command (Debug menu, Pattern 
Tool), 173

Step Into command (Debug menu, C 
Debugger), 106

Step Into command (Debug menu, 
Pattern Tool), 173

Step Out command (Debug menu, C 
Debugger), 108

Step Over command (Debug menu, C 
Debugger), 106

Step Over command (Debug menu, 
Pattern Tool), 174

Step to Next Error command (Debug 
menu, Pattern Tool), 174

Step to Previous Error command (Debug 
menu, Pattern Tool), 174

stepping, single (C Program 
Debugger), 127

Stop Build command (Build menu, 
Bitmap Tool), 371

Stop Build command (Build menu, C 
Debugger), 105

Stop Build command (Build menu, 
Pattern Tool), 172

Stop Build command (Build menu, 
Waveform Tool), 237

Stop command (Debug menu, C 
Debugger), 109

sts VOS terminal command, 290
system software usage, 26

T
Tabular command (Mode command 

submenu, Timing Tool), 305
Test Communication command (File 

menu, C Debugger), 87
test program commands used to set up 

timing, 289
get_drive_time_ps, 289
get_io_time_ps, 289
get_strobe_time_ps, 289
set_cycle_time, 289
set_cycle_time_ps, 289
set_drive_time, 290
set_drive_time_ns, 290
set_drive_time_ps, 290
set_io_time, 290
set_io_time_ns, 290

set_io_time_ps, 290
set_strobe_time, 290
set_strobe_time_ns, 290
set_strobe_time_ps, 290
set_tsmap, 290

Test Program Document command (New 
command submenu, Bitmap Tool), 353

Test Program Document command (New 
command submenu, C Debugger), 82

Test Program Document command (New 
command submenu, Pattern Tool), 142

Test Program Document command (New 
command submenu, Waveform 
Tool), 216

Test Program Document command (Open 
command submenu, Bitmap Tool), 355

Test Program Document command (Open 
command submenu, C Debugger), 85

Test Program Document command (Open 
command submenu, Pattern Tool), 144

Test Program Document command (Open 
command submenu, Waveform 
Tool), 218

test program loading, Pattern Tool, 181
test program loading, Timing Tool, 324
test program loading, Waveform 

Tool, 256
test program, loading on system for C 

Program Debugger, 114
Tester menu (Bitmap Tool), 367

Abort Acquire command, 369
Acquire Data command, 369
Apply Changes command, 369
Set Offline command, 368
Set Online command, 368
Tester Power Off command, 369
Tester Power On command, 369

Tester menu (C Debugger), 102
Abort Acquire command, 103
Acquire Data command, 103
Apply Changes command, 103
Set Offline command, 103
Set Online command, 103
Tester Power Off command, 103
Tester Power On command, 103

Tester menu (Pattern Tool), 168
Abort Acquire command, 170
Acquire Data command, 170
Apply Changes command, 170
Set Offline command, 169
Set Online command, 169
Tester Power Off command, 170
Tester Power On command, 170

Tester menu (Pin Tool), 49
Abort Acquire command, 51
Acquire Data command, 51
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Apply Changes command, 51
Connect to VersaStation command, 50
Disconnect from VersaStation 

command, 50
Set Offline command, 50
Set Online command, 50
Tester Power Off command, 51
Tester Power On command, 51

Tester menu (Timing Tool), 314
Abort Acquire command, 317
Acquire Data command, 316
Apply Changes command, 317
Connect to VersaStation 

command, 315
Disconnect from VersaStation 

command, 315
Set Offline command, 315
Set Online command, 315
Tester Power Off command, 317
Tester Power On command, 317

Tester menu (Waveform Tool), 234
Abort Acquire command, 235
Acquire Data command, 235
Apply Changes command, 235
Set Offline command, 235
Set Online command, 234
Tester Power Off command, 235
Tester Power On command, 235

Tester Power Off command (Tester menu, 
Bitmap Tool), 369

Tester Power Off command (Tester menu, 
C Debugger), 103

Tester Power Off command (Tester menu, 
Pattern Tool), 170

Tester Power Off command (Tester menu, 
Pin Tool), 51

Tester Power Off command (Tester menu, 
Timing Tool), 317

Tester Power Off command (Tester menu, 
Waveform Tool), 235

Tester Power On command (Tester menu, 
Bitmap Tool), 369

Tester Power On command (Tester menu, 
C Debugger), 103

Tester Power On command (Tester menu, 
Pattern Tool), 170

Tester Power On command (Tester menu, 
Pin Tool), 51

Tester Power On command (Tester menu, 
Timing Tool), 317

Tester Power On command (Tester menu, 
Waveform Tool), 235

TesterTool Options command (Options 
command submenu, Bitmap Tool), 366

TesterTool Options command (Options 
command submenu, C Debugger), 100

TesterTool Options command (Options 
command submenu, Pattern Tool), 162

TesterTool Options command (Options 
command submenu, Waveform 
Tool), 232

TesterTool Properties command 
(Properties command submenu, Bitmap 
Tool), 367

TesterTool Properties command 
(Properties command submenu, C 
Debugger), 102

TesterTool Properties command 
(Properties command submenu, Pattern 
Tool), 163

TesterTool Properties command 
(Properties command submenu, 
Waveform Tool), 233

Thumbnail Pane, Bitmap Tool main 
window, 381

Tile command (Window menu, Bitmap 
Tool), 379

Tile command (Window menu, C 
Debugger), 112

Tile command (Window menu, Pattern 
Tool), 175

Tile command (Window menu, Pin 
Tool), 53

Tile command (Window menu, Timing 
Tool), 321

Tile command (Window menu, Waveform 
Tool), 241

timing setup commands in test 
programs, 289
get_drive_time_ps, 289
get_io_time_ps, 289
get_strobe_time_ps, 289
set_cycle_time, 289
set_cycle_time_ps, 289
set_drive_time, 290
set_drive_time_ns, 290
set_drive_time_ps, 290
set_io_time, 290
set_io_time_ns, 290
set_io_time_ps, 290
set_strobe_time, 290
set_strobe_time_ns, 290
set_strobe_time_ps, 290
set_tsmap, 290

Timing Tool
Getting Started, 323
Introduction, 288
launching the IDE and displaying the 

Timing Tool graphical and tabular 
views, 332, 336

loading the test program, 324
Menu bar, 293
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Timing Tool Document command (New 
command submenu, Bitmap Tool), 353

Timing Tool Document command (New 
command submenu, C Debugger), 82

Timing Tool Document command (New 
command submenu, Pattern Tool), 142

Timing Tool Document command (New 
command submenu, Pin Tool), 39

Timing Tool Document command (New 
command submenu, Timing Tool), 296

Timing Tool Document command (New 
command submenu, Waveform 
Tool), 216

Timing Tool Document command (Open 
command submenu, Bitmap Tool), 355

Timing Tool Document command (Open 
command submenu, C Debugger), 85

Timing Tool Document command (Open 
command submenu, Pattern Tool), 144

Timing Tool Document command (Open 
command submenu, Pin Tool), 41

Timing Tool Document command (Open 
command submenu, Timing Tool), 297

Timing Tool Document command (Open 
command submenu, Waveform 
Tool), 218

Timing Tool Getting Started, 323
Getting Started contents, 323
launching the IDE and displaying the 

Timing Tool document window, 332
loading the test program, 324
using the Timing Tool in offline and 

online modes, 336
Timing Tool main window, 291

displaying graphical view, 291
displaying tabular view, 291
Pin List Tree pane, 322

Timing Tool overview, 289
timing VOS terminal commands used to 

debug timing, 290
dgts, 290
dt, 290
dtw, 290
mtde, 290
mtds, 290
mtie, 290
mtis, 290
mtse, 290
mtss, 290
mtswin, 290
sts, 290

TimingTool Options command (Options 
command submenu, Timing Tool), 311

TimingTool Properties command 
(Properties command submenu, Timing 
Tool), 312

Toggle Cursor command (View menu, 
Waveform Tool), 228

Tool Document Pane, Waveform Tool 
main window, 242

Toolbar command (Edit menu, Waveform 
Tool), 224

Toolbar command (View menu, Bitmap 
Tool), 360

Toolbar command (View menu, C 
Debugger), 92

Toolbar command (View menu, Pattern 
Tool), 151

Toolbar command (View menu, Pin 
Tool), 46

Toolbar command (View menu, Timing 
Tool), 302

Tools menu (Bitmap Tool), 365
Options command, 365
Properties command, 366

Tools menu (C Debugger), 99
Options command, 99
Properties command, 101

Tools menu (Pattern Tool), 161
Conditional Stepping tab (Pattern Tool 

Properties dialog box), 165
General tab (Pattern Tool Properties 

dialog box), 164
Logicview tab (Pattern Tool Properties 

dialog box), 166
Options command, 161
Properties command, 163
Vector Unrolling tab (Pattern Tool 

Properties dialog box), 167
Tools menu (Pin Tool), 48

Options command, 48
Properties command, 49

Tools menu (Timing Tool), 311
Options command, 311
Properties command, 311

Tools menu (Waveform Tool), 231
Options command, 231
Properties command, 232

TPIParser Options command (Options 
command submenu, Bitmap Tool), 366

TPIParser Options command (Options 
command submenu, C Debugger), 100

TPIParser Options command (Options 
command submenu, Pattern Tool), 162

TPIParser Options command (Options 
command submenu, Waveform 
Tool), 232

TPIParser Properties command 
(Properties command submenu, Bitmap 
Tool), 367
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TPIParser Properties command 
(Properties command submenu, C 
Debugger), 101

TPIParser Properties command 
(Properties command submenu, Pattern 
Tool), 163

TPIParser Properties command 
(Properties command submenu, 
Waveform Tool), 233

Tree View Pane, Waveform Tool main 
window, 242

U
Undo command (Edit menu, Bitmap 

Tool), 358
Undo command (Edit menu, C 

Debugger), 88
Undo command (Edit menu, Pattern 

Tool), 147
Undo command (Edit menu, Pin Tool), 44
Undo command (Edit menu, Timing 

Tool), 300
Undo command (Edit menu, Waveform 

Tool), 221
Undo Vector Edit command (Debug 

menu, Pattern Tool), 174
Undo Vector Edit command (Edit menu, 

Pattern Tool), 150
Units command (View menu, Bitmap 

Tool), 364
Units command (View menu, Timing 

Tool), 309
Units command submenu (View menu, 

Timing Tool)
NanoSeconds command, 309
PicoSeconds command, 309

Unload Test Program command (File 
menu, C Debugger), 87

use of system software, 26
using the C Program Debugger to control 

program execution, Pattern Tool, 187
using the C Program Debugger to control 

program execution, Waveform Tool, 262
using the Pattern Tool to correct failures, 

Pattern Tool, 201
using the Timing Tool in offline and 

online modes, Timing Tool, 336

V
Variable command (View menu, C 

Debugger), 96
variables watcher, global (C Program 

Debugger), 97
variables watcher, local (C Program 

Debugger), 96
Vector Grid command (View menu, 

Waveform Tool), 230

Vector Unroll tab Output Pane (Pattern 
Tool), 156

Vector Unrolling tab, Pattern Tool 
Options dialog box (Pattern Tool), 167

View menu (Bitmap Tool), 371
Display Grid command, 363
Document Tabs command, 363
Grid Setup command, 364
Logical View command, 363
Navigator Pane command, 363
Output Pane command, 363
Status Bar command, 362
Toolbar command, 360
Units command, 364
Zoom In command, 364
Zoom Out command, 364

View menu (C Debugger), 91
Break Point command, 98
Document Tabs command, 96
Memory command, 97
Navigator Pane command, 94
Output Pane command, 95
Stack command, 98
Status Bar command, 93
Toolbar command, 92
Variable command, 96
Watch command, 97

View menu (Pattern Tool), 150
Document Tabs command, 157
Edit History tab, Output Pane, 156
Edit Vector command, 157
Failures tab, Output Pane, 156
Navigator Pane command, 153
Output Pane command, 155
Registers command, 160
Status Bar command, 153
Toolbar command, 151
Vector Unroll tab, Output Pane, 156
VOS Command tab, Output Pane, 156

View menu (Pin Tool), 45
Document Tabs command, 48
Navigator Pane command, 47
Output Pane command, 48
Status Bar command, 47
Toolbar command, 46

View menu (Timing Tool), 301
Document Tabs command, 305
Edges command, 308
Loads command, 310
Mode command, 305
Navigator Pane command, 304
Output Pane command, 304
Status Bar command, 304
Toolbar command, 302
Units command, 309
Zoom In command, 310
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Zoom Out command, 310
Zoom Reset command, 311

View menu (Waveform Tool), 223
Append Mode command, 231
Auto Scale command, 229
Capture Mode Tooltip command, 230
Cursor Floating command, 228
Cursor Mode command, 227
Decrease V/DIV command, 229
Document Tabs command, 227
Increase V/DIV command, 229
Navigator Pane command, 227
Original Scale command, 229
Output Pane command, 227
Set Bus Value Radix command, 230
Show Legend command, 229
Toggle Cursor command, 228
Vector Grid command, 230
Zoom In X command, 229
Zoom In Y command, 229
Zoom Out X command, 229
Zoom Out Y command, 229

View pane, Bitmap Tool main 
window, 380

VOS Command tab, Output Pane 
(Pattern Tool), 156

VOS terminal commands used to debug 
timing, 290
dgts, 290
dt, 290
dtw, 290
mtde, 290
mtds, 290
mtie, 290
mtis, 290
mtse, 290
mtss, 290
mtswin, 290
sts, 290

W
Watch command (View menu, C 

Debugger), 97
watcher, global variables (C Program 

Debugger), 97
watcher, local variables (C Program 

Debugger), 96
watcher, memory (C Program 

Debugger), 97
watcher, stack (C Program Debugger), 98
waveform capture, Waveform Tool 

Getting Started, 280, 283
Waveform Display Pane, Waveform Tool 

main window, 243
Waveform Document command (New 

command submenu, Bitmap Tool), 353

Waveform Document command (New 
command submenu, C Debugger), 82

Waveform Document command (New 
command submenu, Pattern Tool), 142

Waveform Document command (New 
command submenu, Pin Tool), 38

Waveform Document command (New 
command submenu, Timing Tool), 296

Waveform Document command (New 
command submenu, Waveform 
Tool), 216

Waveform Document command (Open 
command submenu, Bitmap Tool), 355

Waveform Document command (Open 
command submenu, C Debugger), 85

Waveform Document command (Open 
command submenu, Pattern Tool), 144

Waveform Document command (Open 
command submenu, Pin Tool), 40

Waveform Document command (Open 
command submenu, Timing Tool), 297

Waveform Document command (Open 
command submenu, Waveform 
Tool), 218

Waveform Setup Document command 
(New command submenu, Bitmap 
Tool), 353

Waveform Setup Document command 
(New command submenu, C 
Debugger), 82

Waveform Setup Document command 
(New command submenu, Pattern 
Tool), 142

Waveform Setup Document command 
(New command submenu, Pin Tool), 39

Waveform Setup Document command 
(New command submenu, Timing 
Tool), 296

Waveform Setup Document command 
(New command submenu, Waveform 
Tool), 216

Waveform Setup Document command 
(Open command submenu, Bitmap 
Tool), 355

Waveform Setup Document command 
(Open command submenu, C 
Debugger), 85

Waveform Setup Document command 
(Open command submenu, Pattern 
Tool), 144

Waveform Setup Document command 
(Open command submenu, Pin Tool), 41

Waveform Setup Document command 
(Open command submenu, Timing 
Tool), 297
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Waveform Setup Document command 
(Open command submenu, Waveform 
Tool), 218

Waveform Setup Window (Waveform 
Tool)
APG register field, 245
Capture Mode field, 252
Capture Setting field, 246
Capture Trigger By field, 244
Delay by Vector field, 245
Enter the Note field, 254
Expected Data mode (Capture Mode 

field), 253
High Speed mode (Capture Mode 

field), 252
Label field, 254
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